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1. Introduction

1.1 About this manual

1.1.1 What is its structure?

In this chapter you’ll find the product description, an installation guide and an introduc-
tion to the work with Quadstar 32-bit.

The chapters 2 to 7 contain detailed descriptions of the individual programs (Measure, 
Service etc.).

Chapter 8. Process Control, 409 is the reference guide for sequence-programming.

Chapter 9. Access Rights Control, 531 shows you how to setup permission of access 
to Quadstar 32-bit for different users.

Chapter 10. File Handling, Data Formats, Error Messages, Troubleshooting, 541 
describes data formats, error messages and troubleshooting in Quadstar 32-bit.

Chapter 11. Residual Gas Analysis Program for Prisma™, 575 explains the Residual 
Gas Analysis program for QMS 200 (Prisma™).

1.1.2 How do I work with it?
• Use it mainly as a reference book. It doesn’t make too much sense to read it from the 

beginning to the end.

• If you are definitely not familiar with Quadstar 32-bit, you should study thoroughly the 
Chapter 1.5 Getting started, 34; the basic processes are briefly explained there.

• If you have questions concerning a certain part of the program while you are working, 
search for this part in the table of contents of the program and look it up there.

• If you have questions you can not associate to a certain program part, then find 
matching keywords and search for them in the Index. Perhaps you have to try several 
different keywords until you find the reference you are looking for.

• If Quadstar 32-bit doesn’t work the way it should, you might find help in Chapter 10.7 
Troubleshooting, 573. Often encountered problems and possible solutions are de-
scribed there.
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1.2 About Quadstar 32-bit

1.2.1 Product description

Quadstar 32-bit is a powerful, modular application software for the quadrupole mass 
spectrometers QMS 422/421 and QMS 200 Prisma™. Quadstar 32-bit (standard) is 
capable of performing qualitative and quantitative analyses and it is user programmable.

Quadstar 32-bit simplifies the operation of the mass spectrometer, improves the repro-
ducibility of the measurements, and allows all relevant parameters and data to be 
stored. In addition, the consistency of certain parameters is checked and warning mes-
sages are output in case of error.

Quadstar 32-bit allows you to store measurement data, to read them back in, and to rep-
resent them in various formats (table, bargraph, intensity/concentration versus time).

Quadstar 32-bit has two possibilities to communicate with the mass spectrometer:

• Serial via RS232C, available on all PC systems as a standard feature. The required 
connection cable is provided. Only one QMS connectable, medium transmission 
speed.

• Using fiber optics and ArcNet (has to be ordered separately). Several QMSs may be 
operated at the same time at very high transmission speed.

Main features The Main features of the Quadstar 32-bit package are:

• Ease of operation through graphic user interface

• Powerful measurement programs for:
• Qualitative analysis: Multiple Ion Detection (MID), Scan Analog, Scan Bar-

graph
• Quantitative analysis: Multiple Concentration Detection (MCD)
• Optimized analysis of the stored measurement data
• 3-dimensional representation of Scan Analog spectra
• Representation of multiple channel measurements as table, bargraph or Ver-

sus Time
• Documentation of the measurements is supported

• Measuring simultaneously with several control units via the ArcNet interface

• Freely programmable, automatic measurement sequences

• Online data interchange with other programs by DDE

• Comprehensive service functions

• Online parameter setup of the mass spectrometer

• Post-measurement storage of data (temporary save)

• Threshold monitoring with alarm functions

• Automatic electrometer range selection

• Programmable analog and digital inputs and outputs

• Support for special QMS functions such as Chopper Lock In, Ion Counter etc.
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1.2.2 The individual programs

Quadstar 32-bit currently consists of the following main programs:

Measure
Measure is the actual measure program. It provides all kinds of measurements and stor-
age of the acquired data. From here, sequences are started as well.

Dispsav
Dispsav (Display Saved Values) is the analyzing program. Stored data can be repre-
sented in different ways, magnified and processed.

Parset
Parset (Parameter Setup) is the setup program. All kinds of settings for measurements, 
QMS, communication and the working environment can be done here. You can program 
sequences here.

Tune Up
Tune Up is the tuning program. You can tune the ion source, adjust the RF generator 
and optimize the peak shape or degas the filament.

Service
Service is the service program. You can test for leaks, measure total pressure and oper-
ate analog or digital inputs and outputs manually.

Utility
Utility is an additional program. It contains functions for the spectra library.

Accessc
Accessc is the administration program. You can allow or prohibit access to 
Quadstar 32-bit components for individual users.

1.2.3 Quadstar 32-bit main features

Quadstar 32-bit provides qualitative analysis of measurement data. It also contains var-
ious auxiliary and service programs such as leak test, service scan, total pressure mea-
surement, etc. The main features of Quadstar 32-bit are:

Powerful measurement programs

• Multiple Ion Detection (MID) with simultaneous representation of ion currents and ex-
ternal analog signals. Also threshold monitoring, integration, auto ranging, etc.

• Scan Analog with online zero gas or reference subtraction, mean value calculation 
across several cycles if desired

• Scan Bargraph for fast peak detection and display across a certain mass range

Storage functions

• Online storage of an unlimited number of data files

• Post-measurement storage of data through Temporary Save feature

• Documenting measurement data by storing parameters and remarks concerning the 
measurement
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Optimized analysis of the stored measurement data

• Magnify function for representing selected measurement data

• Library support for Scan Bargraph measurements

• Simplified interpretation by means of the measure data documentation

• Integral and statistics functions

• Creation of ASCII files for data export (e.g. to EXCEL, etc.)

Auxiliary functions for Service

• Leak test with audible signal

• Total pressure monitoring

• Digital I/O manual mode

• Password protection with access privileges

• Calibration of the mass scale

• Easily understandable parameter setup

• Standard parameter editors for the different measurement types

• Editor for entering/modifying spectra in the spectra library

• Editor for characteristic curves of the analog inputs and outputs

• Graphic editor to process spectra

• Screen color editor

1.2.4 Quadstar 32-bit «Quantitative Analysis» features

Quantitative Analysis enhances Quadstar 32-bit with quantitative analysis through Mul-
tiple Concentration Detection (MCD measurement).

The calculation of the concentrations is based on a matrix comprising max. 64 x 64 ele-
ments. The mathematical solution of the resulting equations is based on the process of 
elimination according to Givens, and also allows super-determinate equation systems.

The calibration factors are stored in a library and can be entered via the keyboard, or be 
determined through a special measurement method. The matrices access the individual 
elements in the calibration factor library. Recalibration of a component thus updates all 
matrices containing this component.

The main features of the Quadstar 32-bit Quantitative Analysis are:

• Analysis of a gas mixture by Multiple Concentration Detection (MCD measurement) 
with simultaneous display of concentrations, ion currents and external analog sig-
nals. Furthermore threshold monitoring, integration, auto ranging, etc.

• Calibration with internal and external normalization
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1.2.5 Quadstar 32-bit «Process Control»

Using the sequencer that’s supplied with Quadstar 32-bit you can program measure-
ment sequences and control gas inlet systems automatically. Sophisticated, application-
specific measurement programs can be created with the editor. Data may be exchanged 
online with other programs by DDE (Dynamic Data Exchange).

The sequencer also supports online calculations. By entering mathematical formulas 
you can calculate ion current ratios, standard deviations etc. from the measurement 
data that have been stored in a buffer during the execution of a sequence. The Calcu-
lation Module supports not only basic arithmetic functions, but also functions (Log(), 
Exp(), Sqr(), Abs(), etc.).

With the Process Control Module, the following main functions can be programmed in 
any order:

• MID (Multiple Ion Detection), Scan Bargraph and Scan Analog measurements

• Storage of measure data and their documentation

• Programmable calculations with measure data

• Individual control of a process sequence through programmable dialog boxes

• Integrated gas inlet control

• Nested operation loops with conditional branching

• Wait loops

• Zero gas measurement for background analysis (Zero Gas)

• Selection of the display mode (Table, Bargraph, Versus Time)

• Measurement log output on the printer

• Concentration measurements at gas mixtures

• Programmable calculations with concentrations

• Gas specific calibration

1.2.6 Scope of delivery

Software Quadstar 32-bit comprises various compressed files that are supplied on CD-ROM. 
When the software is installed with the supplied setup program, the required directories 
are automatically created and the decompressed files stored in them.

When the software is installed using the given default settings, on drive C the following 
directories are created:

c:\qs32bit\ Program and setup directory

c:\qs32bit\auxi\ Auxiliary file directory

c:\qs32bit\dat\ Measurement data file directory

c:\qs32bit\par\ Measurement parameter file directory
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For each measurement type, parameters and measurement data files are supplied. 
These are intended as sample files for the measurement and analysis programs. The 
following demo files are available:

Quadstar 32-bit distinguishes the different file types by their file extension. An overview 
of those files is given in Chapter 10.3 Quadstar 32-bit files, 544.

Cables/
connectors

• RS232C connection cable for the data exchange between the mass spectrometer 
and the computer

• Additional accessories (ArcNet board, optic fiber etc.) if ordered

1.2.7 Computer system requirements

Quadstar 32-bit can be run on any system that satisfies the following requirements:

airdemo.xxx Parameter/measured data files for Simulation mode

airfar.xxx Parameter/measured data files for Faraday detector

airsem.xxx Parameter/measured data files for SEM/CH-TRON 
detector

CPU 133 MHz or higher Pentium-compatible CPU

Disk drive 2GB hard disk with a minimum of 650MB of free space; 
CD-ROM drive

Monitor 800 x 600 or higher resolution, 1024x768 recom-
mended

RAM 64 MB minimum; 256MB recommended

Interfaces RS232C (Com1-Com9 supported); PCI or PCMCIA for 
Arcnet NIC

Operating System Windows® 2000 or later; Windows® 2000 professional, 
english recommended
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1.3 Abbreviations and terms

1.3.1 Hardware modules and components

Term Significance

AI 421 Analog input module, 16 channels for QMS 422/421

AO/IC 421 Ion counter including 12 analog output channels for 
QMS 422/421

CD-SEM Secondary electron multiplier with high voltage conversion 
dynode

CH-TRON Channeltron multiplier

CLA 400 Chopper lock-in amplifier for QMS/QMI 421

CP 400 Ion counter preamplifier QMS 422/421

CS 421 Front panel of the QMS 421

DI 420 Digital input module, 32 channels for QMS 422/421

DO 420 Digital output module, 32 channels QMS 422/421

EP 422 Electrometer preamplifier for QMS 422

EP 112 Electrometer preamplifier for QMS 422/421

FIR Finite Impulse Response filter

HV 420/421 High voltage supply for the SEM of the QMS/QMI 421

HV 200 High voltage supply for the CH-TRON of the QMS

IS 420 Ion source supply for QMS 422/421

OH 421 Optical HUB for multiplex operation using ArcNet

PE 420 Inverted magnetron (cold cathode) gauge module for 
QMS 422/421

PI 420 Pirani gauge module for QMS 422/421

PKR 250/251 Compact full range gauge for QMS 200

QC 421 Quadrupole controller of the QMS/QMI 421

QC Generic term for quadrupole controller

QMA 4XX Analyzer of the 400 family

QMA 200 Analyzer of the 200 family

QMA 125 Analyzer of the 125 family

QME 125 Quadrupole electronics for the 125 family

QMH 400/410 RF generator of the 400 family

QMS 422 Quadrupole mass spectrometer 422

QMS 421 Quadrupole mass spectrometer 421
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1.3.2 Quadstar 32-bit specific

1.3.3 General

QMS 200 Quadrupole mass spectrometer 200 (Prisma™)

QMS Generic term for quadrupole mass spectrometers, applies to 
QMS 422/421, QMI 421, QMS 421C, QMS 200, etc

QMU 112 Gauge head selector

RF 20x RF generator of the QMS 200, mass range x00

SEM Secondary electron multiplier

TPR 250 Compact Pirani gauge for QMS 200

Term Significance

Term Significance

GSC Gas Specific Calibration

IVT Intensity Versus Time

MCD Multiple Concentration Detection

MID Multiple Ion Detection

MSC Mass Scale Calibration

PCM Process Control Module

QAM Quantitative Analysis Module

SIM Simulation Mode

TIC Total Ion Current

Term Significance

ArcNet LAN with «Token Passing» protocol

ASCII American Standard Code for Information Interchange

Baudrate Data signaling rate in words/sec

F.S.R. Full Scale Range. The highest displayable value of a scale

Hardware Physical equipment/modules such as QMS 422, QME 125, 
etc.

LAN Local Area Network

LED Light Emitting Diode

Node Every device in the network that has its own address

RAM Random access memory (read/write)
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1.3.4 Conventions

Select [xxx] > [yyy] > [zzz] means:

In the current menu select the menu item[xxx]. In the subsequently appearing field 
choose [yyy]. And there choose the entry [zzz].

ROM Read-only memory

RS232C Serial standard interface

SECS Semi Equipment Communications Standards

Windows® Microsoft® Windows® graphic user interface

Term Significance
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1.4 Installation

1.4.1 Using the SETUP installation program

Quadstar 32-bit comprises various compressed files that are supplied on CDROM and 
requires approximately 10 MBytes of hard disk space. SETUP creates the required 
directories automatically and stores the decompressed files there.

The main directory (default: QS32BIT) contains all Quadstar 32-bit program files. Spe-
cial subdirectories are created for the measurement data, parameter and auxiliary files.

NOTE:
The subdirectory names can later be changed, but note that the directory names 
must be entered under [Setup] > [General] in the Parameter Setup program.

When an update installation is performed, SETUP searches for the default direc-
tory QS32BIT on all disks. If this directory can be found, it is shown together with 
the subdirectories in the corresponding dialog boxes and does not have to be re-
entered.

SETUP supports:

• New installation of Quadstar 32-bit

• Update installation of an old version to a new version of Quadstar 32-bit
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1.4.2 Installation/update on a hard disk

Install Quadstar 32-bit by performing the steps outlined below.

1 Start Windows®. If Windows® is already running, close all other applications.

2 Insert the Quadstar 32-bit installation CD-ROM

2.1 Installation should start automatically after a few seconds

2.2 If it does not start up after 30 seconds, the autostart feature may be dis-
abled. In this case, use Windows® Explorer® to navigate to the CD-ROM 
drive and start “SETUP.EXE”.

3 Select the desired language (e.g. English) by clicking on the corresponding com-
mand button. The online documentation will be installed in the selected language.

4 Enter the main directory for Quadstar 32-bit. If in the given directory an older 
Quadstar 32-bit installation is found, then enter the desired installation type (New 
or Update)

NOTE:
If you have an older installation of Quadstar 32-bit and you want to leave it un-
touched, please see Section «Multiple installations», 27.

5 Continue with the installation procedure and enter the requested parameters or 
accept the given standard entries

The SETUP program creates a Quadstar 32-bit entry in the “programs” folder in the start 
menu (if it does not exist yet):

Nonstandard 
directory

Setup installs Quadstar 32-bit in the desired directory. If this is not the default directory 
«QS32BIT», sequences supplied for the Process Control Module must be recompiled:

1 Start the Parameter Setup program in Quadstar 32-bit program group

2 Open [Sequence] > [Editor], choose a sequence and confirm by [OK]

3 Open [File] > [Compile All] to activate the Sequence Compiler dialog box and 
recompile all sequences by [Compile all]
• After the recompilation, Quadstar 32-bit reports that all sequences have been 

compiled successfully

4 Click on [Close] and leave the Parameter Setup program by [File] > [Close] and 
finally [File] > [Exit]

Multiple installa-
tions

For multiple installations, the characteristics of the entry in start menu must be changed 
before the second installation.

1 Right-click the start menu entry (Quadstar 32-bit)

2 Chose [rename]

3 Enter a a new name for the entry, for example “Quadstar 32-bit #1”

4 Use another directory than the standard (qs32bit) for the second installation

Software key Quadstar 32-bit is protected against unauthorized use by a key which contains your indi- 
vidual customer number. This key is stored in the software.
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To order expansion modules or software updates, please use the order card at the 
beginning of this manual and do not forget to specify your key number on it. The key 
number is printed on the CD-ROM.

1.4.3 Connecting the mass spectrometer to the computer

Connection 
cables

Quadstar 32-bit is supplied with a set of connection cables for serial operation. Which 
cables are to be used depends on the type of connector on the computer.

NOTE:
If you use ArcNet/fiber optics, you can skip this section. Installation support for 
ArcNet can be found in Chapter 3.6 Communication parameters, 209.

Connection 
sockets

For connecting the serial communication cable to the mass spectrometer, two types of 
sockets are normally available, depending on the type of interface being used. The pin 
assignment of these two connectors (DB9 male, DB25 male) is as follows:

Tab. 1-1 DB9 connector (male)

Pin Significance

1 Carrier Detect (CD)

2 Receive Data (RXD)

3 Transmit Data (TXD)

4 Data Terminal Ready (DTR)

5 Signal Ground (GND)

6 Data Set Ready (DSR)

7 Request To Send (RTS)

8 Clear To Send (CTS)

9 Ring Indicator (RI)

Pin Significance

1 Chassis ground

2 Transmit Data (TXD)

3 Receive Data (RXD)

4 Request To Send (RTS)

5 Clear To Send (CTS)

6 Data Set Ready (DSR)

7 Signal Ground (GND)

8 Carrier Detect (CD)
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Tab. 1-2 DB25 connector (male)

RS232C null modem cable (DB9 female to DB9 female)

Extension cable (DB9 male to DB9 female)

Installing the 
connection cable

The following combinations are feasible:

Connect the QMS with the supplied cable to your computer and note the selected inter-
face COM1, COM2, etc.

If you use an additional extension, pins 2 and 3 (DB-25 female) of this cable must not 
be crossed. If you have problems with an extension cable, a reverser may have to be 
used.

If several interfaces are used under Windows®, problems can occur. Their solution is 
described in Chapter 3.6.2 Communication via RS232C, 210.

For additional information please see Chapter 3.6 Communication parameters, 209.

1.4.4 Configuring Quadstar 32-bit

If you have just installed Quadstar 32-bit, the following must be configured:

• Communication from PC to mass spectrometer

• The mass spectrometer’s characteristics

If the system has already been configured, you may skip these two sections.

20 Data Terminal Ready (DTR)

22 Ring indicator (RI)

Pin Significance

DB9 connector (female) 1 2 3 4 5 6/8 7 9

DB9 connector (female) 7 3 2 6/8 9 4 1 5

DB9 connector (female) 1 2 3 4 5 6 7 8 9

DB9 connector (male) 1 2 3 4 5 6 7 8 9

Computer connector Connection Connector on QC

DB9connector (male) RS232C cable DB9 connector (male)

DB9 connector (male) RS232C cable + extension cable DB9 connector (male)
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1.4.4.1 Communication with the mass spectrometer
1 Start the Parset program in the program group Quadstar 32-bit

2 Open [Comm] > [QMS Comm. Type]

Fig. 1-1

Quadstar 32-bit shows the following dialog box:

Fig. 1-2

At the time of installation Quadstar 32-bit assigns the port for communication with the 
mass spectrometer to the serial (RS232C Normal) interface COM 1 by default. If your 
mouse is connected to COM 1, the interface to the mass spectrometer must be assigned 
to COM 2.

NOTE:
If more than 2 serial interfaces are operated concurrently, problems can occur.

If a «PS/2 nouse» or «USB mouse» is used, this problems do not occur if the serial 
lines are not already occupied by other applications.

For additional information about communication (e.g. by ArcNet fiber optic) 
please refer to Chapter 3.6 Communication parameters, 209.

If you want to communicate via RS232C Normal, please proceed as follows:

3 Select RS232C Normal (if not selected already)

4 Choose [Comm] > [QMS Comm. Parameters]. Quadstar 32-bit shows the follow-
ing dialog box:
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Fig. 1-3

5 Select the desired Baud Rate (Default = 19200)

6 In the «Connection Line» list box select the desired interface and press [OK]

7 Start the mass spectrometer and wait approximately 5 seconds until the equip-
ment is ready

8 Choose [Comm] > [Connect]

The QMS is automatically adapted to the selected baud rate. When the system is ready 
for operation, the LED simulated in the lower left corner of the active window changes 
to green.

Additional information can be found in the description of the Parameter setup program 
under Communication via RS232C.

Error Message If the connection cannot be established, this is signaled with the error message «QMS 
off, not available or wrong node ID configured». Check the following possible sources of 
trouble:

• Is the mass spectrometer switched on and was it initialized when [Connect] was ac-
tivated?

• Is the connection cable plugged into the mass spectrometer and into the computer?

• If another cable is used, check whether or not the TXD and RXD lines (pins 2 and 3 
of the DB25 female connector) are crossed

• If an extension cable is used, make sure that the TXD and RXD lines (pins 2 and 3 
of the DB-25 socket) are not crossed again

• Is the interface specified under QMS Comm. Parameters the one that’s actually 
used?

1.4.4.2 Configuring the mass spectrometer

Declare the hardware you are using (analyzer, ion source, extensions etc.):

1 Start the Parameter setup program and choose [Comm] > [Connect]

2 Select [Config] > [QMS]. Quadstar 32-bit displays one of the following dialog 
boxes, according to the QMS in use:
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Fig. 1-4

Fig. 1-5

It is recommended to connect the mass spectrometer and to activate the interface via 
[Comm] > [Connect] to setup the configuration, although it’s not mandatory. This way, 
Quadstar 32-bit is able to read back part of the configuration from the mass spectrome-
ter. For the QMS 422/421 this is particularly useful with respect to the optional Hardware 
Boards (AI 421, DO 420, DI 420, etc.) and for the QMS 200 with respect to the available 
analyzers, mass ranges (RF generators) etc.

3 Please enter the following data:
• MASS-R - The mass range of your analyzer
• QMA - The type of analyzer being used
• Detector - The type of collector being used
• IS-Type - The type of ion source being used
• Options - The installed options
• Protection (SEM+FIL) - Select INTERN if you are not using an external vacu-

um control system. See Chapter 5.2.1.2.5 Filament Protection Extern (QMA 
200/QMA 4XX), 323.

Confirm these settings by [OK], so they will be stored automatically
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1.4.4.3 Changing the directories

The names of the QS32BIT directories created by Quadstar 32-bit can be changed after 
the software has been installed.

To declare e.g. a different data file directory, proceed as follows:

1 Start the Parameter Setup program

2 Select [Setup] > [General...]

3 Position the cursor at the «Data File Path» input field and change the directory 
(and/or drive) by entering the name directly in this field, or via the [Select Path] 
command button.

NOTE:
The directory or path names are to be changed by Quadstar 32-bit only (as de-
scribed above). If you change them e.g. with Windows® Explorer®, 
Quadstar 32-bit can’t find its files any more and thus works with standard setup.
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1.5 Getting started

1.5.1 Installation

Make sure that Quadstar 32-bit and the mass spectrometer (QMS) are installed and set 
up properly. See Chapter 1.4 Installation, 26.

1.5.2 Choose operating mode «Simulation»

For the following exercises we choose the operating mode «Simulation». This way we 
can work independently from the real vacuum conditions, because the QMS delivers 
simulated measure data.

1 Open the parameter setup program (Parset) and choose [Setup] > [General...]

2 In the now appearing dialog box set the «Simulation Mode» to «Intern» and con-
firm by pressing the [OK] button

Fig. 1-6

3 Activate the communication to the mass spectrometer by [Comm] > [Connect]
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Fig. 1-7

Now you see on the left of the status bar of Parset the green LED (green = communica-
tion is active), then a field for text display and on the right the symbol for the emission 
(filament gray = emission is off) and the abbreviation SIM (for Simulation Mode). If you 
work with ArcNet communication type, then the name of the connected mass spectrom-
eter is displayed in the last field on the right.

Fig. 1-8

4 Leave Parset by [File] > [Exit]
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1.6 Air analysis
The measuring task is to analyze the composition of air. For that purpose we do not use 
a real measurement under vacuum conditions but the simulation data stored in the QMS 
instead. These data represent a typical measurement of air with a Faraday detector. The 
procedures are shown for a Prisma™ mass spectrometer, but of course they are nearly 
the same with other mass spectrometers.

1.6.1 Scan Analog overview measurement

To get an overview of the gases being present, the measuring type Scan Analog (ion 
current as a function of m/e) is suitable.

1 Start the program Measure and choose [Scan] > [Analog]. The following Open 
dialog appears:

Fig. 1-9

2 Click on «sca1f.sap» (DO NOT double click!)

3 Now click [Copy] to copy this file to another one

4 In the «Copy Files» dialog, in the field «To», change the name to myairsim and 
confirm with [OK]

Fig. 1-10

5 Confirm in the Open dialog the choice of myairsim.sap by [OK]. The measure-
ment is started and shows, after a while, the following:
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Fig. 1-11

You can clearly see the characteristic peaks of air on the mass numbers 14, 16, 18, 28, 
32, 40 and 44 m/e.

1.6.2 Save measure data

Now, store some measuring cycles (passes):

1 Choose [File] > [Save Cycle Data] and enter the file name airsim1.sac under «File 
Name». The measured data will be stored in the file airsim1.sac in the path 
c:\qs32bit\dat.

Fig. 1-12

2 If you press [OK], you will be asked for the number of cycles to be stored. Enter 
5 and press [OK].
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Fig. 1-13

You can enter some information on the measurement here. Press "Save measure data 
+ Info" to start the measurement.

Fig. 1-14

The QMS now performs the same measurement five times and stores the results. This 
takes about 4 minutes. In the text field of the status bar the measure/save progress is 
displayed continuously («Saving Cycle ... of ...»). When the text disappears, the storage 
is finished, but the measurement continues. Now you can stop the measurement by 
[File] > [Close] and leave Measure by [File] > [Exit].

1.6.3 Analyzing saved measure data

You can analyze stored measure data very easily and thoroughly with the program 
Dispsav (Display saved values).

1 Open the Dispsav program and choose [Scan] > [Analog Data]. In the now 
appearing Open dialog choose the file airsim1.sac and confirm the choice by 
[OK]. Now you see the following display of measure data:
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Fig. 1-15

If you set the cursor to a certain spot on the graph, you see in the status bar the corre-
sponding X- and Y-values and the information C:1 (displayed cycle: 1). This represen-
tation is not ideal because the peaks are small and their intensities can’t be determined 
accurately. Therefore we enlarge the area we are interested in:

2 Choose [Function] > [Magnify]. Set the cursor to the upper left corner of the area 
to be enlarged (e.g. 10 amu, 0.85 E-8 A) and press the left mouse button. Drag 
the cursor (while still holding the left mouse button pressed) to the lower right cor-
ner of the area (e.g. 35 amu, 0.00 E-7 A) and press the right mouse button addi-
tionally. Now release both mouse buttons.

Fig. 1-16

The peaks can now be seen much better and their intensities may be determined more 
precisely. You can use the magnifier function repeatedly to enlarge certain details to a 
great extent.

• The last magnification step can be undone by [Special] > [Undo Magnify]

• To get back to the original representation, choose [Special] > [Set Default]

Until now, you have only worked with the first one of the five stored cycles. To see the 
changes in the spectrum from cycle to cycle, you can display the other cycles as well:
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3 Choose [Setup] < [3 Dimensional], so the cycles will be displayed one after each 
other in the same diagram, i.e. 3 Dimensional:

Fig. 1-17

Of course, in our simulated measurement the values do not drift over the time. In a real 
measurement you could see such effects in this display mode. Try the settings and func-
tions of Dispsav (e.g. [Setup] > [Graphic]) to become familiar with the features of the 
analyzing tool.

• If you should encounter a stage where the display is not sensible any more, you get 
back to the original representation by [Special] > [Set Default]

• Exit the program by [File] > [Close] and finally [File] > [Exit]
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1.7 Measuring time dependent processes
The Scan Analog measurement gives you information like «The gas consists of ..., ..., 
..., most of it is ... The amount of ... is very small». This measuring type has some dis-
advantages thus. The quantitative composition of the gas in % and ppm can only be fig-
ured out by a lot of hard, manual calculation work. The information about the changes 
of the gas composition is even in 3 dimensional representation very hard to extract and 
after all the amount of measure data gets very large when long term measurements are 
performed.

The solution for this problems is measuring with MID (Multiple Ion Detection) or MCD 
(Multiple Concentration Detection) measurement type. This way, only the mass num-
bers of interest and their peak heights are determined and analyzed. For the MID mea-
surement, those intensities are already the result, while in MCD measurement type the 
intensities are used to calculate concentrations in %, ppm etc.

1.7.1 Basic measuring techniques

1.7.1.1 The MID measurement

First let’s have a look at the MID measurement. In this measuring type you declare the 
m/e ratios for which the intensities (ion currents) are to be measured. Each of these sin-
gle measurements is represented by a separate channel of the QMS, on which all 
parameters can be set.

Example: The m/e ratios (we call them «masses» from now on) 14, 16, 28 and 32 are 
to be measured.

1 Start the Parset program

2 Choose [Measure] > [MID]

3 Enter airsim2.mip in the file name field of the open dialog and confirm by [OK]

4 Quadstar 32-bit reports that this file does not exist (yet) and asks whether to cre-
ate it or not. Confirm the creation by [Yes].

5 The channel parameter editor appears:
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Fig. 1-18

6 Switch on the channels 0…3, according to the four masses of which we want to 
measure the intensities

7 Click in column CH-0, «State» row, on the field with the text OFF with the right 
mouse button

8 In the now appearing list that contains all possible values for this parameter 
(channel state: ENABLE/SKIP/OFF meaning active/currently inactive/off), click 
with the left mouse button on ENABLE

9 Switch on the channels 1, 2 and 3 in the same way. Now we have four active 
channels we can assign the four masses to.

10 Click with the right mouse button on the field CH-0, «Mass» row

11 Change the value from 0.00 to 14.00 and click with the left mouse button on the 
gray button on the left of the new value

12 Enter the masses 16, 28 and 32 in the other three channels in the same way

13 Click at the bottom of the editor with the left mouse button on the register card 
«Display». The editor should now display the following:

Fig. 1-19
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The other parameters have already been set to reasonable values by the basic initial-
ization and need not to be changed for the planned measuring task.

14 Close the file and save the changes by [OK]

15 Close the Parset program in order to get back to the Windows® Desktop

16 Now start the Measure program and choose [MID] > [Versus Time]. Perform the 
measurement with the parameter file airsim2.mip

17 Now you should modify some settings under [Parameters] > [Setup]

17.1 Y-Scale: Set to «log» in order to see small signals as well

17.2 Cycles: Enter 10, in order to get visible results quickly

17.3 Leave the rest of the settings in their standard conditions

17.4 Confirm the changes by [OK]. After a few seconds, the following will be dis-
played:

Fig. 1-20

You see the intensities of the masses versus the measuring cycles. At the right border 
you can see what mass is represented by which color.

18 Now click on the mass number 14.00 with the left mouse button and read its inten-
sity in the status bar. Read the intensity of the mass 32.00 as well. The intensities 
are almost equal, therefore the lines coincide. The displayed intensities are the 
ones of the last cycle.

19 Try the settings of [Parameters] > [Setup] and [Parameters] > [Channel]. You can 
still change the channel parameters under [Parameters] > [Channel].

20 Then close the measure program by [File] > [Close] and eventually [File] > [Exit]

1.7.1.2 How the MCD measurement works

The concentrations of the gases are determined by multiplying every intensity measured 
on a certain mass with a calibration factor (related to the gas to be detected) and solving 
the resulting equation system.

In other words: An MID measurement is performed and the parts of the gas are calcu-
lated by multiplying the intensities with previously determined factors. Those calibration 
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factors can not be declared universally, but they may be found and stored in a library by 
performing a GSC (Gas Specific Calibration) measurement using a calibration gas. The 
solution method provided with Quadstar 32-bit allows determination of gases as well, 
that occur on identical or partly identical masses in the spectrum.

1.7.1.3 Preparatory measurements

Because the gas components are always represented by integer mass numbers, the 
easiest way would be to measure the intensities on integer masses. The measure equip-
ment always causes small deviations between the nominal mass and the real peak max-
imum. Therefore, the (correct) maxima of the peaks are normally located a bit beside 
the theoretical number (e.g. 13.95 instead of 14.00). To perform the measurement with 
the highest possible precision, we use the measure type MSC (Mass Scale Calibration) 
to determine the exact positions of the peak maxima.

Mass spectrometer background
A possible cause for faulty measurements is the so-called «mass spectrometer back-
ground». It consists of gases that are present in the vacuum system which do not come 
from the sample to be measured. Because the background parts of a well-conditioned 
measuring equipment are nearly constant, they may easily be recorded by the Zero Gas 
measurement and eliminated in the actual analysis. The intensities recorded by the Zero 
Gas measurement can be subtracted from all subsequent MID/MCD measurements. 
This is selectable under [Parameters] > [Setup] > [Zero Gas Subtraction]. This way, the 
result consists only of the real parts of the analyzed gas.

1.7.2 Preparing the measurements

First we prepare all measurements , i.e. we create the required parameter files. Open 
the Parset program in order to do so.

1.7.2.1 Mass Scale Calibration
1 Choose [Calibration] > [Mass Scale]

2 Copy the file adjustms.msp to myadjust.msp by [Copy] and open it. This file is 
already prepared for measurements in simulation mode.

NOTE:
For real measurements the mass numbers must match the ones that really occur 
in the gas to be measured.

1.7.2.2 Gas Specific Calibration
1 Choose [Calibration] > [Gas Specific Sensitivity]

2 Copy the file airdemo.gcp to mysense.gcp by [Copy] and open it. This file is 
already prepared for measurements of air and does not require any modifications.

NOTE:
For real measurements, the gases that occur in the calibration gas bottles, their 
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concentrations and the occurring mass numbers must be entered. For every cal-
ibration gas mixture a new file must be created.

1.7.2.3 Analysis file
1 Choose [Measure] > [MCD]

2 Copy the file mcdmedf.mcp to mymcd.mcp by [Copy] and open it. This file is 
already prepared for measurements of air and does not require any modifications.

NOTE:
For real measurements, the gas components of the gas to be analyzed and the 
mass numbers to measure the intensities on must be entered.

3 Choose [Edit] > [Channel Par]. Make sure that the display of all measure channels 
is switched to OFF in the register card Display, «Disp. Mode» row. We do not 
want to display any ion currents but only the concentrations calculated from them 
by using the calibration factors

4 Finally you can define the range of concentrations to be displayed by [Edit] > 
[Concentration Par]. Choose Disp.F.S.R.=100% and DispDecades=4.

5 Then close all files and confirm by [OK] that they shall be saved

6 Eventually exit Parset

1.7.3 Measurements

Now perform the actual measurements. For that purpose start the Measure program. 
Let’s begin with the auxiliary measurements.

1.7.3.1 Calibrating the mass scale
1 Choose [Calibration] > [Mass Scale] and open the file myadjust.msp. 

Quadstar 32-bit performs the mass scale calibration and displays the newly found 
peak maxima. If in later measurements mass numbers are used that have not 
been calibrated, their positions will be interpolated from the calibrated values.

Fig. 1-21

2 Exit the window by [File] > [Close]

3 To let the mass scale calibration take effect, in the MID or MCD measurement 
under [Parameters] > [Setup] the option «Mass Scale Correction» must be 
checked
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1.7.3.2 Measure the zero gas

While you are working with simulated measure data, the Zero Gas measurement must 
not be performed. The simulated data are exactly the same for the analysis and the Zero 
Gas measurement. If you would perform a Zero Gas measurement here, then in a later 
analysis those values would be subtracted from the measured data and the results 
would be ion currents that are all zero.

NOTE:
In real measurements too, the Zero Gas measurement may only be done when the 
analysis chamber is on minimal pressure or a real zero gas has been let in. Oth-
erwise severe measurement errors may occur.

You will get more information about the Zero Gas measurement in Chapter 2.8.2 Back-
ground measurement (Zero Gas), 137.

1 Exit the window by [Close]

1.7.3.3 Calibrate the mass spectrometer
1 Choose [Calibration] > [Gas Specific sensitivity] and open the file mysense.mcp

Quadstar 32-bit carries out the gas specific calibration and shows the resulting gas com-
ponents, the ion currents and the calculated calibration factors. You will get more infor-
mation about the meaning of the calibration factors in Chapter 2.8 Calibration, 134.

Fig. 1-22

1.7.3.4 Measure and store concentrations

Now measure the composition of the gas. In order to store measuring conditions and 
comments additionally to the measure data, check the option «Save File Info».

1 Choose [Setup] > [File Info]

2 Check «Measurement Parameters» and «Save File Info»

3 Confirm the choice by [OK]
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Fig. 1-23

4 Choose [MCD] > [Versus Time] and open mymcd.mcp. The concentrations cal-
culated from the measure data are displayed versus the number of cycles. You 
will get more information about the calculation of concentrations in Chapter 2.6 
MCD measurement type, 103.

5 Try the settings here as well and note the influence of parameter changes

Fig. 1-24

6 To store data, choose [File] > [Save Cycle Data]. Enter myconc.mdc as the file 
name and confirm by [OK].

7 In the following dialog enter 30 for the number of cycles to be saved and confirm 
by [OK].

8 Then the File Info dialog appears, where you can comment and document your 
measurements. Enter notes etc. and confirm by [Save Measure Data + Info]
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Fig. 1-25

9 The measurement is started and 30 cycles are stored. This takes about 3 min-
utes. When the measurement is done, i.e. no text is displayed any more in the text 
field of the status bar, you can close the measurement and exit Measure.

1.7.4 Analysis

1.7.4.1 Display modes
1 Start Dispsav and choose [Process] > [Cycles]

2 Load the file myconc.mdc. The following will be displayed:

Fig. 1-26

You see all measured ion currents and concentrations. At the upper left corner, just 
below the menu bar, you see a list box that provides change over of the axis. At the 
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moment, the axis is set to concentrations in % (’Concentr. [%]’), which causes the con-
centration names on the right to be marked by a short vertical line.

3 Change the axis to ion currents (’Ion Current [A]’), so the axis changes and the 
mass names are marked as valid

4 You may magnify these stored data as well

4.1 Choose [Function] > [Magnify]

4.2 Set the cursor to the upper left corner of the area to be enlarged (e.g. Cycle 
0, 4.0[E+01%] ) and press the left mouse button

4.3 Drag the cursor to the lower right corner of the desired area (e.g. Cycle 25, 
0.5[E+01%] ) while still holding the left mouse button pressed and press the 
right mouse button additionally

4.4 Now release both mouse buttons

5 From the stored data as well, you are only interested in the concentrations and 
therefore you want to hide the ion currents. Choose [Select] > [Blocks]. The fol-
lowing dialog appears:

Fig. 1-27

Under «Available Blocks» you see the existing blocks, i.e. concentrations and ion cur-
rents. Under «Selected Blocks» you see the selected ones, which are at the moment all 
available blocks.

6 Under «Selected Blocks» select the entry «Ion Current» and press [Remove]. 
Now, only the data block concentrations is selected.

7 Confirm this choice by [OK]. Only the concentrations are displayed now.

Apart from the display Versus Time shown above (Intensity (Concentration) Versus 
Time, IVT) there are also table and bargraph display modes.

8 Change the cursor function from magnification to selection by choosing [Function] 
> [Cursor]

9 Press the left mouse button and drag the cursor (which now appears as 
crosshairs) across the measure display. The exact x-and y-position is displayed 
in the status bar.

10 Now drag the cursor to Cycle number 10 while still holding the left mouse button 
pressed. Press the right mouse button additionally and release both. You see the 
data of measure cycle 10 represented as a table. Individual measure values can 
be changed manually by [Change].
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Fig. 1-28

11 Now choose [Bargraph], so the measure data of the chosen cycle are displayed 
as a bargraph

Fig. 1-29

12 Return to the display type «Intensity Versus Time» by choosing [Display] > [IVT]

1.7.4.2 Display additional data as a table

Quadstar 32-bit calculates from all displayed process data (MID, MCD, calculated val-
ues etc.) statistical and integral data that can be displayed as a table. If you have chosen 
a detail display by Magnify, the statistical data will be calculated only for the current 
detail area.
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• [Display] > [Statistic] provides statistical analysis of the cycles. For every item mini-
mum, maximum, mean value, absolute and relative standard deviation are calculat-
ed and displayed.

• [Display] > [Integral] shows the integrals of all items across the time

1.7.4.3 Print data

To get a hardcopy of the measured data there are two possibilities:

[File] > [Print]
Use this to print the displayed measure data as a table. In our case it doesn’t make 
sense to print all data, so we only want the concentrations of the components Ar, N2, O2 
and CO2 of the cycles 1…5.

1 Choose [Setup] > [X Axis]

Fig. 1-30

2 Enter Start Cycle 1 and End Cycle 5

3 Set the Axis Type to «Time Absolute» to have the x-axis labeled for time

4 Then press [OK]

5 Now choose [Select] > [Data] and check whether the chosen components are 
those you want to print

6 If so, then close the Select Data dialog and choose [File] > [Print]. If the printer is 
ready, the table will now be printed.

Key combination CTRL+SHIFT+F12
Use this to print the currently displayed window of Quadstar 32-bit or the complete 
screen. This way you can easily get screenshots of measurements, settings etc. To 
make such screenshots even richer, there is a graphic editor in Dispsav:

7 Choose [Function] > [Graphic Editor]. The following toolbar will appear:
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Fig. 1-31

8 Click on the tool [T] to enter a text. Then click on the spot in the display, where 
the text shall begin. In the Text Editor dialog enter the text (e.g. «Simulated Air 
Measurement») and confirm by [OK].

9 Now we draw a frame around the title: Click on the tool [FRAME] and set the cur-
sor to the upper left corner of the frame to be drawn. Drag the cursor to the lower 
right corner of the desired frame while holding the left mouse button pressed. 
Release left mouse button. Your measure image should now display the follow-
ing:

Fig. 1-32

10 Exit the graphic editor with the tool [EXIT] and confirm that the changes are to be 
saved

11 You should not change the window size of the picture to be printed any more, 
because the size and position of the title wouldn’t be matched to the new window 
size

12 By [Display] > [Graphic Data] you can switch the display of the just created addi-
tional graphic data on or off

13 Make sure the printer is ready. Then press the key combination 
CTRL+SHIFT+F12, so the Print Screen dialog appears.

14 Choose the active window as the printing region and 1.0 as the zoom factor

15 Confirm the settings by [OK]
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Fig. 1-33

The picture is now printed in the same manner as it is displayed on the screen.

1.7.5 Auxiliary tools

1.7.5.1 Documentation

With the measure data you have stored a documentation consisting of measure param-
eters and notes

1 You can recall this documentation by [Info] > [File]:

Fig. 1-34

2 Press [Measurement Parameters] to see the measurement parameters or [About 
File] to get the general file information. The entries of «Additional Information» 
and «Notes» can still be modified.

3 Exit the File Info dialog by [OK]. Use [Cancel], if you don’t want to save changes.
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1.7.5.2 Filter

If your measure data contain a lot of noise (of course, our simulation data contain very 
low noise), you can smoothen them now by using the filter of Dispsav.

1 Choose [Special] > [Filter...], so the following dialog appears:

Fig. 1-35

2 First get a new file by the [File Manager] that will hold the filtered data. Otherwise 
the original data would be overwritten.

3 Press [Start]. The raw data are filtered and stored to the new file.

1.7.5.3 Interpretation support

In Quadstar 32-bit there is a table of key fragments ([Help] > [Key Fragment Ions]), that 
supports the interpretation of spectra. See Chapter 1.9.1 Spectrum interpretation, 56.
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1.8 Measuring real gas components
Now you have learned the basic procedures and possibilities of Quadstar 32-bit by 
using simulated data. If you change over to real measurements with the mass spectrom-
eter, you must check the following:

1 Start Parset and choose [Comm] > [Connect]

2 Switch off the simulation mode by setting the Simulation Mode to Off. See 
Chapter 1.5.2 Choose operating mode «Simulation», 34.

NOTE:
Otherwise you will never get real measure data, but always the simulated ones 
that are completely unrelated to your vacuum system.

3 Switch on the emission, SEM if necessary. If you are sure that the pressure in the 
vacuum chamber is low enough, press the key combination CTRL + S.

4 Check Emission (and SEM, if you want to use the SEM). In the status bar of Par-
set the emission symbol (and SEM Symbol if necessary) changes its color from 
gray to yellow.

Now you should be able to perform your own measurements. You will find detailed 
instructions about that and about subjects that haven’t been explained here (e.g. ion 
source tuning) in the following chapters or in the (equipment-)specific operating manu-
als.
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1.9 Hints concerning the work with Quadstar 32-bit

1.9.1 Spectrum interpretation

Sometimes you may want to know what a peak on a certain mass means, if you didn’t 
expect it e.g. There is a «Key Fragment Ions» table that shows mass number, key frag-
ment, possible parent molecule and additional mass numbers. It may help you to find 
the desired information.

1 You can access the table through the main menu of any Quadstar 32-bit module 
by [Help] > [Key Fragment Ions] or by the key combination Ctrl + L

The example below shows the corresponding entry of the Dispsav module:

Fig. 1-36

2 First have a look at the main mass number (e.g. 12) to determine the key fragment

3 Then compare the additional mass numbers with the ones in your spectrum

4 Try to find the parent molecule that matches your spectrum most accurately (e.g. 
if there is an additional peak on mass number 13 and none on 28, the molecule 
is most likely to be CxHy and not CO or CO2)

Fig. 1-37

Of course there are much more sophisticated methods to analyze a spectrum, but in 
many cases the Key Fragment Ions table is sufficient.
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1.9.2 Starting the Quadstar 32-bit programs

The programs are started from the Windows® start menu. Click the Windows® START 
button, select the “programs” folder, select the entry “Quadstar 32bit” and finally click te 
the corresponding icon of the program needed. Note that changes made in Parameter 
Setup program such as Communication, Setup Configuration etc. are not going to take 
effect in other programs until they are restarted.

1.9.2.1 Open a program with a certain file

If you intend to open a Quadstar 32-bit program always with a certain file, you may 
declare its name in the properties of the shortcut in the Windows® start menu.

Example: You want to see the measure data of airdemo.sac immediately, if you open 
the DISPSAV-program.

1 Right click the shortcut to “DISPSAV” and select “Properties”

2 Enter the name of the data file (airdemo.sac) in the field “Target” behind the pro-
gram’s name (in this case DispSav.exe). Seperate them with a single space.

Fig. 1-38

Of course, you can copy the shortcuts and give them different descriptions and files, e.g. 
in order to start different measurements directly.

For detailed information about managing the start menu and shortcuts please refer to 
the Windows® documentation or online-help.
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1.9.2.2 Automatic start of a program

For automatically starting a measurement, sequence or data display when the PC is 
turned on, an icon that is modified as follows can be inserted into the Startup entry of 
the start menu.

Example: When the PC is booted, you want the measure data of airdemo.sac to be dis-
played automatically with the Dispsav program:

Fig. 1-39

1 Copy the icon «Dispsav» into the folder «Startup»

2 Change the description and the command line under «Properties» as shown 
above

When you turn on the PC and start theWindows® OS, the Dispsav program will be 
started automatically, showing the measure data of airdemo.sac.

For detailed information about the startup folder, please refer to the Windows® docu-
mentation or online-help.

For additional information refer to the Windows® Program Manager description under 
«Starting Applications from the Startup Group».

1.9.3 Transferring screens via the clipboard

Windows® uses a simple method for transferring screens via the clipboard. The clip-
board is a temporary memory that is always available as long as Windows® is active. 
The screens (dialog boxes, etc.) can be copied from Quadstar 32-bit, pasted into the 
clipboard, and then transferred from there into other application programs.

1.9.3.1 Copying an entire screen

The contents of an entire screen can be copied into the clipboard at any time:

1 Make sure that the required information is shown on the screen

2 Press the PRINT SCREEN key

A «snapshot» of the screen is transferred to the clipboard.

1.9.3.2 Copying an active window

You may as well copy the active window only to the clipboard:
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1 Make sure that the required information is shown on the screen

2 Press ALT + PRINT SCREEN key

A «snapshot» of the active window is transferred to the clipboard.

1.9.4 Inserting screens from the clipboard

The screens in the clipboard can be inserted (using SHIFT + INSERT) at any time into 
other programs such as Windows® Word®, Paint®, etc.

Additional information can be found in the Windows® help files.

1.9.5 Save or print Quadstar 32-bit screens

With Quadstar 32-bit you can print or save the active window or the entire screen as a 
picture

1 Call the Save/Print Screen dialog box in any Quadstar 32-bit program by pressing 
the key combination CTRL + SHIFT + F12 (or CTRL + SHIFT + ALT + F2). The 
following dialog box appears:

Fig. 1-40

Control elements Region
Selection of the region to be captured.

• Active Window: The active window will be captured
• Entire Screen: The entire screen will be captured

Bitmap to...
Device to save or print the captured picture.

• Printer: Print out the picture on the active printer
• File (.BMP): Save the picture as a file using the Windows® bitmap format

Printer Option
• Zoom Factor: Magnification factor for the picture to be printed
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2. Measure

Measure is used for capturing or displaying and storing ion currents, analog input sig-
nals, ion counter signals, etc. Concentrations can be calculated from the raw data via 
calibration matrices. With the sequencer, automatic measurement and control 
sequences may be programmed.

When the Measure program is started, Quadstar 32-bit attempts to establish a connec-
tion to the quadrupole mass spectrometer based on the selected transmission mode 
(only for RS232C or ArcNet). If successful, the LED symbolically displayed in the lower 
left corner of the active window changes to green. If the QMS is not connected or not 
switched on, a corresponding error message is output.

After the fault has been remedied, the connection setup can be reinitiated by [Comm] > 
[Connect].

2.1 General information

2.1.1 Measuring with Quadstar 32-bit

2.1.1.1 Measurement types

In Quadstar 32-bit there are different types of measurements:

Scan Analog
Continuous measurement of the ion current as a function of the mass. Representation 
as a curve across the chosen mass range.

Scan Bargraph
Search for peaks across the chosen mass range. The found peaks are represented as 
vertical lines over their masses.

MID
Multiple Ion Detection. On one or several predefined masses the ion current is mea-
sured. Various representation types.

MCD
Multiple Concentration Detection. On one or several predefined masses the ion current 
is measured and concentrations are calculated with them. Various representation types.
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2.1.1.2 Measurement methods

Quadstar 32-bit provides different measurement methods for all measurement types 
(Scan Analog, Scan Bargraph, MID and MCD). The measurement method may be 
defined in advance ([Scan] > [Setup] > [Analog], [MID] > [Setup] > [Table] etc.), or later 
within the measurement ([Parameters] > [Setup]).

Single
The measurement is performed once and then stopped. By [Operation] > [Go] or when 
a new measurement is loaded it can be restarted.

Repeat
The measurement is continuously repeated. The speed depends mainly on the Speed 
or Dwell-time specified in the channels. Repeat measures continuously without interrup-
tion.

Timer
The measurement is restarted in the intervals defined under Timer Step.

Dynamic
Is a special measurement mode and only available for MID/MCD measurements. See 
Chapter 2.1.1.4 Fast MID/MCD measurements, 62.

2.1.1.3 FIR Filter

In Scan Analog and Scan Bargraph mode, a FIR (Finite Impulse Response) filter can be 
activated by setting the mode of SCAN-N or PEAK-L to SCAN-F or PEAK-F in the chan-
nel parameter editor (in group «Mass»).

2.1.1.4 Fast MID/MCD measurements

In Multiple Ion Detection (MID) or Multiple Concentration Detection (MCD) mode, 
Quadstar 32-bit provides different possibilities of data acquisition ([MID/MCD] > [Setup] 
> [Versus Time]):

• In method Single, Repeat and Timer:
• Measure and Display
• Display after Measurement

• The method Dynamic
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Fig. 2-1

The actual measurement method (Single, Repeat, Timer, Dynamic) is selected in the 
upper left corner in the group «Measurement». The display mode (Measure and Display, 
Display after Measurement) is selected in the group «Measure/Display Mode» in the 
lower right corner.

Measure and Display
If fast measurements are to be performed over longer periods of time, «Measure and 
Display» is the right mode to use. Cycle by cycle is measured, transmitted to the PC and 
displayed.

Fast measurement with concurrent saving of data
When the save function is activated (in MID or MCD mode, [File] > [Save Cycle Data]), 
the following dialog box is displayed:

Fig. 2-2

To achieve a higher speed, unmark the checkbox «Display» to switch off the display. 
The PC doesn’t consume computing power for the display then and it stores at maxi-
mum speed instead. If you have a fast graphics cards the effect of «Display» is small. 
Of course, the channel parameters have to be set accurately (short Speed/Dwell times). 
Please note that higher speed means lower measuring accuracy.

NOTE:
Close all Windows® applications that are not needed at the moment.
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If the currently stored measurement cycle should be displayed continuously in 
the status bar, activate «Display» and switch the display function for all channels 
in the channel parameter editor off (in group «Display»).

Display after Measurement
Very fast short time measurements can be achieved using the «Display after Measure-
ment» mode. The measurement is performed with the chosen speed. The data is stored 
in the internal buffer of the QMS and when the job is done, the data is transferred to the 
PC. The disadvantage is that the number of buffered measurement data is limited by the 
capacity of the internal buffer in the control unit. Therefore it is possible that the desired 
number of cycles is not achievable.

NOTE:
Please take into account that the «Display after Measurement» mode is always 
faster than «Measure and Display».

Dynamic Measurement
This measurement method is a combination of the two above-mentioned. It provides 
best measure speed for slow or irregular communication lines. The measure data is 
stored in the buffer of the QMS and concurrently transferred from there to the PC as fast 
as possible. The transmission speed can be optimized by the Performance Test. See 
Chapter 2.5 MID measurement type, 87 and Chapter 2.6 MCD measurement type, 

103. If the buffer overflows, the measurement is stopped, the buffer flushed and the 
measurement started again. In that case, Quadstar 32-bit reports «Measure data drop-
out, measurement too fast», because there was a period of time when no measurement 
was on.

2.1.2 Choosing the measuring range

In Quadstar 32-bit, the measuring range can be adapted manually or automatically. 
Open the channel parameter editor and click on the register card «Amplifier». If you 
choose [Amp. Mode] > [FIX], then you can enter the measuring range under [Amp. 
Range]. By [Amp. Mode] > [AUTO] or [AUTO D] the QMS can be instructed to find the 
correct measuring range automatically:

Fig. 2-3

AUTO
The measuring range is chosen automatically from all available ranges.

AUTO D
The measuring range is chosen automatically from all ranges between the highest (most 
insensitive) and Range-L.
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2.1.3 Status bar

Information concerning the measurement in progress as well as the status of the emis-
sion, the SEM and the simulation are displayed on the status bar. In ArcNet mode the 
name of the QMS is also shown.

Fig. 2-4

Control elements

2.1.3.1 Message text output during the measurement

In the text field of the status bar messages are output. In manual mode the output is 
done automatically. In sequencer mode any text can be output using the sequencer 
command Message(). 

Example: The output of the message text «Saving cycle 1 of 31 to sca1310.sca» origi-
nates from a manually started Scan Analog measurement with data storage.

Fig. 2-5

2.1.4 Configuring the graphic display range

The graphic display range can be set up in channel parameter editor, register card «Dis-
play». Both of the parameters [Disp. F.S.R.] (Display Full Scale Range, upper limit of 
display) and [Disp. Decades] (number of decades to display) may be selected manually 
or automatically (AUTO).

Symbol Significance

Symbol for emission. Orange light when active.

Symbol for SEM operation. Orange light when active.

Simulation ON

SIM on/off. See Chapter 3.7.2 General setup parameters, 
226

Name of the selected QMS in operation via ArcNet.

The name is entered in the Parset program under [Comm] > 
[Unit Identifications].

In order to make use of the QMS, it has to be activated under 
[Comm] > [Unit Identifications] by the checkbox «Enable».

Within a sequence, you can switch over between the activated 
QMS units by the instruction SetUnit().
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Fig. 2-6

2.1.4.1 Upper limit of display (Disp. F.S.R.)

AUTO
Quadstar 32-bit chooses the upper display limit automatically according to the other 
channel parameters.

Manual
The channel parameter editor shows all possible upper limits. Click with the right mouse 
button on the field [Disp. F.S.R.]. The choice may be restricted by other channel param-
eters.

2.1.4.2 Number of decades to display (Disp. Decades)

AUTO
Quadstar 32-bit chooses the number of decades to display automatically according to 
the other channel parameters which determine the maximum number of displayable 
decades. Particularly the resolution of the measured signal is a limiting factor. Example: 
10 bits of resolution equals a range of 0…1024, i.e. three decades.

Manual
The channel parameter editor shows all possible numbers of decades to display. Click 
with the right mouse button on the field [Disp. Decades]. This choice may be restricted 
by other channel parameters as well.

If the parameters Disp. F.S.R. and Disp. Decades are not the same for all channels, the 
display range is selected in such a way that the measurement signals of all channels 
can be displayed in the same chart.

The displayed measure signal may be distorted if e.g. Amp.Range is not set adequately.

Example: Measured signal, 16 bits resolution, highest value 5E-14 A, Amp. Range 1E-
9 A. By reducing the Disp. F.S.R. manually to 1E-13 A, the displayed signal looks stair-
like. This effect is caused by the internal quantization of the mass spectrometer.
66 Measure vpnb68e1 (0302), Quadstar 32-bit



Therefore, make sure the manually selected parameter values match each other, or use 
the AUTO mode.

Example: Scan Analog (First Mass =10, Width = 40, Speed = 1 s/amu) with the following 
settings:

• Amp Mode: Auto (Amplifier register card of the Channel Parameter Editor)
• Decades: 5
• Disp. F.S.R.: 1.0E-8

Fig. 2-7

2.1.4.3 Display range in sequencer operation

For displaying all possible values (e.g. values calculated by the Process() instruction), 
the range for sequences is selectable separately under [Sequence] > [Setup] > [Display 
Range]. These settings are valid if nothing else is specified by the SetScale() instruction.

Fig. 2-8

Control elements Display Ranges
• Maximum: Largest decade to be displayed
• Decades: Number of decades to be displayed
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2.1.4.4 Y-axis lettering (MID/MCD)

Fig. 2-9

The Y-axis lettering can be changed between display in % (concentrations), Amperes 
(for ion currents) and other units of measure (for example, for analog input measurement 
values, etc.)

Total pressure values
• QMS 422/421: The total pressure values are marked with [Pirani] and/or [Cold Cath-

ode]
• QMS 200: The total pressure values are marked with [TPR 250] or [PKR 251]

Marking the affiliation
The affiliation with the Y-axis is marked by identifying the names of the components, the 
names of the AI channels, or the mass numbers of the ion currents (in the table) with a 
vertical line.
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2.1.5 Documenting the measurement data (File Info)

To make measure data evident and reproducible, you can store a documentation with it 
in Quadstar 32-bit. This may include measurement parameters, notes, title etc. In the 
main menu under [Setup] > [File Info], check the option «Save File Info», so the following 
dialog appears when you store measure data:

Fig. 2-10

Control elements Parameters/Data to save
Here you can check which parameters and files you want to store together with the mea-
surement data.

• Measurement Parameters: Measure and channel parameters
• Ion Source Parameters: Current settings of the ion source
• State Parameters: Status information
• Zero Gas Data: Zero gas data that was used for this measurement

Additional Information
In these fields you can enter up to 20 user-defined parameter sets (a name and a value 
each). The previously used entries appear here by default.

• [Delete All Names]: Delete all user-defined parameter names
• [Delete All Values]: Delete all user-defined parameter values

Notes
Notes related to the current measurement (up to 1000 characters of text).

Title
Enter a title for the file (shows up in the file manager).

[Save Measure Data + Info]
Save measurement data and documentation.

[Save Measure Data Only]
Save only the measurement data (without documentation).
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[Cancel]
Cancel data storage.

If data are appended (Append) to an existing data file, but these data have been 
obtained with a different parameter setup than the original data, the documentation is 
always related to the first measured data.

NOTE:
In measure mode (menu [File] > [File Info Notes]) or when recalling data (Display 
Saved Values under [Info] > [File]) you can add additional notes to report special 
events or make clear under which conditions the individual sections of the mea-
surement data file have been created.

2.1.6 Multiplex operation with several control units

If Quadstar 32-bit is run with the optical HUB via the ArcNet-interface, simultaneous 
operation of several control units type QMS 422/421 or QMS 200 is supported.

The configuration is defined in the Parameter Setup program. For each control unit 
declared in the network, a separate path is set up in which the equipment-specific 
parameters and files are stored. After they have been configured, the individual control 
units can be logged on or off the network.

For detailed information on configuring, activating the individual control units etc. see 
Chapter 3.6.2.4 Communication via ArcNet, 211.
70 Measure vpnb68e1 (0302), Quadstar 32-bit



2.1.7 Calibrating the measurement equipment

For simple overview measurements with little accuracy, no calibration is necessary. If 
you want to carry out high precision measurements, Quadstar 32-bit supplies methods 
(depending on the QMS) to compensate different effects that otherwise would cause 
deviations. The following shows an overview of these effects and how they are handled 
in Quadstar 32-bit. The corresponding steps and further information are found in 
Chapter 2.8 Calibration, 134.

Mass scale
The nominal mass scale doesn’t match the real masses exactly. These deviations are 
mostly small, nonlinear and unsystematic. By means of selected known masses, those 
deviations are measured and corrected. See Chapter 2.8.1 Mass scale calibration 
(Mass Scale), 134.

Background
In the vacuum chamber there’s some pollution, also referred to as residual gas back-
ground. Those gas contributions can be subtracted from the measured data so that only 
the contributions from the gas to be measured remain. See Chapter 2.8.2 Background 
measurement (Zero Gas), 137.

Measure amplifier
The amplifier in the QMS that amplifies the (very small) ion currents to be measured 
causes different offsets in the different measure ranges. These offsets can be measured 
and subtracted from the actual measure data (only QMS 422/200). Since the offsets drift 
over longer periods of time, this calibration should be repeated periodically. See 
Chapter 2.8.3 QMS Offset, 140.

Detector
Besides the ions to be measured, the detector is hit as well by accidentally appearing 
ions. This causes another kind of offset which can be measured on a mass where there 
is no peak (channel parameter «Zero Mass», default: 5.5 amu) and then be subtracted 
(only QMS 422/421, in measure modes MID/MCD). This correction is performed for 
each channel before the measurement, if «Zero Mass» is not set to OFF. While the cor-
rection is in progress, the message «Channel x: Zero Equalize in progress» is displayed 
in the status bar. See Chapter 2.5.3 Offset alignment, 90 and Chapter 2.6.4 Offset 
alignment, 108.

Sensitivity
For concentration measurements (MCD mode), the gas specific sensitivity of the QMS 
must be determined. For that purpose, the relative sensitivity of the mass spectrometer 
is determined on several masses by using a special calibration gas. See Chapter 2.8.4 
Gas specific sensitivity, 142.
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2.1.8 Measurement of analog input signals

In MID and MCD mode Quadstar 32-bit supports the capture of measurement data via 
analog inputs. The number of channels depends on the available hardware:

• QMS 422/421: 16 analog input channels of the AI 421 board, which can be installed 
as an option in the QMS 421/422, are available. Measurement range: -
10.24…+10.24 volts.

• QMS 200: The QMS 200 has two analog inputs as a standard feature. The number 
of inputs cannot be expanded. Measurement range -5.12…+5.12 volts.

In the channel parameter editor the analog input channels can be assigned to the indi-
vidual QMS channels under «Det. Type» in the «Main Param.» group. The selected ana-
log input channel is subsequently used as a signal source for the QMS channel.

The characteristic curve (AI curve) of the connected sensor can be assigned in the 
Parameter Setup program to each AI channel that is used.

Default values of the AI characteristic curve
Quadstar 32-bit is shipped with all available channels (QMS 422/421: 0…15, QMS 200: 
0, 1) programmed with a linear characteristic for positive values in millivolts. Thus, an 
input voltage of 0.100 V is interpreted as 100, 5.000 V means 5000 etc.

Fig. 2-11

Fig. 2-12
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For additional information on analog inputs please see Chapter 3.8.3 Analog input char-
acteristic curve configuration, 238.

2.1.9 Total pressure monitoring

In MID and MCD mode (manual and sequencer operation), Quadstar 32-bit also sup-
ports the measurement of the total pressure if the corresponding hardware options 
(PI 420 and/or PE 420) are installed in the QMS 422/421, or if a TPR 250 or a 
PKR 250/251 is connected to the QMS 200.

The total pressure gauge heads can be selected as the signal source in the Detector 
group of the channel parameter editor. The measured data can be displayed and stored.

Turning the PE 420/TPR 250 option ON/OFF
Whereas the PI 420/TPR 250 hardware is always active, the PE 420/PKR 250 gauge 
head must be turned on and off. Turning on and off is done by Quadstar 32-bit, but the 
procedure is different for operation with or without sequencer. The following should be 
noted:

• The PE 420 (QMS 422/421) or PKR 250/251 (QMS 200) hardware option is not con-
tinually ON because the plasma in the cell may interfere with the gas composition

• Quadstar 32-bit only turns on the high voltage if in the current MID/MCD parameter 
file for at least one channel under Detector the PE 420 or PKR 251 option has been 
chosen as signal source

• The high voltage is turned off again when the corresponding measurement type 
(MID, MCD, Sequencer) is terminated

• Please note that it may take some time before the gauge head ignites and indicates 
the correct pressure. See instruction manual of the gauge head.

Operation without sequencer
In manual operation, i.e. when an MID or MCD measurement is started directly via the 
menu, Quadstar 32-bit tests the parameter file and activates the PE 420/TPR 250 hard-
ware if PE or PKR/TPR has been selected as the detector in at least one of the activated 
channels. After the measurement the PE 420/TPR 250 hardware is switched off again.

Operation with sequencer
In sequencer mode, the PE 420 hardware should be switched on by using the keyword 
TotGauge=on available in the SetQMS() commands.

When the sequence is loaded, a sequence test is performed to check whether or not the 
PE 420/TPR 250 hardware is needed in an MID or MCD measurement and, if so, 
whether the SetQMS(TotGauge=on) command is used in the sequence. If this com-
mand is missing, the sequence test displays a warning that the PE 420/TPR 250 hard-
ware will only be switched on immediately before the measurement.

As with manual operation, the PE 420/TPR 250 hardware is switched off when the 
sequencer is terminated.

QMS 200 (Prisma™) using External Protection
If you run a QMS 200 Prisma™ in conjunction with a PKR 250/251 and you have 
selected in Parset program under [Config] > [QMS] > [Protection (SEM+FIL)] the option 
EXTERN or EXT-PROT, then the PKR 250/251 is used for pressure monitoring to pro-
tect filament and SEM. Therefore it stays switched on continuously. Switching it off by 
sequencer command would cause a malfunction.
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2.2 Measurement main menu

Fig. 2-13

Menus File
Display the Quadstar 32-bit Measure program version and terminate the program. See 
Chapter 2.3 File menu, 75.

Scan
Measurement program for Scan Analog and Scan Bargraph mode. See Chapter 2.4 
Scan menu, 76.

MID
Measurement program for Multiple Ion Detection (MID) measurement type. See 
Chapter 2.5 MID measurement type, 87.

MCD
Measurement program for Multiple Concentration Detection (MCD) measurement type. 
See Chapter 2.6 MCD measurement type, 103.

Sequence
Starting a sequence. See Chapter 2.7 Measuring with the sequencer (Sequence), 

120.

Calibration
Calibration programs. See Chapter 2.8 Calibration, 134.

Manual
Operation/display of the digital input and output channels (DI/DO). See Chapter 2.9 
Manual Parameters, 145.

Comm
Switch the communication to the QMS on/off. See Chapter 2.10 Communication menu, 

147.

Setup
Switch the emission and the SEM on/off. See Chapter 2.11 Setup, 148.

Help
Display the «Key Fragment Ions» table and help contents. See Chapter 1.9.1 Spectrum 
interpretation, 56.

NOTE:
The measurement programs are dependent on the parameter files created in the 
Parameter Setup Program. If any configuration changes are made ([Parameter 
Setup] > [Config]), Measure must be restarted before the changed parameters can 
be used.
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2.3 File menu

Fig. 2-14

Submenus About Measure
Information on the Measure program. See Chapter 2.3.1 About Measure, 75.

Exit
Quit the Measure program. See Chapter 2.3.2 Exit, 75.

2.3.1 About Measure

Under this menu entry the version number of the Quadstar 32-bit Measure program is 
displayed:

Fig. 2-15

2.3.2 Exit

Quit the Quadstar 32-bit Measure program.
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2.4 Scan menu
Use this menu to select the scan measurement type.

Fig. 2-16

Submenus Analog
Start Scan Analog measurement. See Chapter 2.4.2 Scan Analog, 77.

Bargraph
Start Scan Bargraph measurement. See Chapter 2.4.3 Scan Bargraph, 82.

2.4.1 Setup submenu

Setup activates a submenu to setup the scan measurement:

• Analog: Input of control parameters for the Scan Analog measurement type. See 
Chapter 2.4.2.5 Setup parameters, 80.

• Bargraph: Input of control parameters for the Scan Bargraph measurement type. See 
Chapter 2.4.3.4 Setup parameters, 85.

NOTE:
The measurement can only be started if the communication with the QMS is acti-
vated. See Chapter 2.10 Communication menu, 147.
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2.4.2 Scan Analog

Open the Quadstar 32-bit file manager by choosing [Scan] > [Analog]. It offers the 
already existing measurement parameter files for Scan Analog (e.g. airdemo.sap) to 
choose from.

Fig. 2-17, 77 shows the measurement of three analog spectra. The status text «Num-
ber of mean value cycles» appears when the entry «Mean Value of Scans» is marked 
in the «Scan Analog Setup» dialog box.

Fig. 2-17

NOTE:
Multichannel operation, i.e. measurement of different scans within the same cy-
cle(s), can be activated in the channel parameter editor by setting several chan-
nels to State=Enable. By [Parameters] > [Setup] the display can be set up.
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2.4.2.1 Scan Analog measurement menu

The acquisition and display of the Scan Analog measurement data is controlled via the 
following menu:

Fig. 2-18

Submenus File
Handling of parameter and measurement data files and return to the main menu of the 
Measure program. See Chapter 2.4.2.2 File submenu, 78.

Operation
Start/Stop the measurement. See Chapter 2.4.2.3 Operation submenu, 79.

Parameters
Parameter handling for control (display) and measurement parameters. See 
Chapter 2.4.2.4 Parameters submenu, 79.

2.4.2.2 File submenu

Fig. 2-19

Load Parameter
Load a different measurement parameter file and start the measurement.

Save Cycle Data
Store the next cycle(s) as a Scan Analog measurement data file. Cycle data can be 
stored only if «Temporary Save» has been turned off in the «Setup» dialog box.

After having chosen the measure data file in the file manager, the «Cycle Save» dialog 
box is displayed in which the number of cycles can be entered which are to be measured 
and stored:

Fig. 2-20

If an existing file containing compatible measurement data is selected, the new data are 
alternatively appended (Append) or the file is overwritten (Reset).
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Save Reference
Store the next cycle as a Scan Analog reference data file.

Load Reference
Load a reference file to compare with the current measure data.

Close Reference
Close the reference file.

File Info Notes
Add notes and remarks to the documentation and store them.

Close
Quit the Scan Analog measurement type. A cycle that has been stopped will not be 
saved.

NOTE:
Do not modify the setup or channel parameters during the storage and don’t 
change the size of the measure window. Otherwise the measurement is started 
anew.

2.4.2.3 Operation submenu

Fig. 2-21

Go
Start the measurement.

Halt
Stop the measurement.

2.4.2.4 Parameters submenu

Fig. 2-22

Setup
Enter various parameters that control the type of measurement as well as the display of 
the measured data.

Channel
Modify the current measurement parameters (channel parameters).
Quadstar 32-bit, vpnb68e1 (0302) Measure 79



2.4.2.5 Setup parameters

Choose [Parameters] > [Setup] to enter the setup parameters:

Fig. 2-23

Control elements Measurement
• Single: Only one Scan Analog measurement (1 Cycle) is performed
• Repeat: Repetitive measurement of the activated channels
• Timer: The measurement is periodically restarted

See Chapter 2.1.1.2 Measurement methods, 62.

Y-Scale
• Lin: Linear display of measurement data
• Log: Logarithmic display of measurement data

Scan Arrangement
Arrangement of the scans if several scans are to be displayed.

• Vertical: The individual scans are arranged one below the other
• Horizontal: The individual scans are arranged side by side

Display Mode
Display mode if a reference is loaded. In this case, the current measure values (Cur-
rent), the reference values (Reference) and the difference between both (Difference) 
can be displayed.

• Multi Chart: Current, Reference and Difference are each displayed in an individual 
diagram with individual axes

• Single Chart: Current, Reference and Difference are displayed in the same diagram 
with the same axes

• Current: Display current measure values. The color of Current is determined by the 
channel parameters under [Parameters] > [Channel] > [Display] > [Color].

• Reference: Display values of the reference measurement. The color of Reference 
correspond to the ones of Bar Reference and Bar Last/Difference found in Parset 
program under [Config] > [Screen Color]. 
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• Difference: Display difference between Current and Reference. The color of Differ-
ence correspond to the ones of Bar Reference and Bar Last/Difference found in Par-
set program under [Config] > [Screen Color].

• Decades: Number of decades to display the difference

NOTE:
Reference and Difference are only available if a reference measurement has been 
loaded before by [File] > [Load Reference].

Save Data As
Determine the data that is to be saved:

• Difference: Save difference between Current and Reference.
• Current: Save current measure values (Current).

Temporary Save
Save the measurement data in a temporary file. When the measurement is stopped, a 
dialog box for entering a file name is displayed. Exactly the values displayed in the mea-
surement window are stored, even a started (incomplete) cycle and a remaining part of 
the preceding cycle.

When this option is chosen, it is not possible to save data by [File] > [Save Cycle Data].

Mean Value of Scan
Performs continuous calculation of mean values during the measurement.

Timer Step
Timer interval for the measurement method Timer.

2.4.2.6 Channel parameters

Choose [Parameters] > [Channel] to change the QMS channel parameters.

Operating modes For a Scan Analog measurement you can select the following operating modes in the 
channel parameter editor. Click [Parameters] > [Channel] > [Mass Mode].

• SCAN-N: Scan Analog measurement. The intensities are recorded in the form of a 
mass scan.

• SCAN-F: Scan Analog measurement with FIR filter. The intensity values are addi-
tionally subjected to an FIR (Finite Impulse Response) filter algorithm. This filter 
largely eliminates superimposed noise from the raw electrometer signal. In this way 
also very small peaks can be detected against the background.

Integral scan For measuring e.g. the total pressure, an integral scan can be produced. To activate it, 
set the Resolution parameter in the group «Mass» to OFF.

Interface load In Scan Analog the interface load is the highest because up to 64 measured values per 
amu are transmitted. At a scan speed of < 0.5 s/amu this can lead to a relatively high 
load on the interface and the computer. If the measurement data are not stored but only 
displayed graphically, a lower data rate should normally be adequate. In Quadstar 32-bit 
it is possible to reduce the data rate via the Steps parameter (group «mass»), e.g. from 
64 to 16 measured values/amu (QMS 422/421 only). Please note that if concurrent stor-
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age is active, only the reduced number of measured values/amu will be stored. Steps 
can be changed in the same group (register card Mass) as Speed.

NOTE:
Due to fast CPUs and graphics cards in modern computers, the effect of the inter-
face load is generally not that high anymore.

2.4.3 Scan Bargraph

In Scan Bargraph mode, only the maximum peak intensities and the corresponding 
mass numbers are collected. This is done by the peak detection (Peak-L and Peak-F) 
integrated in the QMS.

Open the Quadstar 32-bit file manager by choosing [Scan] > [Bargraph]. It offers the 
already existing measurement parameter files for Scan Bargraph to choose from. 
Fig. 2-24, 82 shows the measurement of three bargraph spectra.

Fig. 2-24

NOTE:
Multichannel operation, i.e. measurement of different scans within the same cy-
cle(s), can be activated in the channel parameter editor by setting several chan-
nels to State=Enable. By [Parameters] > [Setup] the display can be set up.

The acquisition and display of the San Bargraph measurement data is controlled via the 
following menu:

Fig. 2-25

Submenus File
Handling of parameter and measurement data files and return to the main menu of the 
Measure program. See Chapter 2.4.3.1 File submenu, 83.
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Operation
Start/Stop the measurement. See Chapter 2.4.3.2 Operation submenu, 84.

Parameters
Parameter handling for control (display) and measurement parameters. See 
Chapter 2.4.3.3 Parameters submenu, 84.

2.4.3.1 File submenu

Fig. 2-26

Load Parameter
Load a different measurement parameter file and start the measurement.

Save Cycle Data
Store the next cycle(s) as a Scan Bargraph measurement data file. Cycle data can be 
stored only if «Temporary Save» has been turned off in the «Setup» dialog box. Save 
Cycle Data is disabled in Multiple Scan, i.e. if more than one channel is switched on 
([State] > [Enable]) in the channel parameter editor.

After having chosen the measure data file in the file manager, the «Cycle Save» dialog 
box is displayed in which the number of cycles can be entered which are to be measured 
and stored:

Fig. 2-27

If an existing file containing compatible measurement data is selected, the new data are 
alternatively appended (Append) or the file is overwritten (Reset).

Save Reference
Store the next cycle as a Scan Bargraph reference data file.

Load Reference
Load a reference file to compare with the current measure data.

Close Reference
Close the reference file.

File Info Notes
Add notes and remarks to the documentation and store them.
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Close
Quit the Scan Bargraph measurement type. A cycle that has been stopped will not be 
saved.

NOTE:
Do not modify the setup or channel parameters during the storage and don’t 
change the size of the measure window. Otherwise the measurement is started 
anew.

2.4.3.2 Operation submenu

Fig. 2-28

Go
Start the measurement.

Halt
Stop the measurement.

2.4.3.3 Parameters submenu

Fig. 2-29

Setup
Enter various parameters that control the type of measurement as well as the display of 
the measured data.

Channel
Modify the current measurement parameters (channel parameters).
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2.4.3.4 Setup parameters

Choose [Parameters] > [Setup] to enter the setup parameters:

Fig. 2-30

Control elements Measurement
• Single: Only one Scan Bargraph measurement (1 Cycle) is performed
• Repeat: Repetitive measurement of the activated channels
• Timer: The measurement is periodically restarted

See Chapter 2.1.1.2 Measurement methods, 62.

Y-Scale
• Lin: Linear display of measurement data
• Log: Logarithmic display of measurement data

Scan Arrangement
Arrangement of the scans if several scans are to be displayed.

• Vertical: The individual scans are arranged one below the other
• Horizontal: The individual scans are arranged side by side

NOTE:
No data can be stored with several scans.

Display Mode
Display mode if a reference is loaded. In this case, the current measure values (Cur-
rent), the reference values (Reference) and the difference between both (Difference) 
can be displayed.

• Multi Chart: Current, Reference and Difference are each displayed in an individual 
diagram with individual axes

• Single Chart: Current, Reference and Difference are displayed in the same diagram 
with the same axes

• Current: Display current measure values. The color of Current is determined by the 
channel parameters under [Parameters] > [Channel] > [Display] > [Color].
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• Reference: Display values of the reference measurement. The color of Reference 
correspond to the ones of Bar Reference and Bar Last/Difference found in Parset 
program under [Config] > [Screen Color].

• Difference: Display difference between Current and Reference. The difference is al-
ways displayed as rounded mass numbers. The color of Difference correspond to the 
ones of Bar Reference and Bar Last/Difference found in Parset program under [Con-
fig] > [Screen Color].

• Decades: Number of decades to display the difference

NOTE:
Reference and Difference are only available if a reference measurement has been 
loaded before by [File] > [Load Reference].

Save Data As
Determine the data that is to be saved:

• Difference: Save difference between Current and Reference.
• Current: Save current measure values (Current).

Timer Step
Timer interval for the measurement method Timer.

2.4.3.5 Channel parameters

Choose [Parameters] > [Channel] to change the QMS channel parameters.

Operating modes For a Scan Bargraph measurement you can select the following operation modes in the 
channel parameter editor. Click [Parameters] > [Channel] > [Mass Mode].

• PEAK-L: Scan Bargraph measurement with threshold definition. Only values greater 
or equal to the threshold are displayed.

• PEAK-F: Scan Bargraph measurement with threshold and FIR filter. In the QC the 
raw measurement signal is subjected to a FIR (Finite Impulse Response) filter algo-
rithm. This filter largely eliminates superimposed noise from the raw measure signal. 
In this way also very small peaks can be detected against the background.

• STAIR: Record a mass spectrum with integer mass jumps across the mass range de-
fined by the QMS channel parameters First and Width.
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2.5 MID measurement type
In MID (Multiple Ion Detection) mode, one measurement on one defined mass is done 
per channel. The measured intensities can be displayed as a table (Table), as a bar-
graph (Bargraph), or as a function of time (Versus Time). If you change the display mode 
while a measurement is running, it will be restarted.

MID Menu Use this menu to select the MID measurement type.

Fig. 2-31

Submenus Table...
Start the measurement, display measured data as a table. See Chapter 2.5.6 MID 
Table, 92.

Bargraph...
Start the measurement, display measured data as a bargraph. See Chapter 2.5.7 MID 
Bargraph, 96.

Versus Time...
Continuous display of the measured data as a function of time, measured cycles, etc. 
See Chapter 2.5.8 MID Versus Time, 98.

• To start a measurement, a parameter file must be specified. Quadstar 32-bit re-
sponds by displaying the file manager in order to choose the appropriate file.

• If display of reference data is chosen in MID Table setup ([Display Option] > [Refer-
ence]) or in MID Bargraph setup ([Display Reference]), the Quadstar 32-bit file man-
ager is called again in order to choose a reference file (*.MDR). Versus Time does 
not support reference display.

2.5.1 Setup submenu
Setup activates a submenu to setup the MID measurement:

• Table: Input of control parameters for the MID Table measuring mode. See 
Chapter 2.5.6.1 Parameter setup, 92.

• Bargraph: Input of control parameters for the MID Bargraph measuring mode. See 
Chapter 2.5.7.1 Parameter setup, 96.

• Versus Time: Input of control parameters for the MID Versus Time measuring mode. 
See Chapter 2.5.8.1 Parameter setup, 99.

Last as Table/Last as Bargraph
With Last as Table/Last as Bargraph the measurement data of the last measure cycle 
can be recalled. See Chapter 2.5.9 MID last measured values, 101.
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NOTE:
Last as Table and Last as Bargraph can only be chosen, if values of the last mea-
surement are available.

2.5.2 MID measurement menu

Recording and display of the MID measurement data is controlled via the following 
menu:

Fig. 2-32

File
Handling of parameter and measurement data files and return to the main menu of the 
Measure program.

Operation
Start/stop a measurement, optimize transmission speed.

Display
Choose the display mode (Table, Bargraph or Versus Time).

Parameters
Handling of control parameters (display) and measurement parameters.

2.5.2.1 File submenu

Fig. 2-33

Load Parameter
Load a different measurement parameter file and start the measurement.

Save Cycle Data
Store the next measurement cycle(s) as MID data file.

After having chosen the measure data file in the file manager, the Cycle Save dialog box 
is displayed.

If an existing file with compatible data is selected, the new data can alternatively be 
appended (Append), or the file is overwritten (Reset).
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Fig. 2-34

Control elements • Number of cycles to save: Enter the number of cycles, you want to measure and 
store.

• Display: For fast measurements the display of the measurement data can be turned 
off. See Chapter 2.1.1.4 Fast MID/MCD measurements, 62.

Save Reference
Store the last measurement (1 cycle) as a MID reference data file.

Load Reference
Load reference data, compare to the current data.

File Info Notes
Add notes and remarks to the documentation and store them.

Close
Quit the MID measurement.

NOTE:
Do not modify the setup or channel parameters during the storage and don’t 
change the size of the measure window, ’cause otherwise the measurement is 
started anew.

2.5.2.2 Operation submenu

Fig. 2-35

Go/Halt
Start/stop the measurement.

2.5.2.3 Display submenu

Choose the display mode. When you change the display mode while a measurement is 
running, the measurement will be restarted.
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Fig. 2-36

Table
Display data as a table.

Bargraph
Display data as a bargraph.

Versus Time
Display data Versus Time.

2.5.2.4 Parameters submenu

Fig. 2-37

Setup
Enter various parameters that control the type of measurement as well as the display of 
the measured data.

• MID Table - See Chapter 2.5.6 MID Table, 92
• MID Bargraph - See Chapter 2.5.7 MID Bargraph, 96
• MID Versus Time - See Chapter 2.5.8 MID Versus Time, 98

Channel
Modify the measurement parameters (channel parameters).

2.5.3 Offset alignment

For MID or MCD measurements, the mass dependent (detector-) offset of the 
QMS 422/421 can be compensated by an automatic correction measurement. On each 
channel, whose parameter Zero Mass contains a mass number, a measurement is car-
ried out on this zero mass. The intensity received thereby is the offset that will be sub-
tracted in the subsequent MID (or MCD) measurement from the measured value of the 
corresponding channel.

Procedure

1 Open the MID or MCD parameter file that you intend to use for the measurement 
and click on the register card Mass of the channel parameter editor.

2 Enter for each channel under Zero Mass the mass number, on which the offset is 
to be measured (or OFF, if the offset of this channel is disregarded). Choose a 
zero mass, where no peak appears (Default: 5.5 amu).

3 Close and save the parameter file and start the MID or MCD measurement. Now 
you see for each channel, for which a Zero Mass has been defined, the message 
«Channel x: Zero Equalize in progress» shown in the status bar; after that, the 
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MID or MCD measurement is started. This correction measurement (Zero Equal-
ize) is automatically redone, if the MID/MCD measurement is restarted or a chan-
nel parameter has been changed.

NOTE:
The automatic offset alignment can be disabled in measurements performed with 
the sequencer (MID(), MCD(), GSC() and ZeroGas() instruction) by the SetPar() 
command (ZeroEq=off). In manual operation, this automatic offset alignment can 
only be switched off by setting the Zero Mass of all channels to OFF.

2.5.4 Background subtraction (Zero Gas)

Please note that the background should be measured before each measurement. See 
Chapter 2.8.2 Background measurement (Zero Gas), 137. The results of the last 
background measurement are stored and subtracted from the measured intensities dur-
ing each measurement, if under [Parameters] > [Setup] the Option Zero Gas Subtraction 
is checked. This can lead to incorrect measurement data if the background has 
changed.

Example
If previously you had measured «air» as the background (Zero Gas) and subsequently 
want to measure air, the measured values (intensities) you obtain are only the difference 
from the currently measured values to the stored values.

NOTE:
Make sure that the background is not measured under incorrect conditions, e.g. 
with an opened inlet valve. In this case the intensities stored as backgrounds 
would be nearly equal to the actual measurement data, so the result of the sub-
traction would be some small differences that are hardly related to the measured 
data.

If the background cannot be measured:

• Check that in the Display Saved Values program, Auxiliary menu, under Zero Gas, 
the stored background measurements are still valid.

• Delete invalid entries (and store again) in the File menu.

NOTE:
In measurements with the sequencer (MID(), MCD() command), the background 
subtraction can be turned off by the SetPar() command (ZeroSub=off).

2.5.5 Temporary save

In MID and MCD mode Quadstar 32-bit allows temporary storage of measurement data. 
Under [Parameters] > [Setup], check the option Temporary Save, so the measurement 
data are written to a temporary file. The number of stored cycles is displayed in the sta-
tus bar («XX cycles saved to temporary file»). After the desired number of cycles has 
been measured (or if you leave the measurement), Quadstar 32-bit asks whether to 
save the displayed measurement data permanently or not.
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Fig. 2-38

2.5.6 MID Table

MID Table represents the measured ion currents or the measured values of an analog 
input channel (AI) as a table. Depending on the selected display mode the results are 
normalized to the largest value (=100%) or shown together with comparative data (ref-
erence, last, etc.).

2.5.6.1 Parameter setup

Under [Parameters] > [Setup] you can enter the control parameters:

Fig. 2-39

Control elements Measurement
• Single: Perform only one measurement (= 1 cycle ) across all activated channels.
• Repeat: Repetitive measurement of the activated channels.
• Timer: The measurement is periodically restarted.
• Dynamic: The measurement data is temporarily stored in the QMS buffer.
See Chapter 2.1.1.2 Measurement methods, 62.

Relative Values
Display the ion currents.

• None: Indicate the intensities in amperes.
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• Sum=100%: Normalize the displayed data to «sum of all intensities = 100%».
• Max=100%: Normalize the displayed data to «highest intensity = 100%».

Display Option
• None: No additional display options.
• Integral: Additional display of the integral of all measurements performed since the 

start.
• Last: Additional display of the measure data of the last cycle.
• Reference: Additional display of the measure data of a reference file.
• Multiple column: Display the measure data in several columns (scrolling). See Sec-

tion «Example 2», 95.

Mass scale correction
Mass scale correction on/off. See Chapter 2.8.1 Mass scale calibration (Mass Scale), 

134.

Zero Gas Subtraction
Zero gas subtraction on/off. See Chapter 2.8.2 Background measurement (Zero Gas), 

137.

Alarm Display
Display the alarm status for all channels with activated threshold monitoring.

Alarm Sound
Enable the alarm buzzer.

Alarm Error Message
Display an alarm additionally as an error.
If the Error History is enabled, incoming threshold monitoring alarms are logged in the 
Error History file. Configurable in the Parameter Setup program under [Setup] > [Gen-
eral].

Temporary Save
Store the measurement data in a temporary file.
When the measurement is stopped, a dialog box is displayed for entering the file name. 
See Chapter 2.5.5 Temporary save, 91.

Mult. Column Width
Column width in pixels in Multiple Column display mode.

Digits for Float Values
Number of digits after the decimal point for float values.

Timer Step
Timer interval for the measurement method Timer.

2.5.6.2 Data display

Example 1
Display Option: Reference

In this mode the current measurement data are compared to the measurement data of 
a reference file. When the measurement is started, Quadstar 32-bit asks for the name 
of the reference file.
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Fig. 2-40

Specify the desired number of decimal places under [Parameters] > [Setup] > [Digits for 
Float ValuesF].

Displayed 
Columns

Number and type of the displayed columns depend on the options selected under 
[Parameters] > [Setup] > [Display Option]:

Nbr
Current number of the displayed measured value.

Type
Data type of the displayed measured value.

• Cur.: Ion current.
• Cnt. R: Ion counter content.
• AI: Measured value of an AI channel.
• PI: Pirani measurement signal(QMS 422/421).
• PE: Cold cathode gauge signal.(QMS 422/421).
• TPR: Measured value of a Compact Pirani Gauge TPR 250(QMS 200).
• PKR: Measured value of a Compact Full Range Gauge PKR 250/251 (QMS 200).

Ident
Data type identification.

• XX.XX: Mass number of the ion current (Cur.) or the counter value (Cnt.)
• ’nnnnnn’: Logical name of the (AI) channel.
• PIR0/PIR1: Pirani 0, Pirani 1 (PI)(QMS 422/421).
• PEN: Cold cathode gauge (PE)(QMS 422/421).
• TPR: Compact Pirani Gauge (QMS 200).
• PKR: Compact Full Range Gauge (QMS 200).

QMU
QMU 112 Channel number on which the specified mass has been measured.

Cur Val
Current measured value.

Rel Val
Relative measured value (sum = 100% or max = 100%).

Integral
Integrated measurement signal since the start of the measurement.
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Last Val
Measured value of the last cycle.

Ref Val
Reference value.

Delta
Deviation Cur Val - Last Val in %.

Alarm
Switching functions.

Threshold 
monitoring

The threshold status is displayed graphically in the last column under alarm.

See Chapter 3.2.5.7 Switching functions (Trip), 186.

Example 2
Display Option: Multiple Column

The measure data is displayed in several columns (width selectable under Setup), 
where each column is one measured cycle.

Fig. 2-41

The individual columns are overwritten cyclically from the left to the right:

Entering 
Parameter setup

For setting the display mode choose [Parameters] > [Setup] (or double click the left 
mouse button) and for changing the QMS channel parameters choose [Parameters] > 
[Channel] (or double click the right mouse button).
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2.5.7 MID Bargraph

In MID Bargraph the measurement is started with the parameter file selected with the 
Quadstar 32-bit file manager and the measurement data are displayed as a bar chart.

Fig. 2-42

In the comments field, the data of the bar marked with the mouse are displayed.

2.5.7.1 Parameter setup

Under [Parameters] > [Setup] you can enter the control parameters:

Fig. 2-43
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Control elements Measurement
• Single: Perform only one measurement ( = 1 cycle ) across all activated channels.
• Repeat: Repetitive measurement of the activated channels.
• Timer: The measurement is periodically restarted.
• Dynamic:The measurement data is temporarily stored in the QMS buffer.
See Chapter 2.1.1.2 Measurement methods, 62.

Y-Scale
• Lin: Linear display of measurement data.
• Log: Logarithmic display of measurement data.

Color Mode
• Single Color: The measurement data are displayed in the colors defined in the Pa-

rameter Setup program under [Config] > [Screen Color].
• Multiple Color: The measurement data are displayed in the colors that are defined in 

the channel parameter editor for the corresponding channels. The bars of a channel 
(normal, last, reference) can only be distinguished by their patterns.

Mass scale correction
Mass scale correction on/off. See Chapter 2.8.1 Mass scale calibration (Mass Scale), 

134.

Zero Gas Subtraction
Zero gas subtraction on/off. See Chapter 2.8.2 Background measurement (Zero Gas), 

137.

Alarm Display
Display the alarm status for all channels with activated threshold monitoring.

Alarm Sound
Enable the alarm buzzer.

Alarm Error Message
Display an alarm additionally as an error.
If the Error History is enabled, incoming threshold monitoring alarms are logged in the 
Error History file. Configurable in the Parameter Setup program under [Setup] > [Gen-
eral].

Temporary Save
Store the measurement data in a temporary file.
When the measurement is stopped, a dialog box is displayed for entering the file name. 
See Chapter 2.5.5 Temporary save, 91.

Display Last
Display the measured data of the last cycle. The bar is shown on the right of the current 
measured value.

Display Reference
Display a reference measurement. The bar is shown on the right of the current mea-
sured value and marked with the pattern chosen by Bar Reference Display. The refer-
ence file is selected by the Quadstar 32-bit file manager when the measurement is 
started.

X-Axis Lettering
X-axis lettering on/off.

Y-Grid
Display a Y-grid on the measurement screen.
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Bar Normal Display
Pattern of the bar for the current measured value.

Bar Last Display
Pattern of the bar for the measured value of the last cycle.

Bar Reference Display
Pattern of the bar for the reference measurement.

Bar Width
Bar width in pixels.

Timer Step
Timer interval for the measurement method Timer.

2.5.7.2 Data display

Parameter setup For setting the display mode choose [Parameters] > [Setup] (or double click the left 
mouse button) and for changing the QMS channel parameters choose [Parameters] > 
[Channel] (or double click the right mouse button).

Operation with 
the QMU 112

When operating with the QMU 112, the QMU channel is shown in square brackets 
behind the mass number. For example «28 [7]» means mass 28, measure on the QMU 
channel 7.

Threshold 
monitoring

The threshold status is displayed graphically below the X-axis. See Chapter 3.2.5.7 
Switching functions (Trip), 186.

2.5.8 MID Versus Time

In MID Versus Time the measurement is started with the parameter file selected in the 
file manager, and the measurement data are displayed as a function of time or number 
of cycles:

Fig. 2-44
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2.5.8.1 Parameter setup

Under [Parameters] > [Setup] you can enter the control parameters:

Fig. 2-45

Control elements Measurement
• Single: Perform only one measurement ( = 1 cycle) across all activated channels.
• Repeat: Repetitive measurement of the activated channels.
• Timer: The measurement is periodically restarted.
• Dynamic: The measurement data is temporarily stored in the QMS buffer.
See Chapter 2.1.1.2 Measurement methods, 62.

X-Scale
• Cycle: Assign the cycle number to the X-axis label.
• Time relative: Assign the relative time since the start to the X-axis label.
• Time absolute: Assign the absolute time (time of day) of the measurement to the X-

axis label.

Y-Scale
• Lin: Linear display of measurement data.
• Log: Logarithmic display of measurement data.

Line Type
• Solid: The measured values are connected by a solid line.
• Dot: The measured values are shown as individual dots.

Mass scale correction
Mass scale correction on/off. See Chapter 2.8.1 Mass scale calibration (Mass Scale), 

134.

Zero Gas Subtraction
Zero gas subtraction on/off. See Chapter 2.8.2 Background measurement (Zero Gas), 

137.
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Alarm Display
Display the alarm status for all channels with activated threshold monitoring.

Alarm Sound
Enable the alarm buzzer.

Alarm Error Message
Display an alarm additionally as an error.
If the Error History is enabled, incoming threshold monitoring alarms are logged in the 
Error History file. Configurable in the Parameter Setup program under [Setup] > [Gen-
eral].

Temporary Save
Store the measurement data in a temporary file.
When the measurement is stopped, a dialog box is displayed for entering the file name. 
See Chapter 2.5.5 Temporary save, 91.

Help table
On the right, beside the measure data, the measured values are displayed additionally 
to the measure data identifications.

X-Grid
Display an X-grid.

Y-Grid
Display a Y-grid.

Marker
Mark the measured values with symbols.

Roll Axis
Each time the end of the X-axis is reached, scroll the screen to the left by 10%.

Cycles
Define the number of cycles that are displayed in the measurement data window before 
the old data are overwritten. For the «Display after Measure» method, Cycles is the 
number of cycles to be measured.

Time-Scale
Select the period of time on the X-axis.

Timer Step
Timer interval for the measurement method Timer.

Measure/Display Mode
• Measure and Display: The values are measured and displayed cycle by cycle.
• Display after Meas.: The values are displayed after the measurement.

2.5.8.2 Data display

Threshold 
monitoring

Changes of the threshold status are indicated with small arrows above and below the 
measured values.

The arrows above the measured values signalize threshold state 1 (=A), the arrows 
below the measured values signalize threshold state 2 (=B). An upward pointing arrow 
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indicates that the threshold monitoring has responded. A downward pointing arrow indi-
cates that the threshold monitoring has returned to normal condition. See 
Chapter 3.2.5.7 Switching functions (Trip), 186.

Parameter setup For setting the display mode choose [Parameters] > [Setup] (or double click the left 
mouse button) and for changing the QMS channel parameters choose [Parameters] > 
[Channel] (or double click the right mouse button).

2.5.9 MID last measured values

[MID] > [Last as Table] and [MID] > [Last as Bargraph display] the last measured cycle.

Fig. 2-46

File
File handling and return to the main menu of the Measure program.

Display
Select the display mode (Table or Bargraph).

Parameters
Control parameter (display) and measurement parameter handling.

2.5.9.1 File submenu

Fig. 2-47

Load Reference
Load a reference data file.

Save Reference
Store the last measurement (1 cycle) as a MID reference data file.

Close
Quit the MID Last Values mode.

2.5.9.2 Display submenu

Fig. 2-48
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Table
Display as a table.

Bargraph
Display as a bargraph.

2.5.9.3 Parameters submenu

Fig. 2-49

Setup
Setup the display of the measured data.
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2.6 MCD measurement type
The MCD (Multiple Concentration Detection) measurement type provides concentration 
measurements. The measured ion currents are input to a solution matrix and the indi-
vidual concentrations of the components in the gas are determined via calibration fac-
tors.

Calibration factor library
The Quantitative Analysis of Quadstar 32-bit works with a calibration factor library. The 
size of this library is not fixed, i.e. it grows with the input of each new component. For 
each component that is referenced in an application or calibration matrix, this library 
contains the calibration factors and the corresponding mass numbers. The number of 
calibration factors is limited to 24 per component.

The application matrix does not contain the actual calibration factors but only «pointers» 
to the location in the calibration factor library. The advantage of this method is, that the 
latest calibration factors are always used when the application matrix is loaded.

Matrix solution method
The matrix offers the possibility to define a calibration factor for every gas component 
and mass number that occur in the measurement task (calibration factors may also be 
0). The resulting equation system must then be solved by a suitable process.

For solving the equation system, Quadstar 32-bit uses the method of elimination accord-
ing to Givens. In this method the linear equation system is transformed to an equivalent 
system with a triangular matrix as a matrix of coefficients. Such equation systems are 
easy to solve by means of backward insertion. The process of elimination according to 
Givens allows also super-determinate equations, i.e. it may contain more equations than 
«unknowns» (more measured intensities than wanted concentrations). For solving such 
equations Givens employs the method of least squares. In this way inaccuracies can be 
minimized.

Additional information on the algorithm for solving linear equation systems used in the 
Quantitative Analysis of Quadstar 32-bit can be found in the books «COMPUTER-
MATHEMATIK» and «COMPUTERMATHEMATIK Lösungen» by Prof. Dr. Walter Gan-
der.

Normalization
The calculated values must be normalized (related to a reference quantity). If all gas 
components are known, normalization modes ’Maximum=100%’ or ’Sum=100%’ can be 
used, otherwise ’Extern’ must be used. See Section «Setting the external normaliza-
tion», 205.

Literature

• COMPUTERMATHEMATIK by Prof. Dr. Walter Gander
Birkhäuser Verlag, Basel/Boston/Stuttgart 1985
ISBN 3-7643-1688-8 (Language: German)

• COMPUTERMATHEMATIK Lösungen by Prof. Dr. Walter Gander
Birkhäuser Verlag, Basel/Boston/Stuttgart 1986
ISBN 3-7643-1802-3 (Language: German)

MCD Menu In MCD measurements (Multiple Concentration Detection) the individual measurement 
channels are set up similarly to MID measurements. The results can be represented as 
a table (Table), as a bar chart (Bargraph), or as a function of time (Versus Time).
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Fig. 2-50

Submenus Table...
Start the measurement, display measured data as a table. See Chapter 2.6.7 MCD 
Table, 108.

Bargraph...
Start the measurement, display measured data as a bargraph. See Chapter 2.6.8 MCD 
Bargraph, 112.

Versus Time...
Start the measurement, continuous display of measured data as a function of time, mea-
sured cycles, etc. See Chapter 2.6.9 MCD Versus Time, 115.

• To start a measurement, a parameter file must be specified. Quadstar 32-bit re-
sponds by displaying the file manager in order to choose the appropriate file.

• If display of reference data is chosen in MCD Table setup [Display Option] > [Refer-
ence] or in MID Bargraph setup [Display Reference], the Quadstar 32-bit file manag-
er is called again in order to choose a reference file (*.MDR). Versus Time does not 
support reference display.

2.6.1 Setup submenu
Setup activates a submenu to setup the MCD measurement:

• Table: Control parameter input (measurement method, display mode, etc) for the 
MCD Table measuring mode. See Chapter 2.6.7.1 Parameter setup, 109.

• Bargraph: Control parameter input (measurement method, display mode, etc) for the 
MCD Bargraph measuring mode. See Chapter 2.6.8.1 Parameter setup, 113.

• Versus Time: Control parameter input (measurement method, display mode, etc.) for 
the MCD Versus Time measuring mode. See Chapter 2.6.9.1 Parameter setup, 

116.

Last as Table/Last as Bargraph
With ]Last as Table] and [Last as Bargraph], measurement data of the last measured 
cycle can be recalled. See Chapter 2.6.10 MCD last measured values, 118.

NOTE:
[Last as Table] and [Last as Bargraph] can only be chosen, if measured values of 
a last measurement are available.
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2.6.2 MCD measurement menu

The recording and display of MCD measurement data is controlled via the following 
menu:

Fig. 2-51

File
Handling of parameter and measurement data files and return to the main menu of the 
Measure program.

Operation
Start/stop a measurement, optimize transmission speed.

Display
Choose the display mode (Table, Bargraph or Versus Time).

Parameters
Handling of control parameters (display) and measurement parameters.

2.6.2.1 File submenu

Fig. 2-52

Load Parameter
Load a different measurement parameter file and start the measurement.

Save Cycle Data
Store the next several measurement data cycles as MCD data file.

After having chosen the measure data file in the file manager, the Cycle Save dialog box 
is displayed.

If an existing file with compatible data is selected, the new data can alternatively be 
appended (Append), or the file is overwritten (Reset).
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Fig. 2-53

Control elements • Number of cycles to save: Enter the number of cycles, you want to measure and 
store.

• Display: For fast measurements the display of the measurement data can be turned 
off. See Chapter 2.1.1.4 Fast MID/MCD measurements, 62.

Save Reference
Store the last measurement (1 cycle) as a MCD reference data file.

Load Reference
Load reference data, compare to the current data.

File Info Notes
Add notes and remarks to the documentation and store them.

Close
Quit the MCD measurement.

NOTE:
Do not modify the setup or channel parameters during the storage and don’t 
change the size of the measure window. Otherwise the measurement is started 
anew.

2.6.2.2 Operation submenu

Fig. 2-54

Go/Halt
Start/stop the measurement.

2.6.2.3 Display submenu

Choose the display mode. When you change the display mode while a measurement is 
running, the measurement will be restarted.
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Fig. 2-55

Table
Display data as a table.

Bargraph
Display data as a bargraph.

Versus Time
Display data Versus Time.

2.6.2.4 Parameters submenu

Fig. 2-56

Setup
Enter various parameters that control the type of measurement as well as the display of 
the measured data.

• MCD Table - See Chapter 2.6.7.1 Parameter setup, 109
• MCD Bargraph - See Chapter 2.6.8.1 Parameter setup, 113
• MCD Versus Time - See Chapter 2.6.9.1 Parameter setup, 116

Channel
Modify the measurement parameters (channel parameters).

Concentration
Setup the trip parameters (threshold monitoring), color assignment and concentration 
display.

2.6.3 Data display

How the data is displayed, depends on the display mode (Table, Bargraph or Versus 
Time).

Which data is displayed, depends on the parameter setup:

• Concentrations are displayed, if under [Parameters] > [Concentration] the Disp.Mode 
of the corresponding concentrations is set to ON.

• Ion currents for concentration calculation are displayed, if under [Parameters] > 
[Channel] on the register card Display the Disp.Mode of the corresponding channels 
is set to ON.

• Incidentally measured ion currents (which are not used for concentration calculation) 
are displayed, if under [Parameters] > [Channel], after the channels being in [State] 
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> [Matrix], more channels are switched on ([State] > [Enable]) and their Disp.Mode 
is set to ON.

2.6.4 Offset alignment

Quadstar 32-bit performs an offset alignment (Zero Equalize) before the MCD measure-
ment, if the ’Zero Mass’ of the measure channels are not switched OFF. See 
Chapter 2.5.3 Offset alignment, 90.

2.6.5 Background subtraction

Before every measurement the background should be determined, in order to subtract 
it from the measure data. Otherwise the Zero Gas Subtraction should be turned off. See 
Chapter 2.5.4 Background subtraction (Zero Gas), 91.

2.6.6 Operation with the QMU 112

MCD measurements don’t provide full support for the QMU 112. The calibration factors 
are only valid for the QMU channel on which the calibration was performed. For correct 
analysis the measurements are to be performed exclusively on this channel.

2.6.7 MCD Table

MCD Table starts the measurement with the paramere file selected cia the 
Quadstar 32-bit file manager and displays the calculated concentrations as a table.
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2.6.7.1 Parameter setup

Under [Parameters] > [Setup] you can enter the control parameters:

Fig. 2-57

Control elements Measurement
• Single: Perform only one measurement (= 1 cycle ) across all activated channels.
• Repeat: Repetitive measurement of the activated channels.
• Timer: The measurement is periodically restarted.
• Dynamic: The measurement data is temporarily stored in the QMS buffer.
See Chapter 2.1.1.2 Measurement methods, 62.

Normalization Mode
Display of the concentrations.

• None: Indicate the intensities in amperes.
• Sum=100%: Normalize the displayed data to «sum of all intensities = 100%».
• Max=100%: Normalize the displayed data to «highest intensity = 100%».
• Extern: External normalization. See Section «Setting the external normalization», 

205.

Display Option
• None: No additional display options.
• Integral: Additional display of the integral of all measurements performed since the 

start.
• Last: Additional display of the measure data of the last cycle.
• Reference: Additional display of the measure data of a reference file.
• Multiple column: Display the measure data in several columns (scrolling).

Mass scale correction
Mass scale correction on/off. See Chapter 2.8.1 Mass scale calibration (Mass Scale), 

134.

Zero Gas Subtraction
Zero gas subtraction on/off. See Chapter 2.8.2 Background measurement (Zero Gas), 

137.
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Alarm Display
Display the alarm status for all channels with activated threshold monitoring.

Alarm Sound
Enable the alarm buzzer.

Alarm Error Message
Display an alarm additionally as an error.
If the Error History is enabled, incoming threshold monitoring alarms are logged in the 
Error History file. Configurable in the Parameter Setup program under [Setup] > [Gen-
eral].

Temporary Save
Store the measurement data in a temporary file.
When the measurement is stopped, a dialog box is displayed for entering the file name. 
See Chapter 2.5.5 Temporary save, 91.

Neg. Conc. Suppression
Suppress negative concentrations.

Mult. Column Width
Column width in pixels in Multiple Column display mode.

Digits for Float Values
Number of digits after the decimal point for float values.

Timer Step
Timer interval for the measurement method Timer.

2.6.7.2 Data display

Example 1:
Display Option: Last

In this mode the current measurement data are compared to those of the last cycle.

Fig. 2-58

Displayed 
Columns

Number and type of the displayed columns depend on the options selected under 
[Parameters] > [Setup] > [Display Option]:

Nbr
Current number of the displayed measured value.
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Type
Data type of the displayed measured value.

• Conc.: Concentration.
• Cur.: Ion current.
• Cnt. R: Ion counter content.
• AI: Measured value of an AI channel.
• PI: Pirani measurement signal(QMS 422/421).
• PE: Cold cathode gauge signal.(QMS 422/421).
• TPR: Measured value of a Compact Pirani Gauge TPR 250(QMS 200).
• PKR: Measured value of a Compact Full Range Gauge PKR 250/251 (QMS 200).

Ident
Data type identification.

• XX.XX: Mass number of the ion current (Cur.), the counter value (Cnt.) or the name 
of the component.

• ’nnnnnn’: Logical name of the (AI) channel.
• PIR0/PIR1: Pirani 0, Pirani 1 (PI)(QMS 422/421).
• PEN: Cold cathode gauge (PE)(QMS 422/421).
• TPR: Compact Pirani Gauge (QMS 200).
• PKR: Compact Full Range Gauge (QMS 200).

Cur Val
Current measured value.

Last Val
Measured value of the last cycle.

Delta
Deviation Cur Val - Last Val in %.

Alarm
Switching functions.

Threshold 
monitoring

The threshold status is displayed graphically in the last column under alarm.

See Chapter 3.2.5.7 Switching functions (Trip), 186.

Example 2
Display Option: Multiple Column

The measure data is displayed in several columns (width selectable under Setup), 
where each column is one measured cycle.
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Fig. 2-59

The individual columns are overwritten cyclically from the left to the right:

Entering 
Parameter setup

For setting the display mode choose [Parameters] > [Setup] (or double click the left 
mouse button) and for changing the QMS channel parameters choose [Parameters] > 
[Channel] (or double click the right mouse button).

2.6.8 MCD Bargraph

In MCD Bargraph the measurement is started with the parameter file selected with the 
Quadstar 32-bit file manager and the measured data is displayed as a bar chart.

Fig. 2-60

In the comments field, the data of the bar marked with the mouse is displayed.
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2.6.8.1 Parameter setup

Under [Parameters] > [Setup] you can enter the control parameters:

Fig. 2-61

Control elements Measurement
• Single: Perform only one measurement ( = 1 cycle ) across all activated channels.
• Repeat: Repetitive measurement of the activated channels.
• Timer: The measurement is periodically restarted.
• Dynamic:The measurement data is temporarily stored in the QMS buffer.
See Chapter 2.1.1.2 Measurement methods, 62.

Y-Scale
• Lin: Linear display of measurement data.
• Log: Logarithmic display of measurement data.

Color Mode
• Single Color: The measurement data are displayed in the colors defined in the Pa-

rameter Setup program under [Config] > [Screen Color].
• Multiple Color: The measurement data are displayed in the colors that are defined in 

the channel parameter editor for the corresponding channels. The bars of a channel 
(normal, last, reference) can only be distinguished by their patterns.

Normalization Mode
Display of the concentrations.

• Sum=100%: Normalize the displayed data to «sum of all concentrations = 100%».
• Max=100%: Normalize the displayed data to «highest concentration = 100%».
• Extern: External normalization. See Section «Setting the external normalization», 

205.
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Mass scale correction
Mass scale correction on/off. See Chapter 2.8.1 Mass scale calibration (Mass Scale), 

134.

Zero Gas Subtraction
Zero gas subtraction on/off. See Chapter 2.8.2 Background measurement (Zero Gas), 

137.

Alarm Display
Display the alarm status for all channels with activated threshold monitoring.

Alarm Sound
Enable the alarm buzzer.

Alarm Error Message
Display an alarm additionally as an error.
If the Error History is enabled, incoming threshold monitoring alarms are logged in the 
Error History file. Configurable in the Parameter Setup program under [Setup] > [Gen-
eral].

Temporary Save
Store the measurement data in a temporary file.
When the measurement is stopped, a dialog box is displayed for entering the file name. 
See Chapter 2.5.5 Temporary save, 91.

Neg. Conc. Suppr.
Suppress negative concentrations.

Display Last
Display the measured data of the last cycle. The bar is shown on the right of the current 
measured value.

Display Reference
Display a reference measurement. The bargraph is shown on the right of the current 
measured value and marked with the pattern chosen by Bar Reference Display. The ref-
erence file is selected by the Quadstar 32-bit file manager when the measurement is 
started.

X-Axis Lettering
X-axis lettering on/off.

Y-Grid
Display a Y-grid on the measurement screen.

Bar Normal Display
Pattern of the bar for the current measured value.

Bar Last Display
Pattern of the bar for the measured value of the last cycle.

Bar Reference Display
Pattern of the bar for the reference measurement.

Bar Width
Bar width in pixels.

Timer Step
Timer interval for the measurement method Timer.
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2.6.8.2 Data display

Parameter setup For setting the display mode choose [Parameters] > [Setup] (or double click the left 
mouse button) and for changing the QMS channel parameters choose [Parameters] > 
[Channel] (or double click the right mouse button).

Threshold 
monitoring

The threshold status is displayed graphically below the X-axis. See Chapter 3.2.5.7 
Switching functions (Trip), 186.

2.6.9 MCD Versus Time

In MCD Versus Time the measurement is started with the parameter file selected in the 
file manager, and the measurement data are displayed as a function of time or number 
of cycles:

Fig. 2-62
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2.6.9.1 Parameter setup

Under [Parameters] > [Setup] you can enter the control parameters:

Fig. 2-63

Control elements Measurement
• Single: Perform only one measurement ( = 1 cycle) across all activated channels.
• Repeat: Repetitive measurement of the activated channels.
• Timer: The measurement is periodically restarted.
• Dynamic: The measurement data is temporarily stored in the QMS buffer.
See Chapter 2.1.1.2 Measurement methods, 62.

X-Scale
• Cycle: Assign the cycle number to the X-axis label.
• Time relative: Assign the relative time since the start to the X-axis label.
• Time absolute: Assign the absolute time (time of day) of the measurement to the X-

axis label.

Y-Scale
• Lin: Linear display of measurement data.
• Log: Logarithmic display of measurement data.

Line Type
• Solid: The measured values are connected by a solid line.
• Dot: The measured values are shown as individual dots.

Normalization Mode
Indication of the concentrations.

• Sum=100%: Normalize the displayed data to «sum of all concentrations = 100%».
• Max=100%: Normalize the displayed data to «highest concentrations = 100%».
• Extern: External normalization. See Section «Setting the external normalization», 

205.
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Mass scale correction
Mass scale correction on/off. See Chapter 2.8.1 Mass scale calibration (Mass Scale), 

134.

Zero Gas Subtraction
Zero gas subtraction on/off. See Chapter 2.8.2 Background measurement (Zero Gas), 

137.

Alarm Display
Display the alarm status for all channels with activated threshold monitoring.

Alarm Sound
Enable the alarm buzzer.

Alarm Error Message
Display an alarm additionally as an error.
If the Error History is enabled, incoming threshold monitoring alarms are logged in the 
Error History file. Configurable in the Parameter Setup program under [Setup] > [Gen-
eral].

Temporary Save
Store the measurement data in a temporary file.
When the measurement is stopped, a dialog box is displayed for entering the file name. 
See Chapter 2.5.5 Temporary save, 91.

Help table
On the right, beside the measure data, the measured values are displayed additionally 
to the measure data identifications.

Neg. Conc. Suppr.
Suppress negative concentrations.

X-Grid
Display an X-grid.

Y-Grid
Display a Y-grid.

Marker
Mark the measured values with symbols.

Roll Axis
Each time the end of the X-axis is reached, scroll the screen to the left by 10%.

Cycles
Define the number of cycles that are displayed in the measurement data window before 
the old data are overwritten. For the «Display after Measurement» method, Cycles is the 
number of cycles to be measured.

Time-Scale
Select the period of time on the X-axis.

Timer Step
Timer interval for the measurement method Timer.

Measure/Display Mode
• Measure and Display: The values are measured and displayed cycle by cycle.
• Display after Measurement: The values are displayed after the measurement.
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2.6.9.2 Data display

Threshold 
monitoring

Changes of the threshold status are indicated with small arrows above and below the 
measured values.

The arrows above the measured values signalize threshold state 1 (=A), the arrows 
below the measured values signalize threshold state 2 (=B). An upward pointing arrow 
indicates that the threshold monitoring has responded. A downward pointing arrow indi-
cates that the threshold monitoring has returned to normal condition. See 
Chapter 3.2.5.7 Switching functions (Trip), 186.

Parameter setup For setting the display mode choose [Parameters] > [Setup] (or double click the left 
mouse button) and for changing the QMS channel parameters choose [Parameters] > 
[Channel] (or double click the right mouse button).

2.6.10 MCD last measured values

[MCD] > [Last as Table] and [MCD] > [Last as Bargraph] display the last measured 
cycle.

Fig. 2-64

File
File handling and return to the main menu of the Measure program.

Display
Select the display mode (Table or Bargraph).

Parameters
Control parameter (display) and measurement parameter handling.

2.6.10.1 File submenu

Fig. 2-65

Load Reference
Load a reference data file.

Save Reference
Store the last measurement (1 cycle) as a MCD reference data file.

Close
Quit the MCD Last Values mode.
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2.6.10.2 Display submenu

Fig. 2-66

Table
Display as a table.

Bargraph
Display as a bargraph.

2.6.10.3 Parameters submenu

Fig. 2-67

Setup
Setup the display of the measured data.
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2.7 Measuring with the sequencer (Sequence)
All measurements, that can be done manually, can be programmed in a sequence as 
well. By using decisions, user calls etc., measurement procedures can be programmed, 
that are adapted to a specific task. This way, dull routine jobs may be automated, and 
sophisticated measurement procedures can be controlled by less skilled users as well. 
The sequencer works with the same parameter files as the manual measurements do, 
and the display of measurement data is the same as well.

While a sequence is running, the only menu entry left is [File] > [Close]. By this entry, 
the sequence can be cancelled. If an exit sequence has been defined by the SeqExit() 
instruction, important closing work can be done such as switching off the emission, 
opening/closing valves, etc.

NOTE:
More information about sequences, programming, instructions etc. can be found 
in Chapter 8. Process Control, 409.

Sequence menu

Fig. 2-68

Submenus Execute
Start a sequence.

Setup
Setup the display (digital in-/output, Lin/Log, etc.).

2.7.1 Setup submenu

Under [Sequence] > [Setup] you can set up the display:

QMS 422/421

Fig. 2-69
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QMS 200

Fig. 2-70

Lines
Number of lines to display

• 16: 16 lines (for screens with low resolution)
• 32: 32 lines (for screens with high resolution)

DI/DO Identification
Channel name display on/off. See Chapter 2.7.2.2 Status display, 122.

Y-Scale
• Lin: Linear display of measurement data.
• Log: Logarithmic display of measurement data.
• [Display range]: Display range for float and integer values, if no scale has been de-

fined by the SetScale() instruction:
• Maximum: Largest decade to be displayed.
• Decades: Number of decades to be displayed.

Fig. 2-71

Selection of DI/DO Boards
• #: Number 0...9 of the entry.
• Unit Name: Logical name of the control unit (in Multiplex mode).
• DI/DO Board: Select the DI/DO board and its channels to be displayed:

• QMS 422/421: 0…15, 16…31 for [Lines] : [16] or 0…31 for [Lines] : [32]
• QMS 200: 0…1

NOTE:
Please note that the selected DI/DO channels are displayed only if the display op-
tion Disp has not been set to OFF in the sequencer instructions (SetDO(), While-
DI() etc.).
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2.7.2 Execute submenu

Starting a sequence
By [Sequence] > [Execute] the file manager is called. Choose the desired sequence and 
start it by [OK].

2.7.2.1 Testing a sequence
Before the sequence is executed, Quadstar 32-bit checks it for programming errors. 
During the test, the name of the sequence and the current line number are displayed in 
the status bar (in the lower left corner). In the following example, the sequence 
demoair.sqe could not be found:

Fig. 2-72

However, a complete error test is not possible, if e.g. file names with consecutive num-
bering (e.g. DEMO00.MIP, DEMO01.MIP, ... DEMOxx.MIP) are used in the sequence. 
In this case, only a warning is output, that files are used, which could not be tested.

NOTE:
Sequences of this type should be tested by copying and simplifying them. Re-
move all lines that contain no file access of this type, and set the loop counters 
for repetitive measures to 1. Now you can start the sequence to check path and 
file names.

2.7.2.2 Status display

The status of the digital in-/outputs and the loop state is only displayed, if in the corre-
sponding instruction (SetDO(), WhileDI(), WhileMeaVal(), WhileVar() etc.) the display 
has been switched on by the keyword Disp=on.

NOTE:
Please note that when Disp=on is set, time is required for building up the screen, 
so the switch-on (e.g. due to a digital input) may be slightly delayed.

Example: Loop( i[0]=0;8 )
SetDO( i[0]=on;1, Disp=on )

WhileVar( i[5]=0, Disp=on, BreakTime=30 )
Begin

SetDO( 16=on;5, Disp=on )
SetDO( 16=off;1, Disp=on )
Loop( i[0]=0;8 )
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SetDO( i[0]=off;1, Disp=on )
End

The example above is a gas inlet control. Start the sequence, so the following is dis-
played:

Fig. 2-73

DI#X/DO#X
State of the digital in-/output channels. The name of the channel is displayed only if its 
display has been switched on under [Sequence] > [Setup] by enabling DI/DO Identifica-
tion. See Chapter 2.7.1 Setup submenu, 120.

While Loop State
Loop state.

NOTE:
The display area is limited. Only as many DI/DO channels are shown, as space is 
available, even if under [Sequence] > [Setup] more channels have been selected.

2.7.2.3 Display of measurement data

The display of measurement data is the same as in manual mode. If several types of 
display are possible, the desired type may be chosen by the keyword Disp.

The MID() instruction e.g. has the following possibilities:

• off: Display is switched off.
• tab: Display the measured values as a table.
• bar: Display the measured values as a bargraph.
• vt: Display the measured values as a function of time.
• default: Display according to the mode set by the SetDefault() instruction (off/on, 

where on=tab).

By the SetPar() instruction, you can do the settings, that are done under [Parameters] > 
[Setup] in manual mode, for example:

• AlarmDisp: Graphic indication of the threshold monitoring.
• AlarmError: Alarm error messages.
• AlarmSound: Audible alarm signal.
• BarWidth: Bargraph bar width.
• ColorMode: Color display mode.
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• Cycles: Number of cycles.
• DispLast: Display Last Values for the bargraph.
• DispOpt: Display option for table output.
• LineType: Line type.
• Marker: Marker display.
• MSC: Mass scale correction.
• NorMode: Normalization mode.
• RelVal: Display of relative values.
• RollAxis: Axis roll mode.
• Scale: Axis mode.
• ScanArran: Display mode, if more than one Scan Analog or Scan Bargraph spectrum 

is to be displayed.
• TimeScale: Time scale extent.
• XLetter: X-axis lettering.
• XRaster: Display a X-grid on the measurement screen.
• XScale: X-scale display.
• YRaster: Display a Y-grid on the measurement screen.
• ZeroEq: Zero equalization.
• ZeroSub: Zero gas subtraction.

Example:
In the Parameter Setup program, open the sequence editor by [Sequence] > [Editor] and 
choose a sequence. Set the mouse cursor to a blank line, type SetPar and press the 
right mouse button. The following dialog box appears that contains all possible param-
eters of the SetPar() instruction:

Fig. 2-74

If you check the box on the left of a parameter (e.g. x AlarmDisp), then you can click on 
the button and enter its value (e.g. on).
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2.7.3 Controlling the display via sequencer instructions

2.7.3.1 Measurement data of the MID() instruction

The following sequence performs the same MID measurement three times and displays 
the results in different ways:

SetPar( 
BarWidth=25,ColorMode=single,Cycles=50,DispOpt=last,LineType=so
lid, Marker =0 )
Loop( i[0]=0;50 )
Begin

MID( Par="d:\qs32bit\par\airdemo.mip", Disp=tab, SaveGfa=0 )
..MID( Par="d:\qs32bit\par\airdemo.mip", Disp=bar, SaveGfa=0 )
..MID( Par="d:\qs32bit\par\airdemo.mip", Disp=vt, SaveGfa=0 )

SetString(gs[0] = «MID measure cycle @, intensity of channel 0 
= @";i[0])

Message( Text=gs[0];gfa[0][0] )
End

• The line containing the SetPar() instruction sets the parameters for the display in 
mode Table (tab), Bargraph (bar) and Versus Time (vt).

• The lines containing the MID() instructions control the measurement of the data and 
the display in the different modes Table (tab), Bargraph (bar) and Versus Time (vt).

• The SetString() instruction loads a text into the string table.

• The Message() instruction outputs the string on the status bar (on the bottom left).

On the following pages you can see the measurement results of this sequence.

Specialties of the MID/MCD measurements
In sequencer mode as well, the background should be taken into consideration. If you 
have done a correct background measurement, switch on the background subtraction 
by the SetPar() instruction (ZeroSub=on); otherwise, switch it off by (ZeroSub=off). See 
Chapter 2.8.2 Background measurement (Zero Gas), 137.

In the same way as in manual mode, an offset alignment (Zero Equalize) is performed 
before every MID/MCD measurement, if you switch it on by the SetPar() instruction 
(ZeroEq=on). The alignment is not done, if you switch it off by the SetPar() instruction 
(ZeroEq=off). See Chapter 2.5.3 Offset alignment, 90.

MID Table measurement data

The sequencer line

MID (Par="d:\qs32bit\par\airdemo.mip", Disp=tab, SaveGfa=0 )

stores the measured values in array 0 of the global field (gfa[0][]) and produces the fol-
lowing table:
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Fig. 2-75

MID Bargraph measurement data

The sequencer line

MID (Par="d:\qs32bit\run\par\airdemo.mip", Disp=bar, SaveGfa=0 )

stores the measured values in array 0 of the global field (gfa[0][]) and produces the fol-
lowing bar chart:

Fig. 2-76

MID Versus Time measurement data

Here the measured data are displayed as a function of time. The extent of the X-axis 
can be specified at will, but it should be adapted to the measure loop. This display mode 
is only useful if the MID() instruction is used within a loop.

The sequencer line

MID (Par="d:\qs32bit\run\par\airdemo.mip", Disp=vt, SaveGfa=0 )

stores the measured values in array 0 of the global field (gfa[0][]) and produces the fol-
lowing picture:
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Fig. 2-77

2.7.3.2 Scan measurement data

Scan Analog and Scan Bargraph display the measurement data of one or several scans. 
The number of displayed scans depends on the number of activated channels (State= 
Enable) in the selected parameter file. If several scans are available, the display mode 
can be chosen by the SetPar() instruction by the keyword ScanArran:

• Vert: The individual spectra are displayed vertically, i.e. above each other, or

• Horiz: The individual spectra are displayed horizontally, i.e. side by side.

NOTE:
If the SetPar() parameter ScanArran is not set explicitly, it defaults to the last set-
ting chosen manually under [Parameters] > [Setup] > [Scan Arrangement].

Measurement data of the ScanAnalog() instruction
The following sequencer lines execute the three Scan Analog measurements of the air-
demo.sap parameter file 25 times, while the current cycle number is shown in the status 
bar:

....
Loop( i[5]=1;25 )
Begin

Message( Text="Scan Measure, Scan Analog # @";i[5] )
ScanAnalog( Par="airdemo.sap", Disp=on )

End
....

This sequence produces the following picture:
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Fig. 2-78

Measurement data of the ScanBar() instruction
The following sequencer lines execute the three Scan Bargraph measurements of the 
airdemo.sbp parameter file 25 times, while the current cycle number is shown in the sta-
tus bar:

Loop( i[5]=1;25 )
Begin

Message( Text="Scan Measure, Scan Bargraph # @";i[5] )
ScanBar( Par="airdemo.sbp", Disp=on, Prot=off )

End
....

This sequence produces the following picture:

Fig. 2-79
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2.7.3.3 Measurement data of the MCD() instruction

The following sequence executes the same MCD measurement three times and shows 
the results in three different ways:

SetPar( AlarmDisp=on, BarWidth=25, ColorMode=single, Cycles=50, 
DispOpt=last, LineType=solid, 
Marker=on, Scale=log, YRaster=off )
Loop( i[0]=0;50 )
Begin

MCD( Par="d:\qs32bit\par\airdemo.mcp", Disp=tab, SaveGfa=0 )
//MCD( Par="d:\qs32bit\par\airdemo.mcp", Disp=bar, SaveGfa=0 )
//MCD( Par="d:\qs32bit\par\airdemo.mcp", Disp=vt, SaveGfa=0 )

SetString( gs[0] = "MCD measure cycle @, Concentration N2 = @ 
%";i[0] )

Message( Text=gs[0];gfa[0][0] )
End

MCD Table measurement data

The sequencer line

MCD ( Par="d:\qs32bit\par\airdemo.mcp", Disp=tab, SaveGfa=0 )

stores the measured value in array 0 of the global field (gfa[0][]) and produces the fol-
lowing table:

Fig. 2-80

MCD Bargraph measurement data

The sequencer line

MCD ( Par="d:\qs32bit\par\airdemo.mcp", Disp=bar, SaveGfa=0 )

stores the measured values in array 0 of the global field (gfa[0][]) and produces the fol-
lowing bar chart:
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Fig. 2-81

MCD Versus Time measurement data

Here the measured data are displayed as a function of time. The extent of the X-axis 
can be specified at will, but it should be adapted to the measure loop. This display mode 
is only useful if the MCD() instruction is used within a loop.

The sequencer line

MCD ( Par="d:\qs32bit\par\airdemo.mcp", Disp=vt, SaveGfa=0 )

stores the measured values in array 0 of the global field (gfa[0][]) and produces the fol-
lowing picture:

Fig. 2-82
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2.7.3.4 Measurement data of the GSC() instruction (gas specific 
calibration)

The sequencer line

GSC( Par="d:\qs32bit\run\par\airdemo.gcp", Disp=on, Prot=off )

produces the following screen:

Fig. 2-83

The table shows the component names, the mass numbers, the concentrations, and the 
determined calibration factors. The line marked with the symbol «*» is the Internal Stan-
dard.

NOTE:
More information about this measurement is found in Chapter 2.8.4 Gas specific 
sensitivity, 142.

2.7.3.5 Measurement data of the ZeroGas() instruction (zero gas 
measurement)

The sequencer line

ZeroGas( Par="d:\qs32bit\run\par\airdemo.mip", Disp=on )

produces the following table:

Fig. 2-84
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The measurement data are stored in Quadstar 32-bit and are subtracted in all subse-
quent measurements from the measured intensities, if the background subtraction is 
switched on.

NOTE:
More information about this measurement is found in Chapter 2.8.2 Background 
measurement (Zero Gas), 137.

2.7.3.6 Measurement data of the MSC() instruction (mass scale 
calibration)

The sequencer line

MSC(Par="d:\qs32bit\run\par\airdemo.msp", CalMode=fine, 
SaveMode=reset, Disp=on)

produces the following table:

Fig. 2-85

Please note the significance of the keyword SaveMode.

• reset: The previous data of the mass scale calibration are deleted and replaced by 
the new data.

• append: The new mass scale calibration data are inserted into the previous data. Al-
ready existing basic points are overwritten and new ones are appended.

Calibration of the mass scale in CalMode=fine should only be performed, if it was previ-
ously possible to perform at least one (successful) calibration in coarse mode.

NOTE:
More information about this measurement is found in Chapter 2.8.1 Mass scale 
calibration (Mass Scale), 134.
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2.7.4 User-controlled sequence

Quadstar 32-bit offers the possibility of programming a user-controlled sequence by the 
Dialog() instruction. The Dialog() instruction produces a Quadstar 32-bit dialog box that 
enables the operator to influence the execution of a sequence. For example, the dialog 
box could contain two pushbuttons that are labeled with «0…100 amu» and «100…200 
amu». The operator would then choose, whether he wants to measure in the range of 
0…100 amu or 100…200 amu.

See Chapter 8.6.2 User-controlled analysis (AIRDEMO2), 431.
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2.8 Calibration
Different calibrations are necessary before a gas analysis is performed for the first time:

• Mass scale calibration
• Background measurement
• QMS Offset calibration (QMS 422/200)
• Gas specific sensitivity calibration.

The calibrations can be performed manually or in the sequencer.

Calibration menu

Fig. 2-86

Mass Scale
Mass scale calibration.

Zero Gas
Background measurement. See Chapter 2.8.2 Background measurement (Zero Gas), 

137.

Gas Specific Sensitivity
Gas specific sensitivity calibration. See Chapter 2.8.4 Gas specific sensitivity, 142.

QMS Offset
Determine the QMS offset. See Chapter 2.8.3 QMS Offset, 140.

2.8.1 Mass scale calibration (Mass Scale)

Why calibrate the mass scale?

For exact MID or MCD measurements it is vital to measure at the peak maximum. For 
that purpose it is necessary to calibrate the mass scale. In this way, deviations of the 
mass scale within the range of ±0.5 amu from the nominal value can be corrected.

Larger deviations must be corrected before:

• QMS 422/421: Perform a rough alignment on the RF generator of the spectrometer.

• QMS 200: Rough alignment in the Tune Up program by [Tune] > [QMS 200 Tune 
Mass Scale].

Under [Calibration] > [Mass Scale] the peak maxima of a few defined masses are accu-
rately determined and the positions of the remaining masses are interpolated or extrap-
olated linearly (for extrapolation only the first and the last basic point are used).

The calibration data that is obtained this way can be checked or modified in the Display 
Saved Values program under [Auxiliary] > [Mass Scale Calibration].
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Application: In MCD measurements only an integer value (14, 16, 28, etc.) is inserted 
for the mass number and the correction value is calculated from the calibration data. 
This method ensures that when the mass scale is recalibrated, the mass numbers of 
previously prepared parameter files are also updated.

Procedure 1 Let a suitable calibration gas into the vacuum chamber. If no specific calibration 
gas is available, you can work with air instead.

2 Choose [Calibration] > [Mass Scale] and open the matching file (e.g. aird-
emo.msp if you work with air).

3 In the now appearing setup dialog box choose [Calibration Mode] > [Coarse]. If 
you want to replace the previous mass scale calibration data, then choose [Save 
Mode] > [Reset], otherwise [Append]. Confirm the choice by [OK], so the calibra-
tion is started:

Fig. 2-87

The calibration produces the table above. The State column shows the status of the indi-
vidual channels:

State column • ok: The calibration has been successfully performed, the exact mass numbers are 
shown in the column New Mass.

• no peak found: No peak was found within the search range.
• mass too low: The entered mass number is too far to the left of the peak.
• mass too high: The entered mass number is too far to the right of the peak.
• int. below threshold: Intensity lower than the level defined by the Threshold parame-

ter.
• int. too high: Intensity equal to or higher than full scale range.
• int. drop insufficient: Intensity is too constant to determine a maximum.
• peak too narrow: The peak is too narrow to determine a maximum.

4 If all mass numbers have been successfully calibrated, perform the calibration in 
[Calibration Mode] > [Fine] as well; the search range is smaller and the accuracy 
even higher.

If many errors have been reported, you should check the peaks and the measure param-
eters by a Scan Analog measurement (measure range, peak position, peak shape etc.). 
Choose [Parameters] > [Channel] or double-click with the right mouse button on the 
table, so the channel parameter editor appears for optimizing the measurement param-
eters.

NOTE:
The parameter optimization is explained in the Parameter Setup program. See 
Chapter 3.4.1 Mass Scale, 199
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In the Display Saved Values program (under [Auxiliary] > [Mass Scale Calibra-
tion]) the data of the mass scale calibration can be checked and corrected if nec-
essary.

Mass Scale 
Calibration menu

Fig. 2-88

Submenus File
File handling and return to the main menu of the Measure program.

Operation
Repeat the measurement.

Parameters
Parameter handling for control and measurement parameters.

2.8.1.1 File submenu

Fig. 2-89

Load Parameter
Load a parameter file.

Close
Quit the mass scale calibration.

2.8.1.2 Operation submenu

Fig. 2-90

Remeasure
Repeat the measurement.

2.8.1.3 Parameters submenu

Fig. 2-91
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Setup
Enter control parameters.

Channel
Enter channel parameters.

2.8.1.4 Setup

Fig. 2-92

Calibration Mode
• Coarse: The QMS works with a fast, coarse search. The search range is wide and 

the result fairly exact.
• Fine: The peak top is searched within a reduced range, the result is very exact.

Save Mode
• Reset: The previous data of the mass scale calibration will be replaced by the new 

data.
• Append: The new data of the mass scale calibration are inserted into the previous. 

Already existing basic points are replaced and new ones are inserted.

2.8.1.5 Channel

Change or optimize channel parameters.

2.8.2 Background measurement (Zero Gas)

Why background measurement ?
The residual gas background in the analysis chamber can falsify the results if it is not 
handled properly. The partial pressures and the composition of the residual gas in the 
analysis chamber are essentially determined by:

• type of vacuum pump (turbomolecular pump, diffusion pump, etc.), and
• history of the system.

Zero Gas enables you to determine the residual gas background that is found in any 
analysis chamber. The ion currents determined this way can be subtracted in all subse-
quent measurements. The residual gas is measured either with a closed gas inlet or with 
the aid of a zero gas (ultra-pure gas that is admitted into the measurement chamber at 
the same pressure that is subsequently used for analysis). Through the admission of a 
zero gas for residual gas determination, adsorption and desorption effects are better 
taken into consideration than if the chamber is pumped down to the ultimate vacuum. 
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Mass numbers on which peaks of the zero gas occur must not be included in the mea-
surement parameter list.

NOTE:
The values of a background measurement are stored and subtracted from the in-
tensities measured in subsequent measurements (MID, MCD or GSC measure-
ments), if the Zero Gas Subtraction is switched on.

The stored data of the background measurement can be checked and corrected if 
necessary in the Display Saved Values program under [Auxiliary] > [Zero Gas].

Zero Gas measurement with SEM
The calibration and measurement operations are greatly simplified if the Common SEM 
Voltage option is used. This ensures that the selected SEM voltage is the same for the 
current background measurement and all subsequent analyses.

NOTE:
The Common SEM Voltage is entered under [Setup] > [SEM/Emission Control] (or 
by Ctrl+S).

Assign the Common SEM Voltage to a channel: Click (in the channel parameter 
editor) on the SEM Voltage of the corresponding channel with the right mouse 
button. Then click with the right mouse button on either of the arrows [up] or 
[down]. The Voltage is now displayed between brackets (e.g. <<2500>>); this in-
dicates that it is always set to the current Common SEM voltage.

Procedure 1 Let a suitable zero gas into the vacuum chamber or pump it down to the ultimate 
pressure.

2 Choose [Calibration] > [Zero Gas] and open the matching parameter file; this is 
normally the MID or MCD file that you use later for the analysis (e.g. airdemo.mip 
if you analyze air).

3 If you want to replace the previous zero gas data, then choose [Save Mode] > 
[Reset], otherwise [Append]. Confirm the choice by [OK], so the zero gas mea-
surement is started. On all mass numbers of the current parameter file the inten-
sities are measured and displayed:

Fig. 2-93

The measurement data are displayed as a table. In the background measurement only 
the Detector types FARADAY, SEM, CH-TRON and ION COUNT are taken into consid-
eration; for other types (AI, PI, PE, TPR or PKR) no measurement data are collected:

Type
Data type of the displayed measurement value.
138 Measure vpnb68e1 (0302), Quadstar 32-bit



• Cur.: Ion current (in Amppere) for Detector Type: FARADAY, SEM or CH-TRON.
• Cnt.R.: Counter reading (in cps) of the ion counter for Detector Type: ION COUNT.

Zero Gas menu

Fig. 2-94

Submenus File
File handling and return to the main menu of the Measure program.

Operation
Repeat the measurement.

Parameters
Parameter handling for control and measurement parameters.

2.8.2.1 File submenu

Fig. 2-95

Load Parameter
Load a parameter file and start the measurement.

Close
Quit the background measurement.

2.8.2.2 Operation submenu

Fig. 2-96

Remeasure
Repeat the measurement.

2.8.2.3 Parameters submenu

Fig. 2-97

Channel
Modify channel parameters.
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2.8.3 QMS Offset

The QMS 422/200 determines all necessary correction values to eliminate offsets of the 
measure amplifier under different conditions. For that, the ion current is measured on 
the mass specified under [Mass Parameters] > [Zero Mass] (default=5.5 amu). The off-
set values are stored in the QMS.

Procedure 1 Choose [Calibration] > [QMS Offset]. The current values are read from the QMS 
and displayed as ’Previous Offset Values’.

NOTE:
Make sure that the measurement window is large enough to display all columns 
and rows. Otherwise, the display may be mutilated.

2 If you want to remeasure the offset values (e.g. if all values are zero, i.e. not deter-
mined yet), then choose [Operation] > [Remeasure]; the offset values of all mea-
suring ranges are now measured and displayed. During the measurement, which 
takes some seconds, the status bar message «QMS Offset Calibration in 
progress !» is displayed. After measurement the offset values are displayed as 
’New Offset Values’, and the end of the measurement is confirmed with the status 
bar message «QMS Offset Calibration done !».

QMS 422

Fig. 2-98

QMS 200

Fig. 2-99

The values are displayed only for check or service purposes. Since they are stored only 
in the QMS and not in Quadstar 32-bit, it’s not possible to display them in the Display 
Saved Values program.
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Fast, Normal, Slow
QMS 200 needs different offset values for the different measurement speeds (Fast, Nor-
mal, Slow), whereas QMS 422 has one value for all speeds.

QMS Offset 
calibration menu

The following functions are available through the QMS Offset Calibration menu:

File
• Close: Terminate the QMS Offset Calibration function.

Operation
• Remeasure: Restart the offset measurement.
• Clear Offset Values: Set all Offset values to zero (only for QMS422 available).

Parameters
• Setup: Call the QMS Offset Calibration Setup dialog box.

2.8.3.1 QMS Offset Calibration Setup

QMS 422

Fig. 2-100

QMS 200

Fig. 2-101
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Control elements Detector Parameters
• Type: Type of detector (FARADAY, SEM or CH-TRON).
• SEM Voltage: Voltage of the SEM or CH-TRON.

Mass Parameters
• Zero Mass: Mass number on which the offset is to be measured.
• Resolution: Resolution.

Output Parameters
• Monitor: Service signal at the monitor output of the QMS on/off.

2.8.4 Gas specific sensitivity

The objective of the quantitative gas analysis (MCD measurement) is to determine the 
concentrations of the individual gas components from the mass spectrum. The mea-
sured ion currents are input to a solution matrix and the individual concentrations of the 
components in the gas to be analyzed are determined via calibration factors.

For calculating the gas concentrations from ion currents, the mass spectrometer sensi-
tivity for the individual gas components must be known. Those relative mass spectrom-
eter sensitivities are determined by the following measurement and stored as calibration 
factors.

Calibration factor library
The Quadstar 32-bit Quantitative Analysis works with a calibration factor library. The 
size of this library is open, i.e. it grows with the input of each new component. For each 
component that is referenced in an application or calibration matrix, the calibration fac-
tors and the corresponding mass numbers must be stored in this library. The number of 
calibration factors is limited to 24 per component.

The calibration factors are stored in a calibration factor library. They are defined as fol-
lows:

which means that the calibration factors are proportional to the intensities.

Calibration factors can be determined for each fragment ion of a component. If it is cer-
tain that on a given mass number only the desired component exists, the concentration 
can also be determined by measuring only this single mass number of the component. 
But the accuracy with which the concentration is determined usually increases with the 
number of measured mass numbers.

NOTE:
Only gas mixtures are to be used for calibration, whose components do not over-
lap in the mass spectrum.

Since all calibration factors are given as relative values, a fixed calibration factor (inter-
nal standard) must be defined. Normally the calibration factor for N2 (m/e = 28) is set to 
1 (default setting), and all other calibration factors relate to this value. In this way a con-
sistent calibration factor library can be built.

Concentration Intensity
CalibrationFactor
------------------------------------------------=
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Procedure NOTE:
Do not forget to measure the background before the calibration, and calibrate the 
mass scale before if necessary.

1 Let a suitable calibration gas into the vacuum chamber.

2 Choose [Calibration] > [Gas Specific Sensitivity] and open the parameter file that 
belongs to the calibration gas in use (e.g. airdemo.gcp if you use air for calibra-
tion), so the gas specific sensitivity calibration is started:

Fig. 2-102

The calculated calibration factors are displayed as a table. The Internal Standard (in this 
example N2/28amu) is marked by an * sign. The analysis matrix does not contain the 
actual calibration factors but only «pointers» to the location in the calibration factor 
library. The advantage of this method is that always the latest calibration factors are 
used when the application matrix is loaded. Already existing matrices are «automati-
cally» updated this way.

Menu for Gas 
Specific 
Calibration

Fig. 2-103

Submenus File
File handling and return to the main menu of the Measure program.

Operation
Restart the measurement.

Parameters
Measurement parameter handling.

2.8.4.1 File submenu

Fig. 2-104

Load Parameter
Load a parameter file and start the measurement.

Close
Quit the gas specific calibration.
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2.8.4.2 Operation submenu

Fig. 2-105

Remeasure
Start the measurement again.

2.8.4.3 Parameters submenu

Fig. 2-106

Channel
Modify/optimize channel parameters.

NOTE:
The optimization of the parameters is described in the Parameter Setup program 
under [Calibration] > [Gas Specific Sensitivity].
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2.9 Manual Parameters

Manual menu Choose Manual for displaying the state of digital input channels and for manually switch-
ing digital output channels on or off. The communication to the mass spectrometer must 
be enabled for that.

Fig. 2-107

For turning a digital output channel on or off, double-click on the corresponding com-
mand button with the left mouse button. The channel state is displayed by the colored 
dot on the command button: green = on, grey = off.

2.9.1 DI/DO Manual for QMS 422/421

Fig. 2-108

Display left
Select the DI/DO group to be displayed on the left side of the screen.

Display right
Select the DI/DO group to be displayed on the right side of the screen.

A group cannot be displayed at the left and the right side simultaneously.
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2.9.2 DI/DO Manual for QMS 200

Fig. 2-109

Only the two standard digital input and output channels are available:
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2.10 Communication menu
Under Communication you can turn on or off the interface to the QMS. If several QMS’s 
are available, the desired unit can be chosen.

Comm Menu

Fig. 2-110

Connect
Establish the connection to the QMS.

Disconnect
Cancel the connection to the QMS.

SetUnit
Select a control unit.
See Section «Selecting a control unit in the ArcNet network (Set Unit)», 218.

NOTE:
For detailed information see Chapter 3.6 Communication parameters, 209.
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2.11 Setup
In the Setup menu you can turn the emission and the SEM high voltage on/off and setup 
the documentation of measure data (file info):

Setup menu

Fig. 2-111

Submenus SEM/Emission Control
Turn the emission and the SEM high voltage on/off. Here you can enter the generally 
usable Common SEM Voltage as well.
The menu entries SEM and Emission Control are only accessible when the QMS-com-
munication is enabled.
You can also call the dialog box directly by <Ctrl+S>.

File Info
Set up the documentation of measure data. You may here preset the parameter groups 
to save (e.g. useful for sequencer operation) and determine generally whether to save 
a documentation or not.

Fig. 2-112

Control elements Parameters/Data to save
Check the groups here you want to save as a documentation:

• Measurement Parameters: Channel parameters valid at measure time.
• Ion Source Parameters: Ion source parameters valid at measure time.
• State Parameters: Settings that may be important for the interpretation of the mea-

sured results.
• Zero Gas Data: Zero gas data valid at measure time.

Additional Information
You may define here up to 20 sets of parameters, each consisting of a Name and a 
Value.

• [Delete All Names]: Delete self defined parameter names.
• [Delete All Values]: Delete self defined parameter values.
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Save File Info
Check here whether to save a measure data documentation at all or not.

[OK]
Adopt the setup and leave the dialog box.

[Cancel]
Drop the setup and leave the dialog box.
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3. Parameter Setup

In Parameter Setup program you can enter and check different settings:
• Get general system information.
• Create parameter files for the different measurement types and calibrations.
• Program sequences.
• Enter control parameters of Quadstar 32-bit.
• Setup communication with the QMS.
• Configure the system.

Quadstar 32-bit does not automatically initiate communication with the QMS when the 
Parameter Setup program is started. This communication must be established by 
[Comm] > [Connect].

Main menu

Fig. 3-1

Submenus File
Display the Quadstar 32-bit software version, recall information about the software key 
and the PC system. General settings for printing. Terminate the Parameter Setup pro-
gram.

Measure
Create measurement parameters for the Scan Analog, Scan Bargraph, MID and MCD 
measurement types. See Chapter 3.2 Measure Parameters, 156.

Sequence
Create/edit a sequence. See Chapter 3.3 Sequence programming, 190.

Calibration
Create calibration parameter files. See Chapter 3.4 Calibration Parameters, 199.

Manual
Operation/display of the digital input and output channels (DI/DO). See Chapter 3.5 
Manual parameters, 207.

Comm
Select the interface to the mass spectrometer (RS232C, ArcNet) and set it up. See 
Chapter 3.6 Communication parameters, 209.

Setup
Set up mass spectrometer, printer and ASCII-export. See Chapter 3.7 Setup parame-
ters, 223.
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Config
Enter the mass spectrometer configuration (e.g. detector type, mass range, options 
such as DO 420, PKR 250, etc.), digital and analog inputs and outputs and the screen 
colors. See Chapter 3.8 Instrument Configuration, 234.

Help
Display the ‘Key Fragment Ions’ table and help contents. See Chapter 1.9 Hints con-
cerning the work with Quadstar 32-bit, 56.
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3.1 File

File menu

Fig. 3-2

System Info
Display information on the installed hardware and software.

About Parameter Setup
Information on the Parameter Setup program.

Print Settings
General settings for printing.

Exit
Quit the Parameter Setup program.

3.1.1 System Information

Fig. 3-3

Software Key 
Info/Option File 
Info

Provides information on the QMS key (if available), the key number, and the enabled 
options of your Quadstar 32-bit software.

Software Key Info
• Key Number: Identification of the QMS key (e.g.: 1234).

Option File Info
• Key Number: Number of this Quadstar 32-bit software.
• Control Option: Process Control Module installed/not installed.
• Calculation Option: Quantitative Analysis Module installed/not installed.
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Free Disk Space Displays the available storage space on the selected disk. Free Disk Space can be used 
before a measurement to check whether or not sufficient space is available on the disk 
drive selected in [Setup] > [General] under Data File Path.

3.1.2 About Parameter Setup

Use this menu option to determine the version of the Quadstar 32-bit Parameter Setup 
program:

Fig. 3-4

3.1.3 Print Settings

In this dialog box you can choose the settings to be printed:

Fig. 3-5

Global Settings
Settings that apply to all connected units:

• Communication Parameters: Settings of the communication line PC <=> QMS.
• General Setup: Quadstar 32-bit settings (Paths, Error History, Alarm etc.)
• ASCII Conversion Parameters: ASCII-Conversion setup.
• Screen Colors: Colors used for the screen display.

Unit Specific Settings
Settings that apply to a single unit:

• DI Identifications: Named digital inputs.
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• DO Identifications: Named digital outputs.
• AI Characteristic Curve: Analog inputs with characteristic curves.
• AO Characteristic Curve: Analog outputs with characteristic curves.
• of [ (Unit Specification) ]: Units, for which these settings are to be printed:

• Current Unit: Currently used unit.
• All Enabled Units: All enabled units of the net.
• All Units: All declared units.

3.1.4 Exit

Quit the Quadstar 32-bit Parameter Setup program.
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3.2 Measure Parameters

Measure menu In the Measure menu of the Parameter Setup program you can choose the type of mea-
surement and afterwards set up the measurement channels.

Fig. 3-6

The following measurement types are available:

Submenus Scan Analog
Analog mass spectrum beginning with a start mass (FIRST MASS) across a selectable 
mass range (WIDTH) on one or more channels.

Scan Bargraph
Peak search, beginning with a start mass (FIRST MASS) across a selectable mass 
range (WIDTH) on one or more channels. Only the intensities of the found peaks with 
their corresponding mass numbers are recorded.

MID
Multiple Ion Detection, a localized measurement on one mass number per channel. To 
get the intensities of several masses, several channels must be used.

MCD
Multiple Concentration Detection, an MID-measurement with subsequent calculation of 
the concentrations. See Chapter 3.2.5.5 Editing the MCD parameter files (Quantitative 
Analysis), 180.

3.2.1 Selecting the parameter file
• Select the desired measuring type (Scan Analog, Scan Bargraph, MID, MCD).

• the File Manager appears that shows the existing parameter files. Choose one of 
them, make a copy of one, or create a new one. See Chapter 10.1 File Manager, 

541.

3.2.2 Storing the parameters

When you exit the editor, Quadstar 32-bit stores all parameters in the opened file that 
has already been assigned a name, and closes it. Each file contains all parameters 
required for the corresponding measuring type. The file size depends on the number of 
activated channels (total max. 64 channels). A channel is activated, if its parameter 
State is set to ENABLE. The different measurement types create parameter files that 
have different file extensions. For an explanation of file extensions see Chapter 10.3 
Quadstar 32-bit files, 544.
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3.2.3 Create or copy a parameter file

There are two methods for creating a new parameter file. An existing file can be copied 
(a) and then modified, or a new file can be created (b) that is initialized with default 
parameter values. In the latter case all parameters must be adapted, in the first one only 
a few.

1 Choose the desired measurement type. The Quadstar 32-bit file manager shows 
up:

Fig. 3-7

2 a) Copy an existing file to a new one: Select a file and click [Copy].
b) Enter a new file name; in this case, Quadstar 32-bit asks whether to create a 
new file with this name or not.

3 Press the [OK] command button.
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3.2.4 The channel parameter editor

When you have opened a parameter file, the channel parameter editor appears in the 
standard configuration shown below:

Fig. 3-8

1 menu
2 cursor position
3 QMS channel number
4 group "Main"
5 group "Detector"
6 no available Parameter
7 Register cards
8 set cursor to activ channel
9 navigate through register cards
10 first channel which is displayed at the active scroll bar position
11 channel selection scroll bar

The number of displayed channels depends on the screen resolution, the font and the 
window size.

The parameters shown in the upper half of the picture (State, Det. Type and Mass) 
belong to the Main group. This group is always displayed and has no register card.

The other parameters are subdivided into groups which are displayed as register cards. 
Those groups are by default arranged as follows:

Detector:
Detector properties (e.g. SEM voltage)

Mass
Parameters for a mass scan.

Amplifier
Signal amplifier properties (measure range, offset etc.).

Output
Programming of the analog measurement output.

Trip
Programming of the switching functions (for MID/MCD measurements).
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Display
Color and display range of the measured values.

NOTE:
You can define your own groups. These can contain any parameters, for example, 
the main parameters for a measuring type (MID, Scan Bargraph, etc.). See 
Chapter 3.2.5.3.1 Configuration, 172.

To changeover the display to a different group (register card), click on the name of the 
desired group. To display the channel parameters of the Mass group click on the Mass 
register card:

Fig. 3-9

Parameters, that have no influence in a channel (due to the selection of higher ranking 
parameters), are marked by a dash only. Parameters, that are not available (e.g. due to 
the configuration), are not displayed at all.

3.2.4.1 Measuring parameters overview

Below you will find a list of the most important measuring parameters (also called ‘chan-
nel parameters’) and their meanings. Depending on the mass spectrometer, the mea-
surement type, the hardware configuration etc. the appropriate parameters are dis-
played. The subdivision into groups (register cards) corresponds to the default setup.

3.2.4.1.1 ‘Main’ group

This group contains the most important parameters, they are displayed constantly:

State
Channel On/Skip/Off (Enable/Skip/Off).

• Enable: The channel is measured and the parameters are stored.
• Skip: The channel is not measured, but its parameters remain stored.
• Off: The channel is not measured and its parameters are deleted.
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Det. Type
Detector type that is used for the measurement.

Mass Mode
Type of the mass scan.

• Scan-N: Normal analog scan.
• Scan-F: Analog scan using the FIR filter.
• Stair: Mass spectrum with integer mass jumps.
• Peak-L: Search for peaks, that reach at least a specified intensity.
• Peak-F: Search for peaks, that reach at least a specified intensity; with FIR Filter.

Mass
Mass on which the measurement is performed.

First Mass
Start mass, at which the measurement begins.

3.2.4.1.2 ‘Detector’ group

This group contains the detector parameters:

SEM Voltage
Operating voltage of the SEM.

3.2.4.1.3 ‘Mass’ group

This group contains the parameters, that control the mass scan.

Speed
Measuring time per amu for scan measurements.

Dwell
Dwell time for the measurement on this channel.

Width
Mass range from the start mass onward.

Resolution
Mass resolution (smaller number = better separation of the peaks).

Steps
Number of measured points per amu for scan measurements.

Threshold
Intensity that a peak must reach at least to get displayed.

Zero Mass
Mass on which the electrometer offset is measured.
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3.2.4.1.4 ‘Amplifier’ group

This group contains the parameters that control the signal amplifier.

Amp. Mode
Amplifier operation mode (Fix/Auto/Auto-D).

• Fix: The measuring range is unchanging and has to be set.
• Auto: The measuring range is variable, it is determined by the mass spectrometer.
• Auto-D: The measuring range is variable, it is determined by the mass spectrometer, 

but a lower limit can be set that is not undercut.

Amp. Range
Measuring range of the amplifier.

Calibration
Fine tuning of the amplifier gain.

Range-L
Lower limit of the automatically selectable amplifier ranges.

Filter
Time constant of the built-in analog filter.

Pause-Cal.
Amount of time between the measurement of two channels, during which no values are 
measured; is used to wait until the amplifier has settled.

Offset
Offset correction value of the amplifier.

Gain
Amplifier gain for detector type Extern.

CP-Level
Threshold of the ion counter preamplifier.

3.2.4.1.5 ‘Output’ group

This group contains the parameters that control the analog output of measured values:

AO-Channel
Number of the analog output, on which the measured values of the channel are output.

AO-Mode
Output the measured values in a linear or logarithmic style on the analog output.

Monitor
Output the measured values in a linear or logarithmic style on the Monitor output.

AO-Decades
Number of decades that are output on the analog output.

AO-Range
Range of measured values that are output on the analog output.
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3.2.4.1.6 ‘Trip’ group

This group contains the parameters of the threshold monitoring function:

Trip Type
Type of the threshold monitoring function.

Level A
Threshold A.

DO# A
Digital output, on which the threshold state A or the result of the threshold monitoring 
function is output.

Level B
Threshold B.

DO# B
Digital output, on which the threshold state B or the result of the threshold monitoring 
function is output.

3.2.4.1.7 ‘Display’ group

This group contains the parameters of the display control:

Disp. Mode
Display measured values On/Off.

Color
Color, in which the measured values of this channel are to be displayed.

Disp. F.S.R.
Full Scale Range, Upper limit of the display.

Disp. Decades
Number of decades.

3.2.4.1.8 ‘<<Rest>>’ group

This group contains the residual parameters:

Baseline Shift
Value by which the display is shifted up or down, relative to the baseline.

3.2.4.2 Modification of parameters

Click on the desired parameter with the right mouse button, so an input field appears. 
This can be (depending on the parameter) a context menu (Speed, Range, etc.) or an 
editing field (Mass, Width, etc.).
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Input of param-
eters via the 
context menu

No direct input is allowed. In the displayed context menu (and depending on the installed 
hardware) the alternatives available for the selected parameter are displayed. In the fol-
lowing example these are the parameters Faraday and AI.

With the right mouse button click on the detector type (Faraday) under CH-1:

Fig. 3-10

The arrow behind AI (=Analog Input) means that for this parameter a subgroup with 
additional parameters (here: analog input channels) is available.

These can be called on the screen by clicking on AI with the left mouse button:

Fig. 3-11

If logical names are assigned to the analog and digital input and output channels, these 
are shown in brackets behind the channel number:

Fig. 3-12

Numeric input via 
the editing field

In contrast to the context menu, clicking on Mass with the right mouse button opens an 
editing field in which direct input is possible.

Fig. 3-13

The parameter value can be typed or changed by the [UP] or [DOWN] arrow buttons. 
Accept the change by clicking the button on the left side of the editing field or reject it by 
ESC.

The [UP] or [DOWN] buttons have the following function:

• Left mouse button + [UP] or [DOWN]: current value ± small steps
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• Right mouse button + [UP] or [DOWN]: current value = Default value

• Right + left mouse button + [UP] or [DOWN]: current value ± large steps 
For this input, the right mouse button must be pressed while the cursor is still located 
in the numeric input field. Then while holding the right mouse button shift the cursor 
to the [UP] or [DOWN] button and click on it with the left mouse button while still hold-
ing the right mouse button.

Special cases For the following parameters a special effect can be achieved with the right mouse but-
ton:

Fig. 3-14

3.2.4.3 Configurations (Parameter groups/register cards)

Separate configurations exist for each application of the editor (MID, ScanAnalog, Peak 
Search parameters, etc.) with differently arranged register cards (Groups). The group 
names remain the same, but they may contain different parameters. You can change 
this groups or create new groups, if you want to:

Parameter Condition Display Effect

SEM Voltage Detector = SEM <<xxxx>> SEM Voltage = Common SEM

AO-Channel ---- OFF No AO channel active

DO# A/DO# B MID measurement OFF No DO channel active

Zero Mass MID measurement OFF Offset calibration disabled

Disp. F.S.R. --- Auto Select the display range auto-
matically
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Configuring the 
editor

Fig. 3-15

1 Choose configuration
2 Current register card
3 Register cards of this configuration
4 Parameters not available for the current hardware configuration
5 All available Parameters
6 Parameters of the current register card
7 Buttons either for moving parameters within "In Group" or for transferring parameters between "In Group" 

and possible

In this dialog box you can define new editor configurations. Each configuration can con-
tain up to 10 register cards that you can put together individually.

NOTE:
Please note that parameters, that are not available in the current hardware config-
uration, are set between brackets in the Possible (and In Group) fields (e.g. QMU 
Channel). They can be transferred from the Possible field to the In Group field, but 
they are not displayed there. See Chapter 3.2.5.3.1 Configuration, 172)

Main Parameters The State, Det. Type and Mass parameters shown in the upper part of the editor are put 
by default in the << Main Param. >> register card in the << Default >> configuration. See 
Chapter 3.2.5.3.1 Configuration, 172.

This group is always displayed. It can be modified and expanded as well.

State
Channel state (on/skip/off).
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Fig. 3-16

The operating states ENABLE, SKIP and OFF have the following meaning:

• ENABLE: The channel is activated and is taken into consideration in a measurement. 
The parameters entered in the parameter editor are stored.

• SKIP: The channel is not executed in the measurement (skipped). Its parameters are 
preserved and are also stored. The channel can be reactivated by ENABLE.

• OFF: The channel is deleted from the parameter file after saving. The parameters 
must be entered again when the channel is reactivated.

Det. Type
Chosen detector (FARADAY, SEM, ION COUNT, etc.). The detector type must be 
defined under [Config] > [QMS...]

Mass Mode
Scan mode (PEAK-N, SCAN-N, STAIR), FIR-Filter (PEAK-F, SCAN-F). The modes that 
can be selected depend on the chosen measuring type (Scan Analog, Scan Bargraph, 
MID, MCD).

Mass
Mass number on which the intensity is to be measured.

Configuration 
example

You want to configure the channel parameter editor in such a way, that it contains only 
the most important parameters for a Scan Analog measurement.

1 Choose [Measure] > [Scan Analog...]:

Fig. 3-17
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2 Open any file in the now appearing File Manager (e.g. AIRDEMO.SAP).

Create a new configuration (called ‘QMS 200 Scan Analog’)

3 Choose [Display] > [Configuration...]

4 Click on the [NEW] command button in the Defined Configurations field, enter the 
name of the configuration to be created (here: ‘QMS 200 Scan Analog) and con-
firm your input with [OK]:

Fig. 3-18

NOTE:
The configurations shown in the Defined Configuration list box are only available 
for Scan Analog. Consequently the new configuration QMS 200 Scan Analog is 
only available when Scan Analog parameter files are edited.

Setup the group “<< Main Param. >>”

5 In the Groups field select the (empty) group name << Main Param. >>, select the 
parameters State, Det.Type, Mass Mode and Color; press [RIGHT] each time. 
This transfers the corresponding parameters into the field In Group, i.e. they are 
now found in the group << Main Param. >>.

Fig. 3-19

Create the register card “Scan”

6 Click on the [New] key in the Groups field, enter the group name (‘Scan’) and con-
firm the entry by [OK].

Fig. 3-20
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Adapt the “Scan” register card

7 In the Groups field select the new group name Scan.

8 Select the desired parameters under Parameters in the Possible field
=> Please note that when the <CTRL> and <SHIFT> keys are pressed, several 
parameters can be selected and shifted jointly (in both directions).

9 With the [RIGHT] button shift these into the In Group field:

Fig. 3-21

10 Sort the parameters as desired by [UP] and [DOWN]

11 quit the configuration editor by [OK].

The editor now shows the following picture:

Fig. 3-22

3.2.5 Channel Parameter Editor menu

The editor provides the following menu and shows the name of the opened file (here: 
‘airdemo.sap’ in the title bar.

Fig. 3-23

Submenus File
Call the File Manager, print the parameters and return to the main menu of the program. 
See Chapter 3.2.5.1 File submenu, 169.
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Edit
Insert and delete channels. Sorting and copying functions. See Chapter 3.2.5.2 Edit 
submenu, 170.

Display
Set up the display options in the parameter editor. See Chapter 3.2.5.3 Display sub-
menu, 171.

Functions
Adjust and Peak Search functions. See Chapter 3.2.5.4 Functions submenu, 174.

3.2.5.1 File submenu

Fig. 3-24

New
Create a new file.

Open...
Call the File Manager for opening a parameter file.

Save
Store the active parameter file under its current name.

Save As...
Store the active parameter file under a different name and/or in a different directory.

Print...
Print the active channel parameter file as a table.

Close
Return to the Parameter Setup main menu.

Print... Print opens a dialog box in which additional information for the printout can be specified.

Fig. 3-25

print QMS configuration
Print the current QMS configuration on the first page.
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column headers on all pages
Print channel headers on all subsequent vertically arranged pages (Enabled)/only on 
the top page (disabled).

row headers on all pages
Print the corresponding parameter name on all subsequent horizontally arranged pages 
(enabled)/only on the first page (disabled).

The last two options should be disabled for printouts on which the pages are subse-
quently pasted together.

The font and the paper orientation is taken from the current printer setup and the printer 
font dialog box. See Chapter 3.7.3.1 Configuring the printer, 229, Chapter 3.7.3.2 Set 
up the printer page (Page Setup), 230 and Chapter 3.7.3.3 Select the printer font, 

230.

3.2.5.2 Edit submenu

Fig. 3-26

Insert Channel
Insert a new measurement channel; shift all channels (including the selected channel) 
one position to the right, starting at the selected channel.

Remove Channel
Remove (delete) the selected channel; shift all channels one position to the left, starting 
at the selected channel.

Compress Channels
Compress all channels that are not in the ‘OFF’ State.

Copy/Exchange...
Copy individual parameters or entire channels.

Sort Mass
Sort the channels by mass numbers (First/Mass).

Sort Range
Sort the channels by their amplifier ranges.

Copy/Exchange Copy opens a dialog box in which you can copy individual parameters or all parameters 
of a channel:
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Fig. 3-27

Mode Selection
Select the desired action:

• Copy: Copy the object chosen under Object Selection to one or to all channels.
• Exchange: Swap all parameters of the channel selected under Source with those of 

the channel selected under Destination. The Exchange function is only accessible if 
[Object Selection] > [Channel] has been chosen.

Object Selection
Select the object to be copied or exchanged:

• Channel Copy or exchange all parameters of the channel.
• Parameter Copy or exchange only the selected parameter.

The channels are selected under Source and Dest:

Source
Enter the channel from which the parameters are to be copied or exchanged.

Dest
Enter the destination channel to which the parameters are to be copied or exchanged. 
To specify ALL (copying/exchanging all channels) click on [UP] or [DOWN] with the right 
mouse button.

Special cases
The following special cases apply to the copying of channel parameters:

• Threshold Parameters: are only copied to channels for which the same Detector has 
been selected under Det. Type.

• Range: If a CLA400 (chopper lock-in amplifier) option is installed in the QMS, Param-
eters are only copied to channels with identical Lock-In state. Without CLA400, there 
is no restriction.

3.2.5.3 Display submenu

Fig. 3-28
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Configuration
Create new configurations and change existing configurations of the selected measure-
ment type (Scan Analog, MID, etc.).

Font
Choose the font type, style and size to be used for the parameter editor.

Measure Data
Start the service measurement (only if the communication to the QMS is switched on). 
See Chapter 3.2.5.3.3 Measure Data, 174.

3.2.5.3.1 Configuration

Fig. 3-29

Control elements Defined Configuration
List of available configurations.

• [Save As]: Save the current settings and register cards as a new configuration:

Fig. 3-30

• [New]: Create a new configuration.
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Fig. 3-31

• [Delete]: Delete the currently selected configuration:

Fig. 3-32

Groups
Groups shows the current register cards (parameter groups).

• [UP]/[DOWN]: With these keys you can change the order of the register cards.
• [Rename]: Rename a register card.
• [New]: Create a new register card.
• [Delete]: Delete the selected register card. The <<Main Param.>> group name can-

not be deleted.

Parameters
Setup the register card.

• Possible: Lists the parameters that can be assigned to the register card selected un-
der Groups. => Those parameters which are not available in the current hardware 
configuration are shown in brackets. They can be transferred to the In Group field, 
but they will not be displayed by the editor.

• In Group: Lists the parameters that have already been assigned to the register card 
selected under Groups. These parameters are no longer listed under Possible.

• [UP]/[DOWN]: With these keys you can change the order of the parameters within a 
register card.

• [LEFT]: Remove the selected parameter from this group.
• [RIGHT]: Move the selected parameter to this group.

3.2.5.3.2 Font selection

Here you can choose the font type, the font style and the font size of the channel param-
eter editor.

The selected font is shown in the Sample box:
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Fig. 3-33

3.2.5.3.3 Measure Data

If a QMS is connected and the communication is on, Measure Data starts a service mea-
surement with the parameters in the currently selected channel.

The display responds to all parameter changes; the type of display depends on the pre-
viously selected measuring type ( Bargraph (MID), Scan Bargraph or Scan Analog).

If no measurement data are displayed, this may (among others), be caused by one of 
these reasons:

• Emission OFF
• SEM Voltage OFF
• Range or SEM Voltage setting too low
• Wrong detector (Det. Type parameter in << Main Parameter >> group)
• Channel State OFF or SKIP
• Inlet system closed, that is, the working pressure is too low (recommended: 2.0E-06 

mbar).

3.2.5.4 Functions submenu

This menu is only available for MID/MCD parameter files. Adjust and Peak Search are 
only enabled if the interface to the mass spectrometer is switched on:

Fig. 3-34

Adjust
Adjust the mass number entered under First/Mass to the peak maximum.
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Peak Search
Search the highest peaks (selectable number) and store their mass numbers in the 
channels.

3.2.5.4.1 Adjust function

The Adjust function is used for optimizing the mass numbers entered under Mass to the 
peak maximum. In Adjust the Range setting can also be tested and optimized.

Adjust opens a window containing an empty table for the adjust data:

Fig. 3-35

The Adjust function is controlled via the following main menu:

File
Quit the adjust function.

Adjust
Start and stop the adjust function.

Options
Select the adjust mode.

Edit
Edit the adjust parameters.

File submenu

Fig. 3-36

Close
Return to the main menu of the Channel Parameter Editor. The optimized mass num-
bers are transferred into the corresponding channels of the editor when an Adjust has 
been performed successfully.
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Adjust submenu

Fig. 3-37

Start
Start the Adjust function.

Stop
Stop the running Adjust function.

The result is displayed as a table:

Fig. 3-38

The Comment column shows the status of the individual channels:

Comment column 
display

• ok: The Adjust function was successfully completed and the mass number in the 
Mass column has been corrected to the value under New Mass.

• no peak found: No peak was found within the search range.
• mass too low: The Adjust function was not completed successfully because the en-

tered mass number is too far to the left of the peak.
• mass too high: The Adjust function was not completed successfully because the en-

tered mass number is too far to the right of the peak.
• intensity too low: Intensity lower than the level specified by the Threshold parameter.
• intensity too high: Intensity greater than or equal to full scale range.

Under [Edit] > [Adjust Parameter], the Mass, Range, and Threshold parameters can be 
modified.

Options submenu This menu controls the Adjust function:

Fig. 3-39
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Coarse
The mass spectrometer performs a fast, coarse search across the specified range, start-
ing at the mass number entered under Mass.

Fine
Fine search of the peak top within a reduced search range but with greater accuracy, 
starting with the mass number entered under Mass or the mass number found by 
Coarse.

All Channels
Adjust all channels.

Single Channels
Adjust only the selected channel.

NOTE:
The time required for completing the Adjust depends on the number of channels 
and the selected Dwell measurement time. If the adjust function is cancelled be-
fore it has been completed, only those mass numbers are accepted for which the 
adjustment was completed without an error message.

Edit submenu

Fig. 3-40

Adjust Parameter
Modify the parameters Mass, Range and ThresholdAdjust:

Fig. 3-41

File
Close Quit the dialog box

NOTE:
The parameters above are stored in the corresponding channels of the MID/MCD 
parameter file.
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3.2.5.4.2 Peak Search function

Peak Search helps you to very quickly setup the parameters of an MID measurement 
containing the highest peaks. A chosen mass range is searched for the highest peaks 
and the mass numbers with the optimized settings are stored in the channels of the cur-
rent parameter file. Using this file, you can start an MID measurement that shows all val-
ues of the found peaks. Peak Search is only available for MID and Mass Scale Calibra-
tion parameter files.

[Functions] > [Peak Search] opens a window with an empty table for the peak search 
data:

Fig. 3-42

Peak Search has the following main menu:

File
Quit the peak search.

Search
Start and stop the search function.

Options
Sort the channels by mass numbers or intensities

Edit
Edit the Peak Search parameters.

Under Number of Peaks, specify the number of peaks that shall be found. Then start the 
peak search by [Search] > [Start]. In order to obtain accurate results, it may be useful to 
modify some parameters under [Edit] > [Search Parameters] (recommended: ‘Thresh-
old’ value of 3 ... 10%, ‘Resolution’ value of 1 ... 10).

File submenu

Fig. 3-43

Close
Quit the Peak Search function.
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Search submenu

Fig. 3-44

Start
Start the Peak Search function.

Stop
Stop the running Peak Search function.

After the start, the peaks found are shown in a table. If the spectrum within the search 
range contains more than the desired number of peaks, the largest peaks are listed:

Fig. 3-45

Peak Search performs as many scans with increased gain each time, until the desired 
number of peaks has been found.

Options submenu

Fig. 3-46

Sort Mass
Sort the found peaks by mass number.

Sort Int.
Sort the found peaks by intensity.

Edit submenu

Fig. 3-47

Search Parameters...
Enter the parameters (search criteria) for the Peak Search function:
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Search Param-
eters

Fig. 3-48

3.2.5.5 Editing the MCD parameter files (Quantitative Analysis)

The MCD measuring type enables you to measure concentrations. For that, an analysis 
matrix is used, that cooperates with the calibration factor library (if you change a calibra-
tion factor in the analysis matrix, it will be changed in the calibration factor library as well 
and vice versa). By the following editor you can edit such an analysis matrix.

3.2.5.5.1 Analysis matrix

Choose [Measure] > [MCD] and select a file, so the following dialog box appears. It 
shows the analysis matrix of the measurement, i.e. the gas components and their cali-
bration factors for the individual mass numbers:

Fig. 3-49

In this example the calibration factor for CO2 on mass 28 has not been taken into con-
sideration, because it has only a minimal influence in the analysis of air.
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Comp.
Name of the component.

Mass
Mass number.

• The maximum size of the matrix is limited to 64 mass numbers and 64 components.
• In an analysis each component is defined by the name and the mass number(s). Due 

to overlaps it is possible that a mass number has intensity portions of several com-
ponents.

• If a calibration factor is missing, a “?” is displayed at its place.

3.2.5.5.2 Expansion of the analysis matrix

Additional components and mass numbers can be added to the displayed analysis 
matrix:

• by inserting spectra from the Spectra Library ([Edit] > [Insert from Spectra Library])
• by manual insertion (by [Edit] > [Insert Mass] or [Edit] > [Insert Component])
• by appending (and subsequent sorting)

When the last line or column has been used, an additional cell is appended automati-
cally. Enter the component names and the mass numbers that are relevant to the anal-
ysis:

• The cursor can be positioned in any field.
• An entry is made when the cursor is moved or the <TAB> key is pressed; <ENTER> 

has no function.

When a component or mass number is removed, the line or the column is deleted.

When a new mass number or a new component is entered, the existing calibration fac-
tors are displayed. Undefined calibration factors are displayed as “?”. By [Options] > [Set 
Calib. Factors Zero] you can set all these undefined factors to zero.

NOTE:
In an analysis matrix, no undefined calibration factors are allowed. All factors 
must contain a positive value or zero.

If a mass number contains concentration portions of different components, a calibration 
factor of each component must exist for accurate analysis of this mass number. Missing 
calibration factors can be determined by the gas-specific calibration, see Chapter 2.8.4 
Gas specific sensitivity, 142, or they can be entered manually here.

3.2.5.5.3 MCD Measure Parameter menu

Fig. 3-50

MCD measurement parameters are edited via the following main menu:
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File
File handling, print analysis matrix, quit the editor.

Edit
Edit and sort the mass numbers and the component names.

Options
Set unknown calibration factors to 0.

File submenu

Fig. 3-51

Open...
Call the File manager.

Save
Store the current file.

Save As...
Store the current file under a different name or in a different directory.

Print
Print the current analysis matrix.

Close
Return to the Parameter Setup main menu.

Edit submenu

Fig. 3-52

Channel Par.
Enter the channel parameters. See Section «Channel Parameters», 183.

Concentration Par.
Enter the threshold values (concentrations) and display parameters. See Section «Con-
centration Parameters», 184.

Insert Mass
Extend the matrix by inserting a mass number (column) at the cursor position.
182 Parameter Setup vpnb68e1 (0302), Quadstar 32-bit



Delete Mass
Delete a mass number from the matrix.

Sort Mass
Sort the mass numbers in ascending order.

Insert Component
Extend the matrix by inserting a component (line) at the cursor position.

Delete Component 
Delete a component from the matrix.

Sort Component
Sort the components alphabetically.

Insert from Spectra Library
Insert components and mass numbers from the spectra library. See Section «Insert 
Spectra into the matrix», 185.

Options submenu

Fig. 3-53

Set Calib. Factors Zero
Set all undefined calibration factors (marked with “?” or “*”) to zero.

Channel Param-
eters

Choose [Edit] > [Channel Par.] to bring up the editor:

Fig. 3-54

• Input or modification of mass numbers is inhibited for the masses ([State] > [Matrix]) 
that have been entered in the analysis matrix editor.

• After the channels marked with [State] > [Matrix], additional channels can be activat-
ed. These channels are additionally measured during the analysis and can be saved 
as well. Additionally measured intensities are ignored in the calculation of the con-
centrations.

• For optimizing the channel parameters use [Functions] > [Adjust].
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NOTE:
In the Display group under Disp. Mode you can determine whether in addition to 
the calculated concentrations also the intensities (raw data) are to be displayed.

Concentration 
Parameters

In this editor you can enter under [Group] > [Trip] the thresholds of the concentrations, 
and under [Group] > [Display] the display parameters (color, etc.) for the individual con-
centration values.

Choose [Edit] > [Concentration Par.] to bring up the MCD concentration editor:

Fig. 3-55

File
• Print: Print the parameters of the groups Display and Trip.
• Close: Return to the MCD parameter editor.

Edit
• Copy/Exchange Supports parameter copying and swapping in the Trip and Display 

group:
• If the cursor is positioned on a channel, that is, on COMPONENT, only the en-

tire group can be copied.
• If the cursor is positioned on one of the parameters at the bottom of the editor, 

you can switch between this parameter (Parameter) and all parameters 
(Channel) in the Copy/Exchange dialog box under Object Selection.

Display
Display parameter group.

• Color: Choose the color.
• Disp Mode: Display concentration on/off.
• Disp. F.S.R.: Full scale range.
• Disp Decades: Number of decades to be displayed.

Trip
Trip parameter group for programming the switching functions. See Chapter 3.2.5.7 
Switching functions (Trip), 186.
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Insert Spectra 
into the matrix

[Edit] > [Insert from Spectra Library] opens the Spectra Library File Manager:

Fig. 3-56

Choose the desired spectrum (have a look at it by Spectrum, if necessary) and then 
press the [Export] button. The following dialog box appears:

Fig. 3-57

Here you can choose the mass numbers that are to be inserted into the analysis matrix 
in conjunction with the molecular formula. You can mark one or several mass numbers 
and move them between the two groups Available and Selected by the arrows [LEFT] 
and [RIGHT].

[More]
Insert the current spectrum into the analysis matrix. Return to the Spectra Library to 
choose more spectra.

[OK]
Insert the current spectrum into the analysis matrix and return to the matrix editor.

[Cancel]
Cancel the current action and return to the matrix editor.

The spectra inserted this way do not contain valid calibration factors. The spots in the 
matrix, where these calibration factors belong to, are marked by ‘*’.
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3.2.5.6 Activation of analog input channels (MID/MCD)

A measurement channel can be used as an analog input by setting its Det. Type to AI.

Fig. 3-58

If AI has been set under Det. Type, Quadstar 32-bit automatically shows the channel 
number (QMS 422/421: 0 ... 15, QMS 200: 0,1) of the analog input channel in the input 
field behind AI.

3.2.5.7 Switching functions (Trip)

In MID- and MCD measurements you can program the switching functions A (measure 
value A < threshold A?) and B (measure value B > threshold B?). The status (OFF/ON) 
can be displayed on the screen. You can combine the switching functions by logical con-
ditions and control a digital output by the result. The parameters below are displayed 
only when a function type has been selected under Type:

Fig. 3-59

Type
Choose the type of function for the two switching functions A and B.

• OFF: Switching functions A and B not active.
• ABS A: Switching function A is turned ON, if the measured intensity is below the 

threshold entered under Level A. (Switching function B not active).
• ABS B: Switching function B is turned ON, if the measured intensity is above the 

threshold entered under Level B. (Switching function A not active).
• ABS A,B: Switching function A and B are both active (See ABS A and ABS B).
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• ABS A AND B: If A AND B are both switched ON, the result is ON.
• ABS A OR B: If A OR B OR BOTH are switched ON, the result is ON.
• ABS A XOR B: If EITHER A OR B are switched ON, the result is ON.

Level A and Level B can also be used as threshold values for the Hysteresis switching 
function. For this switching function the entered Level B must be greater than Level A:

• HYS HI OFF: The result will be OFF when the signal value is above Level B and it 
changes to ON when the signal value drops below Level A.

• HYS HI ON: The result will be ON when the signal value is above Level B and it 
changes to OFF when the signal value drops below Level A.

Threshold values
• Level A: Threshold value of switching function A.
• Level B: Threshold value of switching function B.

DO Channel
• DO# A: Digital output channel of switching function A.
• DO# B: Digital output channel of switching function B.

3.2.5.8 Outputting the switching function state to a DO channel

The channel number is chosen under DO# A or DO# B.

QMS 422/421
The input range depends on the number of installed DO 420 boards (0 ... 31 for one 
board, 0...63 for two boards, and 0...95 for 3 boards; declared under [Config] > [QMS]).

QMS 200
Two digital outputs are available as standard equipment (REL_1 and REL_2).

ABS A, ABS B, ABS A,B
In these modes DO# A and DO# B correspond to the states of the switching functions A 
and B.

In logical combinations the following applies:

ABS A OR B, ABS A XOR B
DO# A and DO# B are inhibited.

ABS A AND B
Under DO# B the channel number of DO# A is adopted.

HYS HI OFF
Only DO# A is enabled.

HYS HI ON
Only DO# B is enabled.
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3.2.5.8.1 Behavior of the switching functions

Level B > Level A

Fig. 3-60

Level A > Level B

Fig. 3-61

Level A > Level B “Hysteresis”

When HYS HI OFF or HYS HI ON is chosen, the threshold value of switching function 
B must be above the value of switching function A:

Fig. 3-62

Graphic symbols The result of the threshold monitoring is displayed with graphic symbols. The colors of 
the following symbols are fixed and have the following meaning:
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Green
 Switching function OFF

Red
 Switching function ON

For the MID Bargraph and MID Table measurements the following symbols are used:

Fig. 3-63

In MID Versus Time mode the monitor trip is signaled by an arrow. The color of the sym-
bols can be selected under [Config] > [Screen Color].

When the two switching functions are logically combined, the symbol of switching func-
tion A is used:

Fig. 3-64

Display the 
switching 
functions

The display of the switching functions can be activated during a measurement (in the 
Measure program) under [Parameters] > [Setup] > [Alarm Display].
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3.3 Sequence programming
The Quadstar 32-bit Process Control enables you to create and execute measurement 
programs (sequences). These programs can be created with the Sequence Editor and 
started in the Measure program. In the following description this is referred to as the 
Sequencer.

The Sequencer executes a previously created instruction sequence instead of directly 
starting a measurement. A sequence may call and start another sequence (subroutine, 
e.g. measurement, valve control etc.) or start additional programs.

The main functions of the Sequencer are:

• Start and control measurements (Scan Analog, Scan Bargraph, MID, MCD, etc.)
• Control valves or auxiliary equipment
• Control data storage
• Exchange data with other programs
• Perform calculations automatically
• Display of measurement data and calculated values
• Display of self defined messages

NOTE:
This section describes only the principal operating elements of the Sequence Ed-
itor. For an overview of all instructions and a complete description of them, please 
refer to Chapter 8. Process Control, 409.

3.3.1 Quadstar 32-bit Sequence editor

[Sequence] > [Editor] opens the File Manager in order to choose or create a sequence 
file. This file is opened and its content (the sequence) is displayed.

Fig. 3-65

The Quadstar 32-bit Sequencer is designed as a command interpreter: the sequence is 
a series of instructions (e.g. MID(), ScanAnalog(), etc.) that are executed one after the 
other. An instruction consists of its name followed by a parameter list in parentheses:
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• The specification of certain parameters is mandatory, whereas other parameters are 
optional.

• If an optional parameter is not specified explicitly, the Sequencer automatically takes 
the default value (for example the parameter “prot=off” does not have to be speci-
fied).

3.3.1.1 Programming

There are two ways of programming the individual sequencer lines:

• Input via the keyboard.
• Compose instructions by using the dialog editor.

Input via the 
keyboard

This method is intended for experienced users and requires familiarity with the com-
mand syntax. The text is entered directly at the cursor position of the selected 
Sequencer line. A new line is inserted with the Enter key. The [Del] , [<-] and [Ins] keys 
have the usual text editor functions.

Input via dialog 
editor

Set the cursor to an instruction (e.g. MID) and choose [Edit] > [Dialog] or click with the 
right mouse button. The dialog editor containing all parameters that are valid for the 
selected instruction is displayed. If the cursor is positioned e.g. on a MID Sequencer line, 
the following dialog box is displayed:

Fig. 3-66

You may now, guided by the dialog editor, compose a MID instruction without knowing 
its syntax.

3.3.1.2 Inserting a new Sequencer line (Choose Line)

Set the cursor to an empty line and choose [Edit] > [Dialog] or click with the right mouse 
button. The Choose Line dialog box appears that offers all possible instructions:
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Fig. 3-67

3.3.1.3 Compiling/storing the sequences

When the sequence is compiled, the instructions are translated into a Quadstar 32-bit 
specific, executable code that is stored separately. Errors are flagged by the compiler 
and the cursor is parked at the corresponding position (of a line) where the first error has 
been detected.

Sequence menu

Fig. 3-68

Editor...
Load and edit a sequence file.

Parameter Files...
Display/edit the parameter files used in a sequence. See Chapter 3.3.1.5 Parameter 
Files, 198.

3.3.1.3.1 Sequence Editor

Fig. 3-69

The sequence editor is operated via the following main menu:

File
File handling, compile and print a sequence.

Edit
Edit a sequence.

Options
Display control, font selection, storage size etc.
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File submenu

Fig. 3-70

Open...
Call the File Manager to open a file.

Save
Store the current sequence.

Save As...
Store the current sequence under a different name or in a different directory.

Print...
Print the sequence or a part of it. To configure the printer use [Setup] > [Printer].

Save & Compile
Compile the sequence and store it.

Compile All...
Translate all sequences in the selected path.

Close
Return to the Parameter Setup main menu.

Print Print prints the current sequence or a part of it:

Fig. 3-71

Print Range
• All Lines: Print all Lines.
• Selected Lines: Print the selected lines (only possible, if lines are marked in the edi-

tor).
• Lines: Print lines starting at From up to To.
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Print Options
• Print Line Numbers Print the numbers of the lines as well.

Compile All Compile All translates all sequences found in the selected path.

Fig. 3-72

[Compile All]
Translates all sequences.

[Continue]
• Translates all sequences beginning at the selected sequence, in the illustrated ex-

ample from the sequence airdemo.seq onward.
• Translates the next sequence if an error has occurred in a sequence.

NOTE:
Please note that a subsequence that is called by another sequence while the se-
quencer is running, may only be modified but not compiled in the sequence edi-
tor.

Edit submenu

Fig. 3-73

Insert Line
Insert a new line between existing lines.

Dialog...
Call the dialog editor.

If the cursor is positioned on a blank line, the Choose Line dialog box (See Section 
«Choose Line», 195) is opened for inserting a new line. If the cursor is positioned on 
a line containing a sequencer instruction, the dialog editor with the matching dialog box 
is displayed directly.
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NOTE:
Instead of choosing [Edit] > [Dialog] you can click with the right mouse button.

To mark text (for the Copy, Cut and Delete commands) drag the cursor with 
pressed left mouse button from the start to the end of the desired text section, or 
use the cursor buttons in combination with Shift, Ctrl, Home, End, Page Up, Page 
Down.

Undo
“Reverse” the last action such as input/deletion of text, etc.

Cut
Delete the text marked with the cursor and save it on the clipboard. This text can be 
inserted in a different place with the Paste function.

Copy
Copy the text marked with the cursor to the clipboard.

Paste
Insert the clipboard content at the current cursor position.

Delete
Delete the marked text.

Goto Line...
Position the cursor on a specific line.

This function can be used for positioning the cursor on a line number flagged by the 
compiler as “containing errors”. The line numbers may be printed with the lines.

Find...
Search text.

Replace...
Replace text.

Choose Line When [Edit] > [Insert Line] is selected, the Choose Line dialog is displayed:

Fig. 3-74

The Controls are described in Chapter 8.5.3 Comments, 428.

The sequencer instructions are found in the list fields Conditions, Loops and Instruc-
tions.
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Options submenu

Fig. 3-75

Display...
Enter the display parameters, select font type etc.

Parameter Limits...
Define the size of the local (i[ ], f[ ]) and the global (gi[], gf[], gfa[][], gs[]) storage arrays 
of the sequencer.

Display

Fig. 3-76

Tabulator Space
Indentation size. The indentation corresponds to twice the width of the letter ‘B’ and is 
valid for the printout as well (=> using [File] > [Print).

[Choose Font]
With the Choose Font command you can select the font, the type face and size.

Fig. 3-77
196 Parameter Setup vpnb68e1 (0302), Quadstar 32-bit



3.3.1.4 Parameter limits (array limits)

3.3.1.4.1 Variable types

The Sequencer works with different variables:

Fig. 3-78

There are the following types of variables:

Integer
Integer number, range -1’000’000...+1’000’000.

Float
Floating point variables, range -1E+37 ... +1E+37, resolution 15 digits.

String
Text, stored as a character string.

The variables are organized as arrays (one dimensional tables), except the global float 
field gfa[][] that is a two dimensional table. Each element of the table is a variable. The 
size of these tables is specific to the sequence and can be defined in the Parameter Lim-
its dialog box by specifying the maximal index.

There are local and global variables:

Local variables i[ ], f[ ]
Local variables are valid only within the sequence being currently processed. In every 
subsequence new local variables are created that are usable independently from the 
ones of the calling sequence.

i - Local integer variable array.

f - Local float variable array.

Global variables gi[ ], gf[ ], gfa[ ][ ], gs[ ]
Global variables are valid for all main- and subsequences. A single set of them is cre-
ated, so they can be used e.g. for exchanging data between main- and subsequences.
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gi -Global integer variable array.

gf - Global float variable array.

gfa - Global float variable field of the dimension N × 64 for intermediate storage of mea-
sured values, calculated values, etc.

gs - Global array of character strings for defining text, error messages, file names etc. 
The maximum length of a character string is 100 characters.

Memory require-
ments

The last column shows the memory requirements. Make sure that the size of the array 
is matched to the application. Dimensioning large arrays may be simple and convenient, 
but wastes memory resources, which on a PC with little memory left can cause prob-
lems. This should be particularly avoided if nested sequences are used, because each 
sequence sets up its own local variables in memory.

Note that the maximum index is entered for dimensioning the array. When you enter, for 
example, 24 for Maximal Index, array elements 0 ... 24 (=25 variables) can be used.

NOTE:
For a detailed description of the variables please refer to Chapter 8. Process Con-
trol, 409.

3.3.1.5 Parameter Files

Fig. 3-79

Parameter Files displays the parameter files (Parameter Files) and subsequences 
(Sequences) used in a sequence. They can be selected and edited:

[Edit Seq.]
Edit sequences

[Edit Par.]
Edit parameter files.
198 Parameter Setup vpnb68e1 (0302), Quadstar 32-bit



3.4 Calibration Parameters

Calibration menu

Fig. 3-80

Mass Scale...
Set the mass scale calibration parameters.

Gas Specific Sensitivity...
Set the parameters for a gas-specific measurement for determining calibration factors.

3.4.1 Mass Scale

By using the mass scale calibration, deviations of the mass scale in the range of 
±0.5amu from the nominal mass can be compensated. For that, a calibration gas with a 
known spectrum is required; on its mass numbers the deviations are measured.

NOTE:
For additional information on the mass scale calibration please refer to 
Chapter 2.8.1 Mass scale calibration (Mass Scale), 134.

Choose [Calibration] > [Mass Scale] and open a parameter file:

Fig. 3-81

Input/optimize the 
parameters

To optimize the parameters, the communication to the mass spectrometer must be 
switched on and the calibration gas must be let in. Then enter the mass numbers of the 
calibration gas.

• If the mass numbers are known, they may be entered manually.

• [Functions] > [Peak Search] automatically searches for the highest peaks and the 
corresponding mass numbers and puts them in the parameter file.
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The mass numbers entered this way should be precalibrated using [Functions] > 
[Adjust]. If errors are reported, optimize the corresponding channels:

1 In the Mass Scale Calibration Parameter editor select the desired channel.

2 Choose [Display] > [Measure Data]. Quadstar 32-bit starts a single-channel mea-
surement that responds immediately to any parameter changes.

Fig. 3-82

3 Optimize the following parameters as a function of the error messages produced 
by Adjust:
• Mass: Enter the desired mass number and shift it until it has reached the peak 

maximum (as shown by the bargraph).
• SEM Voltage: Set the SEM voltage (if a SEM is used) to a value that is appro-

priate for your SEM.
• Amp. Range: Optimize the Amp. Range (only in Amp. Mode FIX), so that the 

bargraph shows approx. 10 ... 90% full scale. Please note that with increasing 
gain the electrometer becomes slower so that the Dwell speed must also be 
adjusted.

• Threshold: Set the threshold (in % full scale) to half the peak intensity.

Hint: With the drag pointer you can observe the maximum deflection.

If errors still occur, you should check the Resolution. The easiest way is to program a 
Scan Analog ([Measure] > [Scan Analog]). Then choose [Display] > [Measure Data] and 
optimize the Resolution according to the shown spectrum.

NOTE:
The resolution should be set in such a way that the smallest value between two 
adjacent peaks is approx. 10% of the intensity of the smaller peak.

Afterwards transfer the resolution into the channels of the parameter file.

3.4.2 Gas-specific sensitivity (Quantitative Analysis)

In order to measure concentrations, calibration factors have to be determined. These 
describe the sensitivity of the mass spectrometer for a certain gas. Under Gas Specific 
Sensitivity you can determine such calibration factors.
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3.4.2.1 Calibration matrix

When [Calibration] > [Gas Specific Sensitivity] is activated, a parameter file (calibration 
matrix) must be selected or created via the File Manager. This file is subsequently 
opened and the dialog box for entering the calibration gas specific parameters is dis-
played.

Each component of a calibration gas measurement is defined by its name, the mass 
number and the concentration. Several calibration factors of a component can be deter-
mined simultaneously:

Fig. 3-83

Int. Std
Component selected as the internal standard.

Ext. Norm
Component selected as the reference point for external normalization.

Component
Component name.

Conc.
Concentration of the component. The concentration is entered in % or in ppm but if it is 
<1% it is always displayed in ppm.

Mass
Mass number.
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3.4.2.2 Extending the calibration matrix

The displayed calibration matrix can be extended with additional components and mass 
numbers:

• by inserting spectra from the Spectra Library ([Edit] > [Insert from Spectra Library]) or
• by inserting manually ([Edit] > [Insert Mass/Insert Component]) or
• by appending with subsequent sorting (via [Edit] > [Sort Mass/Sort Component]).

When the last line or column has been filled, an additional line or column is automatically 
appended. Enter the various component names and mass numbers (that exist in the cal-
ibration gas) and the mass numbers for which the calibration factors are to be deter-
mined:

• Position the cursor in the desired field.
• An entry is accepted when the cursor is moved or when the <TAB> key is pressed; 

<ENTER> has no function.

When you remove a component or a mass number, the line or the column is deleted.

Concentrations can be entered in % (without unit of measure, e.g.: 20 or 1.5) or in ppm 
(with unit of measure, e.g.: 350 p, 350 ppm); 200 p, 200 ppm and 0.02 therefore is 
always the same concentration, shown in different representation each time.

Subsequently, define the positions on which the calibration should take place. No over-
lapping of gases is allowed, i.e. a mass can be assigned to only one component.

At the end you have to tell the program which component is to be used as the standard. 
See Chapter 3.4.3.3.1 Defining the internal standard, 205.

3.4.3 Gas Specific Calibration menu

Fig. 3-84

This function is handled via the following main menu:

File
File handling, print calibration parameters, quit the editor.

Edit
Edit and sort the mass numbers and the components.

Options
Sort the entered parameters, set the internal standards.
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3.4.3.1 File submenu

Fig. 3-85

Open...
Call the File Manager.

Save
Store the current file.

Save As...
Store the current file under a different name or in a different directory.

Print
Print the current calibration parameters.

Close
Return to the Parameter Setup main menu.

3.4.3.2 Edit submenu

Fig. 3-86

Channel Par.
Enter the channel parameters. The editor can also be called by double clicking the right 
mouse button if the cursor is located outside the input fields and not on a scroll bar.

Insert Mass
Extend the matrix by inserting a mass number (column) at the current cursor position.

Delete Mass
Remove a mass number from the matrix.

Sort Mass
Sort the mass numbers in ascending order.

Insert Component
Insert a component (row) into the matrix at the current cursor position.
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Delete Component
Remove a component from the matrix.

Sort Component
Sort the components alphabetically.

Insert from Spectra Library
Insert components and mass numbers from the spectra library. See Chapter  Insert 
Spectra into the matrix, 185.

3.4.3.2.1 Channel Parameters

The mass numbers are adopted from the calibration matrix and the corresponding chan-
nels are marked by [State] > [Matrix]. Under [Display] > [Measure Data] you can use the 
Adjust-function to optimize the peak heights.

Choose [Edit] > [Channel Par.] to call the channel parameter editor:

Fig. 3-87

3.4.3.3 Options submenu

Fig. 3-88

Set Internal Standard
Define the internal standard.

Set External Normalization
Define the external normalization.

Remove External Normalization
Disable the external normalization.
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3.4.3.3.1 Defining the internal standard

Quadstar 32-bit must be told which component is to be used as the internal Standard 
(i.e. which calibration factor is to be considered as fixed). It is displayed in the upper left 
corner of the dialog box. Because the relative sensitivities of the mass spectrometer are 
determined, pressure variations etc. have no influence on the results of an analysis, if 
the internal standard is used.

NOTE:
The Set Internal Standard comand is enabled only if the selected mass number 
has been assigned to a component.

The calibration factor of the Internal Standard must already be defined at the time of the 
calibration. It establishes the relationship between the new and the previously deter-
mined calibration factors.

3.4.3.3.2 Setting the external normalization

In certain cases it may be useful to work with external normalization, e.g.:

• If only one component is to be measured in a gas mixture.
• If a gas mixture contains unknown components.

Through the external normalization the absolute sensitivity of the mass spectrometer is 
calculated based on the selected standard. The mass number selected with the cursor 
and the associated component become the reference point for the external normaliza-
tion. The same component as for the internal standard or a different one can be chosen. 
The chosen component is shown in the upper left corner of the dialog box.

NOTE:
When performing the measurement, make sure the pressure conditions are the 
same as during the calibration, because the External normalization cannot elimi-
nate pressure variations. Changed ion source parameters, changed SEM voltage 
etc. influence the measuring results as well.

The normalization factor NF is calculated as follows:

In an analysis with external normalization the calculated concentration is normalized as 
follows:

NF I g m( , )
S g m( , ) C g( )⋅
---------------------------------=

C g( ) C' g( )
NF
-------------=
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NF = Normalization factor
m = Index for mass number
g = Index for gas component
I(g,m) = Ion current of the gas component g on mass number m
S(g,m) = Calibration factor of the gas component g on mass number m
C(g) = Concentration of the gas component g (%)
C’(g) = Unnormalized concentration of the gas component g (i(g,m)/S(g,m))U

NOTE:
For more information on how to calibrate the mass spectrometer please refer to 
Chapter 2.8.4 Gas specific sensitivity, 142.

C' g( ) I g m( , )
S g m( , )
----------------=
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3.5 Manual parameters

Manual menu By Manual you can display the state of digital input channels and switch on or off digital 
output channels manually, provided that the communication to the mass spectrometer 
is switched on.

Fig. 3-89

For turning the individual digital output channels on or off, double-click the correspond-
ing push button with the left mouse button. The switching state is indicated by the col-
ored dot on the push button: green = on, grey = off.

3.5.1 DI/DO Manual (for QMS 422/421)

Fig. 3-90

Display left
Select the DI/DO group to be displayed on the left side of the screen.

Display right
Select the DI/DO group to be displayed on the right side of the screen.

The same group cannot be displayed at the left and the right side simultaneously.
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3.5.2 DI/DO Manual (for QMS 200)

Only the two standard digital input and output channels are available:

Fig. 3-91

The digital input and output channels of the QMS 200 have the following designation in 
the hardware description:

DI 00
EXT_PROT (Connection TPR/PKR, Pin No. 1 <=> 2)

DI 01
EXT_RUN (Connection Control, Pin No. 10 <=> 15)

DO 00
REL_1 (Connection Control, Pin No. 11 <=> 12)

DO 01
REL_2 (Connection Control, Pin No. 13 <=> 14)
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3.6 Communication parameters

3.6.1 Overview

Transmission 
types

Quadstar 32-bit supports several data transmission types (called ‘communication types’ 
in the following text) to the mass spectrometer (QMS):

Transmission via RS232C Normal

Transmission via ArcNet (duplex fibre optic)
only with ArcNet board in the PC.

Communication 
menu

In the menu Comm you can choose the communication type and set up its parameters, 
or switch the communication to the QMS on or off:

Fig. 3-92

QMS Comm. Type...
Select the type of communication with the QMS. See Chapter 3.6.3.1 Selecting the com-
munication type, 214.

QMS Comm. Parameters...
Enter the communication parameters for the selected communication type. See 
Chapter 3.6.3.2 Setting the parameters for the selected communication type, 214.

Unit Identifications...
Set the Destination Node Identification (DID) for communication via ArcNet. See Section 
«Setting the node address in the QMS», 217.

Connect
Establish the connection to the QMS. See Chapter 3.6.3.5 Connect, 221.

Disconnect
Clear the connection to the QMS. See Chapter 3.6.3.6 Disconnect, 222.

SetUnit
Select a control unit activated in the Unit Identifications dialog box under Enable for 
measurement. See Section «Setting the node address in the QMS», 217.
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3.6.2 Communication via RS232C

3.6.2.1 Protocol/transmission reliability

The communication is based on data packet (frame) transmission and is monitored for 
data loss and corruption. The communication protocol conforms to the “SECS-I” stan-
dard (Semi Equipment Communication Standard I).

A data transmission request transmitted from the sender to the responder must be 
acknowledged by the responder before the sender may start to transmit the actual mes-
sage. After the message (data, parameters, etc.) has been transmitted, a checksum is 
forwarded and a positive or negative acknowledgment is awaited. If a positive acknowl-
edgment is received, the transmission is completed, if a negative acknowledgment is 
received (error in the checksum, etc.), the transmission is repeated up to N times (N = 
retries for data block transmit).

NOTE:
For detailed information such as protocol, data frame formatting, etc., please con-
sult the User’s guide for the QMS interface.

3.6.2.2 Configuration of multiple serial interfaces under Windows

If multiple serial interfaces are operated, problems can occur. The following restrictions 
should be noted:

• The COM1 and COM3 interfaces as well as the COM2 and COM 4 interfaces cannot 
be used simultaneously.

• If a mouse is connected to COM1, COM3 does not function (and vice versa). The 
same applies analogously to COM2 and COM4. Valid combinations are COM1 and 
COM2 or COM3 and COM4.

3.6.2.3 RS232C normal

The normal communication between Quadstar 32-bit and mass spectrometer is based 
on a serial RS232C interface. RS232C is not electrically insulated from the equipment 
and consequently susceptible to noise. The QMS is automatically adapted to the pro-
grammed baud rate.

Connection cable The reliable transmission distance depends on the noise field intensity in the environ-
ment and the selected baud rate. The following values should not be exceeded:

Baud rate Max. cable length (shielded)

1200 90 m

2400 30 m

4800 30 m
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The send and receive lines must be crossed (null modem cable). Quadstar 32-bit oper-
ates with a software handshake, i.e. the control lines for the hardware handshake (DSR, 
DTS, RTS, CTS) are not used.

The pin assignment of the DB9 connector on the QC is described in the User’s guide of 
the mass spectrometers.

Tab. 3-1 DB9 connector (male, on QC)

Make sure that the send and receive lines are crossed only once in the cable. The sup-
plied cable conforms to this requirement. If problems occur, install a Reverser.

NOTE:
To protect the line drivers, the computer and the QMS should be connected to the 
same phase of the power line.

Only shielded cables should be used.

To prevent ground loops, the shield of the cable should only be grounded at the 
QMS.

3.6.2.4 Communication via ArcNet

For high data throughput as well as multiplex operation, Quadstar 32-bit supports the 
ArcNet interface of the mass spectrometer via Duplex Fibre Optic lines.

NOTE:
For communication via the ArcNet interface, a special board OPA 200 or PCMCIA 
(PC-Card) with a matched optical interface is required in the PC. If several mass 
spectrometers are to be connected to the same PC, an optical hub OHA 200 is re-
quired. For additional information please contact our service office.

9600 15 m

19200 7.5 m

Pin Significance

1 Carrier Detect (CD)

2 Receive Data (RXD)

3 Transmit Data (TXD)

4 Data Terminal Ready (DTR)

5 Signal Ground (GND)

6 Data Set Ready (DSR)

7 Request To Send (RTS)

8 Clear To Send (CTS)

9 Ring Indicator (RI)

Baud rate Max. cable length (shielded)
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3.6.2.4.1 Installation of the ArcNet board

For installing and configuring the ArcNet board please consult the instructions of the 
board manufacturer. The ArcNet parameters are preset to the following values:

• Source identification (SID): [hex] A0

For choosing the different parameters call the ArcNet-Parameter dialog box. See 
Chapter 3.6.3.4.2 Communication via ArcNet, 216.

NOTE:
For the OPA 200 the values in Quadstar 32-bit must match the ones that are really 
set on the ArcNet board. To change values on the ArcNet board, perhaps jumpers 
must be changed. Please refer to the user’s guide of the ArcNet board.

Verify that the memory area D000-D07F (HEX) is not being used by another BUS 
board. If it is although, assign the ArcNet board to another area.

If you have done a hardware search with built in ArcNet board by accident, delete 
the ArcNet board completely from the operating system. Quadstar 32-bit uses the 
shared Arcnet board driver included on the installation cd.

3.6.2.4.2 Multiplex operation

With the ArcNet interface, Quadstar 32-bit is able to communicate with several mass 
spectrometers via an optical hub which is available as an option. If you choose [Comm] 
> [Connect], all units that were set to Enable in the Unit Identifications dialog box are 
addressed. See Section «Setting the node address in the QMS», 217.

3.6.2.4.3 Installation of the hub

The hub is an optical star distributor and can be used for setting up a network comprising 
several control units. For larger networks, several hubs can be used. For the installation 
procedure, please refer to the user’s guide of the hub.

3.6.2.4.4 Data collection possibilities

The type of data collection depends on the configuration of the Quadstar 32-bit:

• If the sequencer is used, multiplex operation with several control units QMS 422/421 
and QMS 200 is possible in conjunction with the SetUnit() instruction.

• In operation without a sequencer the desired control unit is selected manually 
through a corresponding dialog box:
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Fig. 3-93

• The Set Unit dialog box is normally called via the Comm menu.
• This dialog box is automatically displayed if several control units are initialized and 

equipment-specific parameters or calibration data are accessed. See Section «Set-
ting the node address in the QMS», 217.

3.6.2.4.5 Unit-specific files

The unit specific files (e.g. required for calibration) are stored in different subdirectories 
associated with the corresponding control unit. The directory is identified via the logical 
number of the control unit.

Example:

For a description of this dialog box see Section «Setting the node address in the QMS», 
217.

Fig. 3-94

For a standard installation of Quadstar 32-bit on drive C and input of the Unit Identifica-
tions as shown on the left, the directories A001 ... A005 are created by Quadstar 32-bit:

C:\qs32bit\AUXI Auxiliary directory for unit 000

C:\qs32bit\A001 Auxiliary directory for unit 001

C:\qs32bit\A002 Auxiliary directory for unit 002

C:\qs32bit\A003 Auxiliary directory for unit 003
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NOTE:
The number of the directories A001 ... A005 corresponds to the Unit number and 
not the Node-ID.

Equipment-specific files (for parameters and data) are assigned to each control 
unit. Always use the dialog box Unit Identifications for changes, do not modify 
those files or directories manually.

3.6.3 Setting the interface parameters

3.6.3.1 Selecting the communication type
1 From the Parameter Setup program choose [Comm] > [QMS Comm. Type].

2 Select the desired type (RS232C, ArcNet, ArcNet Server) via the displayed option 
command buttons.

3.6.3.2 Setting the parameters for the selected communication 
type
1 From the Parameter Setup program choose [Comm] > [QMS Comm. Parame-

ters].

2 Enter the desired transmission parameters.

3.6.3.3 QMS communication type

In the QMS Communication Type dialog box you can select the desired communication 
type via the option command buttons:

Fig. 3-95

RS232C normal
Communication via a serial RS232C interface.

ArcNet
Communication of one Quadstar 32-bit application with one or several control units via 
ArcNet.

C:\qs32bit\A004 Auxiliary directory for unit 004

C:\qs32bit\A005 Auxiliary directory for unit 005
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ArcNet Server
Communication of one or several Quadstar 32-bit applications with several control units 
via ArcNet. Two independent Measure programs can be run on two control units e.g., 
but it’s not allowed to let two programs communicate with the same control unit.

3.6.3.4 QMS communication parameters

For each of the possible communication types a separate dialog box with separate stor-
age of the transmission parameters is available.

For each communication type the standard setting can be retrieved via the [Default] 
command button. The entered parameters are saved only if you quit the dialog box by 
choosing the [OK] button.

3.6.3.4.1 Communication via RS232C Normal

Fig. 3-96

The baud rate to be selected depends on the transmission distance and the level of the 
noise fields in the environment. The QMS is automatically adapted to the selected baud 
rate.

Connection 
related param-
eters

Baud Rate
Speed in bit/sec. at which the data are transmitted between the PC and the mass spec-
trometer.

Connection Line
Select the serial PC interface.

Protocol related 
parameters

The communication protocol is derived from the block transfer protocol specified in 
SEMI E4-87 (SEMI = Semiconductor Equipment and Material International). For the 
communication of Quadstar 32-bit with the mass spectrometer the protocol timeouts T1, 
T2 and T3 have fixed settings:

Transmit protocol timeout T2
Maximum time (in ms) the sender waits for:

• A response to a data transmission request.
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• A positive or negative acknowledgement from the responder after the checksum has 
been transmitted.

• Maximum time (in ms) the responder waits for incoming data after an <EOT> has 
been sent (in response to <ENQ>).

Reply timeout T3
Maximum waiting time (in ms) after a data transmission request by the mass spectrom-
eter.

Inter-character timeout T1
Maximum waiting time (in ms) for the next byte during the reception of the individual data 
bits within a frame.

The number of retries is recorded in two separate counters, i.e. a distinction is made 
between the attempt to establish a connection and the frame transmission retries after 
receipt of a <NAK>.

Retries for handshake
Number of attempts to establish a connection to the QMS after a transmit protocol tim-
eout.

Retries for data block transmit
Number of times Quadstar 32-bit has tried to transmit a frame after receipt of a negative 
acknowledgment.

Control Elements [Default]
Restore the communication parameters to their standard factory settings.

3.6.3.4.2 Communication via ArcNet

Fig. 3-97

Protocol related 
parameters

Transmit protocol timeout T2
Maximum waiting time (in ms) for the confirmation of a correct data transmission to the 
QMS.

Reply timeout T3
Maximum waiting time (in ms) after a data transmission request from the QMS.

Retries for data block transfer
Number of transmit retries after a Transmit Timeout before a Transmit Timeout error is 
signaled.
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Retries for data block receive
Number of receive retries after a Receive Timeout before a Receive Timeout error is sig-
nalled.

Retries after failed transmission
Number of times Quadstar 32-bit attempts to retransmit a frame after a negative 
acknowledgment has been received.

ArcNet related 
parameters

Source identification (SID)
Station number 01 ... FF of the sender (PC).

The default values accessible via the [Default] command button correspond to the stan-
dard configuration normaly used.

Control elements [Default]
Restore the communication parameters to their standard factory settings.

The ArcNet related parameters are restored to the following default values:

Source identification (SID)
A0h

Retries for data block transfer
3

Retries for data block receive
3

Retries after failed transmission
6

NOTE:
The [Default] comand button may change settings, that have to be modified on the 
mass spectrometer (node address DID).

Setting the node 
address in the 
QMS

The node address 01...FF (Destination identification DID) of each QMS can be entered 
in the following dialog box. This address must be programmed as a unique identification 
number on every QMS:
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Fig. 3-98

Control elements Identifications
• Unit: Internal logical number of the control unit
• Name: Logical name of the control unit.
• Node-ID: Node address (Node) of the control unit on the ArcNet network.
• Enable: Activate the unit in the net.

[Set Node Address at ‘Q_Unit1’]
This button is used to program a new node address (HEX 01 ... FF) in the selected mass 
spectrometer, in this case in the unit Q_Unit_5.

NOTE:
This option is only available if the cursor is located in an input field (Name, Node-
ID or Enable) and if the communication is switched off.

Setting the node 
addresses of 
several control 
units

To put the units into operation, a node address must be programmed to each control unit 
in the network by the button Set Node Address at “Unit Name”.

NOTE:
Only the mass spectrometer to be programmed right now may be connected to 
the ArcNet board in the PC. Remove the connectors of all other units of the optical 
hub or switch off the power supply of all other units or connect the control unit 
with a direct line to the PC.

Selecting a 
control unit in the 
ArcNet network 
(Set Unit)

In Set Unit you can choose (with a double click of the left mouse button) one of the QMS 
units activated in the Unit Identifications dialog box under Enable:

Fig. 3-99
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Parallel multiplex 
operation of 
several mass 
spectrometers

The operation mode ArcNet (Communication Type: ArcNet) provides the fastest mea-
suring and data acquisition, but allows only peer to peer communication (one 
Quadstar 32-bit application to one control unit). It’s not possible to operate another 
Quadstar 32-bit application at the same time on ArcNet. In contrast, operation mode 
ArcNet Server (Communication Type: ArcNet Server) allows to operate several 
Quadstar 32-bit applications at the same time on ArcNet, but the transmission gets the 
slower the more applications are run simultaneously.

Fig. 3-100

For example, you can tune the ion source of unit 1 (TuneUp) while you run a Scan Ana-
log measurement on unit 2 (Measure). Every application communicates independently 
from the other with the units assigned to it. Although, it is never allowed to access a unit 
simultaneously by different applications. You must not run a Scan Analog measurement 
(Measure) and a Leak Test (Service) on unit 2 at the same time for example.

Example You intend to use two mass spectrometers named ‘MS1’ and ‘MS2’. On MS1, a Scan 
Analog measurement shall be performed while MS2 is doing a MID measurement. In 
order to do so, proceed as follows:

1 Select all units you want to use (in Parset program under [Comm] > [Unit Identifi-
cations]), i.e. here MS1 and MS2. Confirm the choice by pressing the [OK] button 
and leave Parset.

Fig. 3-101

2 Start a Measure program and select unit ‘MS1’ under [Comm] > [Set Unit]. Con-
nect the unit by [Comm] > [Connect] and start the Scan Analog measurement:
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Fig. 3-102

3 Start a second Measure program and select unit ‘MS2’ under [Comm] > [Set Unit]. 
Connect the unit by [Comm] > [Connect] and start the MID measurement:

Fig. 3-103

The second (new) Measure window conceals the first one, so place the mouse cursor 
on the title bar and drag it aside while holding the left mousebutton pressed. Now you 
see the two simultaneously running measurements on MS1 and MS2. For better distinc-
tion, the title bars of the measure windows are consecutively numbered ([1], [2], ..). In 
the lower right corner of the status bar you see the current unit name (e.g. ’MS1’).

Naturally the parallel multiplexing works with the sequencer (Process Control) as well, 
but the used units are selected by the instruction SetUnit() then. The windows can be 
positioned by the instruction DispWindow(). To avoid interference between different 
sequences, make sure the groups of units used by the sequences are strictly separated.

Example You want to run two sequences. The first works with the units ‘SPM1’ and ‘SPM2’ and 
the second uses ‘MS1’ and ‘MS2’. So you mark all units you intend to use (under ‘Unit 
Identifications’):
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Fig. 3-104

3.6.3.5 Connect

The communication to the QMS is switched on by Connect.

Connect establishes the connection based on the communication type RS232C Normal, 
ArcNet or ArcNet Server selected under QMS Communication Type.

Automatic adaptation of the baud rate on the QMS for RS232C Normal
In RS232C normal mode the Quadstar 32-bit communication module tests the baud rate 
setting and changes it to the value set with the QMS Comm. Parameter.

Sequence 1 Sequence 2

...
SetUnit(Unit="SPM
1")
...
SetUnit(Unit="SPM
2")
...

...
SetUnit(Unit="MS
1")
...
SetUnit(Unit="MS
2")
...

Right
The groups of units for sequence 
1 and sequence 2 are completely 
separated.

...
SetUnit(Unit="SPM
1")
...
SetUnit(Unit="SPM
2")
...

...
SetUnit(Unit="MS
1")
...
SetUnit(Unit="SP
M2")
...
SetUnit(Unit="MS
2")
...

Wrong !
The unit ‘SPM2’ appears in both 
sequences and will presumably 
cause a malfunction.
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Fig. 3-105

• During the baud rate search the transmission speed is displayed.
• To terminate the process choose [Cancel].

When the communication link is ready for operation, the LED simulated in the lower left 
corner of the active window changes to green:

Fig. 3-106

1 LED for communication state
2 Message field

3.6.3.6 Disconnect

Choose Disconnect to switch off an activated communication link.
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3.7 Setup parameters

Setup menu

Fig. 3-107

SEM/Emission Control...
Display the dialog box of the SEM/Emission Control for:

• Switching the SEM voltage on/off.
• Entering the Common SEM voltage.
• Switching the emission on/off.

General...
Display the General Setup dialog box for general settings. See Chapter 3.7.2 General 
setup parameters, 226.

Printer...
Configure the printer. See Chapter 3.7.3.1 Configuring the printer, 229.

Page Setup...
Setup the printer page (margins). See Chapter 3.7.3.2 Set up the printer page (Page 
Setup), 230.

Printer Fonts...
Select printer font. See Chapter 3.7.3.3 Select the printer font, 230.

Print Testoutput
Print a specimen. See Chapter 3.7.3.4 Print test output, 231.

Sequence Printing...
Change over the printing mode for sequencer operation. See Chapter 3.7.3.5 Log out-
put, 231.

ASCII Conversion...
Parameter selection for binary to ASCII conversion of measurement data. See 
Chapter 3.7.4 ASCII Conversion, 232.

3.7.1 SEM/Emission Control

SEM/Emission Control supports:

• Turning the Emission on/off
• Turning the SEM high voltage on/off and entering the Common SEM Voltage, if a 

SEM is used.
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NOTE:
This dialog box can also be called by entering <Ctrl+S>.

SEM and Emission can only be switched ON/OFF if the communication to the 
QMS is established.

The type of displayed dialog box depends on the selected operating mode (normal or 
with a QMU 112):

3.7.1.1 Normal Operation (without QMU 112)

Fig. 3-108

Control elements SEM
The SEM status is displayed symbolically in the status bar: when the SEM voltage is ON, 
the symbol changes to orange:

Common SEM Voltage
Enter the SEM voltage in common for all channels.

NOTE:
The common voltage is set in the channel parameter editor in Detector group un-
der the SEM Voltage parameter by clicking on either arrow with the right mouse 
button. The voltage is now marked by << xxxx >> on the display.

Emission
The status of the ion source emission is displayed symbolically in the status bar: when 
the emission is on, the symbol changes to Orange:

SEM high voltage OFF (grey).

SEM high voltage ON (orange).

Emission switched off (grey).

Emission switched on (orange).

Emission switched on, but FAULT (red).
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3.7.1.2 Operation with QMU 112

If [Option] > [QMU 112] has been selected under [Config] > [QMS], the dialog box 
changes.

The connected QME 125 units must be tagged under QME 125 # and the emission for 
each QME 125 must be switched on individually.

Fig. 3-109

SEM
The SEM status is shown jointly in the status bar for all activated QME 125 units; when 
the SEM voltage is on, the symbol changes to Orange:

Common SEM
Input of the common SEM for all channels of each QME 125.

NOTE:
The entered voltage is activated and displayed symbolically as << xxxx >> by the 
channel parameter editor in the Detector group under SEM Voltage when you click 
the right mouse button.

Emission
The emission status is shown in the dialog box with ON/OFF and also displayed sym-
bolically in the status bar as a LED:

Fig. 3-110

The symbol on the far left corresponds to QME 125 #0, the one on the far right to QME 
125 #7. The symbol colors have the following meaning:

SEM high voltage switched off (grey).

SEM high voltage switched off (grey).
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3.7.2 General setup parameters

Various general settings:

Fig. 3-111

Control elements Unit of Total Pressure
Select unit of measure as mbar, Pa(scal), Torr for total pressure measurement

NOTE:
For total pressure measurement, additional hardware is required:

QMS 422/421: The total pressure is measured by using extension boards; one of 
each type can be installed in the QMS:
• PI 420: Evaluation electronics for two Pirani gauges.
• PE 420: Evaluation electronics for one cold cathode gauge.

QMS 200: The total pressure is measured by a sensor (with built-in evaluation 
electronics) that can be connected to the QMS 200:
• TPR 250: Compact Pirani Gauge
• PKR 250/251: Compact Full Range Gauge

Disk Memory Space Warning Thres. [MB]
Warning threshold for low remaining disk space.

QME 125 not selected (light grey).

QME 125 selected, emission switched off (dark green).

QME 125 selected, emission switched on (light green).

QME 125 selected, emission switched on, but Fault (red).
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A warning is output to the operator if after the data save less than the specified amount 
of storage capacity remains on the selected disk drive.

Enter the warning threshold numerically (0.01 ... 655.35 MB) or by clicking on the [UP] 
or [DOWN] arrows on the right side of the list box. To turn the threshold monitoring OFF, 
click on either arrow with the right mouse button.

Execution File Path
Directory of the Quadstar 32-bit program files (.EXE, .DLL) (has strictly informative char-
acter and cannot be changed).

Auxiliary File Path
Directory of the auxiliary parameter files. Can be entered directly or via the Select Path 
command button.

Parameter File Path
Directory of the QMS measurement parameter files. Can be entered directly or via the 
Select Path command button.

Data File Path
Directory of the measurement data files. Can be entered directly or via the Select Path 
command button.

User Name
Enter the operator name via the ACCESSC program (password protection). See 
Chapter 9. Access Rights Control, 531.

Alarm Sound Definition
Enter the duration and frequency of the alarm tone.

• Frequency: Tone frequency - input range 1 ... 20,000 Hz.
• Duration [ms]: Warning tone duration - input range: 10 ... 60,000 ms.
• [Test Sound]: Test the tone.

Simulation Mode
Switch the Simulation Mode in the QMS on/off. See Chapter 3.7.2.1 Simulation mode, 

228.

• OFF: Simulation switched off.
• Internal: Simulation via QC internal measurement path.
• External: Simulation via QC external connection.

Error History
Turn the saving of the error messages on/off.

This function is used for recording errors that have occurred during a measurement. If 
the programmed maximum number of recorded error messages is exceeded, the oldest 
messages are overwritten.

Max. number of Errors in Error History
Maximum number of error messages in the error history.

Digits for Float Values
Number of decimal positions for float values.

This parameter can also be modified in the setup dialog boxes of MID Table and MCD 
Table.
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[Select Path]
Select the drive and directory under which the corresponding files are to be stored or 
searched.

The [Select Path] command button is only accessible if the cursor is located in the Gen-
eral Setup dialog box on one of the three input boxes such as Auxiliary File Path, Param-
eter File Path or Data File Path.

3.7.2.1 Simulation mode

Simulation Mode provides a simulated measurement mode without vacuum, i.e. with the 
ion source switched off. For this purpose the air spectrum covering the masses 1 ... 63 
is stored in the Quadrupole Controller (QC). To allow “testing” of higher mass numbers, 
the spectrum is repeated after mass 64. The parameters of the Amplifier group are not 
relevant in the simulation.

The simulation works in Scan Analog, Scan Bargraph, MID and MCD mode. For opera-
tion with Quadstar 32-bit, two simulation modes are available:

Fig. 3-112

Internal 
simulation

When [Simulation Mode] > [Intern] is selected, the D/A converter signal is transmitted 
via an analog MUX and the filter to the amplifier. This operating mode requires no exter-
nal connection on the rear panel of the QC. However, it can only be used for Detector 
Type FARADAY, SEM or CH-TRON.

External 
simulation

With [Simulation Mode] > [Extern], noise can be added to the signal for test purposes.

QMS 422/421:
The output signal of the D/A converter can be tapped on the rear panel of the QC 
421/422 at the QME/QMH connector, and be returned to the corresponding input, 
depending on the type of collector.

• If Detector Type FARADAY/SEM is selected, the electrometer input of the 
QME/QMH-connector must be used for the signal return.

• If Detector Type ION COUNT is selected, the signal input of the IC 421 (Ion counter 
preamplifier) installed on the QC must be used for the signal return.

QMS 200:
The output signal of the D/A converter can be tapped at the Control connector and be 
returned via the same connector.

Status bar infor-
mation

The simulation state is displayed in the status bar: SIM is displayed when simulation is 
switched on:

Simulation switched on.
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SIM
Simulation switched on.

NOTE:
Always switch the simulation mode to OFF when not intentionally in use! It might 
be very irritating to get simulated measure data instead of real data.

Behavior of the 
digital outputs

Please note that for safety reasons the digital outputs are disabled in simulation mode.

3.7.3 Printer

Quadstar 32-bit supports the output of measurement data, error messages and param-
eters in text form as well as the Print Screen function.

3.7.3.1 Configuring the printer

Only the installed printers are displayed. The printer identified with the color bar is the 
currently active standard printer:

Fig. 3-113

In this dialog box you can define the (standard) printer and its configuration.

The printer ports must be configured through the Windows Control Panel. Information 
on how to install a printer can be found in the Windows Manual or Online Help

Control elements Install
Under Install you can call a dialog box in which you can define the standard settings of 
the selected printer.
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3.7.3.2 Set up the printer page (Page Setup)

In this dialog box you can enter the margins of the printer page in cm or inches (left, right, 
top, bottom). The values shown below correspond to the default values:

Fig. 3-114

Control elements Margins
Page margins in cm or inches.

• Left: Left margin.
• Right: Right margin.
• Top: Top margin.
• Bottom: Bottom margin.

[Default]
Restores the standard settings.

3.7.3.3 Select the printer font

In this dialog box you can select the type of printer font, the style and the points for out-
putting Quadstar 32-bit documents. The selected font is displayed in the Sample field.

Fig. 3-115

NOTE:
To get quick and adequate printouts, we recommend to use a Printer font instead 
of a True Type font; moreover, it should not be larger than 12 points.
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3.7.3.4 Print test output

Choose this option to create a test output using the selected font. This option can also 
be used for testing the correct functioning of the connected printer.

Print Testoutput produces the following:

PRINTER TEST Selected Configuration with NORMAL
TYPEFACE: Arial
SIZE 10
PRINTER: HP LaserJet4/4M
PORT: LPT1:

PRINTER TEST: Selected Configuration with BOLD
TYPEFACE: Arial
SIZE 10
PRINTER: HP LaserJet4/4M
PORT: LPT1:

3.7.3.5 Log output

Quadstar 32-bit supports the output of a buffered line-by-line log (Line Printing) instead 
of the full page output that’s normally performed by Windows (Page Printing).

In the following dialog box you can choose the printing mode (page-by-page/line-by-line) 
and the printer if necessary. Choose [Setup] > [Sequence Printing]:

Fig. 3-116

Printing Mode
• Page Printing: The sequencer log is output on the standard printer. A page is only 

printed when it is full.
• Line Printing: The sequencer log is output line-by-line on the selected printer. The 

printer specified here does not have to be the same as the standard printer. You can 
use several printers this way (e.g. an inkjet and a matrix printer).

NOTE:
Laser or inkjet printers do not output a page unless it is full. An incomplete page 
can normally be output by manual form feed.

For more information about the log output in sequencer operation see Chapter 8. 
Process Control, 409.

Line Printing Parameter
• Printer Port: Port, to which the line printer to be used is connected (LPT1 ... LPT3).
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3.7.4 ASCII Conversion

The Display Saved Values program of Quadstar 32-bit is able to convert binary mea-
surement data to ASCII data so that they can be exported to other applications such as 
EXCEL, etc.

Control characters, time format and options for this export can be specified in the follow-
ing dialog box:

Fig. 3-117

Column Separator
Separator for dividing columns

• Char 1: Character 1 (Default: Horizontal tabulator ‘HT’)
• Char 2: Character 2 (Default: OFF)

Line Separator
Separator for dividing lines

• Char 1: Character 1 (Default: Carriage return ‘CR’)
• Char 2: Character 2 (Default: OFF)

Fraction of Seconds
Outputting fraction of seconds

• Char: Separating character (Default: Colon ‘:’)
• Digits: Number of digits (Default: 2)

Conversion Options
Select auxiliary information

• Write Header: Create complete file header containing auxiliary information and col-
umn labeling (Default selected)

• Write Column Title: Label columns only

NOTE:
The option Write Column Title is only available if Write Header is not checked al-
ready. If no option is selected, an ASCII-file is created that contains only the mea-
sure data as columns of numbers. This is useful if the data is automatically pro-
cessed, because the data is always located at the same file position.
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[Default]
Set the above values to their defaults (e.g. for Excel).

NOTE:
Make sure that in the Windows Control Panel/International/Number Format, the 
1000 Separator is set to the quotation mark (‘) in order to avoid problems with the 
exponents under Microsoft® EXCEL®.
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3.8 Instrument Configuration

Configuration 
menu

Fig. 3-118

QMS...
Define the hardware configuration of the QMS. See Chapter 3.8.1 QMS Configuration, 

234.

DI/DO Identification...
Define the names of analog and digital I/O channels. See Chapter 3.8.2 Digital inputs 
and outputs, 237.

AI Characteristic Curve...
Specify the sensors, enter the characteristic curve of the analog input channels. See 
Chapter 3.8.3 Analog input characteristic curve configuration, 238.

AO Characteristic Curve...
Enter the characteristic curve of the analog output channels. See Chapter 3.8.4 AO 
Characteristic Curve Configuration, 240.

Screen Color...
Select the Quadstar 32-bit specific desktop colors. See Chapter 3.8.5 Screen Colors, 

245.

3.8.1 QMS Configuration

The different parameter editors of Quadstar 32-bit read the QMS hardware configuration 
table to determine which options are installed. Only those options appear in the list 
boxes of the channel parameter editors which are feasible according to the [Config] > 
[QMS...] menu.
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Fig. 3-119

Fig. 3-120

The displayed picture depends upon whether or not the interface to the QMS is active.

• If the interface is switched on, the configuration (the hardware installed in the QMS) 
is read back and displayed under Hardware Boards.

• If the interface is switched off, the existing components can be switched on or off 
manually via the control fields displayed under Hardware Boards.

The following information items are read in by the QMS if the interface is switched on 
but they cannot be modified:

• QMS EPROM Version: Software version of the main processor on the QC 
422/421/200.

• DSP EPROM Version: Software version of the digital signal processor on the QC 
422/421/200.

In the following list boxes the installed hardware can be specified (except if only one 
entry is possible, then there is no list box but a text instead, which can’t be modified):
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QMS
Define the mass spectrometer type. (QMS422, QMS421, QMS200)

QMA
Define the analyzer type. (QMA 125, QMA 4xx, QMS 200).

MASS-R
Mass range of the analyzer.

Detector
Declare the detector type: FARADAY, SEM, CD-SEM, CH-TRON, depending on the 
installed analyzer (QMA 125, QMA 4xx or QMS 200).

IS-Type
Define the ion source type. The possible selections depend on the QMS.

Option
Declare the hardware extensions installed in the QMS.

The possible choice (QMU 112, CLA 421, CP 400) depends on the installed analyzer.

Protection (Sem+Fil)
Control the filament and the SEM supply (INTERN, EXTERN or EXT-PROT).

• INTERN: SEM and Emission are switched on and off manually (=>Ctrl+S).
• EXTERN: SEM and Emission are controlled by an external system (e.g. a pressure 

gauge or a switch).
• EXT-PROT: SEM and Emission are protected by an external system (e.g. a pressure 

gauge or a switch), but otherwise switched on and off manually.

For further information on this topic see Chapter 5.2.1.2.5 Filament Protection Extern 
(QMA 200/QMA 4XX), 323.

HV External Supply
Operate the QMS with an external SEM supply.

With this switch it is possible to operate the QMS in SEM mode even if the HV 420 or 
HV 421 boards are not installed.

Emission External
Operate the QMS with external Emission control.

With this switch on, the emission is neither controlled nor monitored by Quadstar 32-bit. 
Control must be supplied by a separate system.

3.8.1.1 First time operation, configuration changes

In the parameter editors only those parameters appear which are valid for the installed 
hardware. For this reason the hardware configuration must be updated in the QMS XXX 
Configuration dialog boxes when Quadstar 32-bit is put into service for the first time or 
whenever system changes have been made.

Example:
In the Type list box under [Group] > [Detector] of the channel parameter editor only those 
ion collectors are offered for selection, which are actually feasible according to [Config] 
> [QMS] > [Detector].
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NOTE:
After a change in the QMS XXX configuration the old measurement parameter files 
are not updated automatically.

3.8.2 Digital inputs and outputs

3.8.2.1 QMS 422/421

In the QMS 422/421 the number of available channels depends on the hardware config-
uration, that is, the number of installed supplementary boards (Options: DI#0, DI#1, 
DO#0, DO#1, DO#2):

• DO 420: Board 0 ... Board 2 (DO 00 ... DO 31, DO 32 ... DO 63, DO 64 ... DO 95)
• DI 420: Board 0 ... Board 1 (DI 00 ... DI 31, DI 32 ... DI 63)

Up to three DO 420 boards and two DI 420 boards can be installed in the QMS 422/421 
in any slot sequence. Quadstar 32-bit enables the corresponding DO channels.

3.8.2.2 QMS 200

The QMS 200 features two digital inputs and two digital outputs as standard equipment, 
but no additional options can be installed:

• two digital inputs: DI 00 (‘ext. Protection’) and DI 01 (‘ext. Run’)
• two digital outputs: DO 00 (REL_1) and DO 01 (REL_2)

3.8.2.3 DI/DO identification

With the DI/DO Identification editor, logical names (max. 8 characters) can be assigned 
to the individual lines of the digital inputs/outputs:

Fig. 3-121

Identifications
Logical name of the DI/DO channels
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I/O Boards
Declaration of the DI/DO board

• DI#0, DI#1: board 0 ... board
• DO#0 ... DO#2: board 0 ... board 2

Fig. 3-122

DI 00
Logical name DI 0 (‘Ext. Protection’)

DI 01
Logical name DI 1 (‘Ext. Run’)

DO 00
Logical name DO 0 (‘REL_1’)

DO 01
Logical name DO 1 (‘REL_2’)

Procedure 1 Choose [Config] > [DI/DO Identifications].

2 Select the desired hardware option by activating the command buttons of the I/O 
Boards group.

3 In the Identifications list box select the desired channel by means of the vertical 
scroll bar, position the cursor, and enter the names.

NOTE:
If several identifications are entered, move the cursor by TAB key or mouse.

3.8.3 Analog input characteristic curve configuration

3.8.3.1 Overview

In MID/MCD mode Quadstar 32-bit supports the data acquisition via analog inputs. The 
number of channels depends on the installed hardware:

QMS 422/421
The AI 421 board, which can be installed in the QMS as an Option, offers 16 analog input 
channels.

Resolution  5 mV/lsb

Measurement range  -10.24 ... +10.24 Volt
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QMS 200

The QMS 200 features two analog inputs. This configuration cannot be extended.

The measurement data acquisition via the analog inputs is based on the following two 
possibilities:

• An Analog Input channel is assigned via Det.Type = AI to a QMS channel. During 
each measurement cycle the analog input channels are measured and the measure-
ment data (analogously to the intensities) made available for further processing (sav-
ing, displaying, etc.).

• Only in sequencer operation mode: The analog inputs are read in by the QMS as 
channel-independent parameters at any time. This method is used if a sensor of a 
secondary function is to be measured or monitored.

3.8.3.2 Specifying an AI sensor

For operation with Quadstar 32-bit, the AI characteristic curve of the connected sensor 
must be assigned to the used AI channel; Quadstar 32-bit works with this curve. The 
sensor type (AI Type) and unit of measure (Unit) can be specified as well as the sensor 
characteristic.

If no Characteristic Curve is specified, the factory supplied, linear Characteristic Curve 
(0 ... 10’000 mV <=> 0 ... 10’000 Units for QMS 422/421, or 0 ... 5’119 mV <=> 0 ... 5’119 
Units for QMS 200) is used.

Programming an 
AI characteristic

When programming the characteristic curve of a sensor, the curve must be entered by 
means of basic points or formula. A linear characteristic can be fixed with two set points; 
for programming a non-linear characteristic, up to 32 basic points are possible. Interme-
diate values are calculated through linear interpolation.

NOTE:
The characteristic curve should only be defined across the expected range of val-
ues.

Input ranges AI 421
Input voltage: -10240 ... 10238 mV

Value range: -1.000E+37 ... 1.000E+38

QMS 200
Input voltage: -5120 ... 5119 mV

Value range: -1.000E+37 ... 1.000E+38

Resolution  156.25 µV/lsb

Measurement range  -5.12 V ... +5.12 V
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3.8.4 AO Characteristic Curve Configuration

3.8.4.1 Overview

In Process Control (sequencer, SetAO() command) Quadstar 32-bit can output any ana-
log values, that are assigned to voltages by the characteristic curve. The number of 
available channels depends on the installed hardware:

QMS 422/421
The AO 421 board, which can be installed in the QC 421 as an Option, offers 12 analog 
output channels.

QMS 200

The QMS 200 features four analog output as standard equipment. This configuration 
cannot be extended.

3.8.4.2 Specifying an analog output

For operation with the sequencer, an output characteristic (AO characteristic) must be 
assigned to the used AO channel. The sensor type (AO Type) and unit of output (Unit) 
can be specified as well.

If no Characteristic Curve is specified, the factory supplied, linear Characteristic Curve 
(0 ... 10’000mV <=> 0 ... 10’000 Units for QMS 422/421, or 0 ... 5’119mV <=> 0 ... 5’119 
Units for QMS 200) is used.

When operated manually, the AO characteristic curve is not used. The value to be out-
put is then scaled in a linear or logarithmic mode to the output voltage range of the AO, 
according to the setting made under AO-Mode (Register card Output of the channel 
parameter editor).

3.8.4.3 Programming the characteristic

The programming of the analog outputs (AO’s) is similar to the programming of the ana-
log inputs (AI’s). The curve can be defined by means of basic points or formula. A linear 
characteristic can be fixed with two set points; for programming a non-linear character-
istic, up to 32 basic points are possible. Intermediate values are calculated through lin-
ear interpolation.

Resolution  5 mV/lsb

Output range  -10.24 ... +10.24 Volt

Resolution  156.25 µV/lsb

Output range  -5.12 V ... +5.12 V
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NOTE:
Please note that the programmed output voltage (entered under mV) shall not ex-
ceed -10240 ... +10240 mV in the case of the AO 421 board, or -5120 ... +5119 mV 
for the QMS 200.

Example Specifying an analog input (AI)

Procedure

1 In the Parameter Setup program choose [Config] > [AI Characteristic Curve].

2 In the AI Channel text field, select the desired channel by entering its number 
directly, or use the [UP]/[DOWN] buttons.

3 In the AI-Type text field enter the type (pressure, temperature etc.) and in the Unit 
field enter the unit of measure (mbar, °C etc.).

4 The type of sensor characteristic determines how to continue:
• The sensor has a linear characteristic:

• Enter start- and endpoint in the Basic points field. Press the TAB key af-
ter each entry or move the cursor to the next input field with the mouse.

• The characteristic of the sensor is non-linear but given by an algebraic expres-
sion:

• Call the Formula Editor by pressing the Formula button. See Section 
«[Formula]», 244.

• Enter the formula for your measurement as a function of the X-value in 
mV (variable X).

• Enter the minimal and maximal voltage for X in mV and press [OK]; the 
basic points are now calculated in such a way that the largest relative 
deviation of the values between the points is minimized.

• The characteristic of the sensor is non-linear and not given by an algebraic ex-
pression that contains only allowed elements as described in Section «[For-
mula]», 244:

• Under Basic points enter the desired basic points. Press the TAB key 
after each entry or move the cursor to the next input field with the 
mouse.

Expanding an 
existing table of 
basic points

Make sure not to exceed the maximum of 32 basic points.

1 In the AI Channel text field select the desired channel.

2 Enter the new basic points at the end of the Basic points table.

3 Activate the Sort command button for resorting the basic points.

Deleting 
individual basic 
points

1 In the AI Channel text field select the desired channel.

2 Position the cursor in the Basic points table at the basic point to be removed.

3 Delete the basic point by pressing the Delete command button.

Displaying the 
sensor character-
istic

1 Select the desired channel in the AI Channel text field.

2 Click on the [Diagram] command button for graphic representation.

3 Under Option choose the desired display mode: Linear or Logarithmic.
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Copying/exchang
ing AI channel 
parameters

1 Press the [Copy] command button.

2 Choose Copy for copying one channel to another or Exchange to exchange two 
channels.

3 Under Source and Dest enter the corresponding channel numbers and press the 
[OK] button.

3.8.4.4 Enter the characteristic curves (AI)

In this dialog box you can program the characteristics of the individual AI channels.

Fig. 3-123

Control elements AI Channel
Number of analog input channel.

AI Type
Type of AI channel (sensor type, max. 12 characters).

Unit
Unit of measure applicable to the AI channel (max. 12 characters).

Basic points
Basic points table that defines the AI-characteristic.

[Sort]
Sort the table of basic points.

[Copy]
Copy all parameters of the selected AI channel to another AI channel or exchange their 
characteristics.
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Fig. 3-124

Copy control 
elements

Mode Selection
• Copy: Copy one channel to another.
• Exchange: Exchange two channels.

Source
Channel from which will be copied or that is to be exchanged.

Destination
Channel to which will be copied or that is to be exchanged with Source.

[Delete]
Delete the table entry selected by the cursor.

[Diagram]
Choose the Diagram command button to show the programmed sensor characteristic:

Fig. 3-125

Under Options you can choose the display mode:

Linear
Linear scale.

Logarithmic
Logarithmic scale. No negative values can be displayed on the Y-axis if [Options] > [Log-
arithmic] is chosen

X-Grid
Display the vertical grid for the X-axis.
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Y-Grid
Display the horizontal grid for the Y-axis.

[Formula]
Formula enables you to enter the sensor characteristic by an algebraic formula:

Fig. 3-126

Enter Formula...
In this field, enter the formula that characterizes the sensor. Only the capital X is allowed 
as variable.

Minimal X
Lower limit for X in mV.

Maximal X
Upper limit for X in mV.

The formula describes the Y-value (any measure unit) as a function of X (voltage in mV). 
The following operations are allowed:

• Basic operations: + - */
• Calculation of e to the power of p: exn(p)
• Calculation of 10 to the power of p: exp(p)
• Calculation of the logarithm, base e: lgn()
• Calculation of the logarithm, base 10: log()
• Squaring: sqr()
• Calculation of the square root: srt()
• Determination of the absolute value: abs()
• Expressions in brackets (....)

Blanks are not allowed; they will cause a syntax error to be reported.

Example You want to measure with your pressure gauge in a range of 5E-8 to 5E-3 mbar. Its char-
acteristic is given by the expression ‘p[mbar] = 10^(U[V] * 1.667 - 10.5)’.

1 ‘Translate’ the expression to the form that Quadstar 32-bit expects. Note that the 
voltage must be given in mV. The formula therefore reads as follows:

‘exp(X/1000 * 1.667 - 10.5)’

2 Determine the limits for minimal and maximal X as restrictively as possible (i.e. 
calculate the voltage for highest and lowest expected pressure) and enter them 
(in mV) as Minimal X and Maximal X. In our example, voltages between 2 and 5 
Volts are expected:

Minimal X: 2000
Maximal X: 5000
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Actually, you could forget this and simply set the largest possible range (-10 ... 10 
Volts). But you would lose precision by doing so: the 32 basic points would be 
spread over the whole (too large) range.

In some cases the formula might not even be defined across the whole range (e.g. 
division by zero!). Formula and limits must always be set in a manner that results 
of the calculation (intermediate results too) remain in the range of -1E+37 ... 
+1E+38.

3 Start the calculation by [OK]. The program will return to the previous dialog box 
and the calculated points will occur in the table ‘Basic Points’. Check the curve by 
using ‘Diagram’ and modify limits and formula if necessary or delete and add 
manually calculated points.

3.8.5 Screen Colors

[Config] > [Screen Color] is used for defining the Quadstar 32-bit specific desktop colors. 
With the aid of three test screens (Versus Time - Graphic, bar chart and table) colors 
can be selected individually for the elements of graphically displayed measurement 
data. The colors of the individual screen elements can be stored as a set, i.e. as color 
palettes, and reactivated via the Color Palette list box. The selected colors affect only 
the measurement data pictures of Quadstar 32-bit.

Quadstar 32-bit is supplied with a standard color palette. You can either adopt this pal-
ette or change the colors and store the palette under a different name.

Preparation of a suitable color palette is particularly important when outputting measure-
ment data graphics on a printer. Colors that appear as white on a monochrome display 
should not be used. If a suitable color palette for the printout is defined, all visible ele-
ments will be drawn.

NOTE:
Quadstar 32-bit can display up to 192 colors, provided that the PC supports this.

3.8.5.1 Changing the colors of the individual screen elements

This change relates to the color palette selected under Color Palette. There are two 
ways of selecting the individual screen elements: indirect selection via the Screen Ele-
ment list box, or direct selection by clicking on the desired screen element in one of the 
three test pictures.

The following screen elements are available in the Screen Element list box:

• Alarm Off: Alarm deactivated.
• Alarm On: Alarm activated.
• Axis: Horizontal and vertical axes.
• Axis Text: Numeric labeling of the axes.
• Axis Unit: Text Name of the vertical axis.
• Background: Background of the test pictures
• Bar Current: Currently measured value (Bargraph).
• Bar Last/Difference: Measured value of the last cycle (Bargraph)/difference 

(Analog).
• Bar Reference: Reference value (Bargraph/Analog).
• Cursor: Line cursor.
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• Curve: Versus Time line.
• Grid: Grid lines.
• Table Frame: Frame for Multiple Table display.
• Table Head: Header line of the table.
• Table Line Separator: Line separator for Multiple Table display.
• Table Marker: Mark the current cycles for Multiple Tables display.
• Table Text: Contents of the table.
• Text Lightened: Emphasized text.
• Text: Normal Text.
• Trip Level A: Threshold A.
• Trip Level B: Threshold B

Selecting a color 
palette

Select the colors via the Color Palette field. You can either modify an existing color pal-
ette or create a new palette and store it under a different name.

1 Choose [Config] > [Screen Color].

2 Open the Color Palette list box and click on the desired color palette.

Indirect selection 
through the list 
box

1 Choose [Config] > [Screen Color].

2 Open the Screen Element list box and click on the desired screen element. (you 
can access the next element without opening the list box by pressing the up/down 
arrow key).

3 Assign a different color to the selected screen element by clicking on the desired 
color in the Colors field

Direct selection in 
the test picture

1 Choose [Config] > [Screen Color].

2 Click on the desired element in one of the test pictures. The selection is confirmed 
in the Screen Element list box.

3 Assign a different color to the selected screen element by clicking on the desired 
color in the Colors field.

Storing a color 
palette

1 Choose Save. Quadstar 32-bit responds with the Save Color Table dialog box.

2 Change the displayed name if you want to store a new color palette.

3 Activate the [OK] command button.
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Screen Colors 
dialog box

Fig. 3-127

The Screen Colors dialog box is subdivided into the following Groups and control ele-
ments:

Control elements Color Palette
Choose a color palette.

Screen Element
Choose a screen element via the list box.

Colors
Color range of the installed video card.

Test screens
• Versus Time graphic.
• Bar chart graphic.
• Table output.

NOTE:
The entered values are stored automatically when the Screen Color editor is 
closed with the [OK] command.

[Alternating Colors]
Choose the colors to be used alternatingly (used in TuneUp and Sequencer instructions, 
where no fixed colors can be set).

• #0 ... #63: The alternatingly used colors, maximum 64.
• [Set Default Colors]: Choose the standard colors (suitable for a bright back-

ground).

[Save]
Store the current state in the selected color palette.

[Delete]
Delete the selected color palette.
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4. Display Saved Values

Display Saved Values is used for displaying and analyzing stored measurement data. 
Such files may contain intensities, concentrations, calculated values and measured val-
ues from analog inputs. With Display Saved Values you can select these blocks and ele-
ments individually.

Main menu Choose the type of measure data to work on:

Fig. 4-1

Submenus File
Display the version number of the Quadstar 32-bit Display Saved Values program and 
exit the program.

Scan
Load and evaluate the scan measurement data.

• Scan Analog measurement mode. See Chapter 4.2.1 Scan Analog data, 251.
• Scan Bargraph measurement mode. See Chapter 4.2.2 Scan Bargraph Cycles, 

271.

Process
Load and evaluate MID (Multiple Ion Detection) or MCD (Multiple Concentration Detec-
tion) measurement data, or data that has been created by the sequencer instructions 
Process.

Auxiliary
Display zero gas data, mass scale calibration and error history.

Help
Display the ‘Key Fragment Ions’ table and help contents. See Chapter 1.9 Hints con-
cerning the work with Quadstar 32-bit, 56.
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4.1 File

File menu

Fig. 4-2

About Display Saved Values...
Info on the Display Saved Values program.

Exit
Quit the Display Saved Values program.

4.1.1 About Display Saved Values

Read out the version number of the Quadstar 32-bit Display Saved Values program:

Fig. 4-3
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4.2 Scan measurement data

Scan menu

Fig. 4-4

Analog Data...
Display Scan Analog measurement data.

Analog Reference...
Display Scan Analog reference measurement data

Bargraph Cycles...
Display Scan Bargraph measurement data. See Chapter 4.2.2 Scan Bargraph Cycles, 

271.

4.2.1 Scan Analog data

Analog Data are data, that contain one or more cycles. Analog Reference are data, that 
contain just one cycle and serve as reference data.

In the subsequent Sections we distinguish between 2-dimensional and 3-dimensional 
representation. The display mode can be changed over in the Setup menu.

• [3 Dimensional] checked: 3-dimensional representation.
• [3 Dimensional] not checked: 2-dimensional representation.

2-Dimensional 
representation

In this display mode only the measurement data of one cycle is displayed. The file can 
contain the measurement data of one or several cycles.

Fig. 4-5
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The status bar shows the coordinates of the mouse. The function Magnify or Cursor can 
be assigned to the mouse. See Chapter 4.2.1.5.1 Magnify, 261 and Chapter 4.2.1.5.2 
Cursor, 263.

3-Dimensional 
representation

With this display mode, Scan Analog measurement data that have been measured and 
stored across several cycles can be represented in a 3-dimensional diagram.

Depending on the choice of X-Axis Type under [Setup] > [Graphic], the X-axis can show, 
for example, the mass numbers...

Fig. 4-6

...the measured cycles...
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Fig. 4-7

...or also the relative and the absolute time.

The status bar shows the coordinates of the mouse.

NOTE:
Please note that 3-dimensional representation is only feasible, if several cycles of 
a scan have been stored in the measurement data file.

Analog data 
menu

Fig. 4-8

File
Load, save or ASCII-convert a file. Return to the main menu of the evaluation program. 
See Chapter 4.2.1.1 File submenu, 254.

Display
Display selected intensities of a scan numerically, show/hide added graphic elements. 
See Chapter 4.2.1.2 Display submenu, 255.

Select
Select the scans that are to be displayed. See Chapter 4.2.1.3 Select submenu, 256.

Setup
Set up display range and options. See Chapter 4.2.1.4 Setup submenu, 257.
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Function
Set the cursor function (‘magnify’/’show position’), call the graphic editor. 
Chapter 4.2.1.5 Function submenu, 260.

Special
Show data using standard settings, call the filter function, and reset magnification. See 
Chapter 4.2.1.6 Special submenu, 269.

Info
Display measure data documentation. See Chapter 4.2.1.7 Info submenu, 270.

4.2.1.1 File submenu

Fig. 4-9

Open Data...
Open a measurement data file (*.sac).

Open Reference...
Open a reference data file (*.sar).

Load Reference...
Load and display a reference file for the currently displayed data file.

Close Reference...
Close the reference file for the currently displayed data file.

Save Difference As...
Save the difference between the measure data and the reference data.

Reload Cycles
Reload newly measured cycles of the currently displayed data file.

Reload Setup...
Reload newly measured cycles automatically:
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Fig. 4-10

• Number of Cycles: Number of cycles to reload (of the last measured ones).
• Automatic Reload: Reload automatically on/off.
• Repeat Time[s]: Time between automatic reloads.

Save
Store the active measurement data file under its current name.

Save As...
Store the current measurement data file under a different name and path

Save Selected Cycles As...
Store the cycles selected under [Setup] > [Graphic] as a new file.

Convert to ASCII...
Convert the current Scan Analog file to an ASCII file.

Convert to Data...
Convert a Scan Analog reference data file to a Scan Analog measurement data file.

Convert to Reference...
Convert a Scan Analog measurement data file to a Scan Analog reference data file.

Close
Return to the main menu of Display Saved Values.

4.2.1.2 Display submenu

Display the intensity of a selectable mass number, show or hide added graphic ele-
ments:

Fig. 4-11

Value
Numerically display or change the intensity of a selected mass number in the dialog box 
Scan Analog Display. See Chapter 4.2.1.5.2 Cursor, 263.

Graphic Data
Display the graphic elements that have been added to the measurement data picture by 
the Graphic Editor. See Chapter 4.2.1.5.3 Graphic editor, 267.
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4.2.1.3 Select submenu

Fig. 4-12

Scans/Additional Data
Choose those scans or additional data that shall actually be displayed. Opens the dialog 
box Select Scans/Additional Data:

Fig. 4-13

Control elements Scans
• Scan Number: Choose the scan.
• Display: Show or hide the chosen scan.
• Display All: Show all scans.
• Comment: Short comment (will be displayed together with this scan).

Scan Data
• Scan Name: Mass Axis Name
• Scan Unit: Mass Axis Unit
• Start Value: First value of Mass Axis
• End Value: Last value of Mass Axis
• Value Name: Intensity Axis Name
• Value Unit: Intensity Axis Unit
• Comment: Short Comment (will be displayed together with this scan)

Additional Data
Additional measurement data (if present)

• Name: Designation of the additional measurement data.
• Unit: Unit of measure of the additional measurement data.
• Display: Display additional measurement data on/off.
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4.2.1.4 Setup submenu

Fig. 4-14

3 Dimensional
Display several Scan Analog spectra as a 3-dimensional diagram. This option is only 
available if the file contains the measurement data of more than one cycle.

Graphic...
Setup the display.

Fill Curve
Fill the envelope with the Fill Color.

Curve Color...
Enter the Curve Color and the Fill Color:

Fig. 4-15

• Curve Color: Select the color of the envelope.
• Fill Color: Select the color to fill the envelope with.

Arrangement
Arrange scans, if several of them are stored in this file:

• Vertical: Display scan below previous.
• Horizontal: Display scan beside previous.

The following menu entries are only relevant for 3-dimensional representation of mea-
surement data:

Cursor
Show the cursor projection lines.

• Cross: Normal cursor.
• Cross & Projection: Projection of the cursor line to the X-, Y- and Z-axis.
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Draw Box
The graphic is drawn in a box.

Align Cursor
The cursor jumps from cycle to cycle.

Graphic... The type of dialog box that is displayed depends on the setting of [Setup] > [3 Dimen-
sional]: enabled or disabled.

2-Dimensional 
Representation

Fig. 4-16

NOTE:
The dialog box can also be called by double-clicking the left mouse button inside 
the displayed measurement data.

Scan
• Scan Number: Choose the scan, if more than one scan is stored in the file.
• Start Value: Enter the starting value at which the graph should start.
• End Value: Enter the last value to be displayed.

Grid
• X-Axis: Display the vertical grid for the X-axis.
• Y-Axis: Display the horizontal grid for the Y-axis.

Cycle
• Number: Select the cycle, if the file contains several cycles.

Value
Name (Ion current, Ion Counts, ...) and unit (A, cps, ...) of measure data.

• Highest Value: End value of Y-axis.
• Lowest Value: Start value of Y-axis.

Scale
• Lin: Display the measurement data on a linear scale.
• Log: Display the measurement data on a logarithmic scale.

NOTE:
Number-parameters (e.g. Start Value/End Value) can be restored to the original 
values by clicking on the or arrows with the right mouse button
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3-Dimensional 
representation

Fig. 4-17

NOTE:
This dialog box can also be called up by double clicking the left mouse button in-
side the displayed measurement data.

Cycle
Select the cycles to be displayed

• Start Cycle: First cycle to be displayed
• End Cycle: Last cycle to be displayed

X-Axis Type
The following data types may be shown on the X-axis:

• Cycle: The X-axis is labeled with the cycle numbers.
• Scan: The X-axis is labeled with scan values.
• Data: The X-axis is labeled with additional measurement data.
• Time Relative: The X-axis is labeled with the relative time since the start.
• Time Absolute: The X-axis is labeled with the absolute time (time of day).

Z-Axis Type
The following data types may be shown on the Z-axis:

• Cycle: The Z-axis is labeled with the cycle numbers.
• Scan: The Z-axis is labeled with the scan values.
• Data: The Z-axis is labeled with additional measurement data.

Scan
Name (Mass,...) and unit (amu,...) of the scan.

• Start Value: First cycle to be included in the displayed graph
• End Value: Last cycle to be included in the displayed graph.

Data
Additional data with name and unit of measure.

• Start Value: Starting value of the display.
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• End Value: Ending value of the display.

Display
• Angle between X- and Z-axis: Enter the angle between the X- and the Z-axis
• Length of Y-axis in % of X-axis: Length of the Y-axis in % of the X-axis.
• Length of Z-axis in % of X-axis: Length of the Z-axis in % of the X-axis.

Grid
• X-Axis: Display the vertical grid for the X-axis.
• Y-Axis: Display the horizontal grid for the Y-axis.
• Z-Axis: Display the horizontal grid for the Z-Axis.

Data Reduction
Reduction of the displayed points by a factor of 2, 4 or 8.

Value
Name (Ion Current, Ion Counts ,...) and unit (A, cps, ...) of measure data.

• Highest Value: End value of Y-axis
• Lowest Value: Start value of Y-axis.

Scale
• Lin: Display the measurement data on a linear scale.
• Log: Display the measurement data on a logarithmic scale.

NOTE:
Number-parameters (e.g. Highest Value/Lowest Value) can be restored to the orig-
inal values by clicking on the or arrows with the right mouse button

4.2.1.5 Function submenu

Fig. 4-18

To select the cursor function type or call the graphic editor, open the Function menu:

Magnify
Switch to block marking for the magnifier function.

Cursor
Switch to crosshairs.

Graphic Editor
Call the graphic editor.

NOTE:
Changeover from Magnify to Cursor and vice versa is also possible with a click of 
the right mouse button anywhere within the measurement data screen.
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4.2.1.5.1 Magnify

Magnifying a screen section

If [Function] > [Magnify] is chosen, a section of the displayed screen can be marked and 
magnified:

2-Dimensional 
representation

Hold down the left mouse button and drag the mouse to mark a rectangle:

Fig. 4-19

If you click the right mouse button while still holding the left mouse button pressed, the 
selected rectangle is magnified on the display.

Fig. 4-20

• This magnify function can be nested several times.

• The last picture magnification can be reversed using [Special] > [Undo Magnify].

• The graphic can be restored to its original size by [Special] > [Set Default].
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3-Dimensional 
representation

Hold down the left mouse button and drag the mouse to mark a rectangular solid:

Fig. 4-21

If you click the right mouse button while still holding the left mouse button pressed, the 
selected part is magnified on the display.
262 Display Saved Values vpnb68e1 (0302), Quadstar 32-bit



Fig. 4-22

In this way it is possible e.g., to view the peaks that have been concealed by the peak 
of mass 20 before:

4.2.1.5.2 Cursor

Determine measurement data graphically
If [Function] > [Cursor] is selected, a measured value within the graphic display can be 
marked by the crosshairs. Its values for X and Y are displayed in the status bar.

2-Dimensional 
representation

Press the left mouse button within the graphic display, so the cursor appears as 
crosshairs and the values for X and Y are displayed in the status bar:
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Fig. 4-23

If you click the right mouse button while still holding the left mouse button pressed, the 
mass selected with the vertical line of the crosshairs (X: 28.00) and the corresponding 
intensity are displayed numerically in a dialog box.

Fig. 4-24

The mass number can be selected directly, the intensity is modified by Change:

Control elements Scan Number
Number of the selected scan (if more than one scan is available).

Cycle
Number of the cycle (if more than one cycle is available).

Cycle Time
Relative start time of the cycle.

Date
Date and time when the scan was started.

Mass
Selected Mass number.
264 Display Saved Values vpnb68e1 (0302), Quadstar 32-bit



Ion Current/Countrate
Intensity of the selected mass number.

[Change]
Manual elimination of freak values. See Section «Manual elimination of freak values», 

302.

Fig. 4-25

Faulty measurements (“freak values”) can also be corrected automatically by [Special] 
> [Filter].

3-Dimensional 
representation

Press the left mouse button within the displayed graphic, so the cursor is displayed as 
crosshairs. The values of the current cursor position appear in the status bar:

Fig. 4-26

About cursor operation:

• The cursor always moves to the scan of the first cycle. If the Ctrl key is pressed si-
multaneously, the cursor can be shifted on the Z-axis.

• If [Setup] > [Align Cursor] is active and the Ctrl key is pressed, the cursor jumps from 
cycle to cycle on the Z-axis.
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• When a peak top is marked within a group of peaks, it may be difficult to find the cor-
rect peak in the correct cycle. By using [Setup] > [Cursor] > [Cross & Projection] this 
can be done much easier since the cursor is projected to the different axes then.

If you click the right mouse button while still holding the left mouse button pressed, the 
mass selected with the vertical line of the crosshairs (for example, mass 16.00) and the 
corresponding intensity are displayed numerically in a dialog box:

Fig. 4-27

Control elements The selected mass number can be modified directly, the intensity is modified by Change.

Scan Number
Number of the selected scan (if more than one scan is available)

Cycle
Selected cycle.

Cycle Time
Relativ start time of the cycle.

Date
Date and time when the scan was started.

Mass
Selected mass number.

Ion Current/Countrate
Intensity of the selected mass number.

[Change]
Manual elimination of freak values. See Section «Manual elimination of freak values», 

302.

Additional Data
Additional data (one value per cycle) stored with this cycle.
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4.2.1.5.3 Graphic editor

You can add text and drawings to your measurement pictures, for example, to prepare 
them for printout or as an aid for interpretation. The dialog box shown below contains 
ten functions, each of which is identified by a symbol:

Fig. 4-28

Insert text

Position the insert marker where the text should start and click the 
left mouse button. The following text input dialog box is displayed:

Fig. 4-29

In addition you can specify the desired Font and the background 
mode (Background mode: normal overprints existing picture ele-
ments, transparent only superposes the characters), Delete the 
entered text, if desired, and accept ([OK]) or cancel ([Cancel]) the 
input.

Draw line

Position the crosshairs where the line should start. While keeping 
the left mouse button pressed drag the mouse to the point where the 
line should end and then release the mouse button.

Draw rectangle

Position the crosshairs at one corner of the rectangle. While keeping 
the left mouse button pressed drag the mouse to the diagonally 
opposite corner and then release the mouse button.

Draw solid bar

Position the crosshairs at one corner of the solid bar. While keeping 
the left mouse button pressed drag the mouse to the diagonally 
opposite corner and then release the mouse button.
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NOTE:
Do not change the size of the measurement picture after you have processed it 
with the graphic editor. This would have the result that the graphic elements 
would be shifted relative to the measurement curve and consequently be posi-
tioned in the wrong place.

Choose options

Click on the graphic element to be processed or choose one of the 
above functions. If you now click on the Options button and depend-
ing on the graphic element, a dialog box for Draw lines is displayed, 
for example as the one shown below:

Fig. 4-30

You can now adjust the options (for example, color and style) of the 
graphic element to your requirements and accept the setting with 
[OK] or quit with [Cancel].

Resize element

Resize element: Click on the graphic element to be processed which 
is then displayed with eight handles. While holding down the left 
mouse button drag one of the handles (larger/smaller) or move the 
element itself. Release the mouse button.

Bring to front

Click on the graphic element to be processed which is then dis-
played with eight handles. When you click on this command the 
marked element will be brought forward by one layer relative to the 
next higher graphic element, but not relative to the measurement 
data.

Bring to back

Send to back: Click on the graphic element to be processed which is 
then displayed with eight handles. When you click on this command 
the marked element will be sent one layer back relative to the next 
lower graphic element, but not relative to the measurement data.

Delete

Click on the graphic element to be processed which is then dis-
played with eight handles. Click on the [Delete] command to remove 
the marked graphic element. If no graphic element is marked, all 
graphic elements are removed. To prevent inadvertent removal the 
operation has to be conformed with [OK] or [Cancel] in the subse-
quent dialog box.

Quit

Click on this command button to quit the graphic editor.
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4.2.1.6 Special submenu

Fig. 4-31

Undo Magnify
Reverse the changes of the last magnification.

Set Default
Restore all settings for measurement data display to their standard values.

Filter...
Automatic elimination of freak values.

4.2.1.6.1 Filter

Choose filter for automatic elimination of freak values:

Fig. 4-32

Filter Type
Select the desired filter type.

• Moving Median: Determines a moving median. For this purpose a certain number 
(selectable via Rank) of the last measured values is sorted by their magnitude and 
the one in the middle is used as the filter output (this way, extremely high or low val-
ues do not affect the results at all, since they are never taken into consideration).

• FIR QMS...: The individual measured values are subjected to the same FIR filter al-
gorithm (Finite Impulse Response) that is implemented in the QMS.

Moving Median
• Rank: Determines the number of measured values taken into consideration for the 

filter type Moving Median (number of measured values = 2 * Rank +1).

Output File Name
Name of the file in which the results are to be written. The name can be entered by acti-
vating the File Manager command button.
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NOTE:
Record the filtered data on a new file so that the original data will be preserved in 
any case.

4.2.1.7 Info submenu

Display measure data documentation

Fig. 4-33

File...
Display measure data documentation, if there is one. Otherwise a new documentation 
is created that consists of additional info, notes and title only:

Fig. 4-34

Control elements [Measurement Parameters]
Display the measurement or channel parameters in effect at the time of the measure-
ment.

[Ion Source Parameters]
Display the ion source parameters in effect at the time of the measurement.

Additional Information
Display the user-defined parameter sets, each comprising Name and Value. These 
names and values can be added or modified later.

• [Delete All Names]: Delete all names of the user-defined parameters.
• [Delete All Values]: Delete all values of the user-defined parameters.

Notes
User notes/appendices to the measurements can be added directly by positioning the 
insertion mark within the notice field and entering the text on the keyboard.
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Title
File title (shows up in the file manager).

[OK]
Accept and save the file information.

[Cancel]
Cancel the input, leave the old information unchanged.

NOTE:
It is important that you quit this dialog box with [Cancel] if you have inadvertently 
changed something. (for example, name of additional information deleted). In the 
subsequent dialog box (“...save current changes?”) enter [NO], you can then re-
call the original file information from [Info] > [File].

[About File]
Display certain specifications of the measurement data file.

Fig. 4-35

Filename
Name of the selected measurement data file.

Software Version
Quadstar 32-bit version used for creating this file.

Date
File creation date.

Time
Time of day the file has been created.

Author
Operator name.

4.2.2 Scan Bargraph Cycles

Menu

Fig. 4-36

Submenus File
Load, save, ASCII-convert or print a file. Return to the main menu.
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Mode
Select the display mode: 

• Total Ion Current (TIC)
• Intensity Versus Time (IVT)

Display
Display all mass numbers and peak intensities of a scan in numeric and graphic form, 
show/hide added graphic elements. See Chapter 4.2.2.3 Display submenu, 275.

Select
Select the mass numbers for which graphic representation of the peak intensities is 
desired. See Chapter 4.2.2.4 Select submenu, 277.

Setup
Set up the X-axis and Y-axis parameters. See Chapter 4.2.2.5 Setup the display, 279.

Function
Define the cursor type or function and start the graphic editor. See Chapter 4.2.2.6 
Function submenu, 281.

Special
Show data using standard settings or reset magnification. See Chapter 4.2.2.7 Special 
submenu, 284.

Info
Display measure data documentation or supplementary information of the opened mea-
surement data file. See Chapter 4.2.2.8 Info submenu, 284.

4.2.2.1 File submenu

Fig. 4-37

Open...
Call the Quadstar 32-bit file manager for opening a measurement data file.

Reload Cycles
Reload newly measured cycles of the currently displayed data file.

Reload Setup...
Reload newly measured cycles automatically:
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Fig. 4-38

• Number of Cycles: Number of cycles to reload (of the last measured ones).
• Automatic Reload: Reload automatically on/off. 
• Repeat Time[s]: Time between automatic reloads.

Save
Store the active measurement data file under its current name.

Save As...
Store the active measurement data file under a different file name and/or path.

Print
Print the selected masses and their peaks of the selected cycles.

Convert to ASCII...
Convert the current Scan Bargraph file to an ASCII file.

NOTE:
The format of the ASCII file is described in more detail in Chapter 10.5 Data export 
ASCII, 549.

Close
Return to the Display Saved Values main menu.

4.2.2.2 Mode submenu

Fig. 4-39

Scan Bargraph measurement data can be represented in two formats:

TIC
Total Ion Current: All measured intensities per cycle are added. The results of this addi-
tion are displayed as a function of time.

IVT
Intensity Versus Time: The peak intensities of the chosen masses are displayed as a 
function of time.
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4.2.2.2.1 TIC display mode (Total Ion Current)

This window shows the Total Ion Current [A] (calculated by adding all measured peak 
intensities per cycle) across a selectable time range. The time range, i.e. the number of 
cycles to be displayed, can be selected under [Setup] > [X-Axis].

Fig. 4-40

When displayed for the first time, the screen is automatically stretched in the Y-Axis; the 
display range is reduced to the range, in which the sum of all ion currents (TIC) varies. 
This display area can be changed by [Setup] > [Y Axis] or by double clicking on the Y-
Axis.

The measured cycles are displayed on the X-Axis. The display area can be changed to 
Time Relative or Time Absolute in the Setup menu under X-axis (or by double clicking 
the X-axis label).

4.2.2.2.2 IVT display mode (Intensity Versus Time)

The picture shows the peak intensities of the masses chosen under Select Data, across 
a selectable time range. This time range can be defined under [Setup] > [X-Axis] by 
specifying the number of cycles to be displayed.
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Fig. 4-41

4.2.2.3 Display submenu

Fig. 4-42

Cycle...
Numerically display the Peak intensities of a selectable scan/cycle.

Graphic Data
Display the supplementary graphic elements that have been added to the measurement 
data picture with the Graphic Editor.
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4.2.2.3.1 Cycle

Fig. 4-43

Cycle
Number of the cycle, of which the spectrum is to be displayed.

Cycle Time
Relative measurement data time (time, since the measurement has started).

Date
Date and absolute time of the measurement.

TIC
Total Ion Current of the selected spectrum.

[Spectrum]
Graphic representation of the measurement data.

[Library]
Call the spectra library. You may compare the current spectrum with spectra of the 
library and save spectra. (=> Command button Spectrum, Menu [Spectrum] > [S1 to 
Library])

NOTE:
All peaks of a spectrum are listed, even if under [Select] > [Data] not all peaks 
have been selected.
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[Spectrum]

Fig. 4-44

Setup
• Y-Axis: Setup the display range of the Y-Axis.
• X-Axis: Setup the mass range to display.

You may access these setup boxes as well by double clicking on the corresponding axis.

Print
• Cycle: Print the peaks of the displayed spectrum.

Library
• Manual: Call the spectrum library.

4.2.2.4 Select submenu

Fig. 4-45

Data...
Dialog box for selecting the mass numbers whose peak intensities are to be displayed 
in IVT mode.

NOTE:
This dialog box can also be called up by double-clicking the left mouse button in 
the measurement data display.

4.2.2.4.1 Data

In the Select Data dialog box you can select the mass numbers of which the intensities 
are to be displayed in IVT mode . The “intensity” shown in graphic mode is of a static 
nature and represents the frequency in percent (Freq. [%]), with which the peak was 
found in the selected cycles.
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Remove, selected color etc. always relate to the currently marked peak. To select the 
color, click on the desired field in the color palette.

By Select, several masses can be selected simultaneously:

Fig. 4-46

Mass
Mass number of the selected peak.

Freq.[%]
Frequency in % at which the peak was measured in the selected number of cycles, 
where 100% means that the peak was found in every cycle, 50% means that the peak 
was found only in half the cycles.

Color
Peak color.

Marker
Marker for monochrome display. To get this marker on the menu, activate the Marker 
option under [Setup] > [Y-Axis].

[Remove]
Remove the marked mass number from the display table.

[Remove All]
Remove all mass numbers from the display table.

[Select]
Choose peaks of a range.
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[Select]

Fig. 4-47

Control elements From Mass
Starting mass number.

To Mass
Ending mass number.

Threshold
Threshold value in % that must be exceeded for the peak to be selected.

NOTE:
A new peak can be selected via Select or via the displayed spectrum: hold down 
the left mouse button and click simultaneously on the desired peak with the right 
mouse button.

4.2.2.5 Setup the display

Fig. 4-48

X-Axis...
Determine the display range of the X-axis.

Y-Axis...
Determine the display range of the Y-Axis.

NOTE:
The dialog boxes for setting up the X-axis and Y-Axis can also be activated by 
double clicking the lettering of the corresponding axes.

Number-parameters (e.g. Start Cycle/End Cycle) can be restored to the original 
values by clicking on the [UP] or [DOWN] arrows with the right mouse button
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4.2.2.5.1 X-Axis

Fig. 4-49

Start Cycle
First cycle to be displayed.

End Cycle
Last cycle to be displayed.

X-Scale
The X-axis can be lettered according to the following types:

• Cycle: Cycle numbers.
• Time Relative: Relative time since the start.
• Time Absolute: Absolute time (time of day).

X-Grid
Display the vertical grid for the X-axis.

4.2.2.5.2 Y Axis

Fig. 4-50

Highest Value
End value for lettering the Y-Axis.

Lowest Value
Start value for lettering the Y-Axis.

Y-Scale
• Lin: Display the measurement data on a linear scale.
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• Log: Display the measurement data on a logarithmic scale.

Line Type
• Solid: Display the measurement data with a solid line.
• Dot: Display the components:

• Dots: when Marker is switched off.
• Symbols: when Marker is switched on.

Y-Grid
Display the horizontal grid for the Y-Axis.

Marker
Display the symbols.

In [Mode] > [TIC], you can choose the Type of the marker symbol:

Fig. 4-51

4.2.2.6 Function submenu

Fig. 4-52

You can select the type of cursor function via the Function menu:

Magnify
Magnify a screen section by marking a block with the cursor.

Cursor
Display the scan measurement data numerically.

NOTE:
Switching from Magnify to Cursor and vice versa is also possible directly with a 
click of the right mouse button within the picture of the measurement data.

Table
Display the measurement data as a table. See Chapter 4.3.1.2.1 Cycle, 289.

Spectrum
Display the measurement data graphically as a spectrum. See Chapter 4.2.2.6.4 Dis-
play format of [Function] > [Spectrum], 284.

Graphic Editor
Call the graphic editor. See Chapter 4.2.2.6.5 Graphic editor, 284.
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4.2.2.6.1 Magnify a Screen Section

If [Function] > [Magnify] is chosen, an area of the measurement data screen can be 
marked that is to be magnified:

Fig. 4-53

The cursor position is shown on the status bar. C: XX represents the cycle number; the 
position on the Y-Axis [A] can be read under Y. Now press the right mouse button while 
still holding the left mouse button pressed to magnify the marked area.

Fig. 4-54

This magnifier function can be nested several times.

The graphic can be restored to its original size by [Special] > [Set Default].

4.2.2.6.2 Determine measurement data graphically (Cursor)

If [Function] > [Cursor] is active, you can select a cycle with the left mouse button.
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Fig. 4-55

When the right mouse button is pressed, while still holding the left mouse button 
pressed, the measurement data are displayed as a table (if [Function] > [Table] is set) 
or as a spectrum (if [Function] > [Spectrum] is set).

4.2.2.6.3 Display format of [Function] > [Table]

Fig. 4-56

This table is the same as the one that is called by [Display] > [Cycle]. See 
Chapter 4.2.2.3.1 Cycle, 276.
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4.2.2.6.4 Display format of [Function] > [Spectrum]

Fig. 4-57

4.2.2.6.5 Graphic editor

You can add text and drawings to your measurement pictures, for example, to prepare 
them for printout or as an aid for interpretation. See Chapter 4.2.1.5.3 Graphic editor, 

267.

4.2.2.7 Special submenu

Fig. 4-58

Undo Magnify
Undo the last magnification.

Set Default
Restore all measurement data display settings to their standard values. All components 
and measurement data blocks are displayed across the stored range (all cycles).

4.2.2.8 Info submenu

Fig. 4-59
284 Display Saved Values vpnb68e1 (0302), Quadstar 32-bit



File...
Display measure data documentation, if there is one. Otherwise a new documentation 
is created that consists of additional info, notes and title only. See Chapter 4.2.1.7 Info 
submenu, 270.
Quadstar 32-bit, vpnb68e1 (0302) Display Saved Values 285



4.3 Process

Process menu

Fig. 4-60

Cycles...
MID or MCD measure data that contain one or more cycles.

Reference...
MID or MCD reference measure data that contain just one cycle.

4.3.1 Cycle/Reference measurement data

Cycle data are measurement data that contain one or more cycles of the Multiple Ion 
Detection (MID) or the Multiple Concentration Detection (MCD) measurement type. Ref-
erence data are actually the same as cycle data, except that they consist of just one 
cycle. By the sequencer instruction Process, Cycle- or Reference- data may be created 
out of random data records.

Fig. 4-61

• The Y-axis lettering always relates to the selected measurement data block (in the 
above example the name of the selected block is: Ion Current). The names (here: 
mass numbers) of the components that belong to this block are marked by a short 
vertical line in front of them.

• If several blocks have been selected under [ Select] > [Blocks], the Y-axis display can 
be assigned to a different block via the list box displayed in the upper left corner:

Fig. 4-62
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• The X-axis is lettered with the cycle numbers.

Data block The data are summarized and displayed (separated by type and origin) as blocks. Sev-
eral blocks may be displayed simultaneously.

QMU 112 If the data have been collected by a QMU 112, the QMU-channel is shown between 
brackets behind the mass number. For example 28 [7] signifies Mass 28, measured via 
QMU channel 7.

Menu

Fig. 4-63

Submenus File
Load, reload, save, print or ASCII-convert a file; return to the main menu of the Dispsav 
program. See Chapter 4.3.1.1 File submenu, 287.

Display
Display the selected components of a block. See Chapter 4.3.1.2 Display setup, 288.

Select
Select the measurement data groups (blocks) and the components that are to be dis-
played. See Chapter 4.3.1.3 Select data to be displayed, 294.

Setup
Set up the display of the X-axis and Y-axis. See Chapter 4.3.1.4 Setup the display, 

298.

Function
Define the cursor function, call the graphic editor. See Chapter 4.3.1.5 Function sub-
menu, 299.

Special
Restore the standard display mode, call the filter function. See Chapter 4.3.1.6 Special 
submenu, 303.

Info
Display measure data documentation. See Chapter 4.3.1.7 Info submenu, 304.
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4.3.1.1 File submenu

Fig. 4-64

Open...
Call the File Manager for opening a measurement data file.

Reload Cycles
Reload newly measured cycles of the currently displayed data file.

Reload Setup...
Reload newly measured cycles automatically:

Fig. 4-65

• Number of Cycles: Number of cycles to reload (of the last measured ones).
• Automatic Reload: Reload automatically on/off.
• Repeat Time[s]: Time between automatic reloads.

Save
Store the current measurement data file.

Save As...
Store the current measurement data file under a different file name and/or path.

Print
Print the displayed cycles as a table.

Convert to ASCII...
Store the displayed measure data as an ASCII file under a user-assigned name.

NOTE:
The ASCII file format is described in Chapter 10.5 Data export ASCII, 549.

Close
Return to the Display Saved Values main menu.
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4.3.1.2 Display setup

Fig. 4-66

Cycle...
Display the Cycle Data Display dialog box.

Statistic...
Display statistical information.

Integral...
Integration, i.e. summing of the displayed measured values across time.

Bargraph
Display an individual cycle as a bargraph.

IVT
Display several cycles in Intensity Versus Time mode.

Graphic Data
Display supplementary graphic elements.

4.3.1.2.1 Cycle

Display the Cycle Data Display dialog box with the measured values of the chosen data 
block. See Chapter 4.2.2.6.2 Determine measurement data graphically (Cursor), 282.

4.3.1.2.2 Statistical Functions

Statistic provides statistical information on the stability, reproducibility etc. of the mea-
sured data. The statistical calculations are performed block by block for the data records 
from Start Cycle to End Cycle :
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Fig. 4-67

The dialog box displays the statistical information of the Ion Current block. The number 
of cycles (Start Cycle and End Cycle) can be changed by [Setup] > [X Axis].

To display the other activated data blocks, press [Next] or [Previous]:

[Previous]
Display the statistical information of the previous block.

[Next]
Display the statistical information of the next block.

Block related 
information

The Title, the mass Unit and the Comment can be entered in the corresponding input 
fields of the Select menu under Data. They always relate to the selected data block. See 
Chapter 4.3.1.3.2 Select Data, 296: Title, Unit and Comment parameters.

Calculating 
statistical data

Name
Designation of the data (concentrations Ar, CO2, ...; intensities 28, 32, ...; AI measured 
values, etc.)

Minimum
Smallest measured value stored between Start Cycle and End Cycle:

Maximum
Largest measured value stored between Start Cycle and End Cycle:

X1 ... Xn = Measured values 1...n (beginning at Start Cycle, ending at End Cycle)

X1 ... Xn = Measured values 1...n (beginning at Start Cycle, ending at End Cycle)

Minimum Minimum x1 x2 x3 … xn,,,,( )=

Maximum Maximum x1 x2 x3 … xn,,,,( )=
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Mean
Mean value of the measured values stored between Start Cycle and End Cycle:

STD ABS
Absolute standard deviation of the measured values stored between Start Cycle and 
End Cycle:

STD REL
Relative standard deviation of the measured values stored between Start Cycle and End 
Cycle:

4.3.1.2.3 Integration (Integral)

Integral integrates (from Start Cycle to End Cycle) across the time all selected signals 
of the chosen data block:

Xi. = Measured values i

n = Number of measured values

Xi. = Measured values i

n = Number of measured values

Mean
xi∑
n
-----------=

STDABS
xi
2

∑ n Mean2⋅–

n 1–
-------------------------------------------=

STDREL STDABS
Mean

------------------------=
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Fig. 4-68

Zero Based shows the integral over the x axis:

Fig. 4-69

Curve Based shows the integral over the line between the first and the last displayed 
measure value:

Fig. 4-70
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The number of cycles (Start Cycle and End Cycle) can be changed under [Setup] > [X 
Axis].

To display other activated data blocks, press the [Next] or [Previous] command button:

[Previous]
Previous block.

[Next]
Next block.

The displayed unit of measure (in this picture As) is composed of Ampere (A, defined 
under Unit) and seconds (s).

Block related 
information

The Title, the mass Unit and the Comment can be entered in the corresponding input 
fields of the Select menu under Data. They always relate to the selected data block. See 
Chapter 4.3.1.3.2 Select Data, 296: Title, Unit and Comment parameters.

4.3.1.2.4 Bargraph

Bargraph displays an individual cycle as a bar chart. If there are several cycles, one can 
be selected under [Display] > [Cycle] (in this example: Cycle No. 183):

Fig. 4-71
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4.3.1.2.5 Intensity Versus Time (IVT)

IVT displays the cycles selected under Select Data across a selectable time range. This 
display mode can only be chosen if more than one cycle is available, otherwise only Bar-
graph display mode is possible.

Fig. 4-72

4.3.1.2.6 Graphic Data

Display the supplementary graphic elements that have been added to the measurement 
data picture with the Graphic Editor.

4.3.1.3 Select data to be displayed

Fig. 4-73

Choose here the blocks and components to be displayed:

Blocks...
Select the blocks available for display from the opened measurement data file.

Data...
Select the block components to be displayed.
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4.3.1.3.1 Select Blocks

Quadstar 32-bit stores the different measurement data of a cycle measurement (inten-
sities, analog input values, etc.) in separate blocks within the data file. Before the eval-
uation of the measurement data, the available blocks can be selected by Select Blocks:

Fig. 4-74

Control elements Filename
Name of the file.

Available Blocks
Title of the available data blocks.

Selected Blocks
Measurement data blocks that have already been selected.

Title
Title of the measurement data block marked under Available Blocks or Selected Blocks.

Comment
Comments field of the measurement data block marked under Available Blocks or 
Selected Blocks.

[Select]
Add the block selected under Available Blocks to Selected Blocks. This function can also 
be activated by double-clicking the block to be selected in the Available Blocks field.

[Remove]
Remove the block selected under Selected Blocks.

[Select Data]
Call the Select Data dialog box. This function can also be activated by double-clicking 
the corresponding block in the Selected Blocks field.
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4.3.1.3.2 Select Data

In the Select Data dialog box you can choose individual components of the selected data 
block. In Select Data you can also set display properties such as colors, markers, etc.:

Fig. 4-75

NOTE:
This dialog box can also be called up by double-clicking with the left mouse but-
ton on a mass number in the measurement data window.

Control elements [Precious]
Previous measurement data block.

[Next]
Next measurement data block.

[Select Blocks]
Branch to the Select Blocks dialog box.

The following input fields apply to a measurement data block:

Title
Title of the measurement data block.

Comment
Comment for the measurement data block.

Unit
Unit of measure (A, etc.) for the measurement data block.

The following fields relate to the individual components of the displayed measurement 
data block:

Name
Input fields for displaying/modifying the names of the individual components.
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Display
Control field for switching the measurement data display of the individual components 
on/off.

Color
Color in which the current component will be displayed. Click on the color bar to choose 
a different color.

Marker
Marker symbol for the current component.

The following values have strictly informative character and cannot be changed.

Level A
Threshold of switching function A.

Level B
Threshold of switching function B.

Thr.-Type
Switching function type.

The following parameter groups are used for display control:

Line Type
• Solid: Display the components with a solid line.
• Dot: Display the components with:

• Dots, if Display Marker is switched off.
• With the symbols selected under Marker, if Display Marker is on.

Y-Scale
• Lin: Display the measurement data on a linear scale.
• Log: Display the measurement data on a logarithmic scale.

Range
• Low. Value: Start value for the Y-axis labeling.
• High. Value: End value for the Y-axis labeling.

NOTE:
Number parameters (e.g. Start Cycle/End Cycle) can be restored to the original 
values by clicking on the [UP] or [DOWN] arrows with the right mouse button.

Display Thresh.
Display the switching thresholds.

Display Marker
Display the symbols selected under Marker.

Display Grid
Display the horizontal Y-axis grid.
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4.3.1.4 Setup the display

Fig. 4-76

X-Axis...
Enter the parameters for selecting the display range applicable to the X-axis.

Y-Axis...
Enter the parameters for selecting the display range applicable to the Y-axis. [Setup] > 
[Y-Axis] opens the same dialog box as [Select] > [Data]. See Chapter 4.3.1.3.2 Select 
Data, 296.

NOTE:
The dialog boxes for setting up the X-axis and Y-Axis can also be activated by 
double clicking the lettering of the corresponding axes.

Number parameters (e.g. Start Cycle/End Cycle) can be restored to the original 
values by clicking on the [UP] or [DOWN] arrows with the right mouse button.

4.3.1.4.1 X-Axis

Fig. 4-77

Display Range
The display range of the X-axis relates to the measured Cycles:

• Start Cycle: First cycle to be displayed.
• End Cycle: Last cycle to be displayed.

X-Grid
Display the vertical grid for the X-axis.

Axis Type
The X-axis label can be chosen as follows:

• Cycle: Label the X-axis with the cycle number.
• Time Relative: Label the X-axis with the relative time since the measurement started.
• Time Absolute: Label the X-axis with the absolute time (time of day).
• Data: The measured values of one component are used as the X-Axis:
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Fig. 4-78

• Datablock: Data block for the X-Axis
• Dataname: Component of the data block.
• Lowest Value: Lowest X-value to be displayed.
• Highest Value: Highest X-value to be displayed.
• Scale: Linear (Lin) or logarithmic (Log) X-axis scale.

4.3.1.5 Function submenu

Fig. 4-79

You can select the type of cursor function via the Function menu or call the graphic edi-
tor:

Magnify
Magnify a screen section.

Cursor
Display crosshairs to determine measure values.

Graphic Editor
Call graphic editor.

NOTE:
Switching from Magnify to Cursor and vice versa is also possible with a click of 
the right mouse button in the measurement data window.
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4.3.1.5.1 Magnifying a Screen Section

With Magnify you can define an area of the measurement data screen with the left 
mouse button.

Fig. 4-80

To magnify the marked area, hold down the left mouse button, then click the right mouse 
button:

Fig. 4-81

• The magnifier function can be nested several times.

• To reverse the last magnification, choose [Special] > [Undo Magnify].

• The graphic can be restored to its original size by [Special] > [Set Default]:
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4.3.1.5.2 Determine measurement data graphically (Cursor)

If [Function] > [Cursor] is selected, a measured value within the graphic display can be 
marked by the crosshairs. Its values for X and Y are displayed in the status bar.

Fig. 4-82

Hold down the left mouse button and position the crosshairs on the spot in the measure 
data graphic, of which you want to know the exact values. They are displayed in the sta-
tus bar then. In mode Bargraph, a horizontal line appears instead of the crosshairs, 
which serves as cursor. The cycle selected by the cursor can be displayed as a table by 
holding the left mouse button down and simultaneously clicking the right mouse button:

Fig. 4-83

Measurement data block and cycle can be changed within this dialog box:

[Previous]
Display the measurement data of the previous block.
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[Next]
Display the measurement data of the next block.

Cycle
Number of the selected cycle.

Cycle Time
Measurement time of the cycle (since the measurement started).

Date
Current date and absolute measurement time of the cycle.

[Change]
Manual elimination of freak values. See Section «[Change]», 302.

[Bargraph]
Display the bargraph of the current cycle. See Chapter 4.3.1.2.4 Bargraph, 292.

Displaying the 
threshold values

L/L, L/H, H/L, H/H
If switching functions were activated during the measurement, an L (Low) or H (High) is 
shown behind the exponent of Value for documenting the switching functions A and B.

Operation with 
QMU 112

If the measure data have been recorded by a QMU 112, the QMU channel is displayed 
in square brackets after the mass number. 28 [7] means thus, mass number 28, mea-
sured on QMU channel 7.

Manual elimi-
nation of freak 
values

[Change]
Measured values can be corrected manually:

Fig. 4-84

The measured value to be changed is selected with the cursor, modified in the Value 
field and stored by [Save].

Measurement errors (“freak values”) can also be corrected automatically by [Special] > 
[Filter].
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4.3.1.5.3 Graphic editor

You can add text and drawings to your measurement pictures, for example, to prepare 
them for printout or as an aid for interpretation. See Chapter 4.2.1.5.3 Graphic editor, 

267.

4.3.1.6 Special submenu

Fig. 4-85

Undo Magnify
Cancel the changes of the last magnify function.

Set Default
Restore all display settings to their basic values. All components and measurement data 
blocks are displayed across the stored range (all cycles).

Filter...
Automatic elimination of freak values.

4.3.1.6.1 Filter

Choose filter for automatic elimination of freak values:

Moving Median determines a moving median. For this purpose a certain number (select-
able via Rank) of the last measured values is sorted by their magnitude and the one in 
the middle is used as the filter output:

Fig. 4-86

Moving Median
• Rank: Determines the number of measured values taken into consideration for the 

filter type Moving Median (number of measured values = Rank * 2 + 1).

Output File Name 
• Name of the file in which the results are to be written. The name can be entered by 

activating the [File Manager] command button.
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NOTE:
Write the filtered data on a new file so that the original data will be preserved in 
any case.

4.3.1.7 Info submenu

Fig. 4-87

File...
Display measure data documentation, if there is one. Otherwise a new documentation 
is created that consists of additional info, notes and title only. See Chapter 4.2.1.7 Info 
submenu, 270.

4.4 Auxiliary

Menu

Fig. 4-88

Mass Scale Calibration...
Display the measurement data (characteristic curve) of the mass scale calibration.

Zero Gas...
Display the measurement data of the background measurement.

Error History...
Display the stored error messages and warnings.

4.4.1 Mass scale calibration

Choose Mass Scale Calibration to display the calibration curve of the current analyzer:
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Fig. 4-89

The exact peak position is determined for each defined mass. In the graphic, the devia-
tion of the peak maximum from the nominal mass is shown. Deviations of up to ±0.5 amu 
can be corrected. For larger deviations, a coarse alignment of the HF unit must be per-
formed first.

NOTE:
More information about the mass scale calibration can be found in Chapter 2.8.1 
Mass scale calibration (Mass Scale), 134.

Mass Scale 
Calibration menu

Fig. 4-90

File
Store/close the basic point file of the calibration curve.

Edit
Edit the mass numbers.

Info
Retrieve supplementary information about the file.

4.4.1.1 File submenu

Fig. 4-91

Save
Store the current calibration curve.

Close
Return to the Display Saved Values main menu.
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4.4.1.2 Edit submenu

Fig. 4-92

4.4.1.2.1 Masses

With Edit Masses you can define mass numbers through manual input:

Fig. 4-93

NOTE:
This dialog box can also be called up by double-clicking the left mouse button in 
the measurement data window.

Defined Masses
• Number of Masses: Number of stored mass numbers.
• First Nominal Mass: Smallest stored nominal mass number.
• Last Nominal Mass: Largest stored nominal mass number.

Valid Range
Validity range of the correction curve. Prevents errors in case of an unfavorably defined 
mass range. Mass numbers outside this range are not extrapolated.

• Start Mass: Lower validity limit of the calibration curve.
• End Mass: Upper validity limit of the calibration curve.

In the above window (calibration gas = air) these two limits are calculated as follows:
•  Start Mass = 14 - (44 - 14)/2 = -1 => 0
•  End Mass = 44 + (44 - 14)/2 = 59

X-Grid
Display the vertical grid for the X-axis.

Y-Grid
Display the horizontal grid for the Y-axis.
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[Add/Replace]
A mass number that is marked in the List of Masses box is transferred to the edit box by 
Add/Replace where it can be modified. A new mass number can also be entered in this 
field. The changed mass number is adopted, when Add/Replace is activated.

You can enter the mass number directly or change it with the or buttons. A click of the 
left mouse button changes the fraction of the mass by ±0.01, and if the right mouse but-
ton is pressed simultaneously, the step width of the change increases to ±1.00.

[Remove]
Remove the selected mass number.

Inserting a 
nominal mass 
with the cursor

Press the left mouse button in the calibration curve picture. A line cursor appears and 
the selected mass number is displayed numerically in the status bar.

Fig. 4-94

Please note that only integer mass numbers can be selected on the horizontal axis. The 
fraction (max: ±0.49 amu) must be changed with the cursor position in the vertical direc-
tion.

When the right mouse button is pressed simultaneously the selected mass number is 
accepted and the Edit Masses dialog box is displayed:
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Fig. 4-95

The inserted mass number can now be edited. Afterwards, press Add/Replace again.

NOTE:
The change is stored when [File] > [Save] is chosen.

Fig. 4-96

If you press [OK], the calibration curve is corrected:

4.4.1.3 Info submenu

Fig. 4-97

File...
Retrieve supplementary information about the file.
308 Display Saved Values vpnb68e1 (0302), Quadstar 32-bit



4.4.1.3.1 File

Fig. 4-98

Filename
Name of the file.

Software Version
Quadstar 32-bit version under which this file has been created.

Date
File creation date.

Time
Time of day the file has been created.

Author
Operator name.

4.4.2 Background measurement (Zero Gas)

[Auxiliary] > [Zero Gas] opens the file containing the measurement data of the back-
ground measurement, that belongs to the current analyzer. The intensities and mass 
numbers are displayed as a bar chart.

Fig. 4-99

The mass numbers are displayed below the X-axis and at the right edge.
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NOTE:
More information about the background measurement can be found in 
Chapter 2.8.2 Background measurement (Zero Gas), 137.

Zero Gas menu

Fig. 4-100

File
Store/close the file.

Edit
Edit the mass numbers and intensities.

Info
Retrieve supplementary information about the file.

4.4.2.1 File submenu

Fig. 4-101

Save
Store the mass numbers and their intensities.

Close
Return to the main menu of Display Saved Values.

4.4.2.2 Edit submenu

Fig. 4-102

4.4.2.2.1 Values
Values shows the intensities and the corresponding mass numbers of the chosen signal 
source:
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Fig. 4-103

NOTE:
This dialog box can also be called up by double-clicking the left mouse button in 
the measurement data window.

Last modification
Date/time of the last modification.

Detector
Select the signal source. (For each selectable collector (Faraday .. Extern) a separate 
set of peaks is stored).

Defined Masses
Number and limits of the mass numbers.

• Number of Masses: Number of stored mass numbers.
• First Nominal Mass: Mass number of the first peak.
• Last Nominal Mass: Mass number of the last peak.

Defined Values
Limits of the peak intensities.

• Lowest: Lowest intensity of the stored peaks.
• Highest: Highest intensity of the stored peaks.

X-Grid
Display the vertical grid for the X-axis.

Y-Grid
Display the horizontal grid for the Y-axis.

Values
Edit values.

• Mass: Mass number.
• Value: Intensity.
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The mass number and its intensity displayed in the Values dialog box under Mass and 
Value can be changed or deleted. Additional (new) peaks can also be entered:

[Add/Replace]
Click on the desired peak to edit it in the Mass and Value input fields. In these fields new 
values can also be entered numerically. To transfer the new or changed values to the 
list, press Add/Remove.

[Remove]
Remove removes the marked peak from the list.

Inserting a new 
peak with the 
cursor

Click on the spectrum with the left mouse button. Crosshairs are displayed in the mea-
sure picture and the cursor position is displayed numerically in the status bar:

Fig. 4-104

Now press the right mouse button additionally, so the selected mass is accepted and 
the Edit Masses dialog field is displayed:
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Fig. 4-105

Press Add/Replace to include the new peak in the list of peaks:

Fig. 4-106

You can now edit the inserted peak. Press Add/Replace when you have finished.

NOTE:
The peak is not stored until [File] > [Save] is chosen.

Press [OK] to correct the displayed spectrum:
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Fig. 4-107

4.4.2.3 Info submenu

Fig. 4-108

File
Retrieve supplementary information about the file.

4.4.2.3.1 File

Fig. 4-109

Filename
Name of the file.

Software
Version Quadstar 32-bit version used for creating this file.

Date
File creation date.

Time
Time of day the file has been stored.
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Author
Operator name.

4.4.3 Error History (Stored Error Messages)

Display the stored error messages and warnings. This is only possible if the Error His-
tory control field has been activated in the Parameter Setup program under [Setup] > 
[General]. If the same error occurs several times consecutively (in the window below: 
‘MS 1’: RF error), the error is not shown each time, but from the second time onwards a 
number is appended to the message. This number indicates the repetitions of the error 
(in the example: ‘MS 1’: RF error(15) there were 15 repetitions of the error). This way, 
the first and last occurrence of a repeated error is documented.

Fig. 4-110

Print...
Print the listed error messages. First you are asked for the message numbers to be 
printed. The printer can be configured in the Parameter Setup program under [Config] > 
[Printer].

Reset
Delete the error history file.

Close
Close the error history window.
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5. Tune Up

Quadstar 32-bit Tune Up is used to set the QMS 422/421 or QMS 200 into an opera-
tional state. For example, the ion source can be tuned or the peak shape may be opti-
mized graphically. The parameters available depend on the basic setting. See 
Chapter 3.8.1 QMS Configuration, 234.

When the Tune Up program is started, Quadstar 32-bit attempts to establish a connec-
tion to the QMS. When this connection has been successfully established, the LED sym-
bolically displayed in the lower left corner changes to green. If the QMS is not connected 
or not switched on, an error message is output. After the fault has been remedied, the 
connection setup can be reinitiated by [Comm] > [Connect].

Main menu

Fig. 5-1

File
Display version number of the Quadstar 32-bit Tune Up program and terminate it.

Tune
Tune the ion source, optimize peak shape, print ion source settings. In addition 
(QMS200): adjust mass scale, show operating conditions. See Chapter 5.2 Tune, 

319.

Manual
Operation/display of the digital input/output channels (DI/DO). See Chapter 5.3 Manual 
parameters, 341.

Comm
Switch the interface to the QMS on/off, select active QMS. See Chapter 5.4 Communi-
cation Parameters, 343.

Setup
Switch the emission and the SEM on/off, degas the filament. See Chapter 5.5 Setup 
Parameters, 344.

Help
Display the ‘Key Fragment Ions’ table and help contents. See Chapter 1.9 Hints con-
cerning the work with Quadstar 32-bit, 56.
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5.1 File

File Menu

Fig. 5-2

5.1.1 About Tune Up

In this menu entry the version number of your Quadstar 32-bit Tune Up program is 
shown:

Fig. 5-3

5.1.2 Exit

Terminate the Quadstar 32-bit Tune Up program.
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5.2 Tune

Tune menu

Fig. 5-4

Ion Source...
Parameter setup for the different ion source types:

• Ion source parameter setup when a QMA 200 analyzer is used. See 
Chapter 5.2.1.1.1 QMA 200 (Prisma™), 320.

• Ion source parameter setup when a QMA 4XX analyzer is used. See 
Chapter 5.2.1.1.2 QMA 4XX, 320.

• Optimize ion source settings when a QMA 125 analyzer is used. See Chapter 5.2.1.3 
QMA 125, 323.

• Print ion source settings.

Peak Shape...
Optimize peak shape graphically. See Chapter 5.2.2 Peak Shape Optimizer, 333.

QMS 200 Tune Data...
Graphic and numeric display of QMS 200 operating conditions. See Chapter 5.2.3 
QMS 200 Tune Data, 337.

QMS 200 Tune Mass Scale...
Calibration of the QMS 200 mass scale. See Chapter 5.2.4 QMS 200 Tune Mass Scale, 

338.

QMS Offset...
Offset calibration of the measure amplifier. See Chapter 2.8.3.1 QMS Offset Calibration 
Setup, 141.

5.2.1 Ion Source

Depending on the selected hardware configuration Tune Ion Source supports:

• Parameter setup of the Ion Source
• Optimizing the ion source settings by tuning it while a measurement is performed
• Display of the emission current (QMA 125)
• Printing the ion source parameters

The type of dialog box that is presented depends on the installed analyzer and RF gen-
erator. If the parameters or the appearance of the displayed dialog box do not agree with 
the installed hardware, you must first define the correct QMS configuration by calling up 
the [Config] > [QMS] menu of the Parameter Setup program.
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5.2.1.1 Parameter setup for the QMA 200/QMA 4XX

In this dialog box you can enter the ion source parameters Ion Source, IS-Emission and 
IS-Voltages. To optimize these parameters choose the [Display] > [Measure Data] menu 
where you will find a test measurement in Sample, Scan Bargraph and Scan Analog 
mode.

5.2.1.1.1 QMA 200 (Prisma™)

Fig. 5-5

5.2.1.1.2 QMA 4XX

Fig. 5-6
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5.2.1.2 Modifying parameters

All ion source and channel parameters can be modified while the measurement is in 
progress. The parameters can be entered via the input field located below the Tune Ion 
Source menu bar. This field shows the parameter that has been selected by the cursor.

In the dialog boxes above, the cursor is positioned in the emission current input field:

Fig. 5-7

To enter a changed value

• Press the <ENTER> key

• Click on the small command box on the left of the input field or

• Press the Tab key.

5.2.1.2.1 Channel parameters
1 First choose a channel and switch it on (Enable):

Channel
Channel number (QMS channel 0...63) and state (Enable/Skip/Off )

2 Then enter the required parameters in the corresponding groups:

Detector
Detector parameter group.

Mass
Mass parameter group.

Amplifier
Amplifier parameter group.

NOTE:
For More information on the channel parameters see Chapter 3.2.4.1 Measuring 
parameters overview, 159 or in the User’s Guide of the corresponding QMS.

Ion source 
parameters (Ion 
Source)

QMA 200: The ion source type can not be chosen for the QMA 200, but it must have been set cor-
rectly under [Config] > [QMS]. It is displayed here in the field IS Type.

Filament #
Select the desired filament (Fil 1, Fil 2 or Fil 1+2). Fil 1+2 means here, that both filaments 
are switched on simultaneously.
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IS-Set #
Load an IS set (Set0 ... Set3). There are four IS sets with ion source voltages that con-
tain one record each for all filament configurations (Fil 1, Fil 2 and FIL 1+2).

QMA 4XX: Type
Selection of special ion source types that are feasible according to the configuration 
(Parameter Setup program, [Config] > [QMS...] > [IS-Type]).

Filament #
Select the desired filament (Fil 1, Fil 2 or Fil 1+2). The number of available filaments 
depends on the ion source type.

Set for Fil 1
Assign an IS set (0 ... 3) to Filament 1.

Set for Fil 2
Assign an IS set (0 ... 3) to Filament 2.

5.2.1.2.2 Filament

IS-Emission
These parameters relate to the filament selected under Ion Source.

• Current: Enter the desired emission current (0.00 mA corresponds to OFF).
• Protect: Enter the maximum overload current (Protection).

5.2.1.2.3 RF supply (QMS 200)

RF Polarity
QMA 200: Allows the changeover of the RF polarity on the mass filter rods.

5.2.1.2.4 Ion source voltages

IS-Voltages
Four independent IS sets are available for each ion source type:

• QMA 4XX: The IS-Voltages relate to the IS set that has been chosen under Set for 
Fil x.

• QMA 200: The IS Voltages relate to the IS set selected under IS-Set #. In this set a 
separate ion source voltage group (IS-Voltages) exists for each filament configura-
tion (Fil 1, Fil 2 and Fil 1+2).

NOTE:
For detailed information on these parameters and their optimization please con-
sult the User’s guide of the QMS, or the installed ion source.
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5.2.1.2.5 Filament Protection Extern (QMA 200/QMA 4XX)

QMA 200 On the QMA 200 (Prisma™) the SEM and filament can automatically be switched on 
when evacuated and off when flooded, if a total pressure sensor 
(TPR 250/PKR 250/251) is connected.

Fil. Prot. Thresh.
On/Off thresholds for the measured total pressure.

• ON below: Lower threshold to be attained before the filament and the SEM voltage 
are switched on in automatic operation [Protection (SEM+FIL)] > [EXTERN].

• OFF above: Upper threshold at which the filament and the SEM voltage are switched 
off in automatic operation [Protection(SEM+FIL)] > [EXTERN] and in [EXT-PROT] 
mode.

In operation under [Protection(SEM+FIL)] > [EXT-PROT] the filament and the SEM volt-
age must be switched on manually.

The function (INTERN/EXTERN/EXT-PROT) is chosen in the Parameter Setup program 
under [Config] > [QMS...] in the Protection(SEM+FIL) field.

QMA 4XX When a QMA 4xx is used, no thresholds can be entered. The protection mechanisms in 
[SEM+FIL] > [EXT-PROT] and [SEM+FIL] > [EXTERN] mode relate to external switch-
ing contacts.

5.2.1.3 QMA 125

When operating with a QMA 125 (without QMU 112) a test measurement may be started 
in the same way as with QMA4XX/200 ([Display] > [Measure Data]). The actual ion 
source parameters have to be adjusted at the QME itself. The parameters marked by a 
‘*’ (*IS Type and *Emiss) are only shown in the editor and cannot be modified via 
Quadstar 32-bit:

Operation without QMU 112

Fig. 5-8
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Operation with QMU 112

Fig. 5-9

Emission

• *Emiss/Current: Emission current.

• Filament #: Filament (Fil1 or Fil2). The number of available filaments depends on the 
type of ion source.

QMU Channel
Choose the QMU 125 channel. Only the QME 125 units activated in the Parameter 
Setup program ([Config] > [QMS]) can be selected.

NOTE:
If Filament Select Remote is selected on the individual QME 125 units in configu-
rations with a QMU 112, all filaments are switched jointly.

*IS Type/Ion Source Type
Ion source type in use.

Tune Ion Source 
menu

Fig. 5-10

File
Save or print the ion source parameters.

Display
Display the measurement data. See Chapter 5.2.1.3.5 Optimizing the parameters (Mea-
sure Data), 329.

Option
Edit/copy channel parameters and ion source parameters.

File submenu

Fig. 5-11
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Save
Save the ion source parameters.

Print Ion Source Settings
Print the ion source settings.

Close
Close the parameter file and return to the Tune Up main menu.

Display submenu

Fig. 5-12

Measure Data
Perform a test measurement. See Chapter 5.2.1.3.5 Optimizing the parameters (Mea-
sure Data), 329.

Option submenu

Fig. 5-13

Edit Channel Par...
Edit the channel parameters. See Chapter 5.2.1.3.1 Standard editor (Edit Channel Par), 

326.

Copy/Exch. IS-Set...
Copy/exchange IS parameter sets. See Chapter 5.2.1.3.2 Copy/Exch. IS-Set, 327.

Copy/Exch. Channel...
Copy/exchange channel parameters. See Chapter 5.2.1.3.3 Copy/Exch. Channel, 

328.

Default IS-Set...
Set the current ion source parameters to default values. See Chapter 5.2.1.3.4 Default 
Ion Source Set, 329.
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5.2.1.3.1 Standard editor (Edit Channel Par)

Set up the QMS channel parameters with the standard editor of Quadstar 32-bit:

Fig. 5-14

The Ion Source Channel Parameter editor basically corresponds to the standard editor 
described in Chapter 3.2 Measure Parameters, 156. It fulfills the same functions as 
the input fields described in Chapter 5.2.1.1 Parameter setup for the QMA 200/QMA 
4XX, 320 and Chapter 5.2.1.3 QMA 125, 323, but in addition to that, other param-
eters may be changed as well (e.g. Display which controls the display range). Because 
several channels can be displayed simultaneously, it provides greater clarity (e.g. for 
copying functions).

NOTE:
More information is found in Chapter 3.2 Measure Parameters, 156.

Selecting the 
measuring mode

Click on the Mass Mode field with the right mouse button of the desired channel, so the 
context menu for selecting the desired measuring mode appears:
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Fig. 5-15

5.2.1.3.2 Copy/Exch. IS-Set

Copy or exchange complete ion source parameter sets (IS-Sets):

Fig. 5-16

Mode Selection
Desired action:

• Copy: Copy an IS set to another IS set or to all other IS sets of the current ion source.

• Exchange: Exchange all parameters of the Source IS set with those of the Dest. IS 
set of the current ion source.

Source
IS set, whose parameters are to be copied or exchanged.

Dest.
Target IS set to copy the parameters to or exchange with. ALL (for copying to all IS sets) 
can be specified by clicking on the [UP] or [DOWN] arrow with the right mouse button.
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5.2.1.3.3 Copy/Exch. Channel

Copy or exchange individual parameters or all parameters of the selected channels:

Fig. 5-17

Mode Selection
Desired action:

• Copy: Copy the object chosen under Object Selection to a different channel or to all 
channels.

• Exchange: Exchange all parameters of the Source channel with those of the Dest. 
channel. Exchange is only possible if [Object Selection] > [Channel] is active.

Object Selection
Choose the object to be copied or exchanged:

• Channel: All parameters of the channel are copied or exchanged.

• Parameter: Only the current parameter (marked before Copy/Exch. Channel was 
called) is copied or exchanged. Parameter cannot be chosen if no parameter is se-
lected.

Source
Channel whose parameters are to be copied or exchanged.

Dest
Target channel to copy the parameters to or exchange with. ALL (for copying to all chan-
nels) can be specified by clicking on the [UP] or [DOWN] arrow with the right mouse but-
ton.

Special cases The following special cases must be taken into consideration when copying parameters:

Range
QMS 421: Copies only into those channels that have the same Lock-In status (only 
meaningful, if the optional Chopper Lock In Amplifier CLA 421 is in use).

Threshold
Copies only into those destination channels for which the same Detector has been 
selected under Det. Type.
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5.2.1.3.4 Default Ion Source Set

Default IS set loads default values for the ion source parameters of the current IS-set.

Fig. 5-18

Default Selection

• Factory: Load factory default values for the current filament.

• User Fil #X: Load or save a self defined Default ion source set (User Fil #X) by Load 
or Save.

Mode Selection

• Load: Load factory default or self defined IS-set.

• Save: Store the current IS set as User Default (for that, [Default Selection] > [User 
Fil #X] must be selected).

5.2.1.3.5 Optimizing the parameters (Measure Data)

[Display] > [Measure Data] starts a measurement on the selected channel, provided the 
communication with the QMS is switched on.

Optimize the ion source by watching the influence of parameter changes on the mea-
surement. To check whether there is an offset, the measurement scale reaches from 
100% positive to 10% negative (of full scale range). If there is an offset, QMS 422/200 
can be calibrated by [Tune] > [QMS Offset], the QMS 421 must be adjusted by the chan-
nel parameter Offset.
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Scan Analog 
measurement 
data

Fig. 5-19

The measured values of the different cycles are drawn in different colors in the same 
picture. The display field is only cleared if:

• the size of the Measure Data window is changed,
• the First, Width or Range parameters are changed, or
• if this is explicitly chosen by the user through [Refresh] > [Display].

NOTE:
For printing pictures in Quadstar 32-bit (by Ctrl+Shift+F12), stop the measure-
ment by [Operation] > [Halt] in order to prevent errors of the interface.

Sample 
Measurement 
data

Fig. 5-20

In this measurement, the largest measured intensity is marked with a drag pointer. The 
status of the measurement (Go or Halt) is shown behind the mass number.

NOTE:
For printing this picture you should select [Operation] > [Halt] in order to prevent 
error messages (Time Out, etc. ) from the interface.

Measure Data 
menu

Fig. 5-21
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File
Store the reference data (only Scan Analog)

Operation
Start/stop the measurement. Its status is shown in the measurement window.

Setup
Scale the Y-axis, change alternating colors.

Display
Refresh the display, show the reference on/off

File submenu

Fig. 5-22

Save Reference
Store the measurement data of the next scan as a reference (only in Scan Analog mode 
SCAN-N und SCAN-F).

Close
Close the measurement window.

Operation 
submenu

Fig. 5-23

Go
Start the measurement.

Halt
Stop the measurement.

Setup submenu

Fig. 5-24

Axis...
Choose between linear and logarithmic Y-axis scale. This box can also be accessed by 
double-clicking the left mouse button.

Fig. 5-25
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• Y-Scale
• Lin: Display the measurement data on a linear Y-axis.
• Log: Display the measurement data on a logarithmic Y-axis.

Colors...
Dialog box to choose the alternating colors for a repeated scan analog.

Fig. 5-26

In the fields #0 ... #63, enter the colors to draw the cycles with (alternatingly). The stan-
dard color table, that contains 8 colors, produces scans with good contrast that are eas-
ily distinguishable in most cases. It can be recalled by [Set Default Colors], but the cur-
rent settings of the Alternating Colors for the current color palette will be lost then. See 
Chapter 3.8.5 Screen Colors, 245.

Display submenu This menu is only accessible in Scan Analog measuring mode (SCAN-N and SCAN-F):

Fig. 5-27

Refresh
Clear the display.

Reference
Display a reference scan.

Displaying 
reference data 
(Reference)

In SCAN-N and SCAN-F measuring mode you can also display the measurement data 
of a reference scan. When the Reference option (Display menu) is active, a reference 
scan is automatically stored

• When the first scan is performed, or
• If either the First, Width or Range parameter changes.

You may store a reference scan manually as well by [File] > [Save Reference]. This may 
be necessary for example, to make the option Reference accessible again, if it has been 
grayed.
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5.2.2 Peak Shape Optimizer

[Tune] > [Peak Shape] allows:

• to shape peaks by varying the ion source voltages.
• to compare the shapes of two peaks close to their maximums.
• to determine mass number and relative intensity precisely.

The displayed parameters depend on the hardware configuration. If the parameters or 
the appearance of the displayed dialog box do not agree with the installed hardware, you 
must first define the correct QMS configuration by calling the [Config] > [QMS] menu of 
the Parameter Setup program.

Fig. 5-28

5.2.2.1 Channel parameters

In group Channels you can set up the two measure channels you want to use. These 
are ‘virtual’ channels, they do not interfere with the ones you normally use on the QMS. 
You may set all channels to ENABLE, but only the ones shown as Peak A and Peak B 
are really measured. If you often switch between different measurements, just enter the 
corresponding channel numbers for Peak A and Peak B to do so. If you wish to measure 
Peak A only (here: channel 0), just set Peak B to State ‘SKIP’.

5.2.2.2 Ion source voltages

Under IS-Voltages you find those voltages of the used ion source, that can be set up by 
software. They are channel independent and provide peak shape conditioning and opti-
mization.

NOTE:
The ion source parameters entered here do apply to the Peak Shape Optimizer 
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only. As soon as you quit it, the settings shown under [Tune] > [Ion Source] will 
take effect again.

5.2.2.3 Display width

Under [Display] > [Width] you can enter the mass range to display. This value is a min-
imum that is rounded up to the next multiple of the current stepwidth (QMS 422/421: 
inverse value of the channel parameter Steps; QMS 200: 1/32).

5.2.2.4 Mean value

[Mean Value] > [Scans] allows you to choose the number of scans to be performed per 
channel. Then the mean value of these scans is built in order to achieve higher resolu-
tion and precision.

Peak Shape 
Optimizer menu

Fig. 5-29

File
Save measurement parameters, quit Peak Shape Optimizer.

Display
Perform and display measurement (See Chapter 5.2.2.5 Start measurement (Peak 
Shape), 335).

Option
Call standard editor, set measurement parameters to default values.

File submenu

Fig. 5-30

Save
Save all parameters (channel, ion source, display and mean value parameters).

Close
Quit the editor, return to the Tune Up main menu.

Display submenu

Fig. 5-31

Peak Shape...
Perform and display measurement using the entered parameters. See Chapter 5.2.2.5 
Start measurement (Peak Shape), 335.
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Option submenu

Fig. 5-32

Edit Channel Par...
Call the standard editor to edit channel parameters that are not present in the Peak 
Shape Optimizer Editor. You should use this option only if you are sure that you really 
want to change those values that are set to default and are not displayed usually (e.g. 
Steps).

Set Default
Set all parameters to default values.

5.2.2.5 Start measurement (Peak Shape)

Start measurement by [Display] > [Peak Shape]. The QMS first measures Peak A (from 
Mass -0.5 to Mass+0.5) as many times as entered under [Mean Value] > [Scans]. After 
that, the peak maximum is scaled and displayed across the mass range specified by 
[Display] > [Width]. Then Peak B is measured the same way. The status (Op: 
Go/Halt/Done) and progress (Progress: XX %) of the measurement are displayed at the 
bottom of the measure window.

The x axis is lettered with mass numbers, the y axis with relative intensities in %.

Fig. 5-33

Should the shown curves seem unsensible or ‘untrustworthy’, please check the used 
parameters (esp. Amp.Range and Mass) on a scan analog measurement. Particularly a 
slight Overrange, although indicated during the measurement instead of Progress, 
might not obviously show up in the finished measurement.
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Peak Shape menu

Fig. 5-34

File
Close measurement window.

Operation
Start/stop measurement. The status of the measurement is shown at the bottom of the 
measurement window.

Setup
Setup display.

File submenu

Fig. 5-35

Close
Close measurement window.

Operation 
submenu

Fig. 5-36

Go
Start measurement.

Halt
Stop measurement.

Setup submenu

Fig. 5-37

Axis...
Setup display (lin/log, grid).

Fig. 5-38

• Y-Scale: linear (Lin) or logarithmic (Log) display of the y axis.
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• X-Grid: show or hide the mass scale grid.
• Y-Grid: show or hide the intensity scale grid.

5.2.3 QMS 200 Tune Data

QMS 200 Tune Data displays certain operating parameters of the QMS 200 Prisma™ 
and provides tuning of the RF 20X RF generator:

Fig. 5-39

The individual fields have the following meaning:

Emission Current
Actual value of the emission current.

Filament Current
Actual value of the filament current.

Tune Voltage
Tuning voltage of the RF generator. The RF generator is tuned at the QMS 200 itself.

Sem Voltage
Actual value of the SEM voltage.

Temperature
Temperature inside the QMS 200. Normal: 30 ... 50 ºC/maximum: <80 ºC. If the temper-
ature rises too high: change the filter mat of the QMS 200 (See User’s Guide of the 
QMS 200), check the fan if necessary.

Reset Arrows 
(Display menu)

The drag pointers for minimum and maximum values can be reset to the current value 
by [Display] > [Reset Arrows].

Ion Source 
(Parameters 
menu)

Ion Source opens the same dialog box as [Tune] > [Ion Source] in the main menu does.
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Setup (Param-
eters menu)

[Parameters] > [Setup] (or double-clicking the mouse within the window) opens the dia-
log box shown to choose the colors for the individual display bars:

Fig. 5-40

Click on the desired color above the horizontal scroll bar or change the color number in 
the corresponding edit field.

5.2.4 QMS 200 Tune Mass Scale

The mass scale of the QMS 200 can be calibrated with one peak in the upper and one 
in the lower region of the mass scale. If no special calibration gas is available, the peaks 
of air can be used (for example, for measurements within the mass range 0 ... 50):

Fig. 5-41

A measurement can be stopped by [Operation] > [Halt] and restarted by [Operation] > 
[Go].

Calibrating the 
mass scale

• Manually 
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• With the keys [<<], [<], [>] and [>>] the peak tops can be shifted slowly or fast 
in either direction of the mass scale within the given limits (Offset: -767 ... 
+767, Slope: -394 ... +394).

Fig. 5-42

• The values can also be entered directly in the fields Offset and Slope and the 
result can be seen on the display.

• Using the mouse

1 Press the left mouse button and hold it.

2 Position the cursor on the peak top.

3 Press the right mouse button and hold it.

4 Drag the cursor to the correct position while still holding both mouse buttons 
pressed.

5 Release the right mouse button.

6 Release the left mouse button.

Parameter setup In the Parameters menu you can change the setup of the display and the measurement 
channels:

Fig. 5-43

Setup [Parameters] > [Setup] opens a dialog box to choose between linear and logarithmic Y-
axis scale. This dialog box can also be activated by a double-click of the left mouse but-
ton.

Fig. 5-44

Y-Scale
• Lin: Display the measurement data on a linear Y-axis.
• Log: Display the measurement data on a logarithmic Y-axis.

Channel [Parameters] > [Channel] enables you to change certain channel parameters that are 
relevant for the scans. This dialog box can also be called by double-clicking the right 
mouse button:
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Fig. 5-45
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5.3 Manual parameters

5.3.1 Digital I/O

By [Manual] you can display the state of digital input channels and switch on or off digital 
output channels manually, provided that the communication to the mass spectrometer 
is switched on.

Fig. 5-46

For turning the individual digital output channels on or off, double-click the correspond-
ing push button with the left mouse button. The switching state is indicated by the col-
ored dot on the push button: green = on, grey = off.

DI/DO Manual for 
QMS 422/421

Fig. 5-47

Display left
Select the DI/DO group to be displayed on the left side of the screen.

Display right
Select the DI/DO group to be displayed on the right side of the screen.

A group cannot be displayed at the left and the right side simultaneously.

DI/DO Manual for 
QMS 200

Only the two standard digital input and output channels are available:
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Fig. 5-48

The digital input and output channels of the QMS 200 have the following designation in 
the hardware description:

DI 00 : EXT_PROT (Connection TPR/PKR, Pin No. 1 <=> 2)

DI 01 : EXT_RUN (Connection Control, Pin No. 10 <=> 15)

DO 00 : REL_1 (Connection Control, Pin No. 11 <=> 12)

DO 01 : REL_2 (Connection Control, Pin No. 13 <=> 14)
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5.4 Communication Parameters

Fig. 5-49

Connect
Establish connection to the QMS.

Disconnect
Cancel the connection to the QMS.

SetUnit...
Select current measuring device. See Section «Setting the node addresses of several 
control units», 218.

NOTE:
For detailed information see Chapter 3.6 Communication parameters, 209.
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5.5 Setup Parameters

Setup menu

Fig. 5-50

SEM/Emission Control...
Open the dialog box SEM/Emission Control to:

• Switch the SEM high voltage on/off.
• Input the Common SEM voltage.
• Switch the Emission on/off.

See Chapter 3.7 Setup parameters, 223.

Degas Control...
Degas the filament

Operation with QMA 200/QMA 4XX, see Chapter 5.5.1.1 Operation with QMA 200/QMA 
4XX, 344, Operation with QMA 125, see Chapter 5.5.1.2 Operation with QMA 125, 

345.

5.5.1 Degas Control

If the communication to the QMS is switched on, you can degas the current filament of 
the ion source (Fil 1 or Fil 2).

5.5.1.1 Operation with QMA 200/QMA 4XX

For the QMA series 400 and the QMA 200 (Prisma™), the Filament #, degas time, emis-
sion current and the maximum filament current can be programmed:

QMA 200

Fig. 5-51
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QMA 4XX

Fig. 5-52

[Start]
Start degassing.

[Stop]
Stop degassing.

Degas

• Filament #: Filament to be degassed.

• Current: Emission current for degassing.

• Protect: Maximum filament current for degassing.

• Time: Time in minutes during which the filament is to be degassed; when this time is 
over, the degassing stops automatically. If you prefer to start and stop manually rath-
er than state a time, click on [UP] or [DOWN] with the right mouse button; now in the 
Time field, man. (manual) is displayed.

Degasing
Elapsed time since the start, during which the ion source has already been degassed.

5.5.1.2 Operation with QMA 125

When a QMA 125 is used, only the filament can be selected:
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Operation without QMU 112

Fig. 5-53

Operation with QMU 112

Fig. 5-54

[Start]
Start degassing.

[Stop]
Stop degassing.

QMU Channel
QMU 125 channel, whose ion source is to be degassed.

Degas

• Filament #: Filament to be degassed.

• Time: Time in minutes during which the filament is to be degassed; when this time is 
over, the degassing stops automatically. If you prefer to start and stop manually rath-
er than state a time, click on [UP] or [DOWN] with the rightleft mouse button; now in 
the Time field, man. (manual) is displayed.

Current
Emission current during degassing (display only; Emission and Protection must be set 
up at the spectrometer itself).
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Degasing
Elapsed time since the start, during which the ion source has already been degassed.
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5.6 PPM Tune Up
Quadstar 32-bit PPM Tune Up is used for entering and adjusting/optimizing various 
parameters of the energy filter or the mass filter (Ion mode), and the ion source (Neutral 
mode) of the PPM 422 Plasma Process Monitor. You can manually perform measure-
ments in Tune Up as well.

When the Tune Up program is started, Quadstar 32-bit PPM attempts to establish a con-
nection to the PPM 422 Plasma Process Monitor. If this attempt is successful, the LED 
symbolically indicated in the lower left corner of the active window changes to Green. If 
a QMS 422 is not connected or not switched on, a corresponding error message is dis-
played.

After the fault has been remedied, a new attempt to connect can be made by [Comm] > 
[Connect].

5.7 PPM 422 Plasma Process Monitor
The PPM 422 Plasma Process Monitor is a differentially pumped mass spectrometer 
with an energy filter between the ion source and the mass filter. It is used in plasma pro-
cesses for analyzing ions and neutral particles (molecules, radicals) which are extracted 
(for example, from a sputter plasma) by means of an entrance orifice. The analysis is 
not limited to the mass of the particles, it also includes their energy.

NOTE:
For a detailed description please refer to the user’s guide “PPM 422 Plasma Pro-
cess Monitor”.

The potentials required for operating the various function groups of the PPM 422 are 
illustrated in Fig. 5-55, 350. Depending on the operating mode the potentials are con-
nected differently. The detailed function of the individual potentials is described in the 
PPM 422 User’s guide. The Quadstar 32-bit PPM Tune Up module described in this 
chapter allows access to all relevant system parameters. These are the potentials for 
operating the transfer lens/ion source, the energy filter, and the mass filter (including 
detector), as well as the filament current and emission current of the ion source. 
Tab. 5-1, 351 provides an overview of the parameters accessible in Quadstar 32-bit 
PPM Tune Up. These can be optimized for various operating modes while the measure-
ment is running.
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5.7.1 Functional diagram Ion-optical potentials

Fig. 5-55

For operating the PPM 422 Plasma Process Monitor, two QMS 422’s are needed: 
“QMS-E” or “E-Chassis” for the energy analysis and “QMS-M” or “M-Chassis” for the 
mass analysis. Depending on the selected operating mode the ions are detected 
through one of the QMS chassis. A separate operating voltage for the extraction hood, 
if required, must be supplied by the user. (See PPM 422 user’s guide).

The QMS-E generates the voltage Ve for the energy scan. Its IS 420, designated as “IS-
E”, essentially supplies the energy analyzer and the mass filter. In Neutrals mode, Ve 
defines the potential of the IS-E to ground. In Ions mode the IS-E and IS-M are both con-
nected to the Ve potential.

5.7.2 Parameter overview

Name Operation 
mode Voltage Default 

value Function

CATH C N V2-M 70 V El. energy Coarse

IONREF N V1-M - Ions’ Reference

ENTRY I ‘ V9-M 30 V Entrance lens

ITRO I ‘ V5-M 200 V Ion lens

EXTR N V5-M 4 V Extraction Coarse

EXTR N V5-M and div. - Extraction Fine

FOC 1 I ‘ N V8-M 60 V Lens 1

CENTR I ‘ N ‘ V2-E 41 V Inner cylinder

MIRR I ‘ N ‘ V8-E 17 V Outer cylinder

INFL I N V9-E 26 V Inflection/deflection
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Tab. 5-1 Parameter Overview

Operation modes: N = Neutrals, I = Ions

The apostrophe in the operating mode designation means that this value can be 
changed for hardware adjustment (or: intentional shift with the SHIFT function) of the 
energy scale.

Main menu The menu with its parameter groups deviates from the standard Quadstar 32-bit Tune 
Up software and is specially fitted to the PPM 422 Plasma Process Monitor:

Fig. 5-56

File
Display the version number of the Quadstar 32-bit PPM Tune Up program and exit the 
program. See Chapter 5.8.1.1 About Tune Up, 352.

Tune
Input of ion source parameters, perform measurement. See Chapter 5.9 Tune, 353.

Comm
Turn the interface to the PPM 422 on/off. See Chapter 5.10 Communication Parame-
ters, 375.

Setup 
Turn the emission and the SEM on/off. See Chapter 5.11 Setup Parameters, 376.

Help
Display the ‘Key Fragment Ions’ table and help contents. See Chapter 1.9.1 Spectrum 
interpretation, 56.

FOC 2 I ‘ N ‘ V3-E 7 V Lens 2

CASE I ‘ N ‘ V5-E 28 V QMA tube

F.AXIS I ‘ N ‘ V4-E 4 V Field axis

DFLI I ‘ N ‘ V6-E 300 V Inner deflection

DFLO I ‘ N ‘ V7-E 145 V Outer deflection

Current N - 1.0 mA Emission current

Protect N - 3 A Max. filament current

ORIF I N AO 422 - Extr. hood

Ve/Energy I ‘ N ‘ E-Scan - Ion energy

Name Operation 
mode Voltage Default 

value Function
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5.8 File

5.8.1 File menu

Fig. 5-57

5.8.1.1 About Tune Up

Under this menu entry you can identify the version number of the Quadstar 32-bit PPM 
Tune Up program.

Fig. 5-58

Exit
Quit the Quadstar 32-bit PPM Tune Up program.
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5.9 Tune

Tune menu Choose the Tune menu to adjust and optimize the transfer lens, the ion source and the 
energy- or mass filter. You may perform measurements with it as well.

Fig. 5-59

PPM 422...
Adjust and optimize the PPM 422 specific parameters, perform measurements manu-
ally.

NOTE:
[Tune] > [PPM 422...] is only accessible when the communication is switched ON.

5.9.1 PPM 422

Choose [Tune] > [PPM 422] for entering and adjusting/optimizing the parameters of the 
energy- or mass filter, the ion transfer optics (Ions mode) and the ion source (Neutrals 
mode), in order to prepare the PPM 422 Plasma Process Monitor for operation.

The following parameters can be optimized:

• Operating modes Ions+/Ions- Voltages of the mass/energy filter and of the ion trans-
fer optics

• Operating mode Neutrals Voltages of the mass/energy filter and the ion source

5.9.1.1 Parameter setup

In the following dialog boxes you can enter the mass/energy parameter (M- or E- param-
eters) as well as the ion source parameters Ion Source, IS-Emission and IS-Voltages:

• For selecting the PPM 422 operating mode the groups Scan, Sampling Mode, Ions 
and Neutrals are available.

• For adjusting/optimizing these parameters, an on-line measurement in different scan 
modes is available under [Display] > [Measure Data] menu.
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5.9.1.1.1 Parameter setup of an E-Scan

Fig. 5-60

Fig. 5-61
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5.9.1.1.2 Parameter setup of an M-Scan

Fig. 5-62

Fig. 5-63
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5.9.1.1.3 Modifying Parameters

The displayed parameters can be modified while a measurement is in progress, by click-
ing on the desired parameter. It then appears in the edit field displayed below the menu 
line of Tune PPM 422 and can be modified there.

The change takes effect, when you
• Press the Enter key,
• Click on the small [*] command button on the left of the input field, or
• Press the Tab key.

In the dialog box below, the cursor is positioned at the Mode parameter of the group 
Scan.

Fig. 5-64

The parameters are subdivided into groups:

Channel
Enter the channel number (QMS 422 channel 0 ... 63)

Detector
Parameter group Detector

Mass/Energy
Parameter group Mass/Energy

Amplifier
Parameter group Amplifier

NOTE:
For detailed information on the parameters please refer to the QMS 422 user’s 
guide (Parameters, sorted alphabetically).
Please note that the parameter designations are modified by the prefixes “E-” and 
“M-” (for Energy/Mass).

IS-Voltages
IS Voltages relates to the IS sets that have been selected under E-Set and M-Set. Six-
teen IS sets are available for each QMS 422. The voltage display corresponds to the 
selected sets of both QMS 422.

Special
Special parameters

• SHIFT: SHIFT shifts the data display (only in Energy scan mode) in such a way, that 
negative values can be displayed as well and therefore the distribution near zero can 
be seen (adjustment range 0 ... +10 Volt). The energy calibration remains un-
changed. SHIFT has only a temporary effect and is only useful when a measurement 
is made.

• CORR: Software implemented correction of the residual deviation between the ener-
gy scale and the true energy. The possible hardware adjustments are not fine 
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enough for this purpose. CORR is determined separately for each E-Set and saved 
together with the set. (Adjustment range -2.0 ... +2.0 Volt).

NOTE:
For detailed information, please refer to the user’s guide of the PPM 422 Plasma 
Process Monitor, Interrelation between ion energy and Ve.

• ORIF: Extraction hood potential. The extraction hood potential can be output via an 
analog output channel and the corresponding AO characteristic curve. It serves as a 
control voltage for an external power supply. ORIF has only an effect, if the corre-
sponding AO characteristic curve has been defined and an external power supply is 
connected.

Ion Source
• Filament #: Select the desired filament (Fil1 or Fil2) for the Neutrals mode.
• E-Set: Load an IS-E- Set (0 ... 15) for the QMS E.
• M-Set: Load an IS-M-Set (0 ... 15) for the QMS M.

The QMS E and the QMS M each have sixteen separate IS-sets.

IS-Emission
These parameters relate to the filament selected under Ion Source (Fil1 or Fil2).

• Current: Emission current in mA (0.00 means OFF).
• Protect: Maximum filament current in A (Protection).

Scan
These parameters determine the operating mode of the measurement. They are stored 
together with the other channel parameters.

• Mass: Mass scan. The parameter Fixed E determines the fixed energy value in the 
QMS-E that is used for the mass scan.

• Energy: Energy scan. The parameter Fixed Mass determines the fixed mass value 
in the QMS M that is used for the energy scan.

NOTE:
In a changeover between MASS and ENERGY all parameters of a channel are pre-
served, only the designations change. A channel whose parameters were origi-
nally set for M-Scan would now be switched to E-Scan. A large part of the param-
eters would no longer be applicable. For example “Fixed Ve 5.4” would become 
“Fixed Mass 5.4”. For changing the scan mode, it is therefore more convenient to 
select a different channel.

It is recommended to reserve the channels for the corresponding scan mode 
based on their numbers, for example odd numbers for M-scan. In the supplied 
software Channel 0 is set for E-Scan and Channel 1 for M-Scan.

Sampling Mode
Select the operating mode (plasma sampling mode PSM).

• Ions +: Measurement of positive ions.

• Ions -: Measurement of negative ions.

• Neutrals: Measurement of neutral species by means of electron impact ionization in 
the ion source.

NOTE:
In a change of the Plasma Sampling Mode (PSM) from “Ions” to “Neutrals” (and 
vice versa), the original parameter values remain stored. When you change back 
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to the previous operation mode, the stored values are reinserted. So it is not nec-
essary to reserve specific M-Sets for the different PSM’s.

Ions
Select the polarity (in mode Ions):

• Ve+: Positive polarity of the energy scan voltage.
• Ve-: Negative polarity of the energy scan voltage.

Neutrals
Select the mode for the detection of Neutrals:

• Coarse: Normal operating mode for measuring Neutrals. The minimum step width of 
the extraction voltage EXTR is 2 Volts.

• Fine: Measurement of Neutrals with accurately adjustable extraction voltage EXTR 
(minimum step width is 0.02 Volts).

Tune PPM 422 menu

Fig. 5-65

File
Store the ion source parameters, leave the editor.

Display
Display measurement data. (See Chapter 5.9.2 Optimizing the parameters (Measure 
Data), 369)

Option
Copy the channel and IS set parameters, set default parameters, single- or common 
increment/decrement of potentials.

File submenu

Fig. 5-66

Save
Store the ion source parameters.

Print Ion Source Settings
Print the current ion source settings.

Close
Close the parameter file and return to the Tune Up main menu.

Display submenu

Fig. 5-67
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Measure Data
Start the measurement. (See Chapter 5.9.2 Optimizing the parameters (Measure Data), 

369)

Option submenu

Fig. 5-68

Copy/Exch. IS-Set...
Copy/exchange IS parameter sets.

Copy/Exch. Channel...
Copy/exchange channel parameters.

Default IS-Set
Reset the ion source parameters to default values.

Single Incr/Decr
Increment/decrement the potentials of the IS-Voltages group individually.

Common Incr/Decr
Increment/decrement the potentials of the IS-Voltages group together, that are marked 
with **....**. This simplifies the coarse correction of the energy scale without losing a pre-
vious optimization.

5.9.1.2 Copy/Exch. IS-Set

Copy/Exch IS-Set opens a dialog box for selecting an E-set or M-set. This dialog box is 
skipped when the cursor is positioned within the Ion Source group on E-Set or M-Set.

Fig. 5-69

Choose [Copy/Exch. E-Set] or [Copy/Exch. M-Set] to open a dialog box for copying or 
exchanging the selected E-Sets or M-Sets:
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Fig. 5-70

Mode Selection
Select the desired action:

• Copy: Copy an IS set to a different set or to the other 15 sets of the selected QMS E 
or QMS M.

• Exchange: Exchange all parameters of the IS set selected under Source with those 
in the IS set selected under Dest (within the selected QMS-E or QMS-M).

The desired IS set can be selected under Source and Dest:

Source
IS set whose parameters are to be copied.

Dest
Target IS set to which the parameters are to be copied. For copying to all IS sets, click 
on the [UP] or [DOWN] arrow with the right mouse button to choose ALL.

5.9.1.3 Copy/Exch. Channel

Choose Copy/Exch. Channel to open a dialog box for copying individual channel param-
eters or for copying all parameters of the current channel:

Fig. 5-71

Mode Selection
Select the desired action:

• Copy: Copy the object (Channel or Parameter) selected under Object Selection to a 
different channel or to all channels.

• Exchange: Exchange all parameters of the channel selected under Source with 
those of the channel selected under Dest.. You can choose Exchange only in con-
junction with [Object Selection] > [Channel].
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Object Selection
Choose the object to be copied:

• Channel: Copy or exchange whole channels (all parameters).

• Parameter: The selected parameter is copied (exchange is impossible). Parameter 
cannot be chosen if no parameter has been selected.

The channels are selected under Source and Dest:

Source
Enter the channel whose parameters are to be copied.

Dest
Enter the destination channel to which the parameters are to be copied. For copying to 
all channels click on the [UP] or [DOWN] arrow with the right mouse button to choose 
ALL.

Special cases In the parameter copying functions the following Special cases must be taken into con-
sideration:

[Scan Mode] > [Mass/Energy]
Cannot be copied as a parameter.

Threshold
It is only possible to copy into channels in which the same Detector has been selected.

5.9.1.4 Default IS-Set

[Option] > [Default IS-Set] loads standard values for the E-Set and the M-Set.

NOTE:
[Option] > [Default IS-Set] deletes and overwrites the current E-Set and M-Set 
without request for confirmation. Do not choose this option unless you are sure, 
you don’t need the parameter values of the chosen IS-Sets any more.
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5.9.1.5 Single/Common Incr/Decr

Single Incr/Decr By choosing Single Incr/Decr the Ion source potentials of the IS-Voltages group can be 
modified individually.

Fig. 5-72

Common Inc/Decr If Common Incr/Decr is chosen, a modification of a single potential influences all poten-
tials of the IS-Voltages group that are marked by “**...**”.

The step width for all those potentials is ±2.0 V then.

Fig. 5-73

Difference 
between 
Common 
Incr/Decr and 
SHIFT

With Common Incr/Decr all potentials marked with **...** can be shifted in steps of ±2 
Volt. This simplifies the coarse correction of the energy scale because a previous opti-
mization is not destroyed. The changed potentials are stored in the same way as in Sin-
gle Incr/Decr.

SHIFT shifts the energy scale into the negative, without affecting the energy calibration. 
The scale and the measurement curve are shifted jointly, so that distributions close to 
zero can be watched. For that purpose, an intentional misadjustment (all potentials 
marked with **...**) in the range of 0 ... +10 Volt is created and the resulting deviation 
between the energy scale and Ve scale is corrected. Shift is not stored. In measuring 
sequences, Shift can be calculated and set automatically based on the selected param-
eters.
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NOTE:
For detailed information, please refer to the User’s guide of the Plasma Process 
Monitor PPM 422, Interrelation between ion energy and Ve.

5.9.1.6 Relations (Ion energy and Ve, CORR and SHIFT)

The detailed interrelation is described in the User’s guide of the PPM 422 Plasma Pro-
cess Monitor. The following Examples provide a brief overview:

5.9.1.7 Measurement parameters for determining the energy zero

Set-up of the Quadstar 32-bit PPM Tune Up measurement parameters for determining 
the energy zero in the Sampling Mode Neutrals, Scan Mode Energy and Fixed Mass 40 
(Argon peak):

Fig. 5-74
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Fig. 5-75

5.9.1.7.1 Energy scan in Sampling Mode Neutrals

Fixed mass = 40 (Argon peak), CORR = 0, SHIFT = 0.

In this measure mode you can determine the CORR Value graphically: choose [Func-
tion] > [CORR] from the measure window menu, move the crosshairs to energy zero 
while having the left mouse button pressed, and press the right mouse button addition-
ally. The crosshairs move only within ±2.0 eV. In the now appearing Set CORR Value 
dialog box you can adopt the determined value by pressing [OK].
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Fig. 5-76

5.9.1.7.2 Effect of the correction value CORR

CORR can be entered by [Operation] > [Set CORR] or by the mouse into the dialog box 
Set CORR Voltage shown below. If you choose [OK], the value is adopted:

Fig. 5-77

CORR = 1.4 V shifts the measurement curve relative to the energy scale by this amount:
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Fig. 5-78

Since CORR changes neither the Ve scale nor the IS voltages, the measurement curve 
does not shift relative to the window frame (First Ve always meets the starting point of 
the horizontal scale of the window).

5.9.1.8 Measurement parameters for positive ions

The following picture shows the measurement parameters for measuring positive ions 
produced in the argon sputter plasma (Sampling Mode Ions +, Scan Mode Energy and 
Fixed Mass = 40 [argon peak]):
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Fig. 5-79

5.9.1.8.1 Energy distribution of positive ions

The following picture shows the energy distribution of positive ions produced in the 
argon sputter plasma. The different curves originate from the optimization process:

Fig. 5-80
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5.9.1.8.2 Effect of SHIFT

SHIFT = 2Volts influences the groups IS-Voltages and Special as follows:

Fig. 5-81

The next picture shows the same measurement data (energy distribution of positive ions 
produced in the argon sputter plasma) after SHIFT = 2 Volts has been entered.

Fig. 5-82

The measurement curve does not shift relative to the energy scale. Both are shifted the 
same way relative to the window frame (or relative to the Ve scale that is not explicitly 
shown). By using the [Function] > [Cursor] - Mode (See Chapter 5.9.2.1.3 Function sub-

SHIFT = 0 Volt SHIFT = 2 Volt
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menu (crosshairs), 372) you can determine the measured values directly within the 
graphic: move the crosshairs to the desired location while having the left mouse button 
pressed and press the right mouse button additionally. The Values are now shown in the 
status bar of the measure window:(X: 0.83, Y: 2.380E+02).

The same measurement with identical parameters in sample mode (E-Mode SAMPLE) 
on the maximum of the energy curve (fixed E: 0.83 eV) produces the following result:

Fig. 5-83

The field on the right in the status bar shows the measured value numerically 
(2.380E+02).

“Fixed Energy” 
setting

The energy value cannot be entered directly in the Tune Up menu. Fixed Ve is entered 
instead (See Section «Scan», 357). Fixed E is calculated and displayed by taking 
CORR and SHIFT into consideration (see Fig. 5-83, 369). The desired energy value 
can be set by modifying Fixed Ve with the UP/DOWN keys.

5.9.2 Optimizing the parameters (Measure Data)

By choosing [Display] > [Measure Data] you can open a measure window and start a 
measurement on the currently used Channel.

You can perform measurements manually and optimize the parameters by means of the 
measurement. See also example in Chapter 5.9.1.8.1 Energy distribution of positive 
ions, 367.
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Scan Analog 
measurement 
data

Fig. 5-84

In the display, the old measurement data are displayed together with the new measure-
ment data in a different color. The display field is not cleared before each new measure-
ment. The displayed scans are only erased if:

• the size of the Measure Data window is changed,
• either the First, Width or Range parameter is changed, or
• if the user explicitly requests this by choosing [Display] > [Refresh].

NOTE:
For printing pictures in Quadstar 32-bit (by Ctrl+Shift+F12), stop the measure-
ment by [Operation] > [Halt] in order to prevent errors of the interface.

Displaying 
reference 
measurement 
data

In measurement modes SCAN-N and SCAN-F also the measurement data of a refer-
ence scan can be displayed. If the option Reference (menu Display) is checked, a ref-
erence scan is stored automatically

• if the first scan after Measure Data has been chosen in the menu Display, or
• when either the First, Width or Range parameter has been changed.

You may store a reference scan manually as well, by [File] > [Save Reference]. This is 
necessary for example, to make the option Reference accessible again, if it is grayed.
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Sample 
measurement 
data

Fig. 5-85

In this measurement the highest measured intensity is flagged with a drag pointer. The 
measurement Operation status (Go or Halt) and the measured value (Val: 9.864E+05) 
are displayed in the status bar.

5.9.2.1 Measure Data menu

Fig. 5-86

File
Store reference data, quit measure window.

Operation
Start/stop the measurement, set CORR.

Function
Setup the function mode of the crosshairs.

Setup
Scale Y-axis, set its display range, choose colors.

Display
Refresh the display, display reference data.

5.9.2.1.1 File submenu

Fig. 5-87

Save Reference
Store the measurement data of the next scan as reference data. This command is only 
accessible in Scan Analog mode (SCAN-N and SCAN-F).

Close
Quit the measurement window.
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5.9.2.1.2 Operation submenu

Fig. 5-88

Go
Start the measurement.

Halt
Stop the measurement.

Set CORR...
Enter the CORR parameter for the selected E-set.

Set CORR... 
parameter input

Choose Set CORR to enter the CORR parameter. CORR performs a software shift of 
the energy scale relative to the Ve scale. See Chapter 5.9.1.7.2 Effect of the correction 
value CORR, 365.

Fig. 5-89

NOTE:
This dialog box can as well be invoked in mode Scan Energy, Function: CORR by 
mouse (See Chapter 5.9.1.7.2 Effect of the correction value CORR, 365).

5.9.2.1.3 Function submenu (crosshairs)

Fig. 5-90

CORR
The crosshairs are used to determine and input the CORR-value, restricted to X-values 
within ±2.0. The X- and Y- values are not displayed in the status bar. This mode is only 
accessible in scan mode Energy, sampling mode Neutrals.

Cursor
The crosshairs are used to determine the X- and Y- values of a certain point in the mea-
sured scan. The values are displayed in the status bar.

You bring up the crosshairs by holding the left mouse button pressed and moving the 
mouse cursor into the graphic. The crosshairs now follow the mouse cursor and are 
quite exactly positionable on a certain point of the graphic. With a click of the right mouse 
button the crosshairs are released and the last displayed values in the status bar are 
frozen (e.g. useful for printing) or the CORR-dialog box appears.
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If CORR and Cursor are both possible, you can switch between these two function 
modes by a click of the right mouse button.

NOTE:
The X- and Y-values are displayed with constant number of significant digits. The 
real resolution may though be far lower, depending on the graphic; it is generally 
determined by the ratio of pixelwidth to window width/height.

5.9.2.1.4 Setup submenu

Fig. 5-91

Axis...
Display the Setup dialog box to scale the Y-axis (lin/log). This setup dialog box may as 
well be activated with a double-click of the left mouse button.

Fig. 5-92

• Lin: Display measurement data on a linear scale.
• Log: Display measurement data on a logarithmic scale.

Display Range...
Setup the display range of the Y-axis.

Fig. 5-93

• Disp. F.S.R.: Upper limit for the values to be displayed.
• Disp. Decades: Number of decades to display.

Colors...
Choose the colors to draw the scans with.
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Fig. 5-94

In the fields #0 ... #63, enter the colors to draw the scans with (alternatingly). The stan-
dard color table, that contains eight colors, produces scans with good contrast that are 
easily distinguishable in most cases. It can be recalled by [Set Default Colors], but the 
current settings of the Alternating Colors for the current color palette will be lost then. 
See Chapter 3.8.5 Screen Colors, 245.

5.9.2.1.5 Display submenu

This menu is only available in Scan Analog Mode (SCAN-N and SCAN-F):

Fig. 5-95

Refresh
Erase the graphic that’s already drawn, get new measure data and draw it.

Reference
Show reference scan on/off.
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5.10 Communication Parameters
Under Communication the interface to the PPM 422 can be turned on or off:

Fig. 5-96

Connect
Establish connection to the PPM 422.

Disconnect
Cancel the connection to the PPM 422.

NOTE:
For detailed information please refer to Chapter 3.6 Communication parameters, 

209.

CAUTION
The Plasma Process Monitor PPM 422 works only with communication 
type ArcNet. The communication type RS232C is reserved for service 
purpose and does not provide a correct, safe operation of the Plasma 
Process Monitor.

For safety reasons, no electrical conductive connection between PC and 
PPM is allowed. ArcNet and fibre optics provide this, while RS232C ca-
bles don’t!
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5.11 Setup Parameters

Setup menu

Fig. 5-97

Choose Setup to turn the emission and the SEM high voltage on or off (and to enter the 
Common SEM Voltage).

5.11.1 Turning the SEM high voltage and emission on/off

SEM/Emission Control...
Display the SEM/Emission Control dialog box in which the emission and the SEM high 
voltage can be turned on/off and the Common SEM Voltage can be entered. See 
Chapter 3.7 Setup parameters, 223.

NOTE:
This dialog box can also be called directly by pressing <Ctrl+S>.

SEM and Emission can only be switched on or off, when the communication with 
the PPM 422 is enabled.
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6. Service

Quadstar 32-bit Service provides test measurements (in the Measure menu) and man-
ual operation of analog and digital input and output channels (in the Manual menu). The 
available options depend on the quadrupole mass spectrometer (QMS):

QMS 422/421
DO 420, DI 420, AI 421, AO 421, PE 420 and PI 420

QMS 200
PKR 250/251 or TPR 250 (total pressure gauges). The QMS 200 is equipped with two 
analog inputs and four analog outputs, two digital inputs and two digital outputs as a 
standard feature. The only possible options are PKR 250/251 or TPR 250.

When the program is started, Service automatically activates the communication with 
the QMS and reads in the hardware configuration. The individual functions of Measure 
and Manual are enabled only if the required hardware is present.

Main menu

Fig. 6-1

File
Display the version number of the Quadstar 32-bit Service program and terminate the 
program. See Chapter 6.1.1 About Service, 378.

Measure
Start the service programs 

• Leak Test - See Chapter 6.2.1 Leak Test, 379.
• Total Pressure - See Chapter 6.2.2 Total Pressure, 382.

Manual
Operate/display the DI/DO and AI/AO channels. See Chapter 6.3 Manual, 386.

Comm
Switch the interface to the QMS on/off, choose the measuring device. See Chapter 6.4 
Communication Parameters, 389.

Setup
Switch the emission and the SEM on/off. See Chapter 6.5 Setup Parameters, 389.

Help
Display the ‘Key Fragment Ions’ table and help contents. See Chapter 1.9.1 Spectrum 
interpretation, 56.
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6.1 File

Fig. 6-2

6.1.1 About Service

Display the version number of the Quadstar 32-bit Service program:

Fig. 6-3

Exit
Quit the Quadstar 32-bit Service program.
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6.2 Measure

Fig. 6-4

The measurements can only be started if the communication link to the QMS is switched 
on:

Leak Test
Find leaks in the vacuum system.

Total Pressure
Measure and display the total pressure.

6.2.1 Leak Test

Leak Test provides assistance in the search for a leak in the vacuum system. A special 
test gas (helium, for example) can be used for locating the leak. The measurement data 
are displayed Versus Time (on the left) and as a bar (on the right):

Fig. 6-5

File
• Close: Close file, terminate measurement.

Parameters
• Setup: Control the measurement data display. This dialog box can also be activated 

by a double-click of the left mouse button.
• Channel: Channel parameters (Range, Mass etc.). This dialog box can also be acti-

vated by a double-click of the right mouse button.

Alarm display The alarm threshold set in the Channel Parameters dialog box under Trip Level B is indi-
cated with the symbol ‘B>’ in the bar chart. It can be switched on/off by the enable/dis-
able Alarm Display control field under [Leak Test] > [Setup].
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6.2.1.1 Setup

Fig. 6-6

Y-Scale
• Lin: Display the measurement data on a linear scale.
• Log: Display the measurement data on a logarithmic scale.

Time Scale
Time scale on the X-axis.

X-Grid
X-grid in the measurement window on/off.

Y-Grid
Y-grid in the measurement window on/off.

Alarm Display
Indication of the alarm threshold and the alarm state on/off.

Alarm Sound
Alarm buzzer on/off.

Colors
Assign colors to the two alarm states. The colors can be entered numerically or by a 
mouse click on the color palette.

• Alarm On: Color of the bar and the alarm symbol if there is an alarm.
• Alarm Off: Color of the bar and the alarm symbol if there is no alarm.
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6.2.1.2 Channel

Fig. 6-7

Command 
buttons

[Default]
Set all parameters to default values (test gas = helium)

[Adjust]
Optimize the selected mass number to the peak maximum.

Parameters Number and type of displayed parameters depend on the options selected in the Param-
eter Setup Program under [Config] > [QMS...]. The following parameters are possible:

Mass
Mass number on which the specific measurement is conducted.

Resolution
Resolution of the quadrupole mass filter.

Amp. Range
Electrometer measurement range.

Amp. Mode
Amplifier operation mode (automatic/manual).

Amp. Offset
Amplifier offset.

Dwell
Measurement time.

Trip Level B
Alarm threshold B.
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Detector
Detector type.

SEM Voltage
SEM or CH-TRON high voltage.

Activate the Common SEM Voltage (<< XXXX>>) by clicking on the [UP] or [DOWN] 
arrow with the right mouse button.

DO# B
Digital output channel for the alarm status message.

Disp. F.S.R.
Upper limit for display.

Disp. Decades
Number of decades to display when a logarithmic scale is used.

Special param-
eters 
(QMS 422/421)

When a QMS 422/421 is used and additional options are installed, then there are special 
parameters to operate those options:

Ion counter CP 
400

CP Level
Response threshold of the ion counter preamplifier.

Multiplex 
operation with 
QMU 112

QMU Channel
Channel selection in multiplex operation with QMU 112.

Operation with 
chopper lock-in 
amplifier CLA 421

Lock In
Switch the CLA 421 Lock In amplifier on/off. OFF means normal electrometer mode.

Phase
Phase shift (0º or 180º) of the Chopper Lock In amplifier.

6.2.2 Total Pressure

Total Pressure shows the total pressure in the vacuum system, provided the required 
hardware options (measurement gauge, additional plug-in board for QMS 422/421) are 
installed.
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6.2.2.1 QMS 422/421: PE 420 and/or PI 420

Fig. 6-8

6.2.2.2 QMS 200: TPR 250 or PKR 250/251

Fig. 6-9

Parameters
• Setup: Control the measurement data display. This dialog box can also be activated 

by a double click of the left mouse button.

6.2.2.3 Setup

[Parameters] > [Setup] controls the display of measurement data. This dialog box (Total 
Pressure Setup) can also be activated by double-clicking the left mouse button:
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QMS 422/421

Fig. 6-10

QMS 200

Fig. 6-11

Unit of Total Pressure
Unit of measure (mbar, Pa(scal), Torr) for total pressure measurement with the PI 420 
and/or PE 420 when the QMS 422/421 is used, or a PKR 250/251 or TPR 250 when a 
QMS 200 is used.

Time Scale
Time scale on the X-axis

X-Grid
X-grid on the measurement screen on/off.

Y-Grid
Y-grid on the measurement screen on/off.

Marker
Mark the measured values with a symbol. The symbol is selected automatically.

Colors
Assign colors to the different sensors. The color can be entered numerically or by a 
mouse click on the color palette.
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• Cold cathode: Sensor (Cold cathode Gauge) of the PE 420 for QMS 422/421.
• Pirani #1: Sensor 1 (Pirani Gauge #1) of the PI 420 for QMS 422/421.
• Pirani #2: Sensor 2 (Pirani Gauge #2) of the PI 420 for QMS 422/421.
• PKR 250/251: Compact Full Range Gauge for QMS 200.
• TPR 250: Compact Pirani Gauge for QMS 200.
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6.3 Manual
Choose Manual to display analog or digital input channels and manually change the out-
put of analog or digital output channels. For that, the communication with the mass spec-
trometer must be switched on.

Fig. 6-12

6.3.1 Digital I/O (DI/DO)

For turning the individual digital output channels on or off, double-click the correspond-
ing push button with the left mouse button. The switching state is indicated by the col-
ored dot on the push button: green = on, grey = off.

QMS 422/421

Fig. 6-13

Display left
Select the DI/DO group to be displayed on the left side of the screen.

Display right
Select the DI/DO group to be displayed on the right side of the screen.

A group cannot be displayed at the left and the right side simultaneously.

QMS 200 Only the two standard digital input and output channels are available:
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Fig. 6-14

The digital input and output channels of the QMS 200 have the following designation in 
the hardware description:

• DI 00: EXT_PROT (Connection TPR/PKR, Pin No. 1 <=> 2)
• DI 01: EXT_RUN (Connection Control, Pin No. 10 <=> 15)
• DO 00: REL_1 (Connection Control, Pin No. 11 <=> 12)
• DO 01: REL_2 (Connection Control, Pin No. 13 <=> 14)

6.3.2 Analog I/O (AI/AO)

The input and output voltages of the analog channels are displayed numerically and 
graphically. Please note, that the AI channels might not display 0.0 V, if their input is 
open (floating). The single channels can be configurated and given names in the Param-
eter Setup program under [Config] > [AI Characteristic Curve] and [Config] > [AO Char-
acteristic Curve].

NOTE:
The values shown here are the real input and output voltages in Volts, not the 
physical values (such as “ °C “ for temperatures) assigned to them by the Char-
acteristic Curve.

QMS 422/421

Fig. 6-15
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QMS 200 Only the two analog input and four output channels provided as a standard feature are 
available:

Fig. 6-16
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6.4 Communication Parameters

Fig. 6-17

Connect
Establish connection to the QMS.

Disconnect
Cancel connection to the QMS.

SetUnit...
Select current measuring device. See Section «Setting the node addresses of several 
control units», 218.

NOTE:
For detailed information see Chapter 3.6 Communication parameters, 209.

6.5 Setup Parameters

Fig. 6-18

SEM/Emission Control...
Open the dialog box SEM/Emission Control to:

• Switch the SEM high voltage on/off.
• Input the Common SEM voltage.
• Switch the Emission on/off. 

See Chapter 3.7 Setup parameters, 223.
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7. Utility

Quadstar 32-bit Utility contains the spectra library and an installation utility.

The spectra library allows to store, load and edit spectra as well as to compare them with 
other spectra. You can export the library to a text file. The installation utility is used for 
installing custom-specific Quadstar 32-bit extensions.

Main menu

Fig. 7-1

File
Display the version number of Quadstar 32-bit Utility and quit the program.

Spectra Library
Call the Spectra Library File Manager or export the library to a text file. See Chapter 7.2 
Spectra library menu, 393

Installation
Install custom-specific extensions. See Chapter 7.3 Installation menu, 408.

Help
Display the ‘Key Fragment Ions’ table and help contents. See Chapter 1.9.1 Spectrum 
interpretation, 56.
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7.1 File menu

Fig. 7-2

7.1.1 About Utility

Fig. 7-3

Exit Quit the Quadstar 32-bit Utility program.
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7.2 Spectra library menu
The spectra library supplied with Quadstar 32-bit contains 72 spectra and can be 
expanded to up to 10,000 spectra. New spectra can be entered manually ([New] or [Edit] 
command button), or by measuring a spectrum under Scan Bargraph (Quadstar 32-bit 
Measure program).

The spectra library features the following functions:

• Displaying stored spectra.
• Modifying stored spectra.
• Inserting new spectra.
• Subtracting spectra.
• Removing spectra.

The following information is stored for each spectrum:

• Title of the component.
• Formula of the component.
• Spectrum of the component (max. 32 peaks normalized, the largest peak corre-

sponding to 100%).

Spectra Library 
menu

Fig. 7-4

Open Library...
Call the Spectra Library File Manager to work with one or more spectra of the library. 
See Chapter 7.2.1 Open Library, 394.

Export Library to Text File...
Export the complete Quadstar 32-bit Spectra Library to a text file that is readable e.g. by 
the NIST mass spectral search program. See Chapter 7.2.3 Export Library to Text File, 

406.
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7.2.1 Open Library

Fig. 7-5

Library State
State of the library (sorted/unsorted).

Stored Spectra
Number of spectra stored in the spectra library.

Please note that any change in the stored spectra or the input of a new spectrum sets 
the Library State to UNSORTED. In order to work efficiently with the library, you should 
Sort it.

The following functions are available for modifying the spectra library:

[Spectrum]
Display the selected spectrum - See Chapter 7.2.2 Displaying a spectrum, 395.

[Copy Spec]
Copy the selected spectrum - See Chapter 7.2.2.2 Copying a spectrum, 401.

[Remove]
Remove a spectrum - See Chapter 7.2.2.3 Removing a spectrum, 402.

[Search]
Search a spectrum by the known formula - See Chapter 7.2.2.4 Searching a spectrum, 

402.

[Goto]
Select a spectrum by the known spectrum number - See Chapter 7.2.2.5 Go to a spec-
trum, 403.

[Sort]
Sort the library - See Chapter 7.2.2.6 Sorting the library, 403.

[New]
Enter a new spectrum - See Chapter 7.2.2.7 Entering a new spectrum, 403.

[Edit]
Modify the selected spectrum - See Chapter 7.2.2.8 Editing a spectrum, 404.
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[Print]
Print spectra - See Chapter 7.2.2.9 Printing the spectra, 405.

7.2.2 Displaying a spectrum

[Spectrum]
Open the window SPECTRUM Comparison.

The selected spectrum (in our example: Argon) is displayed as S1 in the upper half of 
the window:

Fig. 7-6

In the lower half of the screen you can load a comparison spectrum by [Spectrum] > 
[Select/Load S2].

SPECTRUM 
Comparison 
Menu

Fig. 7-7

Spectrum
Load and compare spectra.

Subtraction
Subtract and normalize spectra.

Parameters
Set up the display (lin/log, X/Y grid on/off)
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7.2.2.1 Spectrum submenu

Fig. 7-8

Select/Load S2...
Select the spectrum to be displayed under S2.

Display Numeric...
Display the spectrum as a table.

Overlap S2 on S1
Load and compare spectra.

S1 to Library...
Store the spectrum displayed under S1 in the spectra library.

Close
Close the Spectrum Comparison window.

7.2.2.1.1 Load a comparison spectrum (Select/Load S2)

Fig. 7-9

[Spectrum]
Return to Spectrum Comparison, display the selected spectrum under S2. Double click-
ing the spectrum does the same.

[Search]
Search a spectrum by its known formula - See Chapter 7.2.2.4 Searching a spectrum, 

402.

[Goto]
Select a spectrum by its known number. See Chapter 7.2.2.5 Go to a spectrum, 403.
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The selected spectrum is shown in the lower half of the window as S2:

Fig. 7-10

7.2.2.1.2 Display spectrum as a table (Display Numeric)

You can display the spectra as a table:

Fig. 7-11
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7.2.2.1.3 Overlap S2 on S1

Overlap spectrum S2 to spectrum S1:

Fig. 7-12

Both spectra are displayed in the upper half of the screen, differences are easy to see.

7.2.2.1.4 Store spectrum (S1 to Library)

S1 to Library stores the spectrum displayed as S1 in the upper half of the window to the 
library. Before it is stored definitely, you can check it by the (automatically displayed) 
Edit window and make last changes if necessary. See Chapter 7.2.2.8 Editing a spec-
trum, 404.

Subtraction 
submenu

Fig. 7-13

Subtract S1-S2...
Subtract spectrum S2 from spectrum S1. The result is displayed as S1.

Subtraction List...
Display the subtractions that have already been performed.

Undo last Subtraction...
Reverse the last subtraction.

Normalize S1...
Normalize the spectrum displayed under S1 (largest peak = 100%).
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7.2.2.1.5 Subtract S1 - S2

Before the subtraction you must determine the mass number to be eliminated:

Fig. 7-14

Mass to eliminate
S2 is normalized in such a way, that the chosen mass number (in our example: mass 
18) is eliminated in spectrum S1. Only a mass number, that appears in both spectra, can 
be chosen. The ratio of their intensities can be checked in advance by Overlap S2 on 
S1. See Chapter 7.2.2.1.3 Overlap S2 on S1, 398.

Ratio
Calculated normalization factor.

[Subtract]
Start the subtraction.

The result of the subtraction is displayed in the upper half of the display as S1.

Fig. 7-15

NOTE:
In the logarithmic representation, the upper spectrum is always displayed in the 
range of -100% ... +100%.

• The last subtraction can be reversed by [Subtraction] > [Undo last Subtraction].

• Before another subtraction is performed, the spectrum should possibly be normal-
ized again if the largest peak (=100%) has been changed. See Chapter 7.2.2.1.8 
Normalize S1, 400.
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7.2.2.1.6 Subtraction List

Subtraction List shows a list containing the subtractions that have been performed so 
far.

Fig. 7-16

7.2.2.1.7 Undo last Subtraction

Fig. 7-17

With Undo last Subtraction you can reverse the previous subtraction. In our example, 
spectrum nbr. 48 (H2O: water) has been subtracted from S1 and mass 18 (Mass to elim-
inate = 18) has been eliminated.

7.2.2.1.8 Normalize S1

Normalize the spectrum so that the intensity of the largest peak corresponds to 100%:

Fig. 7-18
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Parameters 
submenu

Fig. 7-19

Setup opens a dialog box for controlling the display

Fig. 7-20

Y-Scale
• Linear: Display the measurement data on a linear scale.
• Logarithmic: Display the measurement data on a logarithmic scale.

X-Grid
Grid for the X-axis on/off.

Y-Grid
Grid for the Y-axis on/off.

Colors
• Spec S1: Color of the spectrum S1.
• Spec S2: Color of the spectrum S2.

7.2.2.2 Copying a spectrum

[Copy Spec]
Copy spectrum S1 to another, already existing spectrum.

Fig. 7-21
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NOTE:
The target spectrum, whose number is entered, is replaced by S1. The original 
spectrum (in our example: nbr. 48) will be lost.

7.2.2.3 Removing a spectrum

[Remove]
Remove a spectrum from the library by deleting it.

Fig. 7-22

7.2.2.4 Searching a spectrum

[Search]
Search a spectrum by its known formula.

Fig. 7-23

You can search a spectrum by:

• A known formula (such as Air, H2O, N2, O2, etc.)

• The starting characters of the formula name and ‘*’ (such as H2*, SO2*, C2CI*, C2F*, 
etc.)

The search function does not distinguish between upper and lower case letters. The 
search works only with a sorted library.
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7.2.2.5 Go to a spectrum

[Goto]
Go to a spectrum, whose spectra number is known.

Fig. 7-24

NOTE:
By “Print Spectra” you can create a list of all spectra, which provides the required 
numbers quickly. See Chapter 7.2.2.9 Printing the spectra, 405.

7.2.2.6 Sorting the library

[Sort]
Sort the spectra library.

Fig. 7-25

The formulas are sorted alphabetically, the peaks by their intensities.

NOTE:
Sort the library, when you have entered all changes. Depending on the number of 
stored spectra, the sort may take some time.

7.2.2.7 Entering a new spectrum

[New]
Enter a new spectrum - See also Chapter 7.2.2.8 Editing a spectrum, 404).
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7.2.2.8 Editing a spectrum

[Edit]
Edit a spectrum.

In the Edit <spectrum> dialog box you can edit an existing spectrum or enter a new one:

Fig. 7-26

[Insert]
Add to the current spectrum S1 another peak (mass number, intensity). The intensity 
must be entered in normalized form, i.e. in %. The maximum of peaks that can be 
present in a spectrum is 32.

[Spectrum]
Display the spectrum.

[Remove]
Remove a peak from the current spectrum S1:

Fig. 7-27

[Norm]
Normalize the spectrum (largest peak = 100%).

[Sort Mass]
Sort the spectrum by ascending mass numbers.

[Sort Intern]
Sort the spectrum by descending intensities.

[Spectrum]
Display the changed spectrum S1:
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Fig. 7-28

Options submenu

Fig. 7-29

Linear
Display the measurement data on a linear scale.

Logarithmic
Display the measurement data on a logarithmic scale.

X-Grid
Grid for the X-axis on/off.

Y-Grid
Grid for the Y-axis on/off.

7.2.2.9 Printing the spectra

[Print]
Print one or several spectra as a table:

Fig. 7-30
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from Nbr
First spectrum to be printed.

to Nbr
Last spectrum to be printed.

Options
• Print all information: Print all information of the selected spectra.
• Print Formula and Titles: Print only the number, the formula and the title of the se-

lected spectra.

7.2.3 Export Library to Text File

[Spectra Library] > [Export Library to Text File] allows to export the complete 
Quadstar 32-bit Spectra Library to a text file. This text file can be read e.g. by the NIST 
Mass Spectral Search program that uses the NIST Mass Spectral Library. This way you 
can compare any spectrum stored in Quadstar 32-bit to any spectrum of an external 
library such as the NIST library.

Fig. 7-31

Choose path and...
Path and name of the text file to be created. The default path is the Quadstar 32-bit data 
path and the default name is ‘qspeclib.msp’.

[File Manager]
Choose the file using the file manager instead of entering it manually.

Function State
Status of the export function.

[Start]
Start export.

[Cancel]
Leave dialogbox.

The resulting text file consists of the following elements:

• Name of the component, normally capitals (e.g. ‘ACETIC ACID’)

• Formula of the component (e.g. ‘C2H4O2’)

• Number of peaks for this component (e.g. ‘11’)
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• Masses and relative intensities of this component (e.g. ‘43 999; 45 935; 60 576; 29 
156; 42 145; 28 56; 44 49; 31 45; 41 45; 46 14; 61 12; ‘). The mass number of the 
highest peak (here: 43 amu) is followed by its intensity (999), a semi-colon and a 
blank. Then the next mass number (45), intensity (935), semi-colon and blank follows 
etc. The highest intensity is always 999, all other intensities refer to this one. Inten-
sities lower than 0.05% of the highest intensity are disregarded, those between 
0.05% and 0.15% are displayed as ‘1’ etc.

This structure is repeated for every component.
Quadstar 32-bit, vpnb68e1 (0302) Utility 407



7.3 Installation menu
Install custom-specific extensions such as special sequences, parameter sets etc.:

Fig. 7-32

Current Installation
Current pathnames of your installation (they can be changed in Parameter Setup pro-
gram under [Setup] > [General]).

Installation Disk
Information concerning the running installation (will only occur when the installation is 
started).

Source Drive
Source drive, from which the extensions are to be read.

[Install]
Start installation.

[Cancel]
Leave dialogbox.

For such installations proceed as follows:

1 Make sure the above declared paths for parameters, data etc. match the ones you 
desire.

2 Choose the drive to read from in the field Source Drive (in this example: Drive a:, 
which contains the floppy disk that includes the extensions to install).

3 Choose [Install] to install or [Cancel] to leave without taking action; once the 
installation process is started, it cannot be cancelled any more.
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8. Process Control

NOTE:
If the Plasma Process Monitor PPM 422 is used, please see Chapter 8.8 Process 
Monitor PPM 422, 521.

8.1 Introduction
The Quadstar 32-bit sequencer is designed as a command interpreter. There are two 
methods for programming the individual sequencer lines (in program Parset, under 
[Sequence] > [Editor]):

• indirectly via dialog boxes ([Edit] > [Dialog]).

• through direct text input in the text editor.

A sequence essentially comprises a series of instructions (e.g. MID(), ScanAnalog(), 
etc.). An instruction comprises the name, followed by an opening and closing parenthe-
sis. These two parentheses delimit the parameter input field.

NOTE:
Certain parameters are mandatory while others can be selected as options.

If an optional parameter is not specified explicitly, the sequencer inserts the de-
fault value (for example, setting “prot=off” is not necessary).
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8.2 Programming

8.2.1 Input via the keyboard

This input method is intended for experienced users and requires thorough familiarity 
with the command syntax. The text is entered directly at the position in the sequence 
line selected with the cursor. Enter inserts a new line, Del , Backspace and Ins have the 
same functions normally found in text input programs.

8.2.2 Input via dialog editor

Set the cursor to an instruction (e.g. MID) and select [Edit] > [Dialog] or click with the 
right mouse button. The dialog editor containing all possible parameters of this instruc-
tion will show up. You may as well select [Edit] > [Dialog] on an empty line; in the now 
appearing window, choose the desired instruction and click [OK]. The dialog editor will 
be displayed then as well.

NOTE:
During the familiarization phase you should use the dialog editor. The advantage 
is, that incorrect entries are avoided to a great extent.
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8.3 Variables
The Quadstar 32-bit sequencer works with the following types of variables:

Integer
Integer variables, range -1’000’000 ... +1’000’000.

Float
Floating point variables, range -1E+37 ... .+1E+37, resolution 15 decimal places.

String
Text, stored as character strings.

Integer- as well as Float- variables are internally handled with higher accuracy than out-
lined above. But the input and output arguments of Quadstar 32-bit instructions must be 
within those ranges.

The variables are represented as arrays and, depending on the type, have either local 
or global validity.

These arrays have fixed names and are defined as follows:

The size of these arrays can be entered in the Parameter Setup program under 
[Sequence] > [Editor] > [Options] > [Parameter Limits] and is designated as the config-
urable maximum in the description of the individual sequencer instructions.

NOTE:
The first group, the local arrays i[] and f[], are specific to the sequence. These 
variables are known only to the current sequence and the declared array size ap-
plies only to this sequence.

The second group (gi[], gf[], gfa[] and gs[]) are global arrays. The declared size 
applies to all sequences and the arrays are also known to the sequences called 
by Sequence() or SeqExit().

gs[] is a global array in which character strings such as filenames, messages etc. can 
be stored. The different array types can be loaded with the SetString() instruction.

The index of an array must be either an integer number or an element of the array i[] or 
gi[]; further nesting of indices is not allowed.

i[] Local integer variable array.

f[] Local float variable array.

gi[] Global integer variable array.

gf[] Global float variable array.

gfa[] Global float variable field size N × 64 for 
storing measured values, calculated values 
etc.

gs[] Global array of character strings for defining 
messages, error messages and file names. 
The length of a character string must not 
exceed 100 characters.
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Examples

Right:

f[2], gfa[gi[12]], gfa[i[24]], gs[gi[5]], etc.

Wrong:

f[i[i[2]]], gfa[gi[i[3]]], gfa[f[2]], etc.

8.3.1 Local integer variables i[..]

Description:
Local array of integer variables (known only to the current sequence)

Syntax:
i[xx]

Parameters:
xx - Index (0 ≤ xx ≤ configurable maximum)

Example(s):
i[5], i[0], i[i[7]], ...

8.3.2 Global integer variables gi[..]

Description:
Global array of integer variables (known also to sequences called by the Sequence() 
and SeqExit() instructions).

Syntax:
gi[xx]

Parameters:
xx - Index (0 ≤ xx ≤ configurable maximum)

Example(s):
gi[22], gi[10], gi[i[12]], ...

8.3.3 Local float variables f[..]

Description:
Local Array of float variables (known only to the current sequence).

Syntax:
f[xx]

Parameters:
xx - Index (0 ≤ xx ≤ configurable maximum)
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Example(s):
f[43], f[1], f[gi[9]], ...

8.3.4 Global float variables gf[..]

Description:
Global array of float variables (known also to sequences called by the Sequence() and 
SeqExit() instructions).

Syntax:
gf[xx]

Parameters:
xx - Index (0 ≤ xx ≤ configurable maximum)

Example(s):
gf[12], gf[90], gf[i[0]], ...

8.3.5 Global field of float variables gfa[..][..]

Description:
Global field of float variables (known also to sequences called by the Sequence() and 
SeqExit() instructions).

Syntax:
gfa[xx][yy]

Parameters:
xx - Array vector number (0 ≤ xx ≤ configurable maximum)

yy - Array index number (0 ≤ yy ≤ 63)

Example(s):
gfa[0][5], gfa[i[8]][gi[28]]

8.3.6 Global character string gs[..]

Description:
Global array of character strings (known also to sequences called by the Sequence() 
and SeqExit() instructions). The maximum length of a character string is 100 charac-
ters.

Syntax:
gs[xx]

Parameters:
xx - Index (0 ≤ xx ≤ configurable maximum)

Example(s):
gs[0], gs[i[4]], gs[gi[2]]
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8.4 Sequencer instructions

8.4.1 General information

8.4.1.1 Syntax of a sequencer instruction

Per line only one instruction is allowed. The instructions all have the same format. They 
consist of the name and a list of parameters (between parentheses):

Instruction(parameter list)

Example:
The instruction Delay() has one mandatory (tim) and two optional parameters (unit and 
d). The first optional parameter (unit) relates to the mandatory tim parameter (can be 
recognized by the separator ‘;’). By default, unit is set to s (seconds):

Delay(Time=tim[;unit][,Disp=d])

Delay Designates the name of this instruction. 

(...) The name is followed by a parameter list between parentheses.

Time Time is a keyword. Since it’s not located between parentheses, it is mandatory. 
Keywords are emphasized with bold letters and are always followed by a ‘=’ 
character.

= Assign a value to the parameter

tim tim is the parameter value assigned to the keyword Time.

[ ] Brackets identify optional parameters. Optional parameters need to be 
declared only if they differ from the default value. These brackets have only 
symbolic value and are not actually entered.

{} These braces identify configuration-dependent parameters. They need to be 
declared only if this is required by the configuration (hardware, communication 
type etc.). These braces have only symbolic value and are not actually entered.

Example: Define the Unit (QMS) if Quadstar 32-bit runs in multiplex mode
SetDO(var{;unit}=state[;tim[;unit]][,Disp=d])

_ The underscore indicates that the command does not end here and that it is 
continued on the next line. It has symbolic value only and is not actually 
entered. Its purpose is to make the syntax and code lines more readable in this 
documentation.

Example:
DDERequest(Service=ServName, Topic=TopName,_

Item=ItemName, Data=Dat)

; Is located inside the brackets and serves as a separator between the individual 
values if a parameter consists of multiple specifications such as Time=5;min. 
The character ‘;’ indicates that min relates to 5.

unit unit is an optional parameter. Only the specific character sequences ms, s, 
min, h, may be entered for this parameter.
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Examples:
Delay(Time=10)
Delay(Time=10;min)
Delay(Time=10;min,Disp=on)
Delay(Time=10;min,Disp=default)

8.4.1.2 Default values

In the description of the instruction parameters, the default values (they don’t have to be 
declared explicitly) are listed between brackets. An example is the default value “sec-
onds” in an instruction containing a time specification. The Delay instruction e.g. has the 
following syntax:

Delay(Time=tim[;unit][,Disp=d])

The parameters ;unit and ,Disp=d in brackets are optional. If they are not declared, the 
compiler sets them to default values:

• Parameters without a keyword (such as unit etc.) are initialized to a default value that 
cannot be changed.

• Parameters with a keyword (such as Disp, Prot etc.) are initialized to a default value 
that can be altered by the SetDefault() instruction.

In the sequencer line:

Delay(Time=10;min)

the time specification 10 is interpreted as minutes because of the subsequent (optional) 
parameter min.

The following initialization table applies to the SetDefault() instruction:

The default value is loaded with the initialization value when the main sequence is 
started and is valid also for the called sub-sequences. This way it is possible, for exam-
ple, to switch the printer log on or off from a central location, i.e. it does not have to be 
specified in each instruction.

If you are programming by [Edit] > [Dialog], you can choose the values from list boxes. 
Optional parameters are accessed by pushbuttons (e.g. [Disp]). Without an explicit dec-
laration, all optional parameters are set to their default values and are not displayed. If 
you use the dialog editor to program a Delay() instruction e.g.

Disp Disp is the second optional parameter. It is used to switch the display on or off 
and can be set to [default], off or on with ‘=’.

, When a keyword is entered manually, it must be preceded by a comma.

Keyword Designation Initialization value

Disp Display mode tab

Prot Protocol mode off
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Fig. 8-1

and you click on [Options] > [Disp] > [default],

Fig. 8-2

this means ‘Disp not specified’; “,Disp=default” will not be displayed therefore:

Delay(Time=10;min)

8.4.1.3 File names with indices

In all sequencer instructions that contain file or program names, an index may be 
appended to those names. This enables you e.g. to

• save measure data to files, whose names are consecutively ‘numbered’ (indiced).

• perform a series of different measurements by a single loop, if the corresponding pa-
rameter files are indiced.

• execute different indiced batch programs comfortably (by using one loop).

The file index is a number in the range 0 ≤ Index ≤ 1’000’000, that is appended to the 
file’s or program’s name. Please note that this new name including the index number 
may not exceed 255 characters.

The actual file name is built using the following rules:

• File name with index contains less than 8 characters:
Zeros are inserted before the index until the length equals 8 characters.

• File name contains less than 8 characters, and the file name with index contains 
more than 8 characters:
Index is simply appended to the file name.

• File name contains 8 or more characters:
Index is extended to 5 digits with leading zeros and then appended to the file name.

Examples:
'Name="air";5'
results in “air00005”
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'Name="c:\par\air";17'
results in “c:\par\air00017”

'Name="c:\par\airdemo";5'
results in “c:\par\airdemo5”

'Name="c:\par\airdemo";125'
results in “c:\par\airdemo125”

'Name="c:\par\newairdemo";125'
results in “c:\par\newairdemo00125”

You may set the index by:

Application examples:
// Start 'batprog1', then 'batprog5'
Execute(Prog="batprog";1)
Execute(Prog="batprog";5)
// Measure 10 AnalogScans by using the parameter files 'airmeas0'
// to 'airmeas9' and save the data in 'scan0000' to 'scan0009'
Loop(i[0]=0;9)

ScanAnalog(Par="c:\par\airmeas";i[0], SaveCyc="scan";i[0])

8.4.1.4 String values

In all sequencer instructions that contain strings, those strings may be extended by so 
called string values: any data object (text, integer number, float number; direct input or 
element of an array) is being defined as the string value and inserted at a certain position 
of the original string. The position to insert the string value is marked by an ‘@’ charac-
ter. The first encountered ‘@’ character in the string is replaced by the string value. If the 
string doesn’t contain an ‘@’ character, the string value is appended to the original 
string.

Examples:
The string value is defined as the integer number ‘422’:

'Name="q@name";422'

results in the text “q422name”.

'Name="qname";422'

results in the text “qname422”.

Now the string value is 3.1416 and is stored in the global float array gf[0]; it is to be 
inserted in a text:

'Text="Pi is @ approx.";gf[0]'

results in the text “Pi is 3.1416 approx.”.

cc Numeric value (integer)

i[xx] Element xx of the local integer array

gi[xx] Element xx of the global integer array
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Finally the name of a unit (“Prisma5”) that’s stored in the global string array gs[11] shall 
be appended to a message:

'Message="Alarm at ";gs[11]'

results in the text “Alarm at Prisma5”.

You may set string values by:

8.4.1.5 Syntax of a sequence

The compiler indents the lines belonging to one instruction by one horizontal tab stop in 
order to keep the program readable. If an instruction is followed by a block, the latter 
must be marked by Begin and End:

// Test digital input 12 (channel 12) for off
IfDI(12=off)
Begin

// Wait 5 seconds
Delay(Time=5)
// Switch the digital output 8 (channel 8) on
SetDo(8=on)

End

Begin and End themselves are not indented, but only the instructions belonging to the 
block. Wrong indentations are detected by the compiler and corrected. In the case of an 
If-Else instruction this can lead to ambiguities. See Chapter 8.4.2.1 If-Else instructions, 

419.

NOTE:
The width of the indentation is twice the width of the letter ‘B’. It can be changed 
in the Parameter Setup program under [Sequence] > [Editor] > [Options] > [Dis-
play].

cc Direct input of a numeric value (integer or float).

i[xx] Element xx of the local integer array.

gi[xx] Element xx of the global integer array.

f[xx] Element xx of the local float array.

gf[xx] Element xx of the global float array.

gfa[xx][yy] Element xx/yy of the global float field.

gs[xx] Element xx of the global character string array.
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8.4.2 Control structures

8.4.2.1 If-Else instructions

For conditional instructions (IfDI(), IfString() etc.) the same If-Else syntax is always 
used, where the Else portion is optional; the following syntax applies:

Ifxxx(condition)
statement1

or

Ifxxx(condition)
statement1

Else
statement2

xxx = instruction type like DI, DO, Emi, etc.

If condition is true, statement1 is executed. Otherwise statement2 is executed if an Else 
part exists.

statement1 and statement2 represent individual instructions such as:

IfDI(12=off) // Test digital input channel 12 for off state
Delay(Time=5) // Wait 5 seconds

Else
Delay(Time=10) // Wait 10 seconds

or a block of instructions (See Chapter 8.5.1 Definition of blocks, 426):

IfDI(12=off) // Test digital input (channel 12) for off
Begin

Delay(Time=5) // Wait 5 seconds
SetDo(8=on) // Switch digital output 8 (channel 8) to on

End
Else
Begin

Delay(Time=10) // Wait 10 seconds
SetDo(12=on) // Switch digital output 12 (channel 12) on

End

Since the Else part of an If-Else instruction is optional, a missing Else part in nested If 
instructions may cause ambiguity. The compiler associates any Else part to the last If 
for which no Else part exists. For example in:

IfDI(12=off) // Test digital Input channel 12 for off state
IfDi(14=on) // Test digital Input channel 14 for on state

Delay(Time=1;min) // Wait 1 minute
Else

Delay(Time=10;min) // Wait 10 minutes

the Else part belongs to the inner If, as is implied by the indentation. But if the Else part 
belongs to the outer If, Begin and End statements must be inserted to force correct 
association:
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IfDI(12=off) // Test digital input channel 12 for off state
Begin

IfDi(14=on) // Test digital input channel 14 for on state
Delay(Time=1;min) // Wait 1 minute

End
Else

Delay(Time=10;min) // Wait 10 minutes

Always set instruction blocks within nested If-Else structures between Begin and End 
to avoid errors. Indentations are not recognized by the compiler as associations. They 
are corrected according to the compiler rules, which might cause logical mistakes that 
are hard to find.

8.4.2.2 Loop instructions

8.4.2.2.1 Loop()

The following syntax is used for defining a Loop():

Loop(expr1; expr2; expr3)
statement

NOTE:
The configurable maximum for the loop variable can be set in the Parameter Setup 
program under [Sequence] > [Editor] > [Options] > [Parameter Limits].

Examples:
// Perform loop with i[8]=0 to i[8]=30,Step = 2
// Set digital output 0,2,4,6, ... 30 on
Loop(i[8]=0;30;2)

SetDO(i[8]=on)

// Perform loop with i[8]=12 to i[8]=0,Step = -1
// Set digital output 12,11,10 ... 0 on
// Wait 10 seconds after each DO setting
Loop(i[8]=12;0;-1)
Begin

SetDO(i[8]=on)
Delay(Time=10)

expr1 Is the initialization of the loop variable. The loop variable must be a valid 
element of the local (i[xx]) or the global (gi[xx]) integer array. The index xx 
must be within the range of 0 ≤ xx ≤ Max (Max = configurable maximum).

expr2 Is the exit condition. When expr1 reaches expr2, the loop is exited.

expr3 Is the increment that is added to expr1 after each loop execution before 
expr2 is checked; expr3 is a positive or negative integer within the range -
1’000’000 ≤ expr3 ≤ +1’000’000.

statement represents an individual instruction such as SetDO() or a block of instruc-
tions. See Chapter 8.5.1 Definition of blocks, 426.
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End

8.4.2.2.2 While instructions

There are two types of While instructions:

• WhileDI() and WhileDO() only accept equality comparison to on or off:

// Wait while DI channel 12 remains on
WhileDI(12=on)

// Wait while DO channel 3 remains off
WhileDO(3=off)

• WhileMeaVal() and WhileVar() accept several comparison operators, that is =, <, >, 
<=, >= and <>.

Additional loop termination conditions can be specified for all While loops. The termina-
tion criteria ‘Count’ and ‘Time’ defined with the two keywords Break and BreakTime can 
be used for exiting a loop if the main criteria is never reached due to malfunctions or 
unexpected process conditions, etc.

Break
Break sets a counter that is decremented by one during each loop pass.

BreakTime
BreakTime defines a time after which the loop is exited if no other condition has 
responded.

If one of these two conditions becomes true, i.e. if the test variable var of Break has 
reached zero or if the time specified with BreakTime has run down, the Break sequence 
defined as an option under the keyword BreakSeq is started.

Examples:
// Wait until the intensity of channel 12 >= 9E-10
WhileMeaVal(12<9E-10,par="d:\qs\par\myfile",Mode=integral)

Delay(Time=60)

If several instructions shall be performed within the While loop, they must be defined as 
a block using Begin and End (See Chapter 8.5.1 Definition of blocks, 426):

// Perform a MID measurement and a calculation until the content
// of element 21 of the global float array >= 45.5
//
WhileVar(gf[21]<45.5)

Begin
MID(Par="midpar",SaveGfa=0)
Calculate(gf[21]=gfa[0][0]*srt(2)/10)

End

// Purge the gas inlet until element 2 of the local integer array
// has reached a value of 3.
// After 60 passes or max. 60 seconds the While loop shall be
// cancelled and the sequence "c:\qs\par\seq" be executed.
// 
WhileVar(i[2]=3,Disp=on,Break=60,BreakTime=60;s,_
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BreakSeq="c:\qs\par\seq")
Begin

SetDO(5=off)
Delay(Time=5)
SetDO(6=on)
Delay(Time=1)
SetDO(6=off)
SetDO(5=on)
IfMeaVal(3>1E-5,par="testpar")

SetVar(i[2]=0)
End

8.4.3 Log output

In sequencer mode, Quadstar 32-bit allows buffered output of a line-by-line log instead 
of the page-by-page printing that’s normally performed by Windows®. Changeover: See 
Chapter 3.7.3.5 Log output, 231.

Quadstar 32-bit uses a phyiscal printer port for line-by-line printing. A printer driver has 
to be installed and connected to a port like shown in the following screenshot:

Fig. 8-3

For detailed information about installing printer drivers, please refer to the Windows® 
documentation or online-help.

If the printer fails for any reason (paper out, paper jam, power fail etc.), the sequence 
continues and the lines that could not be printed are stored in a temporary file. After a 
while the following message (which does not prevent the program execution) appears:
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Fig. 8-4

Get the printer ready and switch it online, then choose [Yes] to print the missing lines. If 
the program has already been terminated, the lines can although be printed by using the 
Quadstar 32-bit PrintManager:

Fig. 8-5

Double click on the icon (shown above) in the program group Quadstar 32-bit; the Print-
Manager (which normally only shows up as a symbol while a sequence is running) dis-
plays the following message:

Fig. 8-6

Choose [No] to prevent the stored lines from being deleted. Click again on the icon , then 
this window will show up:

Fig. 8-7

Get the printer ready, switch it online and choose [File] > [Print/Delete Data Files] 
C:\TEMP\PRTEXEx.DAT. The missing lines will now be printed, presumed they were 
written to the buffer file.
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8.4.4 Data exchange with other programs (DDE)

The Quadstar 32-bit sequencer can exchange data with other programs. For that, the 
feature DDE (Dynamic Data Exchange) supplied by Windows® is used. It allows two 
running programs to pass data to each other. The DDE interface of Quadstar 32-bit 
passes data elements always as strings.

Quadstar 32-bit can act in two ways as a DDE supplier:

8.4.4.1 Passive data exchange

The sequence places its global variables (exclusively those) to other programs’ dis-
posal. They are allowed to read and write these variables. The sequence thus supplies 
a Service, that may be used by other programs.

The service is initialized by DDEInit(...).

Example:
You want to perform a MID measurement of helium 100-times and display the result in 
an EXCEL sheet.

Quadstar 32-bit sequence:

DDEInit(Service="quadserv").
Loop(i[0]=1;100)

MID(Par="c:\qs32bit\par\helium4.mip", SaveGfa=0)
DDEClose()

Entry in the field of the Excel sheet to show the result:

=quadserv|Data!'gfa[0][0]'

This is the far reference formula of Excel. The entries mean:

You notice, that the value in the Excel sheet changes only, if you tell Excel to update it.

8.4.4.2 Active data exchange

The sequence sends data (global or local variables) to other applications 
(DDEPoke(...)) or requests data from them (DDERequest(...)) by its own. It uses the 
Service that must be supplied by the other application.

quadserv: Name of the Quadstar 32-bit service, any name possible

| Vertical line

Data Topic name, in Quadstar 32-bit always ‘Data’

! Exclamation mark

gfa[0][0] Item, in Quadstar 32-bit always a global variable
424 Process Control vpnb68e1 (0302), Quadstar 32-bit



Example:
You want to perform a MID measurement of helium 100-times and display the result in 
an Excel sheet. This time it’s not Excel that asks for the values, but Quadstar 32-bit itself 
who writes them (actively) in row 1, column 1 of the Excel sheet ‘Sheet1’. At the end, 
Quadstar 32-bit asks for the value of the field in Sheet1, row 1, column 2 and saves it in 
gi[0].

Quadstar 32-bit sequence:

Loop(i[0]=1;100)
Begin

MID(Par="c:\qs32bit\par\helium4.mip", SaveGfa=0)
DDEPoke(Service="Excel", Topic="Sheet1", Item="r1c1",_

Data=gfa[0][0])
End
DDERequest(Service="Excel", Topic="Sheet1", Item="r1c2",_

Data=gi[0])

The current values are continuously refreshed in the Excel sheet.

Other properties:

• You may let two or more Quadstar 32-bit or other applications exchange data with 
each other, but each service must have its own name.

• The properties of the service of an application must be known, if you want to use it 
(e.g. Excel, see example above).

• A Quadstar 32-bit sequence can provide a service (passively, DDEInit()) and send 
or request data (actively, DDEPoke()/DDERequest()) at the same time.

• The sequence can make a program execute a certain instruction by 
DDEExecute(...). There are programs that allow execution of internal instructions 
(e.g. macros etc.) by DDE call. Quadstar 32-bit instructions cannot be executed di-
rectly by DDE calls.
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8.5 Auxiliary instructions

8.5.1 Definition of blocks

The expressions Begin and End are used to combine declarations and statements into 
a block. Such a block is handled by the compiler like a single instruction.

For example, you can use Begin and End after functions such as IfDI(), Loop(), 
WhileDI() etc. to execute a set of instructions depending on certain conditions.

8.5.1.1 Begin instruction block

Description:
Mark the begin of an instruction block.

Syntax:
Begin

Parameters:
None.

Example(s):
Loop(i[5]=1;10)
Begin

SetDO(5=on)
Delay(Time=1;min)

End

The instructions between Begin and End are performed 10 times.

8.5.1.2 End instruction block

Description:
Mark the end of an instruction block.

Syntax:
End

Parameters:
None.

Example(s):
Loop(i[5]=1;10)
Begin

SetDO(5=on)
Delay(Time=1;min)

End

The instructions between Begin and End are performed 10 times.
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8.5.1.3 Entering a blank line

Description:
Blank line. You can enter blank lines to keep the program readable; they do not influence 
the program execution.

Syntax:

Parameters:
None.

Example(s):
SetDO(12=on)

Loop(i[3]=1;5)
Begin

SetDO(14=on)
Delay(Time=1)
SetDO(14=off)
Delay(Time=1)

End

MID(Par="sample")

To give the program a structure and thus improve its readability, a blank line has been 
inserted before and after the loop and its instruction block.

8.5.2 Else instruction

If the condition of an If instruction is not true, the instruction following the Else statement 
is performed. The Else can also be followed by a block of instructions between Begin 
and End statements. If Else is true, the entire block of instructions will be processed.

Description:
Covers the “Else” situation of an If instruction.

Syntax:
Else

Parameters:
None.

Example(s):
IfVar(gi[1]=45)

SetDO(5=on)
Else

SetDO(5=off)

If gi[1] has a value of 45, open valve 5, else close valve 5.

IfVar(f[3]>1E-6)
SetDO(i[2]=on)

Else
SetDO("valve3"=off)
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If f[3] is greater than 1E-6, set Digital Output i[2] on, else close “valve3”.

8.5.3 Comments

8.5.3.1 Comments comprising multiple lines

All lines between the begin comment (‘/*’) and end comment (‘*/’) symbols are inter-
preted as comment. Comment symbols may be nested, i.e. within a comment block 
there may be another comment block.

8.5.3.1.1 /* - Begin comment

Description:
Begin comment

Syntax:
/*

Example(s):
See Chapter 8.5.3.1.2 */ - End comment, 428

8.5.3.1.2 */ - End comment

Description:
End comment. Lines between the begin comment (‘/*’) and end comment (‘*/’) symbols 
are treated as comments.

Syntax:
*/

Example(s):
/* Begin of comment
SetDO("Turbo"=on)
MID(Par="measure")
*/End of comment

These two program lines are temporarily not needed but should later be reactivated. 
They can be disabled by placing them between comment symbols.

8.5.3.2 // - Single line comment

Description:
Single line comment. If ‘//’ is set at the beginning of a line, the line is regarded as a com-
ment.

Syntax:
//
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Example(s):
// SetDO("Turbo"=on)
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8.6 Example of a sequence

8.6.1 Sequence AIRDEMO
---------------------------------------------------------------
01 // Test Sequence <AIRDEMO.SEQ>
02
03 Message(Text="Hello, are you ready ?", Confirm=on)
04 SetPar(BarWidth=15, ColorMode=single, Cycles=50,_

DispOpt=last, LineType=solid, Marker=on, YRaster=on)
05
06 // GSC(Par="airdemo.gcp", Disp=on, Prot=off)
07 MSC(Par="airdemo.msp", CalMode=coarse, Disp=on,_

SaveMode=reset)
08 // ZeroGas(Par="airdemo.mip", Disp=on)
09
10 Message(Text="Calibration done, continue ?", Confirm=on)
11
12 Loop(i[1]=0;1)
13 Begin
14 Sequence(Par="didodem1.seq")
15 Sequence(Par="didodem2.seq")
16
17 Loop(i[0]=0;20)
18 Begin
19 MID(Par="airdemo.mip", Disp=tab, SaveGfa=0)
20 SetString(gs[0] = "MID measure cycle @, intensity of_

channel 0 = @ A";i[0])
21 // MCD(Par="airdemo.mcp", Disp=tab, SaveGfa=0)
22 // SetString(gs[0] = "MCD measure cycle @, concentration N2_

= @ %";i[0])
23 Message(Text=gs[0];gfa[0][0])
24 End
25
26 Loop(i[0]=0;20)
27 Begin
28 MID(Par="airdemo.mip", Disp=bar, SaveGfa=0)
29 SetString(gs[0] = "MID measure cycle @, intensity of_

channel 0 = @ A";i[0])
30 // MCD(Par="airdemo.mcp", Disp=bar, SaveGfa=0)
31 // SetString(gs[0] = "MCD measure cycle @, concentration N2_

= @ %";i[0])
32 Message(Text=gs[0];gfa[0][0])
33 End
34
35 Loop(i[0]=0;75)
36 Begin
37 MID(Par="airdemo.mip", Disp=vt, SaveGfa=0)
38 SetString(gs[0] = "MID measure cycle @, intensity of_

channel 0 = @ A";i[0])
39 // MCD(Par="airdemo.mcp", Disp=vt, SaveGfa=0)
40 // SetString(gs[0] = "MCD measure cycle @, concentration N2_

= @ %";i[0])
41 Message(Text=gs[0];gfa[0][0])
42 End
43 End
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---------------------------------------------------------------

NOTE:
The MCD measurements have been flagged with the comments symbol //.

8.6.2 User-controlled analysis (AIRDEMO2)

8.6.2.1 Quadstar 32-bit dialog box

Using the Dialog() instruction, you can program a user-controlled analysis.

The Dialog() instruction produces a Quadstar 32-bit dialog box that enables the opera-
tor to control the execution of an analysis. This control is supplied by Buttons; a return 
value can be assigned to each of the command buttons.

The dialog boxes produced with the Dialog() instruction offer the following functions:

• Labeled command buttons (keyword Button).
• Text output within the dialog box (keyword Text).
• Input of numeric values and texts (keyword Edit).
• Choose an entry from a list field (keyword Combo).
• Input a file name or choose it by using the file manager (keyword Filename).

Within the Dialog() instruction a return variable (keyword ReturnVar) is defined, that 
contains the return value:

• the assigned value rval, when one of the command Buttons is pressed.
• the value EnterVal, when the Enter key is pressed.
• the value EscapeVal, when the Esc key is pressed.

8.6.2.2 Sequence AIRDEMO2
---------------------------------------------------------------
01 // Test Sequence <AIRDEMO2.SEQ>
02 // Test Sequence <AIRDEMO2.SEQ>
03
04 Message(Text="Hello, are you ready ?", Confirm=on)
05
06 // Set Quadstar 32-bit parameter for sequence measure data_

display
07 SetPar(AlarmDisp=on, BarWidth=25, ColorMode=single,_

Cycles=50, DispOpt=last, LineType=solid, Marker=on,_
Scale=log, YRaster=off)

08
09 // Mass Calibration
10 Dialog(Box="Mass Calibration Save Mode ";200;200;370;140,_

ReturnVar=i[0], EnterVal=0, EscapeVal=-1,_
Button="&Append";20;20;150;40;1,_
Button="&Reset";190;20;150;40;2,_
Button="&No Mass Calibration";50;80;260;40;3)

11
12 // Mass Calibration Append
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13 IfVar(i[0]=1)
14 Begin
15 MSC(Par="airdemo.msp", CalMode=coarse, Disp=on)
16 Message(Text="Calibration done, continue ?", Confirm=on)
17 End
18
19 // Mass Calibration Reset
20 IfVar(i[0]=2)
21 Begin
22 MSC(Par="airdemo.msp", CalMode=coarse, Disp=on,_

SaveMode=reset)
23 Message(Text="Calibration done, continue ?", Confirm=on)
24 End
25
26 WhileVar(i[0]>=0, Disp=off)
27 Begin
28 // Select Measure Mode (MID, Scan Analog or Scan Bargraph)

Dialog(Box="Selection Menu"; 200; 200; 460; 420,_
ReturnVar=i[0], EnterVal=0, EscapeVal=-1,_
Text="Quadstar 32-bit Gas Inlet_
Control";90;25;280;20,_
Button="&Open Inlet";20;60;200;60;1,_
Button="&Close Inlet";240;60;200;60;2,_
Text="Quadstar 32-bit Measurement Mode";80;145;300;20,_
Button="&Multiple Ion Detection (MID)";70;180;320;60;3,_
Button="Scan &Analog";20;260;200;60;6,_
Button="Scan &Bargraph";240;260;200;60;7,_
Button="C&ancel";40;340;380;60;-1)

29
30 // Select MID Measure Mode (Table, Bargraph or Versus Time)
31 IfVar(i[0]=3)
32 Dialog(Box="MID Measure Mode Select";200;200;240;200,_

ReturnVar=i[0], EnterVal=0, EscapeVal=-1,_
Button="MID &Table";20;20;200;40;3,_
Button="MID &Bargraph";20;80;200;40;4,_
Button="MID &Intensity vs. Time";20;140;200;40;5)

33
34 // Enter number of Cyles
35 IfVar(i[0]>=3)
36 Dialog(Box="Cycles";200;200;390;60, ReturnVar=i[1],_

EnterVal=0, EscapeVal=-1,_
Text="Enter number of cycles 0...500 :";20;20;250;20,_
Edit=280;15;100;30;i[6])

37
38 IfVar(i[0]=0)
39 Message(Text="Please choose a button !")
40
41
42 // Open Inlet
43 IfVar(i[0]=1)
44 Sequence(Par="didodem1.seq")
45
46 // Close Inlet
47 IfVar(i[0]=2)
48 Sequence(Par="didodem2.seq")
49
50
51 // MID Table
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52 IfVar(i[0]=3)
53 Begin
54 Loop(i[5]=1;i[6])
55 Begin
56 MID(Par="airdemo.mip", Disp=tab, Prot=off, SaveGfa=0)
57 SetString(gs[0] = "MID measure cycle @,_

ion current of channel 0 = @ A";i[5])
58 Message(Text=gs[0];gfa[0][0])
59 End
60 End
61
62 // MID Bargraph
63 IfVar(i[0]=4)
64 Begin
65 Loop(i[5]=1;i[6])
66 Begin
67 MID(Par="airdemo.mip", Disp=bar, Prot=off, SaveGfa=0)
68 SetString(gs[0] = "MID measure cycle @,_

ion current of channel 0 = @ A";i[5])
69 Message(Text=gs[0];gfa[0][0])
70 End
71 End
72
73 // MID Versus Time
74 IfVar(i[0]=5)
75 Begin
76 Loop(i[5]=1;i[6])
77 Begin
78 MID(Par="airdemo.mip", Disp=vt, Prot=off, SaveGfa=0)
79 SetString(gs[0] = "MID measure cycle @,_

ion current of channel 0 = @ A";i[5])
80 Message(Text=gs[0];gfa[0][0])
81 End
82 End
83
84
85 // Scan Analog
86 IfVar(i[0]=6)
87 Begin
89 Loop(i[5]=1;i[6])
90 Begin
91 Message(Text="Scan Measure, Scan Analog # @";i[5])
92 ScanAnalog(Par="airdemo.sap", Disp=on)
93 End
94 End
95
96 // Scan Bargraph
97 IfVar(i[0]=7)
98 Begin
99 Loop(i[5]=1;5)
100 Begin
101 Message(Text="Scan Measure, Scan Bargraph # @";i[5])
102 ScanBar(Par="airdemo.sbp", Disp=on, Prot=off)
103 End
104 End
105
106 End
---------------------------------------------------------------
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8.6.2.2.1 Description of AIRDEMO2

The example AIRDEMO2.SEQ demonstrates partially nested Dialog() instructions. In 
all Quadstar 32-bit dialog boxes of AIRDEMO2, the variable i[0] is used as the return 
value.

With the first dialog box (Mass Calibration Save Mode), the user is requested to perform 
a mass calibration. A choice between the Append and Reset mode is offered.

10 Dialog(Box="Mass Calibration Save Mode ";200;200;370;140,_
ReturnVar=i[0], EnterVal=0, EscapeVal=-1,_
Button="&Append";20;20;150;40;1,_
Button="&Reset";190;20;150;40;2,_
Button="&No Mass Calibration";50;80;260;40;3)

This Dialog() instruction produces the following Quadstar 32-bit dialog box:

Fig. 8-8

The return variable can be loaded with the following values:

•  -1: Esc key has been pressed, cancel the sequence.
•  0: Enter key has been pressed
•  1: Mass calibration Append
•  2: Mass calibration Reset
•  3: No mass calibration

The input is evaluated immediately:

12 // Mass Calibration Append
13 IfVar(i[0]=1)
14 Begin
15 MSC(Par="airdemo.msp", CalMode=coarse, Disp=on)
16 Message(Text="Calibration done, continue ?", Confirm=on)
17 End
18
19 // Mass Calibration Reset
20 IfVar(i[0]=2)
21 Begin
22 MSC(Par="airdemo.msp", CalMode=coarse, Disp=on,_

SaveMode=reset)
23 Message(Text="Calibration done, continue ?", Confirm=on)
24 End

An analysis can be controlled via the return variable by systematically using IfVar() and 
WhileVar() instructions. For canceling via the Esc key (i[0] = -1) the WhileVar() instruc-
tion can, for example, be used as follows:

WhileVar(i[0]>=0, Disp=off)
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Begin
// Select Measure Mode (MID, Scan Analog or Scan Bargraph)

Dialog(Box="Selection Menu";200;200;460;420, ReturnVar=i[0],_
EnterVal=0, EscapeVal=-1, Button="Open ...

...

...

...
End

In the individual dialog boxes, the variable can be loaded with the following values:

First the Quadstar 32-bit dialog box Selection Menu is called. The array element i[0] con-
tains a return value of 0 (Enter key), -1 (Esc key or [Cancel] command button) depending 
on the selected command button 1, 2, 3, 6 or 7:

28 // Select Measure Mode (MID, Scan Analog or Scan Bargraph)
Dialog(Box="Selection Menu"; 200; 200; 460; 420,_

ReturnVar=i[0], EnterVal=0, EscapeVal=-1,_
Text="Quadstar 32-bit Gas Inlet_
Control";90;25;280;20,_
Button="&Open Inlet";20;60;200;60;1,_
Button="&Close Inlet";240;60;200;60;2,_
Text="Quadstar 32-bit Measurement Mode";80;145;300;20,_
Button="&Multiple Ion Detection (MID)";70;180;320;60;3,_
Button="Scan &Analog";20;260;200;60;6,_
Button="Scan &Bargraph";240;260;200;60;7,_
Button="C&ancel";40;340;380;60;-1)

This Dialog() instruction produces the following Quadstar 32-bit dialog box:

Value Quadstar 32-bit dialog box
“Selection Menu”

Quadstar 32-bit dialog box
“MID Mode Selection Menu”

-1  Esc key has been pressed Esc key has been pressed

0 Enter key has been pressed Enter key has been pressed

1 Open gas inlet ----

2 Close gas inlet ----

3 Multiple Ion Detection MID MID Table

4 ---- MID Bargraph

5 ---- MID Versus Time

6 Scan Analog ----

7 Scan Bargraph ----
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Fig. 8-9

If Multiple Ion Detection (MID) is chosen, i[0] contains a value of 3. Through the decision 
IfVar (i[0]=3) the next Quadstar 32-bit dialog box MID Measure Mode Select is offered 
for choosing the MID measurement mode.

The return value is again assigned to the variable i[0], i.e. i[0] contains a return value of 
3, 4 or 5 (or 0, or -1), depending on the selected command button:

30 // Select MID Measure Mode (Table, Bargraph or Versus Time)
31 IfVar(i[0]=3)
32 Dialog(Box="MID Measure Mode Select";200;200;240;200,_

ReturnVar=i[0], EnterVal=0, EscapeVal=-1,_
Button="MID &Table";20;20;200;40;3,_
Button="MID &Bargraph";20;80;200;40;4,_
Button="MID &Intensity vs. Time";20;140;200;40;5)

This Dialog() instruction produces the following Quadstar 32-bit dialog box:

Fig. 8-10

In the last Quadstar 32-bit dialog box, the operator is requested to enter the number of 
measurement cycles. The entered value (number of cycles) is returned via the variable 
i[6]:

34 // Enter number of Cyles
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35 IfVar(i[0]>=3)
36 Dialog(Box="Cycles";200;200;390;60, ReturnVar=i[1],_

EnterVal=0, EscapeVal=-1,_
Text="Enter number of cycles 0...500 :";20;20;250;20,_
Edit=280;15;100;30;i[6])

This Dialog() instruction produces the following Quadstar 32-bit dialog box:

Fig. 8-11

After this input the desired measurement is started. The variable i[5] is used as the loop 
counter.

The following example illustrates the course of the sequence if e.g. Intensity vs Time has 
been selected:

...

...
26 WhileVar(i[0]>=0, Disp=off)
27 Begin
...
...
73 // MID Versus Time
74 IfVar(i[0]=5)
75 Begin
76 Loop(i[5]=1;i[6])
77 Begin
78 MID(Par="airdemo.mip", Disp=vt, Prot=off, SaveGfa=0)
79 SetString(gs[0] = "MID measure cycle @,_

ion current of channel 0 = @ A";i[5])
80 Message(Text=gs[0];gfa[0][0])
81 End
82 End
...
...
106 End

The execution of this loop produces the following measurement data window:
Quadstar 32-bit, vpnb68e1 (0302) Process Control 437



Fig. 8-12
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8.7 Sequencer instructions

8.7.1 Calculate() - Perform a calculation

Description:
Perform a calculation.

Calculate() determines the result of the formula defined under formula and assigns it to 
the variable var. The content of this variable can later be stored in a file via the Process() 
instruction and/or displayed on the screen.

Through the options Name and Unit, a name and/or unit of measure can be assigned to 
the variable (var). The name is subsequently used for identifying the block:

• when the data are processed by the Process() instruction.
• when stored data are shown in the Display Saved Values program.

An individual scale may be assigned to the variable as well.

NOTE:
Of the data calculated with the Calculate() instruction and stored in the gfa[][] 
data field, only those are taken into consideration in the Process() instruction to 
which names have been assigned. All other data of the Calculate() instruction are 
regarded as intermediate results.

Syntax:
Calculate([ScaleID=scID,][Name=name[;strval],][Unit=unit,]_

var=formula)

Parameters:

ScaleID Keyword for scale identification.

scID Number of the scale (defined by the instruction ‘SetScale’).
• cc - Direct input of a numeric value (0 ... 199).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Name Keyword for variable name.

name Name of the variable (max. 12 characters) 
• gs[xx] - Element xx of the global string array. 
• “xxxxxx” - Direct input of the variable name.

strval String value - See Chapter 8.4.1.4 String values, 417

Unit Keyword for unit of measure.

unit unit of measure that fits the result (max. 12 characters) 
• gs[xx] - Element xx of the global string array. 
• “xxxxxx” - Direct input of the unit of measure.
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Example(s):
Calculate(i[3]=(i[4]+gi[5]-2)*3)

Simple calculation with basic operations and assignment of the result to the variable i[3].

Calculate(Name="Temperature";i[8],Unit="°C", gf[24]=(f[4]/i[0]_
+log(srt(gfa[12][i[4]]*12.5)-3.2)+sqr(f[8]))/2)

A more complicated calculation with functions and nested expressions. The result is 
assigned to element 24 of the global float array gf[]. This variable (gf[24]) is given the 
name TemperatureX before and the unit °C is assigned to it, where X is the content of 
i[8] (e.g. Temperature9).

var Variable to assign the result of the calculation to
• i[xx] - Element xx of the local integer array. 
• gi[xx] - Element xx of the global integer array. 
• f[xx] - Element xx of the local float array. 
• gf[xx] - Element xx of the global float array. 
• gfa[xx][yy] - Element xx/yy of the global float field.

formula Input of the calculation formula. This formula can comprise up to 128 
characters. Nesting of function calls is permitted (e.g. srt(abs(gf[3]))). All 
float and integer array element types can be used: 
• cc - Direct input of a numeric value (integer or float). 
• i[xx] - Element xx of the local integer array. 
• gi[xx] - Element xx of the global integer array. 
• f[xx] - Element xx of the local float array. 
• gf[xx] - Element xx of the global float array. 
• gfa[xx][yy] - Element xx/yy of the global float field. 

In an index specification only simple nesting is permitted. In addition to 
the direct specification (e.g. i[12], f[10]) the index itself may be an ele-
ment of an integer array, i.e. also expressions such as i[gi[10]], 
gi[gi[15]], etc. may be entered.

The following functions and operations are possible:
•  +,-,*,/ - Basic operations.
•  () - Parenthesized expressions.
•  exn(x) - Calculation of e to the power of x
•  exp(x) - Calculation of 10 to the power of x.
•  lgn() - Calculation of the logarithm, base e.
•  log() - Calculation of the logarithm, base 10.
•  sqr() - Squaring.
•  srt() - Calculation of the square root.
•  abs() - Determination of the absolute value.

These functions may be nested, i.e. other functions may be specified 
within parentheses. 

Example:
log(srt(gfa[12][i[4]]*12.5)-3.2).

Input of blanks is admissible but they are removed during the syntax 
check of the formula.

Integer fractions are rounded arithmetically:

0.49 => 0 0.51 => 1.
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8.7.2 DDEClose() - Close DDE Service

Description:
Close the DDE service that has been initialized in the sequence beforehand.

Syntax:
DDEClose()

Parameters:
None

Example:
See Chapter 8.4.4 Data exchange with other programs (DDE), 424.

8.7.3 DDEExecute() - Call an instruction in an application by 
DDE

Description:
Call an instruction in another program by DDE.

See Chapter 8.4.4 Data exchange with other programs (DDE), 424.

Syntax:
DDEExecute(Service=ServName, Topic=TopicName, Data=DatString)

Parameters:

Service Keyword for service name.

ServName Name of the service. 
• “nnn” - Direct input of the name.
• gs[xx] - Element xx of the global string array, if the name of the ser-

vice is stored in gs[].

Topic Keyword for topic name.

TopicName Name of the topic.
• “nnn” - Direct input of the name.
• gs[xx] - Element xx of the global string array, if the name of the topic 

is stored in gs[].

Data Keyword for data.

DatString Data that are additionally passed to the application as a string.
• “nnn” - Direct input of the data.
• gs[xx] - Element xx of the global string array, if the data are stored 

in gs[].
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8.7.4 DDEInit() - Initialize DDE Service 

Description:
Initialize DDE Service.

Syntax:
DDEInit(Service=ServName)

Parameters:

Example:
See Chapter 8.4.4 Data exchange with other programs (DDE), 424.

8.7.5 DDEPoke() - Send data by DDE

Description:
Send data by DDE.

Data that exist as global or local variables are passed to another running program.

Syntax:
DDEPoke(Service=ServName,Topic=TopicName, Item=ItemName,_

Data=Dat)

Parameters:

Service Keyword for service name.

ServName Name of the service.
• “nnn” - Direct input of the name.
• gs[xx] - Element xx of the global string array, if the name of the ser-

vice is stored in gs[]. 

Service Keyword for service name.

ServName Name of the service.
• “nnn” - Direct input of the name. 
• gs[xx] - Element xx of the global string array, if the name of the ser-

vice is stored in gs[].

Topic Keyword for topic name.

TopicName Name of the topic.
• “nnn” - Direct input of the name.
• gs[xx] - Element xx of the global string array, if the name of the topic 

is stored in gs[].

Item Keyword for item name.

ItemName Name of the item.
• “nnn” - Direct input of the name.
• gs[xx] - Element xx of the global string array, if the name of the item 

is stored in gs[].
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Example:
See Chapter 8.4.4 Data exchange with other programs (DDE), 424.

8.7.6 DDERequest() - Request data by DDE

Description:
Request data by DDE.

Request data from another program and store it in global or local variables.

Syntax:
DDERequest(Service=ServName, Topic=TopicName, Item=ItemName,_

Data=Dat)

Parameters:

Data Keyword for data.

Dat Data that is passed to the program.
• “nnn” - Direct input of the data.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.
• gs[xx] - Element xx of the global string array, if the data are stored 

in gs[].

Service Keyword for service name.

ServName Name of the service.
• “nnn” - Direct input of the name.
• gs[xx] Element xx of the global string array, if the name of the ser-

vice is stored in gs[].

Topic Keyword for topic name.

TopicName Name of the topic.
• “nnn” - Direct input of the name.
• gs[xx] Element xx of the global string array, if the name of the topic 

is stored in gs[].

Item Keyword for item name.

ItemName Name of the item.
• “nnn” - Direct input of the name.
• gs[xx] Element xx of the global string array, if the name of the topic 

is stored in gs[].
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Example:
See Chapter 8.4.4 Data exchange with other programs (DDE), 424.

8.7.7 Delay() - Time delay

Description:
Delay the execution of the sequence by a certain amount of time.

The time is specified by the value tim. If unit is not specified, the time is interpreted as 
seconds.

Syntax:
Delay(Time=tim[;unit][,Disp=d])

Parameters:

Example(s):
Delay(Time=i[77])

Delay the sequence by the number of seconds stored in i[77].

Data Keyword for data.

Dat Variable to assign the data to that is passed by the program.
• i[xx] - Element xx of the local integer array.
• gi[xx] -Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.
• gs[xx] - Element xx of the global string array, if the data are stored 

in gs[].

Time Keyword for time specification.

tim Time specification (1 ... 1’000’000).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Unit of time
• ms - in milliseconds.
• [s] - in seconds (default).
• min - in minutes.
• h - in hours.
• d - in days.

Disp Keyword for display mode. 

If Disp=on is set, the remaining delay time will be displayed in the status 
bar.

d Display mode
• [default] - Default display mode.
• off - Display off.
• on - Display on.

Without any explicit declaration, the default display mode is on. The 
default settings can be altered by SetDefault().
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Delay(Time=10;min,Disp=on)

Delay the sequence by 10 minutes and display the remaining time.

8.7.8 Dialog() - Displaying a dialog box

Description:
The Dialog() instruction displays a programmer-defined dialog window when the 
sequence is executed (or when the Test button is pressed). A background picture may 
be displayed if necessary. This way, the operator can control the sequence.

To interprete the input, a variable can be defined as ReturnVar which returns

• the value of EnterVal if the dialog box is closed by pressing ‘Enter’
• the value of EscapeVal if the dialog box is closed by pressing ‘Esc’
• the corresponding ReturnVal if any command button has been pressed.

NOTE:
The elements labeled with the keywords Text, Button, Edit, Combo and Filename 
can be listed included as often as desired in any order, but the line length cannot 
exceed 1000 characters.

Syntax:
Dialog(Box=dtext;dx;dy;dxw;dyw,ReturnVar=rvar,EnterVal=ent,_

EscapeVal=esc_
[,Text=ttext;tx;ty;txw;tyw]_
[,Button=btext;bx;by;bxw;byw;rval]_
[,Edit=ex;ey;exw;eyw;eret]_
[,Combo=cfirst;cx;cy;cxw;cyw;cret]_
[,Filename=ftype;fx;fy;fxw;fyw;fret]_
[,Picture=BkGndPict[,XPos=x][,YPos=y][,Height=h]_

[,Width=w]]
...

)

Parameters:

Box Keyword for dialog box.

dtext Name of dialog box
• “ttttttttt” Text for name
• gs[xx] Element xx of the global character string array if the window 

name is stored in gs[].

dx, dy Position X and Y of the dialog box, relative to the coordinate origin, i.e. 
the upper left corner of the screen.

dxw, dyw Extent of the dialog box in the X and Y direction.
• ccc Numeric value 0...screen resolution

ReturnVar Keyword for defining the return variable.

rvar Definition of the array element.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

EnterVal Keyword for defining the return value for the Enter key.
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ent value for ‘Enter’
• cc - Numeric value (integer, -1’000’000 ... +1’000’000)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

EscapeVal Keyword for defining the return value for the Esc key.

esc value for ‘Esc’
• cc - Numeric value (integer, -1’000’000 ... +1’000’000)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Text Keyword for text.

ttext Text to display
• “ttttttttt” Text
• gs[xx] - Element xx of the global character string array if the text is 

stored in gs[].

tx, ty Position X and Y of the text, relative to the upper left corner of the dialog 
box.

txw, tyw Extent of the text field in the X and Y direction.
• ccc - Numeric value 0 ... screen resolution.

Button Keyword for a command button.

btext Name of the command button
• “&ttttttttt” - Direct input of the name => The & marks the character to 

be underscored (shortcut).
• gs[xx] - Element xx of the global character string array if the name 

of the command button is stored in gs[].

bx, by Position X and Y of the command button, relative to the upper left corner 
of the dialog box.

bxw, byw Extent of the command button in the X and Y direction.
• ccc - Numeric value 0 ... screen resolution

rval Value that is returned when the command button is pressed.
• cc - Numeric value (integer, -1’000’000 ... +1’000’000)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Edit Keyword for input (numeric value or text)

ex, ey Position X and Y of the command button, relative to the upper left corner 
of the dialog box.

exw, eyw Extent of the command button in the X and Y direction.
• ccc - Numeric value 0 ... screen resolution.

eret Return value (numeric value or text)
• i[xx] - Element xx of the local integer array. 
• gi[xx] -Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gs[xx] - Element xx of the global character string array in which the 

text is to be stored.

Combo Keyword for list field (Combobox)
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For the elements Edit, Combo and Filename you can set default values by preloading 
each of their return variables with the corresponding value. These default values are 
loaded and displayed when the dialog box is created.

Example(s): 

See Chapter 8.6.2.2 Sequence AIRDEMO2, 431

Dialog(Box="Select Measure Mode";200;200;240;200,_
ReturnVar= i[1], EnterVal=0,_

cfirst String-Position n of the first list entry. The list begins at gs[n] and ends 
where the first empty gs[] is found.
• cc - Numeric value
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

cx, cy Position X and Y of the list field, relative to the upper left corner of the 
dialog box.

cxw, cyw Extent of the list field in the X and Y direction.
• ccc - Numeric value 0 ... screen resolution.

cret Return value (numeric value or text)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gs[xx] - Element xx of the global character string array in which the 

text is to be stored. The return value is either the number of the list 
entry (0, 1, .. for i[ ], gi[], f[ ], gf[]), or the chosen string (for gs[]).

Filename Keyword for entering a file name.

ftype Definition of the file type through the file extension.

fx, fy Position X and Y of the command button, relative to the coordinate ori-
gin, that is, the upper left corner of the dialog box.

fxw, fyw Command button size in the X and Y direction.
• ccc - Numeric value 0 ... screen resolution

fret Text return value (file name)
• gs[xx] - Element xx of the global character array to be stored in the 

file name.

Picture Keyword for background graphic.

BkGndPict Name and path of the background graphic
• “Pict.bmp” - Direct input of a name.
• gs[xx] - Element xx of the global character string array.

XPos, YPos, 
Height, Width

Keywords for position and size of the background graphic.

The position of the background graphic relative to the upper left corner 
of the dialog window can be defined by the values XPos and YPos, the 
size by Height and Width.

x, y, h, w X- and Y- position of the graphic, and height and width.
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
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EscapeVal=-1, Button="&Bargraph";20;20;200; 40;1,_
Button="&Table";20;80;200;40;2,_
Button="&Intensity Versus Time";20;140;200;40;3)

IfVar(i[1]=1)
Begin

Loop(i[2]=1;20)
MID(Par="d:\qs32bit\par\airdemo.mip",Disp=vt,Prot=off)

End
...

8.7.9 LoopDialog() - Loop with Dialog window

Description:
LoopDialog() is a loop that starts with a dialog window. A block of sequencer instruc-
tions follows (delimited by Begin and End), that’s executed repeatedly. This execution 
can be interrupted, the dialog window will be shown then again.

The LoopDialog loop is terminated when the return value RetVar corresponds to the 
value of EscapeVal.

If the key combination <Shift><F4> is pressed within the loop, the dialog window shows 
up immediately. This way the operator can e.g. interrupt a measurement and select a 
new action in the dialog (the second entry in the File menu (text=title of the dialog box) 
does the same as <Shift><F4>).

Syntax:
LoopDialog(...)

Parameters:
See Chapter 8.7.8 Dialog() - Displaying a dialog box, 445.

Example(s):
LoopDialog(Box="Selection";200;200;240;200,_

ReturnVar=i[0], EnterVal=0, EscapeVal=-1,_
Button="Scan Analog";20;70;200;30,1,_

...
Button="MCD Bargraph";20;270;200;30,5)

Begin
...
...

End

Display a dialog box. When the <ESC> key is pressed within the dialog box, the program 
branches to the sequencer instruction that follows the End instruction.

8.7.10 DispEventWindow() - Place and scale the Event window 

Description:
Place the event window somewhere on the screen and enlarge or reduce its scale.

By using this instruction you can place the event window of the running sequence in a 
chosen size at a chosen position on your screen. This instruction is equal to the instruc-
tion DispWindow, except that it controls the event window instead of the measure win-
dow.
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Syntax:
DispEventWindow(...)

Parameters:
See Chapter 8.7.11 DispWindow() - Place and scale the window, 449.

Example(s):
See Chapter 8.7.11 DispWindow() - Place and scale the window, 449.

8.7.11 DispWindow() - Place and scale the window

Description:
Place the sequencer’s measure window somewhere on the screen and enlarge or 
reduce its scale.

By using this instruction you can place the measure window of the running sequence in 
a chosen size at a chosen position on your screen. This is especially helpful, if there are 
several sequences running at the same time.

Syntax:
DispWindow(Disp=dispmode[,Xpos=x][,Ypos=y][,Width=w]

[,Height=h])_

Parameter:

Example(s):
Your PC works with a graphics resolution of 800 × 600 Pixels (X × Y).

DispWindow(Disp=normal, Xpos=200, Ypos=150, Width=400,_
Height=300)

Place the window on the center of the screen and scale it to cover a quarter of the total 
screen area:

DispWindow(Disp=symbol)

Reduce the window to iconic size (symbol). The position is determined by Windows® in 
this case:

Disp Keyword for the display mode of the window (normal or iconic).

dispmode Text
• normal - Normal display.
• symbol - Window reduced to symbol (iconic size).
• top - Window is always visible.

x, y, w, h Horizontal and vertical coordinates that indicate the position of the 
upper left corner of the measure window relative to the upper left corner 
of the screen, where x is the offset to the right and y is the offset down-
wards. w is the width and h is the height of the measure window. The 
values x, y, w, h are meant as units of the screen resolution and are cor-
rected automatically if they are out of range. The following entries are 
possible:
• cc - Numeric value (positive integer)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
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8.7.12 Error() - Outputting an error message

Description:
Output a user-specific error message.

NOTE:
Error messages are normally output on the screen.

The optional parameter Save provides storage in the error history file.

The optional parameter Prot provides “On-line” logging of the error messages on the 
connected printer.

Syntax:
Error(Text=text[;strval][,Save=s][,Prot=p][,Confirm=c])

Parameters:

Example(s):
Error(Text="Calibration of bottle 5 in progress")

Output of an error.

Text Keyword for entering the text (error message) to be output.

text Text
• “Text” - Direct input of Text.
• gs[xx] - Element xx of the global character string array.

strval String value - See Chapter 8.4.1.4 String values, 417

Save Keyword for save mode.

The error messages can be stored in the error history file. The default 
setting for the save mode is on.

NOTE:
This will work only, if in Parameter Setup program [Setup] > [Gen-
eral] > [Error History] is switched on.

s Save mode
• off - Save function off.
• [on] - Save function on (default).

Prot Keyword for log mode.

p Log mode.
• [default] - Default log mode.
• off - Log function off.
• on - Printer log on.

See Chapter 8.4.3 Log output, 422.

If nothing else is specified, the default log mode is off. It can be altered 
with the SetDefault() instruction.

Confirm Keyword for the confirmation mode. When an error message is output, 
user confirmation can be requested with Confirm.

c Confirmation mode
• [off] - Sequence proceeds without confirmation.
• on - Sequence is stopped until the [OK] button is pressed.
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Error(Text=gs[12],Save=on,Prot=on,Confirm=on)

Display an error, log it on the printer and store it in the error history, then wait until the 
operator confirms continuation of the sequence.

8.7.13 Execute() - Execute a program

Description:
Execute any program. You can e.g. start a second Measure, a batch file or an applica-
tion program such as a text editor or similar.

Syntax:
Execute(Prog=name[;ind][,Par=p])

Parameters:

Example(s):
Execute(Prog="myprog.exe")

The program ‘myprog.exe’ is started from the current directory.

Execute(Prog="c:\auxis\batsav.bat";3,Par=gs[0])

The batch file ‘batsav03.bat’ is started from the path ‘c:\auxis’ and the content of the glo-
bal string gs[0] is transferred as a parameter to it.

8.7.14 Exit() - Quitting the sequencer

Description:
Execute any SeqExit() instructions and terminate the sequence. (=> See also 
Chapter 8.7.48 SeqExit() - Defining a sequence for sequence cancellation, 488). Ter-
minate or don’t terminate the program Measure that executes the sequence.

Syntax:
Exit(Terminate=OnOff)

Prog Keyword for program name and path.

name (drive:\path\) program name
• “pppppp” Program name (e.g. “c:\qs\myprog”).
• gs[xx] Element xx of the global string array, if the program name is 

stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

Par Keyword for parameter transfer to the program.

p Any parameters may be transferred to the program; e.g. the name of a 
parameter file. 
• [off] no parameter is transferred.
• “pppppp” transfer a string (e.g. parameterfile name “c:\qs\myfile”). 
• gs[xx] Element xx of the global string array, if the parameter to be 

transferred is stored in gs[].
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Parameters:

8.7.15 ExtractString() - Extracting characters from a string

Description:
Extract a part of a character string and assign it to another variable or string. 
ExtractString() is especially useful to separate the different informations of a string that 
has been assembled and transmitted by an external application. As separation criterion, 
a number of characters or a special character can be used. In the latter case, the sepa-
ration character itself is deleted after the separation.

Syntax:
ExtractString(Type=sep[,Number=nbr][,Character=char],_

Source=src ,Dest=dst)

Parameters:

Example(s):
You want to collect the pressure in mbar and the temperature in °C. The values are mea-
sured by an external application, assembled as a string and sent to Quadstar 32-bit by 
DDE where they are stored in gs[0]. The string now looks like this:

 “1.5E-07mbar ;25°C”

Terminate Keyword ‘terminate measure program automatically Yes/No’.

OnOff • [off] Exit sequence, don’t terminate measure program.
• on Exit sequence, terminate measure program.

Type Type of separation criterion.

sep • Number - Get the first <number> characters.
• Character - Get all characters until a certain character is found.

Number Number of characters to extract.

nbr • cc - Numeric value (integer, 0,....,<stringlength>)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Character Character that indicates the end of the string part to be extracted.

char • “c” - Direct input of the separation character.
• gs[xx] - Element xx of the global character string array.

Source String to extract parts of.

src gs[xx] - Element xx of the global character string array.

Destination Variable to store the extracted part of the string.

dst • i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.
• gs[xx] - Element xx of the global string array.
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First you separate the pressure value and store it in a local float variable; in this exam-
ple, the number consists of 7 characters, so the instruction reads:

ExtractString(Type=number, Number=7, Source=gs[0],_
Destination=f[0])

 The value “1.5E-07” is now found in f[0], gs[0] still holds “mbar ;25°C”. The information 
“mbar” is not needed any more, so you cut off everything until “;”:

ExtractString(Type=character, Character=";", Source=gs[0],_
Destination=gs[1])

gs[0] now holds only “25°C”. Because the temperature value can consist of 1, 2 or 3 
characters, you use “°” as separation character. This way it is guaranteed that the num-
ber is stored correctly in i[0] in any case:

ExtractString(Type=character, Character="°", Source=gs[0],_
Destination=i[0])

8.7.16 FileCopy() - Copy a file

Description:
Copy an existing file to a new or existing file.

NOTE:
The function does not request any confirmation. An already existing destination 
file will be replaced.

See Chapter 8.7.19 FileRename() - Rename a file, 454 for examples.

Syntax:
FileCopy(SrcFile=StrgSrc,DestFile=StrgDst)

Parameters:
• SrcFile - Keyword for source file (name and path).
• DestFile - Keyword for destination file (name and path).

where:
• StrgSrc, StrgDst - Elements of the global string array (gs[xx]) or direct text inputs.

8.7.17 FileDelete() - Delete a file

Description:
Delete an existing file.

NOTE:
The function does not request any confirmation for deleting the file.

See Chapter 8.7.19 FileRename() - Rename a file, 454 for examples.

Syntax:
FileDelete(File=StrgFile)
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Parameters:
• File - Keyword for file (name and path).

where:
• StrgFile - Element of the global string array (gs[xx]) or a direct text input.

8.7.18 FileMove() - Move a file

Description:
Move an existing file to a different path.

NOTE:
The function does not request any confirmation. An already existing file in the 
destination path will be replaced.

See Chapter 8.7.19 FileRename() - Rename a file, 454 for examples.

Syntax:
FileMove(SrcFile=StrgSrc, DestFile=StrgDst)

Parameters:
• SrcFile - Keyword for source file (name and path).
• DestFile - Keyword for destination file (name and path).

where:
• StrgSrc, StrgDst - Elements of the global string array (gs[xx]) or direct text inputs.

8.7.19 FileRename() - Rename a file

Description:
Rename an existing file.

NOTE:
The function does not request any confirmation. An already existing destination 
file will be replaced.

Syntax:
FileRename(SrcFile=StrgSrc, DestFile=StrgDst)

Parameters:
• SrcFile - Keyword for source file (name and path).
• DestFile - Keyword for destination file (name).

where:
• StrgSrc, StrgDst - Elements of the global string array (gs[xx]) or direct text inputs.

Example:
You are repeating a measurement 20 times. The latest completed run is to be saved in 
the temporary path as ‘tempold’ each. After that it shall be stored in the regular data path 
under a different name.

// Repeat the following program 20 times
Loop(i[0]=1;20)
Begin
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// MID measurement using 'airsim2', displayed as a bargraph,
// store in 'temp' path as 'tempfile'
MID(Par="c:\qs32bit\par\airsim2", Disp=bar,_

SaveCyc="c:\temp\tempfile";reset)
// Report the nbr. of the current measurement to the status bar.
Message(Text="Measurement running, Nbr. ";i[0])
// Delete the file 'tempold', if already existing
FileDelete(File="c:\temp\tempold.mdc")
// Copy current measurement file 'tempfile' to 'tempold'
FileCopy(SrcFile="c:\temp\tempfile.mdc",_

DestFile="c:\temp\tempold.mdc")
// Rename the current measurement file 'tempfile' to_

'midcyc...',
// i.e. append the loop counter value to the file name
FileRename(OldFile="c:\temp\tempfile.mdc", 

NewFile="midcyc.mdc";i[0])
// Move the file 'midcyc...' from the temporary path to the_

data path
FileMove(SrcFile="c:\temp\midcyc.mdc";i[0],_ 

DestFile="c:\qs32bit\dat\midcyc.mdc";i[0])
End

8.7.20 FormatDate() - Format date

Description:
Format system time as a date.

The absolute system time (a large integer number that indicates the seconds passed 
since a standardized zero time) can be converted to a date by using FormatDate().

NOTE:
See Chapter 8.7.21 FormatTime() - Format time, 456 for examples.

Syntax:
FormatDate(Abs=AbsInt, Date=Datestring, Day=DInt,_

Month=MoInt, Year=YInt)

Parameters:
• Abs - Keyword to get the absolute system time in seconds (integer) from AbsInt.
• Date - Keyword to store the date string (Windows® format) to Datestring.
• Day, Month, Year - Keywords to store the integer values for day, month, year to 

DInt, MoInt, YInt.

where:
• Datestring - Element of the global string array (gs[xx]).
• DInt, MoInt, YInt, AbsInt - Elements of the global (gi[xx]) or the local (i[xx]) integer 

array.
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8.7.21 FormatTime() - Format time

Description:
Format system time as a daytime.

The absolute system time (a large integer number that indicates the seconds passed 
since a standardized zero time) can be converted to a time by using FormatTime().

Syntax:
FormatTime(Abs=AbsInt, Time=Datestring, Hour=HInt, Min=MiInt,_

Sec=SInt)

Parameters:
• Abs - Keyword to get the absolute system time in seconds (integer) from AbsInt.
• Time - Keyword to store the time string (Windows® format) to Timestring
• Hour, Min, Sec - Keywords to store the integer values for hours, minutes, seconds 

to HInt, MiInt, SInt.

where:
• Timestring - Element of the global string array (gs[xx]).
• HInt, MiInt, SInt, AbsInt - Elements of the global (gi[xx]) or the local (i[xx]) integer 

array.

Example:
Your aim is to measure MID data repeatedly for at least one hour. Because you can’t 
use incomplete spectra, you check whether the end time is already reached before start-
ing a new cycle. Finally you want to know how much time the measurement really took 
and at what date and time it stopped:

// Initialize i[0] to current time
GetTime(Abs=i[0])

// Repeat MID measurement for at least 1 hour
WhileVar(i[0]>0, BreakTime=1;h)

MID(...)

// Get Time when loop was left and calculate running time
GetTime(Abs=i[1])
Calculate(i[2] = i[1]-i[0])

// Display running time
SetString(gs[0] = "The Loop ran for @ seconds")
SetString(gs[0] = gs[0];i[2])
Message(Text=gs[0], Confirm=on)
// Display stop date and time
FormatDate(Abs=i[1], Date=gs[1])
FormatTime(Abs=i[1], Time=gs[2])
SetString(gs[0] = "The Loop was stopped the @ at @ ")
SetString(gs[0] = gs[0];gs[1])
SetString(gs[0] = gs[0];gs[2])
Message(Text=gs[0], Confirm=on)
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8.7.22 GetDate() - Get current date

Description:
Get current date.

The current date is loaded from the system clock and may then be stored in different 
ways (Windows® string, integer values for year/month/day, absolute system time in sec-
onds) in variables.

NOTE:
See Chapter 8.7.23 GetTime() - Get current time, 457 and Chapter 8.7.21 
FormatTime() - Format time, 456 for examples.

Syntax:
GetDate([Date=Datestring][,Day=DInt][,Month=MoInt][,Year=YInt]_

[,Abs=AbsInt])

Parameters:
• Date - Keyword to load the date string (Windows® format) and assign it to Datestring.
• Day, Month, Year - Keywords to load the integer values for day, month, year and 

assign them to DInt, MoInt, YInt.
• Abs - Keyword to load the absolute system time in seconds (integer) and assign it to 

AbsInt.

where:
• Datestring - Element of the global string array (gs[xx]).
• DInt, MoInt, YInt, AbsInt - Elements of the global (gi[xx]) or the local (i[xx]) integer 

array.

8.7.23 GetTime() - Get current time

Description:
Get current time.

The current time is loaded from the system clock and may then be stored in different 
ways (Windows® string, integer values for hours/minutes/seconds, absolute system 
time in seconds) in variables.

NOTE:
See also Chapter 8.7.21 FormatTime() - Format time, 456 for examples.

Syntax:
GetTime(Time=Timestring, Hour=HInt, Min=MiInt, Sec=SInt, 
Abs=AbsInt)

Parameters:
• Time - Keyword to load the time string (Windows® format) and assign it to 

Timestring.
• Hour, Min, Sec - Keywords to load the integer values for hours, minutes, seconds 

and assign them to HInt, MiInt, SInt.
• Abs - Keyword to load the absolute system time in seconds (integer) and assign it to 

AbsInt.

where:
• Timestring - Element of the global string array (gs[xx]).
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• HInt, MiInt, SInt, AbsInt - Elements of the global (gi[xx]) or the local (i[xx]) integer 
array.

Example(s):
You want to create a file within a sequence. The file name shall consist of the year, 
month, day and hour of its creation as two digit numbers. You decide to build this name 
by storing its parts in the correct order in the local integer array, starting with i[0]. The 
result string is then stored in gs[0] and you make sure that all numbers (day, hour etc.) 
contain two digits each:

// Get current date and time
GetDate(Day = i[2], Month = i[1], Year = i[0])
GetTime(Hour = i[3])

// Initialize result string (4 alphanumeric pieces) and aux string
// (leading zero)
SetString(gs[0] = "@@@@")
SetString(gs[1] = "0@")

// if i[0] (year) is single digit, add a leading 0
IfVar(i[0] < 10)

SetString(gs[0] = gs[0]; gs[1])
//replace first '@' of result string by current year
SetString(gs[0] = gs[0]; i[0])

IfVar(i[1] < 10)
SetString(gs[0] = gs[0]; gs[1])

SetString(gs[0] = gs[0]; i[1])

IfVar(i[2] < 10)
SetString(gs[0] = gs[0]; gs[1])

SetString(gs[0] = gs[0]; i[2])

IfVar(i[3] < 10)
SetString(gs[0] = gs[0]; gs[1])

SetString(gs[0] = gs[0]; i[3])

// Display the result string
Message(Text = gs[0], Confirm = on)

The string (e.g. ‘95061916’ for June 19, 1995 at 4 p.m.) is now stored in gs[0] and may 
be used as a file name. The problem may be solved shorter but less obviously the fol-
lowing way:

...
// Get current date and time
GetDate(Day = i[2], Month = i[1], Year = i[0])
GetTime(Hour = i[3])

// Initialize result string (4 alphanumeric pieces) and aux string
// (leading zero)
SetString(gs[0] = "@@@@")
SetString(gs[1] = "0@")

// check local integers 0..3 (Year..Hour) for single digits and
// build the result string
Loop(i[4] = 0;3)

Begin
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// if single digit, add a leading 0
IfVar(i[i[4]] < 10)

SetString(gs[0] = gs[0]; gs[1])
// replace i[4]th '@' of result string by matching number
SetString(gs[0] = gs[0]; i[i[4]])

End

8.7.24 GetErrorCode() - Read error and status register

Description:
Read the error/status frames and store them in selectable variables. The codes are 
briefly explained here. For a detailed description refer to the User’s guide of the 
QMS 422/421, or QMS 200.

NOTE:
• The IfBit() instruction helps you to evaluate the state of the flags (separate bits in a 

variable) contained in Error-, Warning- etc. variables.
• The Error-flags are cleared after being read and are only set again (after approx. 1 

second) if the error occurs still/again.

In the following tables

• X means: valid for this equipment
• - means: not valid for this equipment

Error Variable

Bit 
No Meaning when 1/0

Mes-
sage 
No

QMS 
422/
421

QMS
200

QMU
112

0 QMS controller stack overflow/- 17 X X -

1 QMS reset error/- 18 X X -

2 QMS controller watchdog error/- 19 X X -

3 QMS controller EPROM defect/- 20 X X -

4 QMS controller NOVRAM defect/- 21 X X -

5 QMS controller dual port RAM defect/- 22 X X -

6 QMS controller buffer RAM defect/- 23 X X -

7 DSP EPROM defect/- 24 X X -

8 DSP dual port RAM defect/- 25 X X -

9 Monitor - DAC error/- 26 X X -

10 Resolution - DAC error/- 27 X X -

11 AO - DAC error/- 28 X X -

12 ADC error/- 29 X X -

13 QMS temperature underrange/- 30 - X -

14 QMS temperature overrange/- 31 - X -
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Warning Variable

15 RF-ID error/- 32 - X -

16 QMS controller idle error/- 33 X X -

17 SEM error/- 34 X X -

18 CD error/- 35 X X -

19 Ion source error/- 36 X X -

20 Filament 1 defect/- 37 X X -

21 Filament 2 defect/- 38 X X -

22 Emission error/- 39 X X -

23 CAN error/- 40 X X -

24 Parameter lost in NOVRAM/- 41 X X -

25 Communication error controller <=> console/- 42 X - -

26 Communication error controller <=> DSP/- 43 X X -

27 Communication error on LAN (ArcNet)/- 44 X X -

28 Communication error on RS-232-C/- 45 X X -

29 RF error/- 46 X X -

30 Integrator: intensity < underground/- 47 X X -

Bit 
No Meaning when 1/0

Mes-
sage 
No

QMS
422/

421

QMS
200

QMU
112

0 No High Voltage supply/- 17 X - -

1 No Ion Source supply/- 18 X - -

2 Cannot Degas Fil 1+2/- 19 X - -

3 No Auto (Fil 1+2) on Degas/- 20 X - -

4 Only Filament 1 available 21 X - -

5 Buffer failure 22 X - -

Bit 
No Meaning when 1/0

Mes-
sage 
No

QMS 
422/
421

QMS
200

QMU
112
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Status Variable

QMUEmi

Syntax:
GetErrorCode([Error=err][,Warning=warn][,Status=sta]_

[,QmuEmi=emi])

Parameters:

Bit 
No Meaning when 1/0

Mes-
sage 
No

QMS
422/
421

QMS
200

QMU
112

0 Cycle run/halt - X X -

1 Multi-/mono- channel - X X -

2 Emission on/off - X X -

3 SEM Supply on/off - X X -

4 Wait for external trigger/- - X X -

5 Settling run/halt - X - -

6 Integrator underground run/halt - X - -

7 Display emission current/electrometer value - X X -

8 Degas on/off - X X -

9 Adjust on/off - X X -

10 Adjust run/- - X X -

14 Ringbuffer empty/not empty - X X -

15 Ringbuffer overflow/- - X X -

Bit 
No Meaning when 1/0

Mes-
sage 
No

QMS
422/
421

QMS
200

QMU
112

0 QMU 0: Emission failure/ok - - - X

1 QMU 1: Emission failure/ok - - - X

.. .. .. .. .. ..

7 QMU 7: Emission failure/ok - - - X

Error Keyword for error code.

err Variable to be filled with the error code.
• i[xx] - Local integer variable
• gi[xx] - Global integer variable

Warning Keyword for warning code.
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Example(s):
GetErrorCode(Error=i[0], Warning=i[1], Status=i[2])
Loop(i[3]=0;7)

IfBit(i[0];i[3] = set)
Error(Text="Error, Bit @ in error register: Set !";i[4])

Loop(i[3]=0;7)
IfBit(i[1];i[3] = set)

Error(Text="Warning, Bit @ in warning register: Set !";i[4])
...

Read the QMS error and status word and print out the flags that are set.

8.7.25 GetSysInfo() - Get System Information

Description:
Get information about general system properties like free disc space, horizontal and ver-
tical screen resolution .The screen resolution information is useful for using instructions 
like DispWindow independently of the graphic system, while the free disc space infor-
mation can prevent a storage overflow.

Syntax:
GetSysInfo([DiscSpace=space ;drive][,ResHorz=hRes]_

[,ResVert=vRes])

Parameters:

warn Variable to be filled with the warning code.
• i[xx] - Local integer variable
• gi[xx] - Global integer variable

Status Keyword for status code.

sta Variable to be filled with the status code
• i[xx] - Local integer variable
• gi[xx] - Global integer variable

QmuEmi Keyword for QMU emission status code.

emi Variable to be filled with the QMU emission status code
• i[xx] - Local integer variable
• gi[xx] - Global integer variable

DiscSpace Keyword for disc space (in KiloBytes).

space Variable to hold the value of the free disc space in kBytes
• i[xx] - Local integer variable
• gi[xx] - Global integer variable

drive Disc drive (e.g. A, C, ...)
• “b” - Letter that identifies the disc drive.
• gs[xx] - Element xx of the global string array, if the letter is stored in 

gs[].

ResHorz Keyword for horizontal screen resolution.
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Example(s):
GetSysInfo(DiscSpace=i[0];"c", ResHorz=i[1], ResVert=i[2])

Store the number of free Kilobytes of hard drive C: in i[0], store horizontal and vertical 
screen resolution in i[1] and i[2].

GetSysInfo(DiscSpace=i[0];"c")
WhileVar(i[0] > 1000)
Begin

MID(Par="c:\qs32bit\par\helium4.mip",_
SaveCyc= "c:\qs32bit\dat\helium_c.mdc")

GetSysInfo(DiscSpace=i[0];"c")
End
Message(Text="Drive C is full, switched over to drive D")
WhileVar(i[0] > 0)
Begin

MID(Par="c:\qs32bit\par\helium4.mip",_
SaveCyc= "d:\spare\helium_d.mdc")

End
...

Carry out a helium MID measurement and store the results on drive C, until the residual 
capacity of drive C falls below 1000 kBytes. Then store further data on disc drive D and 
report this in the status bar.

8.7.26 GSC() - Gas-specific calibration

Description:
Perform a gas-specific calibration. To increase precision, a mean value calculation is 
available.

Syntax:
GSC(Par=file[;ind][,Disp=d][,Prot=p][,Mean=nbr])

Parameters:

hRes Variable to hold the value of the horizontal resolution
• i[xx] - Local integer variable
• gi[xx] - Global integer variable

ResVert Keyword for vertical screen resolution.

vRes Variable to hold the value of the vertical resolution
• i[xx] - Local integer variable
• gi[xx] - Global integer variable

Par Keyword for parameter file. No file extension should be used because it 
is added automatically by Quadstar 32-bit.

file (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”).
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416
Quadstar 32-bit, vpnb68e1 (0302) Process Control 463



Example(s):
GSC(Par="gcal", Mean=10)

Perform a gas-specific calibration using the “gcal” parameter file. Take the mean value 
out of 10 measurements.

...
Loop(i[0]=0;3)
Begin

// Flush Inlet
Sequence(Par="flush")
// Open Inlet
Sequence(Par="open";i[0])
// Calibrate
GSC(Par="gcal";i[0])
// Close Inlet
Sequence(Par="close";i[0])

End
...

Perform several gas-specific calibrations. The files “gcal0” ... “gcal3” with one inlet 
sequence each (“open0” ... “open3”) are used as parameter files.

8.7.27 IfBit() - Testing a bit of an integer variable

Description:
Test an individual bit of an integer variable.

This instruction is used in conjunction with the GetErrorCode() instruction:

Disp Keyword for display mode.

d Display mode
• [default] - Default display mode.
• off - Display off.
• on - Display on.

Without any explicit declaration, the default display mode is on. The 
default settings can be altered by SetDefault().

Prot Keyword for log mode.

p Log mode.
• [default] - Default log mode.
• off - Log function off.
• on - Printer log on.

See Chapter 8.4.3 Log output, 422.

If nothing else is specified, the default log mode is off. It can be altered 
with the SetDefault() instruction.

Mean Keyword for mean value calculation.

nbr Number of measurements used for mean value calculation (1-10000)
• cc - Direct input of a numeric value (integer)
• i[xx] - Local integer variable
• gi[xx] - Global integer variable
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 => GetErrorCode() reads the Error and the Status register.

 => IfBit() analyzes the individual error and status flags represented by bits.

Syntax:
IfBit(var;bit=state)

Parameters:

Example(s):
Read the QMS 422/421 or QMS 200 error code and write it into i[0]. If bit 3 is set, per-
form a function:

GetErrorCode(Status=i[0])
IfBit(i[0];3=set)
Begin

...
End

8.7.28 IfDI() - Testing a digital input

Description:
If instruction for monitoring a digital input of the control unit, where the number of avail-
able channels on

• QMS 422/421 depends on the number of installed DI 420 boards
• QMS 200 is limited to 2 (DI 0: Extern Protection, DI 1: Extern Start)

The instruction that follows IfDI() is executed only if the condition (var{;unit} =state) is 
true.

Specify the digital input of the control unit as follows:

• enter the channel number or
• enter the logical name of the input channel.

 => The logical names are specified in the Parameter Setup program under [Config] > 
[DI/DO Identifications].

Syntax:
IfDI(var{;unit}=state)

var Variable containing the bit to be tested
• i[xx] - Local integer variable
• gi[xx] - Global integer variable

bit Number of the bit to be tested (0 ... 31)
• cc - Direct input of a numeric value (integer)
• i[xx] - Local integer variable
• gi[xx] - Global integer variable

state Comparison state
• clear - Test for bit not set
• set - Test for bit set
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Parameters:

Example(s):
IfDI(i[23]=on)

Delay(time=5)

If the digital input whose number is stored in i[23] is in the on state, a five second pause 
is counted down.

IfDI(12; "Q_Unit_1"=off)
Delay(Time=5)

Multiplex mode: If digital input 12 of unit “Q_Unit_1” is off, a pause of five seconds is 
counted down.

IfDI("inlet5"=off)
Begin

Delay(Time=5)
SetDO(10=on)

End

If the digital input “inlet5” is in the off state, a 5 second pause is counted down and digital 
output 10 is subsequently set.

8.7.29 IfDO() - Testing a digital output

Description:
If instruction for monitoring a digital output of the control unit, where the number of avail-
able channels on:

• QMS 422/421 depends on the number of installed DO 420 boards
• QMS 200 is limited to 2 (DO 0, DO 1)

The instruction that follows IfDO() is executed only if the condition (var{;unit} =state) is 
true.

The digital output of the control unit is specified as follows:

var number of the digital input channel.
QMS 422/421: 0 ... 31(63)/QMS 200: 0 ... 1 
• “zzzzz” - Logical name of the digital input. 
• cc - Direct input of a numeric value (integer).
• i[xx] Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Identification of the control unit, only available in multiplex mode.
• “zzzzz” - Logical name of the control unit.
• cc - Direct input of the internal logical number.

=> Only those control units are available whose status has been set to 
Enable in the Parameter Setup program under [Comm] > [Node Identi-
fication]. This entry does not influence the unit selected with SetUnit().

state DI comparison status
• off - Test DI channel status = off.
• on - Test DI channel status = on.
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• enter the channel number or
• enter the logical name of the output channel.

 => The logical names are specified in the Parameter Setup program under [Config] > 
[DI/DO Identifications].

Syntax:
IfDO(var{;unit}=state)

Parameters:

Example(s):
IfDO(gi[8]=on)

Delay(time=5)

If the digital output whose number is stored in gi[8] is in the on state, a five second pause 
is counted down.

IfDO(63;"Q_Unit_1"=on)
Delay(Time=5)

Multiplex mode: If the digital output 63 of the unit Q_Unit_1 is on, a five second pause 
is counted down.

IfDO("cal gas 7"=off)
Begin

Delay(time=5)
SetDo(10=on)

End

If the digital output “cal gas 7” is in the off state, a five second pause is counted down 
and digital output 10 is subsequently set.

8.7.30 IfMeaVal() - Testing a measured value

Description:
If instruction for monitoring a measured value on one of the 64 measurement channels 
of the mass spectrometer. An MID measurement is started invisibly using the given 

var number of the digital output channel.
QMS 422/421: 0 ... 31(63, 95)/QMS 200: 0 ... 1 
• “zzzzz” - Logical name of the digital output. 
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Identification of the control unit, only available in multiplex mode.
• “zzzzz” - Logical name of the control unit.
• cc - Direct input of the internal logical number.

=> Only those control units are available whose status has been set to 
Enable in the Parameter Setup program under [Comm] > [Node Identi-
fication]. This entry does not influence the unit selected with SetUnit().

state DO comparison status
• off - Test DO channel status = off.
• on - Test DO channel status = on.
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parameter file, the measured value is recorded and the measurement is stopped again. 
The instruction following IfMeaVal() is executed only if the condition (var cond val) is 
true.

Syntax:
IfMeaVal(var cond val,Par=file[;ind])

Parameters:

Example(s):
IfMeaVal(5<3.4E-7,Par="myfile")

Delay(Time=5)

If the values on channel 5, measured with the “myfile” parameters, are less than 3.4E-7, 
a pause of five seconds is counted down.

IfMeaVal(gi[4]>12.5E-9,Par="d:\qs\dat\test1\sample5")
Delay(Time=5)

If the values on the channel stored in gi[4], measured with the “d:\qs\dat\test1\sample5” 
parameters, is greater than 12.5E-9, a pause of five seconds is counted down.

var Measure channel number (0 ... 63).
• cc Direct input of a numeric value (integer or float).
• i[xx] Element xx of the local integer array.
• gi[xx] Element xx of the global integer array.

cond Condition
• = - equal.
• < - less than.
• > - greater than.
• <= - less or equal
• >= - greater or equal.
• <> - not equal.

val Comparison variable

All float and integer array element types can be used:
• cc - Direct input of a numeric value (integer or float)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

Par Keyword for parameter file

file (Drive:\Path\) Filename.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416
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8.7.31 IfString() - Compare two text strings

Description:
If-instruction to compare two text strings. The instruction following IfString() is only exe-
cuted, if the condition (string1 cond string2) is true.

Syntax:
IfString(string1 cond string2)

Parameters:

The two strings are compared character by character, disregarding capitals. The first 
two characters that don’t match each other in both strings determine the result of the 
comparison: the character that comes first in alphabet is considered to be ‘smaller’. Two 
strings are only recognized as equal if all their characters are equal (except capital/non 
capital).

Example(s):
IfString(gs[8]="Wait")

Delay(Time=50)

If the string gs[8] contains the text ‘Wait’, then wait 50 s.

IfString(gs[0]>gs[1])
SetString(gs[2]=gs[0])

Else
SetString(gs[2]=gs[1])

Assign the “greater” of the two strings gs[0] and gs[1] to gs[2].

8.7.32 IfVar() - Testing an array or field variable

Description:
If instruction for monitoring a variable. The instruction following IfVar() is executed only 
if the condition (var cond val) is true.

Syntax:
IfVar(var cond val)

string1 First string to compare
• cc - Direct text input
• gs[xx] - Element xx of the global string Array.

cond Condition
• = - equal to.
• < - less than.
• > - greater than.
• <= - less or equal.
• >= - greater or equal.
• <> - not equal.

string2 Second string to compare
• cc - Direct text input
• gs[xx] - Element xx of the global string Array.
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Parameters:

Example(s):
IfVar(i[8]=10)

Delay(Time=5)

If the variable i[8] has a value of 10, a pause of five seconds is counted down.

IfVar(gfa[gi[7]][6]<1.5E-8)
Begin
 SetDO(5=on,10;min)
 SetDO(6=on,1;min)
End

If the value in the array element gfa[gi[7]][6] is less than 1.5E-8, DO 5 is set, a pause of 
10 minutes is counted down, after which DO 6 is set and another pause of 1 minute is 
counted down.

8.7.33 IniFileRead() - Read a value from an INI file 

Description:
Read a value from an INI file.

INI files are files with the extension ‘.ini’, that are normally used (in Windows®) to setup 
configurations. They are built up using a certain format (for more information please con-
sult your Windows® documentation):

 ...
 [SectionIdentification1]

var Variable to be tested. 

All float and integer array element types can be used:
• cc - Direct input of a numeric value (integer or float)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

cond Condition
• = - equal to.
• < - less than.
• > - greater than.
• <= - less or equal.
• >= - greater or equal.
• <> - not equal.

val Comparison value

All float and integer array element types can be used:
• cc - Direct input of a numeric value (integer or float)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.
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 EntryA=ValueA
 EntryB=ValueB
 [SectionIdentification2]
 EntryX=ValueX
 EntryY=ValueY
 ...

You can use such files to read and write data in a program independent format.

Syntax:
IniFileRead(Section=SecId, Entry=EntId, Data=Var, IniFile=File)

Parameters:

All values are read as standard texts. If a value isn’t of the expected format, it’s assumed 
to be empty/zero.

Example(s):
See Chapter 8.7.34 IniFileWrite() - Write a value to an INI file, 471.

8.7.34 IniFileWrite() - Write a value to an INI file

Description:
Write a value to an INI file. See also Chapter 8.7.33 IniFileRead() - Read a value from 
an INI file, 470.

Syntax:
IniFileWrite(Section=SecId, Entry=EntId, Data=Var, IniFile=File)

Section Keyword for section, where the entry is found.

SecId Section identifier.
• cc - Direct text input.
• gs[xx] - Element xx of the global string array.

Entry Keyword for entry, where the value is found.

EntId Entry identifier.
• cc - Direct text input.
• gs[xx] - Element xx of the global string array.

Data Keyword for data container.

Var Variable to assign the read value to.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.
• gs[xx] - Element xx of the global string array.

IniFile Keyword for file to read from.

File File name (and possibly path). 
• cc - Direct text input.
• gs[xx] - Element xx of the global string array.
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Parameters:

Example:
You want to run Quadstar 32-bit controlled by a supervising control unit. This unit 
informs Quadstar 32-bit, what measurement is to be performed and fetches the result 
afterwards. For this purpose, the file remote.ini is created, that contains in the section 
WhatMea the name of the parameter file that defines the next measurement and in the 
section Result the measured value. This value is read and interpreted by the control unit.

File remote.ini, after the control unit has requested to perform the measurement 
PeakO2.mip:

---File: remote.ini ---
[WhatMea]
ParFile=PeakO2.mip
[Result]
MeaVal=
-----------------------

// Read name of the parameter file used for the next measurement
// into gs[0]
IniFileRead(Section="WhatMea",Entry="ParFile",Data=gs[0],_

IniFile="c:\control\remote.ini")
// Perform measurement using the given parameter file;
// save results into gfa[0][0] (only one value)
MID(Par=gs[0], SaveGfa=0)
// Write measurement result to the matching entry in the
// ini-file
IniFileWrite(Section="Result",Entry="MeaVal",Data=gfa[0][0],_

Section Keyword for section, where the value is to be entered.

SecId Section identifier.
• cc - Direct text input.
• gs[xx] - Element xx of the global string array.

Entry Keyword for entry to assign the value to.

EntId Entry identifier.
• cc - Direct text input.
• gs[xx] - Element xx of the global string array.

Data Keyword for data container.

Var Value or variable that contains the value to be written.
• nn - Direct input of a numeric value (integer or float).
• cc - Direct text input.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.
• gs[xx] - Element xx of the global string array.

IniFile Keyword for file to write the data to.

File File name (and possibly path). 
• cc - Direct text input.
• gs[xx] - Element xx of the global string array.
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IniFile="c:\control\remote.ini")

File remote.ini, after Quadstar 32-bit has performed the measurement PeakO2.mip:

---File: remote.ini ---
[WhatMea]
ParFile=PeakO2.mip
[Result]
MeaVal=1.23456E-6
-----------------------

8.7.35 InitDisp() - Initialize the display

Description:
Initialize the display.

This instruction is required for example, if a table is displayed in Multiple Column Mode, 
to remove the data of previous measurements.

Syntax:
InitDisp()

Parameters:
None

Example(s):
InitDisp()

The display is cleared and initialized.

8.7.36 Loop() - Loop

Description:
Loop with counter variable.

The loop starts with the counter value from that’s incremented with step every time the 
loop is passed. If the counter variable reaches the value to, the loop is exited. For the 
counter variable, only integer array elements (i[], gi[]) are allowed. For the parameters 
from, to and step, also integer constants are possible.

Syntax:
Loop(var=from;to[;step])

Parameters:

var Loop variable. 
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

from Start value (-1’000’000 ... 1’000’000)
• cc - Numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
Quadstar 32-bit, vpnb68e1 (0302) Process Control 473



Example(s):
Loop(i[5]=0;15)

SetDO(i[5]=off)

The digital outputs of channels 0 ... 15 are switched off.

Loop(gi[12]=60;30;-2)
Begin

Calculate(gfa[0][gi[12]]=gfa[1][gi[12]]/f[3]*100.0)
Calculate(gfa[1][gi[12]]=gfa[1][gi[12]]*2)

End

The loop starts with gi[12]=60 and is decremented (step = -2) until gi[12] has a value of 
equal or less than 30.

8.7.37 LoopTable() - Loop Table

Description:
Loop with value table.

LoopTable() is a special version of the Loop() function. It doesn’t run through a series 
of numbers with fixed increment, but through any given number table.

The exit condition and the incremental step are missing, instead there is a table of inte-
ger values or variables.

Syntax:
LoopTable(var=num1[;num2][;num3][;...])

Parameters:

Example(e):
// Valves 10, 12, 20 and 22 are opened.
LoopTable(i[34]=10;12;20;22)

SetDO(i[34]=on)

// The DO's 7, 18, 34 etc. are turned on consecutively, in

to End value (-1’000’000 ... 1’000’000)
• cc - Numeric value (integer)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

step Step width (-1’000’000 ... 1’000’000) (default value = 1)
• cc - Numeric value (integer)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

var Loop variable.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

num1..numX table values
• cc Integer value (-1’000’000 ... 1’000’000)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
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// between the DO 12 is switched on and off
LoopTable(gi[1]=7;12;18;12;34;12;23;12;40;12;42;12;44;12;4;12)
Begin

SetDO(gi[1]=on)
Delay(Time=2)
IfVar(gi[1]=12)

SetDO(gi[1]=off)
End

// The numbers of the DO's are stored in gi[]. Switch the ones
// in position i[0,4,8,12] of gi[] on.
LoopTable(i[10]=gi[i[0]];gi[i[4]];gi[i[8]];gi[i[12]])

SetDO(i[10]=on)

8.7.38 MCD() - MCD measurement

Description:
Perform a Multiple Concentration Detection (MCD) measurement.

Options:
• display the measurement data,
• store the measurement data in the field gfa[][] containing global float values,
• store the measurement data in a file containing MCD measurement data,
• store the measurement data in a file containing reference measurement data.

Syntax:
MCD(Par=file[;ind][,Disp=d][,Prot=p][,SaveGfa=var]_

[,SaveRef=file[;ind]][,SaveCyc=file[;ind][;m]])

Parameters:

Par Keyword for parameter file.

file (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

Disp Keyword for display mode.

d Display mode.
• [default] - Default display mode.
• off - Display off.
• tab - Table display.
• bar - Bargraph display.
• vt - Versus Time display.

Without an explicit entry the default mode is set to table display (tab). It 
can be altered with the SetDefault() instruction.

Prot Keyword for log mode
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Example(s):
MCD(Par="mypar")

Perform an MCD measurement with the parameter file “mypar” and display the mea-
sured values as a table (default).

MCD(Par="c:\qs\par\mcd",Disp=vt,SaveCyc="c:\qs\dat\mcd")

Perform an MCD measurement with the parameter file “c:\qs\par\mcd”, display the data 
in Versus Time mode and store them in the data file “c:\qs\dat\mcd”.

p Log mode.
• [default] - Default log mode.
• off - Log function off.
• on - Printer log on.

See Chapter 8.4.3 Log output, 422.

If nothing else is specified, the default log mode is off. It can be altered 
with the SetDefault() instruction.

SaveGfa Keyword for storing measurement data in an array of the global data 
field gfa[][]:
• The measurement data are stored in the float array xx (=var) of the 

gfa[xx][ ] field. Specification of the index yy for gfa[][] is not neces-
sary, the measured value of the 1st element is stored in gfa[][0], the 
measured value of the 2nd element is stored in gfa[][1], etc.. 

• All data stored in the elements yy = 0 ... 63 of the float array xx=var 
of gfa[xx][yy] are cleared before the data are stored.

var Float array number (0 <= var <= configurable maximum).
• cc - Numeric value (integer).
• i[xx] - Element xx of the local integer array. 
• gi[xx] - Element xx of the global integer array.

SaveRef Keyword for storing in a file containing reference data.

file (Drive:\Path\) Filename.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”).
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

SaveCyc Keyword for storing the Cycle data in a file

file (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

m Save mode
• [append] - Add the data to the end of the file (default).
• reset - Clear the file before storing the new data.
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8.7.39 Message() - Message output

Description:
Output a message in the status bar of the measurement window, the Event window 
(Confirm=off) or in a separate dialog box with an [OK] button to confirm the message 
(Confirm=on).

Syntax:
Message(Text=text[;strval][,Confirm=c][,Prot=p]_

[,Delay=tim [;unit][,Save=sav][,Time=t][,Disp=d])

Parameters:

Text Keyword for text.

text Text.
• “Text” - Direct input of text.
• gs[xx] - Element xx of the global character string array.

strval String value - See Chapter 8.4.1.4 String values, 417

Confirm Keyword for confirmation mode.

With confirm, the sequence being executed can be stopped until the 
message (displayed in a separate dialog box) has been confirmed with 
the [OK] button.

c Confirmation mode.
• [off] - Sequence continues without confirmation (default).
• on - Sequence is stopped until the [OK] command is given.

Prot Keyword for log mode.

p Log mode.
• [default] - Default log mode.
• off - Log function off.
• on - Printer log on.

See Chapter 8.4.3 Log output, 422.

If nothing else is specified, the default log mode is off. It can be altered 
with the SetDefault() instruction.

Delay Keyword for time delay. The message remains on the screen until the 
delay has been counted down.

tim Time specification (1 ... 1’000’000).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Unit of time
• ms - Time in milliseconds.
• [s] - Time in seconds (default).
• min - Time in minutes.
• h - Time in hours.
• d - Time in days.

Save Keyword for save message.
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Example(s):
Message(Text="calibration of bottle 5 in progress")

Output a message, the sequence continues.

Message(Text=gs[i[4]],Confirm=on)

Output a message and stop the sequence until the operator confirms by [OK] that the 
sequence shall be continued.

8.7.40 MID() - MID measurement

Description:
Perform a Multiple Ion Detection (MID) measurement.

Options:
• Display the measurement data,
• store the measurement data in the field gfa[][] containing global float values,
• store the measurement data in a file containing MID measurement data,
• store the measurement data in a file containing reference measurement data.

Syntax:
MID(Par=file[;ind][,Disp=d][,Prot=p][,SaveGfa=var]_

[,SaveRef=file[;ind]][,SaveCyc=file[;ind][;m]])

Parameters:

sav Save mode.
• [off] - Message is not stored in the Error History.
• on - Message is stored in the Error History.

Time Keyword for time information.

t Message with or without time information.
• [off] - Message does not contain time information.
• on - Message contains time information.

Disp Keyword for display.

d Indication, where the message is to be displayed.
• off - Don’t display message.
• [status] - Display message in status bar.
• event - Display message in ‘Event’ window.
• both -Display message in ‘Event’ window and status bar.

Par Keyword for parameter file.

file (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

Disp Keyword for display mode.
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Example(s):
MID(Par="mypar")

Perform a MID measurement with the parameter file “mypar” and display the measured 
values as a table (default).

d Display mode.
• [default] - Default display mode.
• off - Display off.
• tab - Table display.
• bar - Bargraph display.
• vt - Versus Time display.

Without an explicit entry the default mode is set to table display (tab). It 
can be altered with the SetDefault() instruction.

Prot Keyword for log mode

p Log mode.
• [default] - Default log mode.
• off - Log function off.
• on - Printer log on.

See Chapter 8.4.3 Log output, 422.

If nothing else is specified, the default log mode is off. It can be altered 
with the SetDefault() instruction.

SaveGfa Keyword for storing measurement data in an array of the global data 
field gfa[][]:
• The measurement data are stored in the float array xx (=var) of the 

gfa[xx][] field. Specification of the index yy for gfa[][] is not neces-
sary, the measured value of the 1st element is stored in gfa[][0], the 
measured value of the 2nd element is stored in gfa[][1], etc.. 

• All data stored in the elements yy = 0 ... 63 of the float array xx=var 
of gfa[xx][yy] are cleared before the data are stored.

var Float array number (0 <= var <= configurable maximum).
• cc - Numeric value (integer).
• i[xx] - Element xx of the local integer array. 
• gi[xx] - Element xx of the global integer array.

SaveRef Keyword for storing in a file containing reference data.

file (Drive:\Path\) Filename.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”).
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

SaveCyc Keyword for storing the Cycle data in a file

file (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

m Save mode
• [append] - Add the data to the end of the file (default).
• reset - Clear the file before storing the new data.
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MID(Par="c:\qs\par\sample",Disp=bar,SaveCyc="c:\qs\dat\midcyc")

Perform a MID measurement with the parameter file “c:\qs\par\sample”, display the data 
in Versus Time mode and store them in the data file “c:\qs\dat\midcyc”.

8.7.41 MSC() - Mass scale calibration

Description:
Perform a mass scale calibration.

Syntax:
MSC(Par=file[;ind][,CalMode=c][,Disp=d][,Prot=p][,SaveMode=m])

Parameters:

Par Keyword for parameter file.

file (Drive:\Path\) Filename.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”).
• gs[xx] - Element xx of the global character string array if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

CalMode Keyword for calibration mode.

c Calibration mode.
• [coarse] - fast and coarse search (default).
• fine - Fine search of the peak top with reduced search range.

Disp Keyword for display mode.

d Display mode.
• [default] - Default display mode.
• off - Display off.
• on - Display on. 

Without any explicit input, the default mode is set to on. It can be altered 
with the SetDefault() instruction.

Prot Keyword for log mode.

p Log mode.
• [default] - Default log mode.
• off - Log function off.
• on - Printer log on.

See Chapter 8.4.3 Log output, 422.

If nothing else is specified, the default log mode is off. It can be altered 
with the SetDefault() instruction.

SaveMode Keyword for save mode.

m Save mode.
• [append] - Add the additional basic points, i.e. mass numbers to the 

end of the data file (default).
• reset - Clear the file before storing the data.
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Example(s):
MSC(Par="mscal")

Perform a mass scale calibration using the “mscal” parameter file.

MSC(Par="c:\qs\par\mscal",Disp=off,SaveMode=reset)

Perform a mass scale calibration with the “c:\qs\par\mscal” parameter file without dis-
play. Clear the old mass numbers before storing the new adjusted mass numbers.

8.7.42 OffsetCal() - QMS Offset calibration

Description:
Perform an offset calibration on the QMS 422/200 (not QMS 421!).

Syntax:
OffsetCal([Clear=onoff,]DetType=type[,SemVolt=volt]_

ZeroMass=mass[,Resol=resol][,Disp=d][,Prot=p])

Parameters:

Clear Keyword for clear QMS 422 Offset-values (does not apply to QMS 200).

onoff • on - Clear offset values of QMS 422
• off - Don’t clear offset values of QMS 422

DetType Keyword for detector type.

type Detector type
• FARADAY - Faraday
• SEM - SEM
• CH-TRON - Channeltron

SemVolt Keyword for SEM voltage of the channeltron (only QMS 200)

volt SEM voltage
• common - Common SEM voltage
• cc - Direct input of a numeric value (integer or float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

ZeroMass Keyword for zero mass.

mass • cc - Direct input of the numeric value (Integer or Float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

Resol Keyword for resolution (only QMS 200)

resol Resolution (off, 1 ... 255)
• off - Resolution switched off
• cc - Direct input of the numeric value (integer or float)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Disp Keyword for display mode.
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Example(s):
OffsetCal(DetType=CH-TRON, SemVolt=common, ZeroMass=5.5, 
Resol=25, Disp=off)

Perform an offset calibration on a QMS 200 Prisma™ (detector type channeltron, com-
mon SEM voltage, on mass number 5.5 with resolution 25) without displaying the mea-
surement results.

OffsetCal(DetType=SEM, ZeroMass=f[2], Disp=on, Prot=on)

Perform an offset calibration on a QMS 422, on the mass number stored in f[2]. Display 
the measurement results and output them on the printer.

OffsetCal(Clear=on)

Set all offset calibration values of a QMS 422 to zero (delete them).

8.7.43 Process() - Data processing

Description:
This instruction is used for selecting different data (ion currents, concentrations, calcu-
lated data, etc.) and to make them available as input for further processing:

What? (DataGfa, DataI, DataF) -> Where? (Disp, Prot, SaveGfa, SaveCyc)

• Select data

The three keywords DataGfa , DataI and DataF are used for selecting the arrays 
(from the float data field gfa[][]), or for selecting the array elements from the integer 
arrays (i[], gi[]) and/or from the float arrays (f[], gf[], gfa[][]).

• Processing facilities

The selected data are assembled in the order shown below and processed according 
to Disp, Prot (displayed, printed) or saved in the array specified under SaveGfa 
and/or in the file specified under SaveCyc.

d Display mode.
• [default] - Default display mode. 
• off - Display off. 
• on - Display as table. 

Without an explicit entry the default mode is set to on. It can be changed 
with the SetDefault() instruction.

Prot Keyword for log mode

p Log mode.
• [default] - Default log mode.
• off - Log function off.
• on - Printer log on.

See Chapter 8.4.3 Log output, 422.

If nothing else is specified, the default log mode is off. It can be altered 
with the SetDefault() instruction.
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Syntax:
Process([,DataGfa=arr1[;arr2][;arr3]...]_

[,DataI=var1[;var2][;var3]...]_
[,DataF=var1[;var2][;var3]...]_
[,Disp=d][,Prot=p][,SaveGfa=var]_
[,SaveCyc=file[;ind][;m]][,SaveRef=file [;ind]])

Parameters:

DataGfa Keyword for selecting float arrays from the float data field gfa[xx][].

arr1;arr2;... Numbers of the arrays
• cc - Numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

NOTE:
Only those elements of the selected float array are processed 
which have a name.
=> The gfa[][] elements are named by Calculate() and SetVar() or 
the name is given automatically for measurement data by compo-
nent and mass number.

DataI Keyword for selecting variables from the integer array.

var1;var2;... Identifier of variables (array elements).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

NOTE:
All selected array elements are processed. If a variable is un-
named, the designation of the array element (for example “i[4]”, 
“gi[10]” etc.) is used.
=> The i[] and gi[] elements are named via the Calculate() and Set-
Var() instructions.

DataF Keyword for selecting individual float variables:

var1;var2;... Identifier of float variables (array elements).
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

NOTE:
All selected array elements are processed. If a variable is un-
named, the designation of the array element (for example, “f[3]”, 
“gf[5]” etc.) is used. 
=> The gf[]-, gf[]- and gfa[][] elements are named by Calculate() 
and SetVar(), or the name is given automatically for measurement 
data by component and mass number.

Disp Keyword for display mode

d Display mode
• [default] - Default display mode.
• off - Display off.
• on - Display on.

Without any explicit input, the default mode is set on. It can be altered 
with the SetDefault() instruction.
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Example(s):
Process(DataGfa=0, Disp=tab)

Display a table of the data stored in float array 0.

Process(DataGfa=4,Disp=off,SaveRef="ref3.mdr")

Save the data of float array 4 in the reference file “ref3.mdr” without displaying them.

Process(DataGfa=0;1,i[3],DataI=i[1];gi[3];gi[4],Disp=on,_
SaveCyc="c:\qs\dat\mix")

Display data from float array 0, 1 and i[3] together with the integer variables i[1], gi[3] 
and gi[4]; store it all in the “c:\qs\dat\mix” Cycle data file.

Prot Keyword for log mode.

p Log mode.
• [default] - Default log mode.
• off - Log function off.
• on - Printer log on.

See Chapter 8.4.3 Log output, 422.

If nothing else is specified, the default log mode is off. It can be altered 
with the SetDefault() instruction.

SaveGfa Keyword for the array in which the selected data are to be stored.

var Number of the float array from the global data field gfa[][].
• cc - Numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

NOTE:
All data stored in the elements yy=0 ... 63 of the float array 
gfa[xx][yy] (xx=var) are cleared before the save operation..

SaveCyc, 
SaveRef

Keywords for defining files in which the selected data are to be stored 
as cycles (SaveCyc) and/or as a reference (SaveRef).

File (Drive:\Path\) Filename.
• “ffffffff” Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

m Save mode
• [append] - Add the data to the end of the file (default).
• reset - Clear the file before storing the data.

NOTE:
In append mode no test is made whether or not the previously 
stored data are compatible with the new data. Since Process() cre-
ates the data dynamically, a compatibility test would have to be 
conducted on-line each time a data item is stored. This would re-
quire a lot of time and might adversely affect the measurement 
speed.
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8.7.44 QMSConnect() - Switch on the communication to the mass 
spectrometer 

Description:
Switch on the communication from the PC to the selected mass spectrometer. If several 
mass spectrometers are online, the last used one will be switched on. If you want to 
switch on a different one, you have to do that by SetUnit().

Syntax:
QMSConnect()

Parameters:
None

8.7.45 QMSDisconnect() - Switch off the communication to the 
mass spectrometer

Description:
Switch off the communication from the PC to the selected mass spectrometer. If several 
mass spectrometers are online, the last used one will be switched off. If you want to 
switch off a different one, you have to select it first by SetUnit() and then you can switch 
it off by QMSDisconnect().

Syntax:
QMSDisconnect()

Parameters:
None

8.7.46 ScanAnalog() - Scan Analog

Description:
Perform a Scan Analog measurement.

Syntax:
ScanAnalog(Par=pFile[;ind]_

[,DataGfa=arr1[;arr2][;arr3]...]_
[,DataI=var1[;var2][;var3]...]_
[,DataF=var1[;var2][;var3]...]_
[,Disp=d][,SaveRef=file[;ind]]_
[,SaveCyc=file[;ind][;m]][,RefFile=rFile[;ind]])

Parameters:

Par Keyword for parameter file.

pFile (Drive:\Path\) filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416
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Example(s):
ScanAnalog(Par="anascan1")

Perform a Scan Analog measurement with the parameter file “anascan1”.

ScanAnalog(Par="c:\qs\par\scan1";SaveCyc="c:\qs\dat\scadata")

Perform a Scan Analog measurement with the parameter file “c:\qs\par\scan1”. Saving 
of the data in the file “c:\qs\dat\scadata” is activated.

DataGfa, DataI, 
DataF

Keywords for additional data. Those data are stored additionally and 
may be displayed later in Dispsav as a table.

Meaning and function of DataGfa, DataI and DataF are explained in 
Chapter 8.7.43 Process() - Data processing, 482

Disp Keyword for Display mode.

d Display mode.
• [default] - Default display mode.
• off - Display off.
• on - Display on.

Without any explicit input, the default mode is set on. It can be altered 
with the SetDefault() instruction.

SaveRef Keyword for storing the reference

File (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g.. “c:\qs\myfile”)
• gs[xx] - Element xx of the global character string array if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

SaveCyc Keyword for storing the measurement data of a scan. The parameter m 
provides the possibility to append data to an existing file.

File (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”)
• gs[xx] - Element xx of the global character string array if the filena-

me is stored in gs[]

ind File index - See Chapter 8.4.1.3 File names with indices, 416

m Save mode
• [append] - Add the data to the end of the file (default).
• reset - Clear the file before storing the new data.

RefFile Keyword for reference file whose data are to be subtracted from the cur-
rently measured data.

rFile (Drive:\Path\) Filename
• “ffffffff” Filename (e.g.. “c:\qs\myrfile”)
• gs[xx] - Element xx of the global character string array if the filena-

me is stored in gs[].

NOTE:
If you declare a reference file, then the data delivered by ScanAn-
alog are always the difference between the currently measured 
and the reference. In other words, it’s always the difference that is 
stored or displayed, not the actually measured data.
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8.7.47 ScanBar() - Scan Bargraph 

Description:
Perform a Scan Bargraph measurement.

Syntax:
ScanBar(Par=pFile[;ind][,Disp=d][,Prot=p]_

[,SaveCyc=file[;ind][;m]][,RefFile=rFile[;ind]])

Parameters:

Par Keyword for parameter file.

pFile (Drive:\Path\) Filename.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”).
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

Disp Keyword for display mode.

d Display mode.
• [default] - Default display mode.
• off - Display off.
• on - Display on.

Without any explicit input, the default mode is set on. It can be altered 
with the SetDefault() instruction.

Prot Keyword for log mode.

p Log mode.
• [default] - Default log mode.
• off - Log function off.
• on - Printer log on.

See Chapter 8.4.3 Log output, 422.

If nothing else is specified, the default log mode is off. It can be altered 
with the SetDefault() instruction.

SaveCyc Keyword for storing the found peaks of a scan as Cycle data in a file.

File (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”) 
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

m Save mode
• [append] - Add the new data to the end of the file.
• reset - Clear the file before storing the new data.
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Example(s):
ScanBar(Par="measure")

Perform a Scan Bargraph measurement with the “measure” parameter file.

ScanBar(Par="c:\qs\par\scan1",Prot=on,_
SaveCyc="c:\qs\dat\scbcyc")

Perform a Scan Bargraph measurement with the “c:\qs\par\scan1” parameter file. Log 
messages on the printer and save the data in file “c:\qs\dat\scbcyc”.

8.7.48 SeqExit() - Defining a sequence for sequence cancellation

Description:
Define a sequence to be executed when the current sequence is terminated or aborted:

• Each sequence can be programmed with a cancellation sequence. If a subsequence 
called by the Sequence() instruction is cancelled, then the SeqExit() instruction be-
longing to the subsequence is executed first. After that, the SeqExit() instruction of 
the main sequence is executed.

• A cancellation sequence can be locked, so it can’t be cancelled itself.

• By calling SeqExit() again, a different sequence can be defined as the cancellation 
sequence. Only the last defined cancellation sequence is valid.

Syntax:
SeqExit(Par=file[;ind],CloseLock=OnOff)

Parameters:

RefFile Keyword for reference file whose data are to be subtracted from the cur-
rently measured data.

rFile (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g.. “c:\qs\myrfile”)
• gs[xx] - Element xx of the global character string array if the filena-

me is stored in gs[].

NOTE:
If you declare a reference file, then the data delivered by Scan Bar-
graph are always the difference between the currently measured 
and the reference. In other words, it’s always the difference that is 
stored or displayed, not the actually measured data.

Par Keyword for parameter file (sequence).

file (Drive:\Path\) Filename of the sequence.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array, if the se-

quence name is stored in gs[] .
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Example(s):
SeqExit(Par="close")

Execute the “close”-sequence when the sequence is cancelled. “Close” may be can-
celled for its part.

SeqExit(Par="close",CloseLock=on)

The sequence “close” is being executed on termination or cancellation of the sequence 
and cannot be cancelled.

8.7.49 Sequence() - Starting a (sub-)sequence

Description:
Call another sequence. When this subsequence has terminated, the current sequence 
is continued.

Syntax:
Sequence(Par=file [;ind])

Parameters:

Example(s):
Sequence(Par="inlet")

Start the “inlet” sequence.

Sequence(Par="c:\par\calib")

Start the “c:\par\calib” sequence.

ind File index - See Chapter 8.4.1.3 File names with indices, 416

CloseLock Keyword to lock the cancellation sequence chosen by SeqExit.
• off - The cancellation sequence is not locked, it can therefore be 

cancelled. 
• on - The cancellation sequence is being executed completely under 

all circumstances, it cannot be cancelled.

Par Keyword for parameter file (sequence).

file (Drive:\Path\) Filename of the sequence.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array, if the se-

quence name is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416
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8.7.50 SetAO() - Setting an analog output channel

Description:
Set one or all analog output channels of the control unit to a certain value.

Syntax:
SetAO(chan=val{;unit},Mode=m])

Parameters:

Example(s):
SetAO(3=f[12])

Set analog output 3 to the value stored in f[12].

SetAO(AO#12; "Q_Unit_1"=gf[18])

Multiplex mode: Sets AO#12 of the unit “Q_Unit_1” to the value gf[18].

SetAO(i[8]=0.1,Mode=inc)

Increase the analog output voltage nbr i[8] by 0.1.

chan AO channel (1 ... 12).
• cc - Direct input of a numeric value (integer). 
• “zzzzz” - Logical name AO#1 ... AO#12 of the output channel. 
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

val Value to be set (-10.24 ... +10.238) 
• cc - Direct input of the numeric value (integer or float)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

unit Identification of the control unit, only available in multiplex mode.
• “zzzzz” - Logical name of the control unit.
• cc - Direct input of the internal logical number.

=> Only those control units are available whose status has been set to 
Enable in the Parameter Setup program under [Comm] > [Node Identi-
fication]. This entry does not influence the unit selected with SetUnit().

Mode AO output mode

m Mode
• [set] - Set the AO voltage to the predefined value. 
• inc - Increase the AO voltage by the specified amount. If it exceeds 

the maximum admissible voltage, it is limited.
• dec - Reduce the AO voltage by the specified amount. If it exceeds 

the minimum admissible voltage, it is limited.

NOTE:
The voltage effectively appearing at the analog output port is nor-
mally not the given float number in volts. This number is converted 
to a voltage by using the AO-Characteristic Curve ([Parameter Set-
up] > [Config] > [AO Characteristic Curve]).
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8.7.51 SetDefault() - Set default values

Description:
Change the default values.

Set the default values (Disp, Prot, etc.), which can be recalled by [default] in the param-
eter list of the individual sequencer instructions. This simplifies e.g. the logging of the 
current measurement, since you can set the optional prot parameter with SetDe-
fault(prot=on). This way, prot doesn’t have to be set in each instruction.

Syntax:
SetDefault([Disp=d][,Prot=p])

Parameters:

Example(s):
SetDefault(Prot=on).

Set Prot default value to on. Every sequencer instruction whose Prot parameter is set 
to default (or not specified), sends its results as a log to the printer.

8.7.52 SetDO() - Set a digital output channel

Description:
Switch one or all digital output channels of the control unit on or off. Delay the sequence 
continuation or display the DO’s (optionally).

Syntax:
SetDO(num{;unit}=state[;tim[;unit]][,Disp=d])

Disp Keyword for display mode.

d Display mode.
• off - Display off.
• tab - Table display.
• bar - Bargraph display.
• vt -Versus Time display.

Prot Keyword for log mode.

p Log mode.
• off - Log function off.
• on - Printer log on.

See Chapter 8.4.3 Log output, 422.
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Parameters:

Example(s):
SetDO(10;"Q_Unit_1"=on)

Multiplex mode: Set the digital output 10 of unit “Q_Unit_1” to on.

SetDO(all=off;1;min)0

Switch all digital output channels off, and perform a 1 minute delay.

num Number of the digital output channel 0 ... 31 (63, 95)
• “zzzzz” - Logical name of the output channel. (=> The logical names 

are defined in the Parameter Setup program under [Config] > [DI/DO 
Identifications].) 

• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• all - All available digital output channels.

unit Identification of the control unit, only in multiplex mode. 
• “zzzzz” - Logical name of the control unit. 
• cc - Direct input of the internal logical number. 

=> Only those control units are available whose status has been set to 
Enable in the Parameter Setup program under [Comm] > [Node Identi-
fication]. This entry does not influence the unit selected with SetUnit().

state DO-Status
• off - Set DO status off.
• on - DO status on.

tim Time specification (1 ... 1’000’000)
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Unit of time.
• ms - Time in milliseconds.
• [s] - Time in seconds (default).
• min - Time in minutes.
• h - Time in hours.
• d - Time in days.

Disp Keyword for display 

Display the sequencer status

See Chapter 2.7.2.2 Status display, 122

d Display mode
• [default] - Default display mode.
• off - Display off.
• on - Display on.

Without any explicit declaration, the default display mode is on. The 
default settings can be altered by SetDefault().

Select the channels to be displayed in the Measure program under 
[Sequence] > [Setup].
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8.7.53 SetFileInfo() - Changing the measure data documentation 
settings

Description:
Changing the File Info settings (See Chapter 2.11 Setup, 148) while running a 
sequence. When a sequence is started, the settings made in that setup box are valid. 
By using the instruction SetFileInfo(), those settings can be changed during sequence 
execution.

Syntax:
SetFileInfo([,SaveFileInfo=mode][,SaveMeaPar=mode]_

[,SaveISPar=mode][,SaveStatePar=mode]_
[,SaveZeroDat=mode][,ResetNames=mode]_
[,ResetValues=mode][,FileTitle=title][;ind]_
[,Name=num;name][,Name=...][,Value=num;val]_
[,Value=...])

Parameters:

SaveFileInfo Keyword for generally switching the file information storage on/off. If 
this switch is on, the items to be stored (measurement parameters, Ion 
Source parameters etc.) may be chosen; if it is off, no documentation is 
stored at all.

mode Switch the file information storage function on/off
• off - File information storage function disabled.
• on - File information storage function enabled.

SaveMeaPar Keyword for switching the measurement parameter storage on/off.

mode Switch the measurement parameter storage function on/off
• off - Measurement parameter storage function disabled.
• on - Measurement parameter storage function enabled.

SaveISPar Keyword for switching the ion source parameter storage on/off.

mode Switch the ion source parameter storage function on/off.
• off - Ion source parameter storage function disabled.
• on - Ion source parameter storage function enabled.

SaveStatePar Keyword for switching the status parameter storage on/off.

mode Switch the status parameter storage function on/off.
• off - Status parameter storage function disabled.
• on - Status parameter storage function enabled.

SaveZeroDat Keyword for switching the zero gas data storage on/off.

mode Switch the zero gas data storage function on/off.
• off - Zero gas data storage function disabled.
• on - Zero gas data storage function enabled.

ResetNames Keyword to delete additional information names.

mode Delete additional information names on/off
• off - Don’t delete names.
• on - Delete all names.

ResetValues Keyword to delete additional information values.
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Example(s):
SetFileInfo(SaveFileInfo=on,SaveISPar=off)

Store file information. No Ion Source parameters shall be stored.

SetFileInfo(Name=0;"Probe ID",ResetValues=on,Value=0;i[1],_
Value=gi[5];gf[5])

Set name nbr. 0 to “Probe ID” and delete all values. Then set value nbr. 0 to the content 
of i[1] and value nbr. gi[5] to the content of gf[5].

8.7.54 SetISPar() - Set Ion Source Parameters of the current unit

Description:
Set or change parameter(s) on the ion source of the current unit. This may be useful for 
automatically optimizing the ion source or adapting it to varying conditions. The new val-
ues can optionally be stored on the hidden file that’s assigned to this ion source; the old 
values will be overwritten then.

mode Delete additional information values on/off
• off - Don’t delete values.
• on - Delete all values.

FileTitle Keyword for title of the measure data file.

title Title text.
• “tttttt” - Direct input of the title text.
• gs[xx] - Element xx of the global character string array.

ind File index - See Chapter 8.4.1.3 File names with indices, 416

Name Keyword for additional information name.

num Index number of the name (0 ... 19).
• cc - Direct input of the numeric value (integer)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

name Name.
• “tttttt” - Direct text input of the name. 
• gs[xx] - Element xx of the global character string array, if the name 

is stored in gs[].

Value Keyword for additional-information value.

num Index number of the value (0 ... 19). 
• cc - Direct input of the numeric value (integer)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

val Value.
• “tttttt” - Direct text input of the value. 
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.
• gs[xx] - Element xx of the global character string array.
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Syntax:
SetISPar([Filament=filnbr][,ISSet=setnbr][,Emission=emicur]_

[,Protection=protcur][,V1=V1][,V2=V2][,V3=V3]_
[,V4=V4][,V5=V5][,V6=V6][,V7=V7][,V8=V8][,V9=V9]_
[,RFPolarity=rfpol],Save=onoff)

Parameters:

Example(s):
Loop(i[0]=105;150;5)
Begin

SetISPar(Filament=1, V1=i[0])
ScanAnalog(Par="c:\QS50\par\temp.sap", Disp=on)

End

Ten Scan Analog measurements are carried out, using filament 1, while the ion source 
voltage V1 (IonRef) is varied from 105 volts to 150 volts, 5 volts each time. The scans 
will show the influence of V1 on the peak shape and height. The values for V1 are not 
stored to file, so it will be the same again (as before this sequence has been run), if you 
call the Tune Up program and there [Tune] > [Ion Source].

Filament Keyword for filament to use.

filnbr nbr of the filament.
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

ISSet Keyword for the number of the Ion Source Set to be used

setnbr nbr of the ISSet
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Emission
Protection
V1
V2
V3
V4
V5
V6
V7
V8
V9
RFPolarity

These are the Ion Source parameters that may be changed on the ion 
source of the currently set unit. Whether a parameter is possible/useful, 
what its possible range is, etc., depends very much on the ion source in 
use, its configuration etc.

Use this instruction only if you are sure, that the parameter values you 
intend to set are correct. Quadstar 32-bit has no possibility to check 
their consistency.

This instruction can cause malfunction, if it is used without comprehen-
sive knowledge of the meaning and relations between the parameters. 

Save Keyword for ‘saving parameters to file yes/no’.

mode Save the new values or not.
• off - Use the new values for this sequence, leave file unchanged. 
• on - Save the new values to file, overwrite the old ones.

NOTE:
Make sure that no Ion Source Sets are overwritten that you may 
need in further measurements.
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8.7.55 SetPar() - Setting Quadstar 32-bit parameters

Description:
Change one or several Quadstar 32-bit parameters. The parameters correspond mainly 
to the display control parameters found in the program Measure under [Scan/MID/MCD] 
> [Setup].

NOTE:
If a keyword is not used, the last settings made in the corresponding program are 
taken as default settings.

Syntax:
SetPar([AlarmDisp=mode][,AlarmError=mode][,AlarmSound=mode]_

[,BarWidth=var][,ColorMode=mode][,Cycles=var]_
[,DispLast=mode][,DispOpt=mode][,LineType=type]_
[,Marker=mode][,MSC=mode][,NorMode=mode][,RelVal=mode]_
[,RollAxis=mode][,Scale=state][,TimeScale=tim[;unit]]_
[,XLetter=mode][,XRaster=mode][,XScale=mode]_
[,YRaster=mode][,ZeroEq=mode][,ZeroSub=mode]_
[,DDETimeout=tmt])

Parameters:

AlarmDisp Keyword for graphic display of the threshold monitoring.

mode Display the alarm status for all channels with enabled threshold moni-
toring (can be set in the Parameter Setup program under [Measure] > 
[Scan/MID/MCD] > [Trip]). 
• off - Alarm display off.
• on - Alarm display on.

AlarmError Keyword for threshold alarm message.

mode Display threshold alarm in the Event window on/off.
• off - Alarm error message off.
• on - Alarm error message on.

AlarmSound Keyword for audible alarm signal.

mode Turn on the audible alarm warning.
• off - Alarm sound off.
• on - Alarm sound on.

BarWidth Keyword for bar width of the bargraph.

var Bar width of the bargraph in pixels (1 ... 255)
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

ColorMode Keyword for color settings of the measure data display.

mode Display mode single color/multiple color. 
• s - Single color. The color can be chosen in the Parameter Setup 

program under [Config] > [Screen Color].
• m - Multiple color. The measurement data are displayed in the colors 

defined in the channel parameter editor.

Each of the bargraph elements (Normal, Last) should be marked by its 
own grid (see Chapter 2.5.7.1 Parameter setup, 96, Chapter 2.6.8.1 
Parameter setup, 113)
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Cycles Keyword for number of cycles. Specifies the number of cycles to be dis-
played in the measurement data window before the old data are over-
written.

var Number of cycles (2 ... 10000)
• cc - Direct input of a numeric value (integer)
• i[xx] - Element xx of the local integer array
• gi[xx] - Element xx of the global integer array

DispLast Keyword for Display Last Values for the bargraph display in MID and 
MCD mode.

mode Display Last
• off - Display Last off.
• on - Display Last on.

DispOpt Keyword for table display option.

mode Display option
• none - Optional display switched off. 
• integral - Display the measurement signal integrated since the start 

of the measurement. 
• last - Display the values of the last measurement.
• MultColumn - Display the measurement data in several columns.

LineType Keyword for line type.

type Line type
• solid - The measured values or markers are interconnected with a 

solid line.
• dot - The measured values or markers are displayed as dots.

Marker Keyword for marker display. Mark a measured value with a symbol. The 
appropriate symbol is selected automatically.

mode Marker display.
• off - Marker display off.
• on - Marker display on.

MSC Keyword for mass scale correction.

mode Mass scale correction. 
• off - Mass scale correction off. The measurement is performed on 

the mass selected in the channel parameter editor. 
• on - Mass scale correction on. The mass selected in the channel pa-

rameter editor is corrected to the mass found during the mass scale 
calibration.

NorMode Keyword for normalization mode.

mode Normalization mode:
• sum100 - Sum of the measured values normalized to 100%.
• max100 - Largest measured value normalized to 100%.
• extern - External normalization.

RelVal Keyword for displaying relative values.

mode Display relative values:
• none - Display relative values.
• sum100 - Sum of all values = 100%.
• max100 - Maximum value = 100%.
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RollAxis Keyword for roll axis mode. Shifts the display to the left when the end of 
the X-axis is reached (unit = cycle or time).

mode Roll axis mode
• off - Roll axis off.
• on - Roll axis on.

Scale Keyword for axis mode.

state Axis mode lin/log
• lin - Linear axes.
• log - Logarithmic axes.

ScanArran Keyword for multiple scan representation.

mode Axis mode vertical/horizontal.
• Vert - Vertical, below each other.
• Horiz - Horizontal, side-by-side.

TimeScale Keyword for time scale extent

tim Time specification (1 ... 1’000’000).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Unit of time
• [s] - Time in seconds (default).
• min - Time in minutes.
• h - Time in hours.
• d - Time in days.

XLetter Keyword for X-axis lettering.

mode X-Axis lettering
• off - X-axis lettering off
• on - X-axis lettering on. 

XRaster Keyword for displaying the X-grid in the measurement picture

mode X-grid display
• off - X-grid display off.
• on - X-grid display on.

XScale Keyword for displaying the X-scale.

mode X-scale display
• cycle - Cycle.
• timrel - Time relative.
• timabs - Time absolute.

YRaster Keyword for displaying the Y-grid in the measurement picture.

mode Y-grid display.
• off - Y-grid display off.
• on - Y-grid display on.

ZeroEq Keyword for zero equalization of the amplifier offset on the ‘Zero Mass’.
• When a QMS 422/421 is used, the zero equalization is switched on 

by default. When a sequence is started, a zero equalization is per-
formed before the first measurement is started.

• When a QMS 200 is used, this switch has no effect (use the instruc-
tion OffsetCal() instead).
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Example(s):
SetPar(BarWidth=20,NorMode=sum100, Scale=lin)

Set the bar width to 20 pixels, the normalization mode to sum=100%, and the Scale 
parameter to linear (applies to bargraph display mode).

8.7.56 SetParFile() - Set value(s) in a channel parameter file 

Description:
Set or change a value in a channel parameter file. This may be useful if you run e.g. 
measurement series in which one parameter changes continuously.

Syntax:
SetParFile(ParFile=pFile[;ind],Channel=chan[,Mass][,Dwell][,Fir
stMass][,Width][,Speed][,Steps][,Resolution][,AmplRange][,Range
Limit][,Filter][,Offset][,DispMode][,DispRange][,DispDec])

Parameters:

mode Zero equalization
• off - Zero equalization on sequence start off.
• on - Zero equalization on sequence start on.

ZeroSub Keyword for zero gas subtraction.

=> This parameter is available only in the sequencer and (like in manual 
mode) always on when the sequence is started.

mode Zero gas subtraction.
• off - Zero gas subtraction off.
• on - Zero gas subtraction on. The zero gas measurement signals ob-

tained during the zero gas calibration are subtracted from the mea-
sured signals.

DDETimeOut Keyword for DDE timeout. If data are exchanged by DDE using a net-
work, the default setting may be too short, so the connection cannot be 
established.

tmt Time in milliseconds (1 ... 60’000).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

ParFile Keyword for parameter file.

pFile (Drive:\Path\) Filename.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”)
• gs[xx] - Element xx of the global character string array, if the file 

name is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

Channel Keyword for channel number
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Example(s):
Loop(i[0]=0;90;10)
Begin

SetParFile(ParFile="c:\as\par\temp.sap", Channel=0,_
FirstMass=i[0], Width=10)

ScanAnalog(Par="c:\as\par\temp.sap", Disp=on,_
SaveCyc="scan";i[0])

End

Ten Scan Analog measurements are carried out, all with a scan width of 10 amu, starting 
at the masses 0, 10, 20, .., 90. For that purpose, the parameter FirstMass in the tempo-
rary file ‘temp.sap’ is changed. The data are stored in the files ‘scan0000’ to ‘scan0090’.

8.7.57 SetQMS() - Setting the QMS parameter(s)

Description:
Set QMS parameters (ion source, total pressure gauge and SEM).

QMS 200 and QMS 422/421 have different assignment rules for the ion source param-
eters. 

QMS 422/421
For each available ion source type, four ion source sets are stored. These sets can be 
assigned to the two filaments by choosing the filament (Filament) and assigning an ion 
source set to it (ISSet).

 => Filament 1+2 selects automatic operation, i.e. filament 2 is activated if filament 1 
becomes defective. In this case, assignment of a set to a filament (1 or 2) is not possible.

QMS 200
There are totally four ion source sets. Each of them contains one complete set of ion 
source parameters for filament 1, 2 and 1+2.

chan Number of the measure channel
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• ALL - All channels in this file

Mass
Dwell
FirstMass
Width
Speed
Steps
Resolution
AmplRange
RangeLimit
FilterOffset
DispMode
DispRange
DispDec

These are the channel parameters that may be changed on the file 
pFile; they partially exclude each other. The range of the individual 
parameters cannot be declared universal, they depend very much on 
the mass spectrometer in use, its configuration etc.

Use this instruction only if you are sure, that the parameter values you 
intend to set are correct. Quadstar 32-bit has no possibility to check 
their consistency.

This instruction can cause malfunction, if it is used without comprehen-
sive knowledge of the relations between the parameters.

NOTE:
Copy the desired parameter file to another one and change this 
copy by SetParFile; this way the original file remains unchanged.
500 Process Control vpnb68e1 (0302), Quadstar 32-bit



ISSet loads the chosen set, the applying ion source parameters are automatically 
loaded by choosing the Filament.

=> Filament 1+2 means that both filaments are switched on concurrently. The corre-
sponding parameters are loaded from the current ISSet.

Syntax:
SetQMS([CommSEM=var[;chan]][,Emission=state[;chan]_

[,Filament=num][,ISSet=set][,ISType=typ]_
[,TotGauge=state][,SEM=state])

Parameters:

CommSEM Keyword for common SEM Voltage

var Common SEM Voltage

QMS 422/421: 0 ... 3500, QMS 200: 0 ... 3000
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

chan QMU channel (0 ... 7)
• cc - Direct input of a numeric value.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array. 

Emission Keyword for emission on/off.

state Emission status.
• off - Emission off.
• on - Emission on.

chan QMU channel (0 ... 7)
• cc - Direct input of a numeric value.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Filament Keyword for filament number. (Function: See Description above)

num Filament number.
• 1 - Filament 1
• 2 - Filament 2
• 1+2 - Filament 1+2

ISSet Keyword for ion source set. (Function: See Description above)

set Ion source set (0 ... 3)
• cc - Direct input of a numeric value.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

ISType Keyword for ion source type.

type Ion source type.
• default - Ion source type specified in the configuration
• spec+ - Spec+
• spec- - Spec-

TotGauge Keyword for turning the total pressure gauge on/off.
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Example(s):
SetQMS(CommSEM=1800)

Set the common SEM voltage to 1800 V.

SetQMS(Emission=on;6,SEM=on)

Switch on the emission of QMU channel 6 and turn on the SEM.

8.7.58 SetScale() - Define a scale

Description:
Define a scale for display. Several scales may be defined and the desired one may be 
accessed by its identification number.

Syntax:
SetScale(ScaleID=scID[,Mode=m][,ScaleName=name][,Unit=u]_

[,Min=minV][,Max=maxV][,Dec=numDecs]_
[,DecMax=topDec])

Parameters:

state Status
• off - total pressure gauge switched off.
• on - total pressure gauge switched on.

SEM Keyword for SEM status.

mode SEM status.
• off - SEM off
• on - SEM on.

ScaleID Keyword for scale identification.

scID Scale identification number, identifies the scale clearly.
• cc - Direct input of a numeric value (0 ... 199).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Mode Keyword for scale mode.

m Scale mode (linear or logarithmic).
• lin - linear scale.
• log - logarithmic scale.

ScaleName Keyword for name of the measured quantity.

name Scale name (e.g. ‘Pressure’).
• “Text” - Direct text input.
• gs[xx] - Element xx of the global character string array.

Unit Keyword for unit of measure.

u Scale unit (e.g. ‘mbar’).
• “Text” - Direct text input.
• gs[xx] - Element xx of the global character string array.

Min Keyword for start value of the linear scale.
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Example(s):
SetScale(ScaleID=0, Mode=log, ScaleName="pressure",_

Unit="mbar",_Dec=5, DecMax=-3)

The scale nbr 0 shall display the pressure between 1E-3 mbar and 1E-8 mbar in loga-
rithmic mode.

SetScale(ScaleID=1, Mode=lin, ScaleName="Oxygen", Unit="%",_
Min=0, Max=25)

The scale nbr 1 shall display the oxygen content between 0 and 25% in linear mode.

8.7.59 SetString() - Setting a character string

Description:
Assign a character string to an array of gs[]. SetString() can also be used for copying 
character strings from one array of gs[] to another array of gs[].

Syntax: 
SetString(var=string[;strval])

minV Scale start value (applies only to linear scale).
• “ccc” - Direct numeric input.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

Max Keyword for end value of the linear scale.

maxV Scale end value (applies only to linear scale)
• “ccc” - Direct numeric input.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

Dec Keyword for number of decades of the logarithmic scale.

numDecs Number of decades to be displayed (applies only to logarithmic scale).
• cc - Direct input of a numeric value.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

DecMax Keyword for highest decade of the logarithmic scale.

topDec Highest decade to be displayed (applies only to logarithmic scale).
• cc - Direct input of a numeric value.
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
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Parameters:

Example(s):
SetString(gs[12]="Please close inlet valve")

Define the message text.

SetString(gs[i[3]]="C:\qs\dat\cycle")

Define the cycle filename.

SetString(gs[i[0]]=gs[12])

Copy gs[12] to gs[i[0]].

8.7.60 SetUnit() - Selecting the mass spectrometer in multiplex 
mode

Description:
With SetUnit() you can select a QMS by specifying its logical unit number (not to be con-
fused with the physical node address) or its logical name. The communication to this 
mass spectrometer is then switched on.

The individual mass spectrometers must first be given a physical node number (node) 
within the range of 01 ... FF (hex).

NOTE:
PPM 422 (Plasma Process Monitor) works with Unit 0 (QMS 422 with mass scan) 
and Unit 1 (QMS 422 with ion energy scan) only.

Syntax:
SetUnit(Unit=u)

Parameters:

Programming the individual nodes (define logical names and Unit numbers) is described 
in Chapter 3.6.3.4.2 Communication via ArcNet, 216.

Example(s):
SetUnit(Unit="MS1")
Select the mass spectrometer named MS1 of the ArcNet network.

var Variable to assign the character string to.
• gs[xx] - Global character string array.

string Character string to assign to the variable.
• “Text” - Direct input of text. 
• gs[xx] - Element xx of the global character string array.

strval String value - See Chapter 8.4.1.4 String values, 417

Unit Keyword for selecting a mass spectrometer within the ArcNet network.

u Unit number within the range of 0 ... 255 or logical name
• cc - Direct input of a numeric value 0 ... 255.
• “zzzzz” - Logical name of the Unit.
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SetUnit(Unit=0)

Select the mass spectrometer with number 0 of the ArcNet network.

8.7.61 SetVar() - Setup of variables

Description:
Assign a value to a variable.

A name (text comprising up to 12 characters) can optionally be assigned to the variable 
var. This name is subsequently used for identifying the block:

• when processing the data via the Process() instruction
• when the stored data are displayed in the Display Saved Values program.

An individual scale may be assigned to the variable as well.

Syntax:
SetVar([ScaleID=scID,][Name=name[;strval],]var=val)

Parameters:

Example(s):
SetVar(i[1]=1200)

Set element 1 of the integer array i[] to a value of 1200.

ScaleID Keyword for scale identification.

scID Number of the scale (defined by the instruction ‘SetScale’, See 
Chapter 8.7.58 SetScale() - Define a scale, 502).
• cc - Direct input of a numeric value (0 ... 199).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Name Keyword for name.

name Name of the variable (max. 12 characters).
• “name” - Direct input of the variable name. 
• gs[xx] - Element xx of the global character string array. 

strval String value - See Chapter 8.4.1.4 String values, 417

var Variable to assign a value to (and possibly a name)
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field. 

val Assignment value (any value)
• cc - Direct input of a number (integer or float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.
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SetVar(gf[i[1]]=100.0)

Set the variable gi[i[1]] to a value of 100.

8.7.62 Sound() - Tone output 

Description:
Output a tone.

The instruction Sound() produces a tone with a certain pitch and determined or undeter-
mined duration using the built in PC-Speaker. A continuous tone can be stopped again 
by Sound.

Syntax:
Sound(Mode=soundmode[,Duration=time],Frequency=hertz)

Parameters:

When a continuous tone is output (Mode = Ever), the sequence goes on immediately. 
A tone with determined duration (Mode = On) in contrast causes the sequence to wait 
until the tone ends and then carry out the next instruction.

Example(s):
Sound(Mode=on, Duration=3, Frequency=500)

Produces a 500Hz tone that lasts three seconds.

Mode Keyword for sound mode.

Soundmode Tonmodus.
• On - Give out a tone for a certain time. 
• Ever - Give out a continuous tone. 
• Off - Stop the continuous tone.

Duration Keyword for the duration of the tone (only with Mode = On).

time Time specification (1 ... 1’000’000) 
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Unit of time
• ms - Time in milliseconds.
• [s] - Time in seconds (default).
• min - Time in minutes.
• h - Time in hours.
• d - Time in days.

Frequency Keyword for pitch in Hertz.

hertz Frequency specification (1,...,1’000’000).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

NOTE:
Make sure the value of hertz is within the range of 50 ... 5000; oth-
erwise the tone might be inaudible.
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Sound(Mode=ever, Frequency=i[1])
MID(Par="mypar")
Sound(Mode=off)

A tone of the pitch stored in i[1] is output and a MID measurement is performed. When 
the MID measurement is done, the tone is switched off.

8.7.63 TextClear() - Clear all text

Description:
Clear all text.

All text elements written to this window by TextSet() are deleted. The text window 
declared by TextInit() and its properties remain present.

Syntax:
TextClear()

Parameters:
None

Example(s):
See Chapter 8.7.66 TextSet() - Write a text to the text window, 508

8.7.64 TextClose() - Close text window

Description:
Close the opened text window.

The current text window declared by TextInit() is closed. Its content and properties are 
deleted.

Syntax:
TextClose()

Parameters:
None

Example(s):
See Chapter 8.7.66 TextSet() - Write a text to the text window, 508

8.7.65 TextInit() - Open a text window

Description:
Open a text window and declare its properties.

The lower part of the current measurement window is declared as a text window, that 
can be filled by any text elements generated by the sequence. In the background, a 
graphic can be displayed.
Quadstar 32-bit, vpnb68e1 (0302) Process Control 507



Syntax:
TextInit([Color=BkGndColor,]Size=WndHeight[,Picture=BkGndPict_

[,XPos=x][,YPos=y][,Height=h][,Width=w]])

Parameters:

Example(s):
See instruction TextSet()

8.7.66 TextSet() - Write a text to the text window

Description:
Write a text to the text window.

Writes a text to the text window declared by TextInit().

Syntax:
TextSet(ID=Ident[,XPos=x][,YPos=y][,Color=TextColor]_

[,Size=TextSize],Text=OutText)

Color Keyword for background color.

BkGndColor Number of the color in the palette.
• off - No background color (transparent)
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Size Keyword for window size.

WndHeight Height of the text window in pixel (the width corresponds to the mea-
surement window)
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Picture Keyword for background graphic.

BkGndPict Name and path of the background graphic
• “Pict.bmp” - Direct input of a name.
• gs[xx] - Element xx of the global character string array.

XPos,
YPos,
Height,
Width

Keywords for position and size of the background graphic

The position of the background graphic relative to the upper left corner 
of the text window can be defined by the values XPos and YPos, the 
size by Height and Width. If nothing is defined, the graphic will fill the 
text window completely.

x, y, h, w X- and Y- position of the graphic, and height and width.
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
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Parameters:

Example(s):
In the following example, a MID measurement is performed over 10 cycles and the cur-
rent cycle nbr is displayed in the lower part of the measurement window. As a special 
effect, the number steps one position forward with every new cycle. At the end, the text 
window is erased and the measurement is performed again.

// Scale the measurement window and place it at the upper left
// corner
DispWindow(Disp=normal, XPos=0, YPos=0, Width=400, Height=500)

// Initialize the text window 130 pixels high, with background
// picture "marble"
TextInit(Size=130, Picture="c:\windows\marble.bmp")

// Perform 10 MID Cycles and display the cycle nbr on forward
// stepping positions
Loop(i[0]=1;10)
Begin

// Calculate x position of cycle nbr
Calculate(i[1] = 30*i[0])
// Load number to be displayed
SetString(gs[0] = "";i[0])
// Measurement
MID(Par="c:\qs\par\airdemo.mip", Disp=vt)

ID Keyword for identification nbr of the text element. The identification nbr 
identifies the text element clearly.

Ident Identification nbr of the text element.
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

XPos, YPos Keywords for position of the text element.

x, y X- and Y- position of the text element. Default: upper left corner.
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Color Keyword for text color.

TextColor Nbr of the color. Default: Quadstar 32-bit standard. 
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Size Keyword for text height.

TextSize Text height in pixel. Default: 12 pixel.
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Text Keyword for text to be output.

OutText Text to be output. Default: nothing.
• “Text” - Direct input of text. 
• gs[xx] - Element xx of the global character string array.
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// Clear old text, set new text
TextClear()
TextSet(ID=0, XPos=30, YPos=50, Color=0, Size=30,_

Text="This is Cycle Number: ")
TextSet(ID=1, XPos=i[1], YPos=100, Color=0, Size=30,_ 

Text=gs[0])
End

// Remove text window, repeat measurement
TextClose()
Loop(i[0]=1;10)

MID(Par="c:\qs32bit\par\airdemo.mip", Disp=vt)

8.7.67 WhileDI() - While loop for monitoring a digital input

Description:
While loop for monitoring a digital input of the control unit. The number of available chan-
nels on the...

• QMS 422/421 depends on the number of installed DI 420 boards,

• QMS 200 is limited to two. (DI 0: Extern Protection, DI 1: Extern Start)

Cancellation criteria:

• Execution of the loop continues as long as the condition var = state is true and the 
cancellation conditions are not true.

• Several cancellation conditions can be tested simultaneously: ‘count down’ (break) 
and ‘time’ (breaktime).

Syntax:
WhileDI(var{;unit}=state[,Disp=d][[,Break=cnt]_

[,BreakTime=tim[;unit]],BreakSeq=file[;ind]])

Parameters:

var number of the digital input channel

QMS 422/421: 0 ... 31(63), QMS 200: 0 ... 1
• “zzzzz” - Logical name of the digital input channel. (See 

Chapter 3.8.2.3 DI/DO identification, 237).
• cc - Direct input of a numeric value (integer). 
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Identification of the control unit, only in multiplex mode.
• “zzzzz” - Logical name of the control unit.
• cc - Direct input of internal logical number. 

=> Only those control units are available whose status has been set to 
Enable in the Parameter Setup program under [Comm] > [Node Identi-
fication]. This entry does not influence the unit selected with SetUnit().

state DI comparison status
• off - DI status off.
• on - DI status on.
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Example(s):
WhileDI(12;"Q_Unit_1"=on)

Delay(Time=5)

Multiplex mode: As long as input 12 of the “Q_Unit_1” is on, wait another 5 seconds.

WhileDI(3=on,Break=180,BreakTime=1;h)
MID(Par="mypar")

A MID measurement is performed as long as the digital input 3 is on. The loop will also 
be cancelled after max. 180 passes or max. 1 hour.

Disp Keyword for display mode.

d Display mode.
• [default] - Default display mode.
• off - Display off.
• on - Display on.

See Chapter 2.7.2.2 Status display, 122.

Without any explicit declaration, the default display mode is on. The 
default settings can be altered by SetDefault().

Select the channels to be displayed in the Measure program under 
[Sequence] > [Setup].

Break Keyword for loop cancellation criterion ‘count down’. 

cnt Loop counter (0 ... 1’000’000).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

BreakTime Keyword for the loop cancellation criterion ‘time’.

tim Time specification (1 ... 1’000’000)
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Unit of time
• [s] - Time in seconds (default).
• min - Time in minutes.
• h - Time in hours.
• d - Time in days.

BreakSeq Keyword for sequence to be performed when the cancellation condition 
‘count down’ or ‘time’ becomes true.

file (Drive:\Path\) Filename of the cancellation sequence.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”)
• gs[xx] - Element xx of the global character string array, if the se-

quence name is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416
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8.7.68 WhileDO() - While loop for monitoring a digital output

Description: 
While loop for monitoring a digital output of the control unit. The number of available 
channels on the...

• QMS 422/421 depends on the number of installed DO 420 boards,

• QMS 200 is limited to two. (DO 0, DO 1).

Cancellation criteria:

• Execution of the loop continues as long as the condition var = state is true and the 
cancellation conditions are not true.

• Several cancellation conditions can be tested simultaneously: ‘count down’ (break) 
and ‘time’ (breaktime).

Syntax:
WhileDO(var{;unit}=state[,Disp=d][[,Break=cnt]_

[,BreakTime=tim[;unit],BreakSeq=file[;ind]])

Parameters:

var number of the digital output channel

QMS 422/421: 0 ... 31(63, 95), QMS 200: 0 ... 1
• “zzzzz” - Logical name of the digital output channel.

(See Chapter 3.8.2.3 DI/DO identification, 237).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Identification of the control unit, only in multiplex mode.
• “zzzzz” - Logical name of the control unit. 
• cc - Direct input of the internal logical number.

=> Only those control units are available whose status has been set 
to Enable in the Parameter Setup program under [Comm] > [Node 
Identification]. This entry does not influence the unit selected with 
SetUnit().

state DO comparison status.
• off - DO status off.
• on - DO status on.

Disp Keyword for display mode.

d Display mode.
• [default] - Default display mode.
• off - Display off.
• on - Display on.

See Chapter 2.7.2.2 Status display, 122.

Without any explicit declaration, the default display mode is on. The 
default settings can be altered by SetDefault().

Select the channels to be displayed in the Measure program under 
[Sequence] > [Setup].

Break Keyword for the loop cancellation criterion ‘count down’
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Example(s):
WhileDO("inlet4";"Q_Unit_1"=off)

Delay(Time=5)

Multiplex mode: A five second pause is counted down as long as the digital output 
“inlet4” of Unit “Q_Unit_1” is off.

WhileDO(3=on,Break=180,BreakTime=1;h)
MID(Par="mypar")

A MID measurement is performed as long as the digital input 3 is ON. The loop will also 
be cancelled after max. 180 passes or max. 1 hour.

8.7.69 WhileMeaVal() - While loop for monitoring a measured 
value

Description:
While loop for monitoring a measured value on a measure channel of the QMS.

Execution of the loop continues as long as the condition var cond val is true and the can-
cellation conditions are not true.

Several cancellation conditions can be tested simultaneously: ‘count down’ (break) and 
‘time’ (breaktime).

Syntax: 
WhileMeaVal(var cond val ,Par=file[;ind][,Mode=m][,Disp=d]_

[,Break=cnt][,BreakTime=tim[;unit]]_
[,BreakSeq=file[;ind]])

cnt Loop counter (0 ... 1’000’000)
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

BreakTime Keyword for the loop cancellation criterion ‘time’.

tim Time specification (1 ... 1’000’000).
• cc Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Unit of time
• [s] - Time in seconds (default).
• min - Time in minutes.
• h - Time in hours.
• d - Time in days.

BreakSeq Keyword for sequence to be performed when the cancellation condition 
‘count down’ or ‘time’ becomes true.

file (Drive:\Path\) Filename the cancellation sequence.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array, if the se-

quence name is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416
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Parameters:

var Measure channel number (0 ... 63).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

cond Condition
• = - equal.
• < - less than.
• > - greater than.
• <= - less or equal.
• >= - greater or equal.
• <> - not equal.

val Comparison value

All float and integer array elements can be inserted:
• cc - Direct input of a numeric value (integer or float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

Par Keyword for parameter file

file (Drive:\Path\) Filename.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”).
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

Mode Keyword for measuring mode

m Measuring mode.
• [normal] - Wait until the ion current exceeds or drops below a spec-

ified value. 
• integral - Wait until the integral (sum) of the determined ion currents 

exceeds or drops below a certain value. 
• delta - Wait until the difference between the momentary ion current 

to the previously determined ion current exceeds or drops below a 
certain value.

Disp Keyword for display mode

d Display mode
• [default] - Default display mode.
• off - Display off.
• on - Display on (sequencer status)

See Chapter 2.7.2.2 Status display, 122.

Without any explicit declaration, the default display mode is on. The 
default settings can be altered by SetDefault().

Break Keyword for the loop cancellation criterion ‘count down’.

cnt Loop counter (0 ... 1’000’000).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
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Example(s):
WhileMeaVal(i[2]<9E-10,par="d:\qs\par\myfile",Mode=integral)

Delay(Time=5)

As long as the integral (sum of measured values on channel i[2], determined with the 
parameter file “d:\qs\par\myfile”) is less than 9E-10, wait another five seconds.

8.7.70 WhileString() - While loop for monitoring a string

Description:
While loop for monitoring a string.

Execution of the loop continues as long as the condition string1 cond string2 is true and 
the cancellation conditions are not true.

Several cancellation conditions can be tested simultaneously: ‘count down’ (break) and 
‘time’ (breaktime).

Syntax:
WhileString(string1 cond string2[,Disp=d][,Break=cnt]_

[,BreakTime=tim[;unit]][,BreakSeq=file[;ind]])

BreakTime Keyword for the loop cancellation criterion ‘time’.

tim Time specification (1 ... 1’000’000)
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Unit of time
• [s] - Time in seconds (default).
• min - Time in minutes.
• h - Time in hours.
• d - Time in days.

BreakSeq Keyword for sequence to be performed when the cancellation condition 
‘count down’ or ‘time’ becomes true.

file (Drive:\Path\) Filename of the cancellation sequence.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array, if the se-

quence name is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416
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Parameters:

The two strings are compared character by character, disregarding capitals. The first 
two characters that don’t match each other in both strings determine the result of the 
comparison: the character that comes first in alphabet is considered to be ‘smaller’. Two 

string1 First string to compare; text or element of the global string array gs[]
• cc - Direct text input
• gs[xx] - Element xx of the global string Array.

cond Condition
• = - equal to.
• < - less than.
• > - greater than.
• <= - less or equal.
• >= - greater or equal.
• <> - not equal.

string2 Second string to compare; text or element of the global string array gs[]
• cc - Direct text input
• gs[xx] - Element xx of the global string Array.

Disp Keyword for display mode.

d Display mode
• [default] Default display mode.
• off - Display off.
• on - Display on.

See Chapter 2.7.2.2 Status display, 122.

Without any explicit declaration, the default display mode is on. The 
default settings can be altered by SetDefault().

Break Keyword for the loop cancellation criterion ‘count down’.

cnt Loop counter (0 ... 1’000’000).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

BreakTime Keyword for loop cancellation criterion ‘time’.

tim Time specification (1 ... 1’000’000).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Unit of time
• [s] - Time in seconds (default)
• min - Time in minutes
• h - Time in hours
• d - Time in days

BreakSeq Keyword for sequence to be performed when the cancellation condition 
‘count down’ or ‘time’ becomes true.

file (Drive:\Path\) Filename of the cancellation sequence.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”). 
• gs[xx] - Element xx of the global character string array, if the se-

quence name is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416
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strings are only recognized as equal if all their characters are equal (except capital/non 
capital).

Examples:
WhileString(gs[2]<>"exit")

MID(Par="midpar")

While gs[2] does not contain the text “exit”, repeat the MID measurement.

WhileString(gs[i[2]]>gs[1],Disp=on,Break=10,BreakTime=60;s,_
BreakSeq="c:\qs\par\seq")

Begin
SetDO(5=off)
Delay(Time=5)
SetDO(6=on)
Delay(Time=1)
SetDO(6=off)
SetDO(5=on)
IfMeaVal(3>1E-5,par="testpar")

SetVar(i[2]=0)
End

While gs[i[2]]>gs[1], the gas inlet is to be purged. After max. 10 passes or max. 60 sec-
onds, the while loop shall be cancelled in any case and the “c:\qs\par\seq” sequence 
executed.

8.7.71 WhileVar() - While loop for monitoring a variable

Description:
While loop for monitoring a variable.

Execution of the loop continues as long as the condition var cond val is true and the can-
cellation conditions are not true.

Several cancellation conditions can be tested simultaneously: ‘count down’ (break) and 
‘time’ (breaktime).

Syntax:
WhileVar(var cond val[,Disp=d][,Break=cnt]_

[,BreakTime=tim[;unit]][,BreakSeq=file[;ind]])
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Parameters:

var Variable to be tested

All float and integer array elements can be inserted:
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

cond Condition
• = - equal
• < - less than
• > - greater than
• <= - less or equal
• >= - greater or equal
• <> - not equal

val Comparison value 

All float and integer array elements can be inserted:
• cc - Direct input of a numeric value (integer or float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

Disp Keyword for display mode.

d Display mode
• [default] Default display mode.
• off - Display off.
• on - Display on.

See Chapter 2.7.2.2 Status display, 122.

Without any explicit declaration, the default display mode is on. The 
default settings can be altered by SetDefault().

Break Keyword for the loop cancellation criterion ‘count down’.

cnt Loop counter (0 ... 1’000’000).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

BreakTime Keyword for loop cancellation criterion ‘time’.

tim Time specification (1 ... 1’000’000).
• cc - Direct input of a numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

unit Unit of time
• [s] - Time in seconds (default)
• min - Time in minutes
• h - Time in hours
• d - Time in days

BreakSeq Keyword for sequence to be performed when the cancellation condition 
‘count down’ or ‘time’ becomes true.
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Example(s):
WhileVar(gf[21]<45.5)
Begin

MID(Par="midpar",SaveGfa=0)
Calculate(gf[21]=gfa[0][0]*srt(2)/10)

End

As long as the value of gf[21] is less than 45.5, the MID measurement is performed 
repeatedly and gf[21] is used for a calculation.

WhileVar(i[2]=3,Disp=on,Break=60,BreakTime=10;min,_
BreakSeq="c:\qs\par\seq")

Begin
SetDO(5=off)
Delay(Time=5)
SetDO(6=on)
Delay(Time=1)
SetDO(6=off)
SetDO(5=on)
IfMeaVal(3>1E-5,par="testpar")

SetVar(i[2]=0)
End

As long as the variable i[2] has a value of 3, the gas inlet is to be purged. After max. 60 
passes or max. 10 minutes, the while loop shall be cancelled in any case and the 
“c:\qs\par\seq” sequence executed.

8.7.72 ZeroGas() - Zero gas measurement

Description:
Perform a zero gas measurement.

If contaminations of an ultra-pure gas in the lower ppm range (parts per million) need to 
be determined, the residual gas background in the analysis chamber must be sub-
tracted, otherwise the result will be incorrect.

For additional information on zero gas measurement refer to Chapter 2.8.2 Background 
measurement (Zero Gas), 137

Syntax:
ZeroGas(Par=file[;ind][,Disp=d][,Prot=p][,SaveMode=m])

file (Drive:\Path\) Filename of the cancellation sequence.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”).
• gs[xx] - Element xx of the global character string array, if the se-

quence name is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416
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Parameters:

Example(s):
ZeroGas(Par="zerocal")

Perform a zero gas measurement with the “zerocal” parameter file.

ZeroGas(Par="c:\qs\par\zero1",Prot=on,SaveMode=reset)

Perform a zero gas measurement with the “c:\qs\par\zero1” parameter file, printer log 
on, and clear the zero gas file before saving the measurement data.

Par Keyword for parameter file.

file (Drive:\Path\) Filename.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”).
• gs[xx] - Element xx of the global character string array if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

Disp Keyword for display mode.

d Display mode.
• [default] - Default display mode.
• off - Display off.
• on - Display on.

Without any explicit declaration, the default display mode is on. The 
default settings can be altered by SetDefault().

Prot Keyword for log mode.

p Log mode.
• [default] - Default log mode.
• off - Log function off.
• on - Printer log on.

See Chapter 8.4.3 Log output, 422.

If nothing else is specified, the default log mode is off. It can be altered 
with the SetDefault() instruction.

SaveMode Keyword for save mode.

m Save mode.
• reset - Clear the data file before storing the data.
• [append] - Append the new data to the end of the file.
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8.8 Process Monitor PPM 422 
The sequencer instructions described on the following pages, which all begin with 
‘PPM...’, are exclusively available for the Plasma Process Monitor PPM 422 .

The following standard instructions are replaced by corresponding PPM 422 specific 
instructions:

8.8.1 PPMGetCorr() - Get correction value CORR

Description:
Load CORR value and assign it to a variable (e.g. for a calculation).

Syntax:
PPMGetCorr(SaveCorr=var)

Parameters:

Example(s):
PPMGetCorr(SaveCorr=gf[3])

Store the correction value CORR in the variable gf[3].

8.8.2 PPMMID() - PPM 422 MID measurement

Description:
Perform a Multiple Ion Detection (MID) measurement (the data are collected from the 
M-Chassis).

Options:
• Display the measurement data
• Store the measurement data in the field gfa[][] containing the global float values
• Store the measurement data in a file containing MID measurement data
• Store the measurement data in a file containing reference measurement data

Syntax:
PPMMID(Par=file[;ind][,Disp=d][,Prot=p][,SaveGfa=var]_

[,SaveRef=file[;ind]][,SaveCyc=file[;ind][;m]])

Standard instruction Replaced by PPM instruction

ScanAnalog() PPMScanMassAnalog()

MID() PPMMID()

SaveCorr Keyword for the correction value CORR

var Variable in which the correction value is to be stored.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.
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Parameters:

Par Keyword for parameter file

file (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”)
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

Disp Keyword for display mode.

d Display mode.
• [default] - Default display mode.
• off - Display off.
• tab - Display as table.
• bar - Display as bargraph.
• vt - Display as Versus Time.

If nothing is entered, the mode for default is set to Display as table (tab). 
The default mode can be changed with the SetDefault() instruction.

Prot Keyword for log mode.

p Log mode.
• [default] - Default log mode.
• off - Log output off.
• on - Log output to printer.

Also see Chapter 8.4.3 Log output, 422.

If nothing else is entered, the mode for default is off. The default mode 
can be changed with the SetDefault() instruction.

SaveGfa Keyword for storing measurement data in an array of the global data 
field gfa[][].
• The measurement data are stored in the float array xx (=var) of the 

field gfa[xx][]. Specification of the index yy for gfa[][] is not neces-
sary, the measured values of the activated channels are stored con-
secutively in gfa[][0], gfa[][1], gfa[][2], etc., irrespective of their 
channel number.

• All data stored in the elements yy = 0 ... 63 of the float array xx=var 
of gfa[xx][yy] are cleared before the data are saved.

var Float array number (0 ≤ var ≤ configurable maximum).
• cc - numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

SaveRef Keyword for storing into a file containing reference data.

file (Drive:\Path\) Filename.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”).
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

SaveCyc Keyword for storing the cycle data in a file.
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Example(s):
PPMID(Par=”mypar”)

Perform an MID measurement with the parameter file “mypar” and display the measured 
values as a table (default).

PPMMID(Par=”c:\qs\par\sample”, Disp=bar,_
SaveCyc=”c:\qs\dat\midcyc”)

Perform an MID measurement with the parameter file “c:\qs\par\sample”, display the 
data in Bar mode and store them in the data file “c:\qs\dat\midcyc”.

8.8.3 PPMNeutrals() - Neutral particle analysis

Description:
PPMNeutrals() sets the mode for neutral particle analysis.

Syntax:
PPMNeutrals(Mode=n)

Parameters:

Example(s):
PPMNeutrals(Mode=coarse)

8.8.4 PPMScanEnergy() - PPM 422 Energy Scan

Description:
This instruction performs an energy scan.

A scan is programmed on the E-chassis. The data are diverted to the E-chassis, so that 
they can be read in synchronously with the E-scan. Start energy and energy width are 
declared in this instruction, the other measurement parameters are taken from the Scan 
Analog parameter file.

Syntax:
PPMScanEnergy(Par=file[;ind],EStart=esta,EWidth=ewid,[,Disp=d]_

file (Drive:\Path\) Filename.
• “ffffffff” - Filename (e.g. “c:\qs\myfile”).
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

m Save mode
• [append] - Add the new data to the end of the file (default).
• reset - Clear the file before storing the data.

Mode Keyword for neutral particle mode.

n Neutral particle mode
• coarse - coarse
• fine - fine
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[,SaveRef=file[;ind]][,SaveCyc=file[;ind][;m]])

Parameters:

Par Keyword for Scan Analog parameter file (*.SAP)

file (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”)
• gs[xx] - Element xx of the global character array if the filename is 

stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

EStart Keyword for energy start value.

esta Start value in the range of -12 ... 512 eV
• cc - Direct input of the numeric value (float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

EWidth Keyword for energy width

ewid EWidth within the range of -12 ... 512 eV
• cc - Direct input of the numeric value (float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Disp Keyword for display mode.

d Display mode.
• [default] - Default display mode.
• off - Display off.
• on - Display on.

If nothing else is entered, the mode for default is set to on. The basic 
default setting can be changed by the SetDefault() instruction.

SaveRef Keyword for storing the measurement data as a reference file.

File (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”)
• gs[xx] - Element xx of the global character string array if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

SaveCyc Keyword for storing the measurement data as a data file.

file (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”)
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

m Save mode
• [append] - Add the data to the end of the file (default).
• reset - Clear the file before storing the new data.
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NOTE:
The other measurement parameters are taken from the Scan Analog parameter 
file (*.SAP), e.g. mass = First Mass, measurement speed = Speed etc.

EStart is calculated as:

EStart = Vestart - SHIFT - CORR,

where the energy scan control voltage Vestart must be within the range 0 ... 512. 
If Estart < 0, SHIFT and CORR have to be set accurately. The sign of the effectively 
measured ion energy depends on the signs of the ions and Ve. Also see 
Chapter 5.9.1.6 Relations (Ion energy and Ve, CORR and SHIFT), 363.

Example(s):
PPMScanEnergy(Par=”c:\qs\par\sample”,EStart=5.0,EWidth=75.0,

Disp=off,SaveCyc=”c:\qs\dat\ppmcyc”)
Load the measurement parameters from the file sample.sap and perform an energy 
scan from 5.0 eV ... 80.0 eV. The display is switched off and the data are stored in the 
file ppmcyc.sac:

8.8.5 PPMScanMassAnalog() - PPM 422 Scan Mass Analog

Description:
Perform a mass scan and save the corresponding energy voltage.

Syntax:
PPMScanMassAnalog(Par=file[;ind][,Energy=ef][,Disp=d]_

[,SaveRef=file[;ind]]_
[,SaveCyc=file[;ind][;m]])

Parameters:

Ve+ Ve-

Ions Pos -12 < E < 512 0 < E < 512

Ions Neg -512 < E < 0 -12 < E < 512

Par Keyword for parameter file.

file (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”)
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

Energy Keyword for energy value.

ef Energy value within the range of -12 ... 512 eV
• cc - Direct input of the numeric value (float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.
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Example(s):
PPMScanMassAnalog(Par=”anascan1”,Energy=200)

Perform a PPM 422 Scan Analog measurement with the parameter file “anascan1” and 
an energy of 200eV.

8.8.6 PPMSetEnergy() - Entering the ion energy

Description:
PPMSetEnergy() sets the ion energy of the E-chassis, considering the CORR and 
SHIFT values.

Syntax:
PPMSetEnergy(Energy=ef)

Parameters:

Disp Keyword for display mode.

d display mode.
• [default] - Default display mode.
• off - Display off.
• on - Display on.

If nothing else is entered, the mode for default is set to on. The basic 
default setting can be changed by the SetDefault() instruction.

SaveRef Keyword for storing the measurement data as a reference file.

File (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”)
• gs[xx] - Element xx of the global character string array if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

SaveCyc Keyword for storing the measurement data as a data file.

file (Drive:\Path\) Filename
• “ffffffff” - Filename (e.g. “c:\qs\myfile”)
• gs[xx] - Element xx of the global character string array, if the filena-

me is stored in gs[].

ind File index - See Chapter 8.4.1.3 File names with indices, 416

m Save mode
• [append] - Add the data to the end of the file (default).
• reset - Clear the file before storing the new data.

Energy Keyword for energy value.

ef Energy value within the range of -512 ... 512 eV
• cc - Direct input of the numeric value (float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.
526 vpnb68e1 (0302), Quadstar 32-bit



Example(s):
PPMSetEnergy(Energy=82.5)

Set the ion energy to 82.5 V.

SetVar(gf[0] = 5.0)
WhileVar(gf[0]<= 150.0)
Begin

PPMSetEnergy(Energy=gf[0])
Delay(5)
...
//Get Data (from M-Chassis)
MID(...)
...
...
Calculate(gf[0]=gf[0]+0.5)

End

Perform a MID measurement with an energy of 5.0 ... 150.0 V and a step width of 0.5 V.

8.8.7 PPMSetEPolarity() - Polarity of the energy voltage

Description:
PPMSetEPolarity() sets the polarity of the energy voltage.

Syntax:
PPMSetEPolarity(Polarity=p)

Parameters:

Example(s):
PPMSetEPolarity(Polarity=neg)

8.8.8 PPMSetIS() - Entering the ion source parameters

Description:
This instruction enables you to:

• Select the ion source sets for the E-chassis (IS-Set-E) and the M-chassis (IS-Set-M) 
separately

• Modify ion source voltages.

• Parameter Shift: modify all shift voltages simultaneously

Polarity Keyword for polarity of the Scan Energy voltage.

p Polarity (0+/-)
• pos - Ve+
• neg - Ve-
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Syntax:

For Plasma 
Sampling Mode 
Ions +/Ions -

PPMSetIS([IsSetM=n][,IsSetE=e][,Itro=mvari5][,Foc1=mvari8]_
[,Entry=mvarf9][,Centr=evarf2][,Foc2=evarf3]_
,Faxis=evarf4][,Case=evari5][,Dfli=evari6]_
[,Dflo=evari7][,Mirr=evari8][,Infl=evarf9]_
[,Shift=volt])

For Plasma 
Sampling Mode 
Neutrals Coarse

PPMSetIS([IsSetM=n][,IsSetE=e][,CathC=mvarf2][,IonRef=mvari1]_
[,ExtrC=mvari5][,Foc1=mvari8][,Centr=evarf2]_
[,Foc2=evarf3],Faxis=evarf4][,Case=evari5]_
[,Dfli=evari6][,Dflo=evari7][,Mirr=evari8]_
[,Infl=evarf9][,Shift=volt])

For Plasma 
Sampling Mode 
Neutrals Fine

PPMSetIS([IsSetM=n][,IsSetE=e][,CathC=mvarf2][,IonRef=mvari1]_
[,ExtrF=mvari5][,Foc1=mvari8][,Centr=evarf2]_
[,Foc2=evarf3],Faxis=evarf4][,Case=evari5]_
[,Dfli=evari6][,Dflo=evari7][,Mirr=evari8]_
[,Infl=evarf9][,Shift=volt])

NOTE:
If you modify voltages of the ion source sets, the modifications remain local, i.e. 
they are modified on the mass spectrometers, but they are not stored to the cor-
responding IS-Sets.

Please note that some of the parameters are mutually exclusive:
• ExtrC - ExtrF is inhibited.
• ExtrF - ExtrC is inhibited.
• CathC, ExtrC or ExtrF - Itro and Entry are inhibited.

Parameters:

IsSetM Load the ion source set for the M-chassis.

n Number of the selected IS-Set 0 ... 15 of the group IS-M
• cc - Direct input of the numeric value (float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

IsSetE Load the ion source set for the E-chassis.

e Number of the desired IS set 0 ... 15 of the group IS-E
• cc - Direct input of the numeric value (float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Keywords for the IS voltages of the sets IS-E and IS-M with correspond-
ing validity range and step width:

IonRef mvari1 - IS-M V1 : 0 ... 150 V, Step 1 V

CathC mvari2 - IS-M V2 : 0 ... 125 V, Step 0.5 V

Itro mvari5 - IS-M V5 : 0 ... 450 V, Step 2 V

ExtrC mvari5 - IS-M V5 : 0 ... 450 V, Step 2 V

ExtrF mvari5 - IS-M V5 : 0 ... 4.500 V, Step 0.02 V
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Example(s):
PPMSetIS(IsSetE=0, IsSetM=2)

Load the IS-Set-E=0 and IS-Set-M=2

SetVar(gf[0] = 10.0)
PPMSetIS(IsSetM=12,IsSetE=12,Mirr=40,SHIFT=4)
WhileVar(gf[0]<= 120.0)
Begin

...
PPMSetIS(Centr=gf[0])
Calculate(gf[0]=gf[0]+0.5)
...
...

End

Foc1 mvari8 - IS-M V8 : -125 ... +125 V, Step 1 V

Entry mvari9 - IS-M V9 : 0 ... 60.00 V, Step 0.25 V

Centr evarf2 - IS-E V2 : 0.0 ... 125.0 V, Step 0.5 V

Foc2 evarf3 - IS-E V3 : -30.00 ... +30.00 V, Step 0.25 V

Faxis evarf4 - IS-E V4 : 0.00 ... 60.00 V, Step 0.25 V

Case evari5 - IS-E V5 : 0 ... 450 V, Step 2 V

Dfli evari6 - IS-E V6 : 0 ... 450 V, Step 2 V

Dflo evari7 - IS-E V7 : 0 ... 250 V, Step 1 V

Mirr evari8 - IS-E V8 : -125 ... +125 V, Step 1 V

Infl evarf9 - IS-E V9 :0 ... 60 V, Step 0.25 V

mvarfx, evarfx Float variables for M-chassis or E-chassis
• cc - Direct input of the numeric value (float).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
• f[xx] - Element xx of the local float array.
• gf[xx] - Element xx of the global float array.
• gfa[xx][yy] - Element xx/yy of the global float field.

mvarix, evarix Integer variables for M-chassis or E-chassis.
• cc - Direct input of the numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.

Shift Keyword for simultaneously modifying the shift-voltages within the 
range of 0 ... 10 V (step width : 2 V).

The following voltages (called ‘shift-voltages’) can be modified by Shift:

IS-Set-E : V2-E...V8-E (Centr, Foc2, Faxis, Case, Dfli, Dflo, Mirr) 

and for Plasma Sampling Mode ‘Ion+/-’ also the IS-Set-M voltages

V5-M, V8-M, and V9-M (ExtrC/ExtrF, Foc1, Entry)

volt Voltage to be added to the shift-voltages.
• cc - Numeric value (integer).
• i[xx] - Element xx of the local integer array.
• gi[xx] - Element xx of the global integer array.
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Load the IS-Set-E=12, IS-Set-M=12, add 4 V to the shift-voltages, set the IS voltage V8-
E to 40 volts and increase the voltage V2-E step by step from 10.00 V ... 120.00 V by 
adding 0.5 V each time.

8.8.9 PPMSetPSM() - Entering the PPM 422 Plasma Sampling 
Mode (PSM)

Description:
Choose PPMSetPSM() to set the PPM 422 Plasma Sampling Mode.

Syntax:
PPMSetPSM(Mode=m)

Parameters:

NOTE:
Please note that before a PPMSetPSM() instruction always the PPMSetIS() in-
struction must be called in order to load the corresponding ion source sets (E-Set 
and M-Set).

Example(s):
PPMSetPSM(Mode=IonPos)
PPMSetPSM(Mode=Neutral)

Mode Keyword for Plasma Sampling Mode (PSM)

m Mode
• IonPos - Ions+
• IonNeg - Ions-
• Neutral - Neutrals
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9. Access Rights Control

In the administration program Quadstar 32-bit Access Rights Control (subsequently 
referred to as ACCESSC) you can define access rights for different users. You can for 
example lock certain functions for certain users by not enabling the corresponding menu 
entries for them. You may as well set up a separate work environment for each user 
(separate directories for measure data, measure parameters, equipment in use etc.). 
The maximum number of users is limited to 20.

Basically we must distinguish between the User name, User password and the 
ACCESSC password (administrator password).

• The User name is defined for each Quadstar 32-bit user in the ACCESSC control 
program and enables him to use the functions of the Quadstar 32-bit programs he is 
authorized for.

• The User password can be defined by the Quadstar 32-bit user. It must be entered 
when a Quadstar 32-bit program is called for the first time. As long as the user has 
not defined a personal password, the default password <ENTER> (ENTER key) is 
used.

• The ACCESSC password is defined in the ACCESSC control program. It prevents 
the utilization of ACCESSC by unauthorized persons. This password protection is 
switched off after a new software installation so that ACCESSC can initially be called 
up without a password.
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9.1 Login

9.1.1 Login to a Quadstar 32-bit program

If Quadstar 32-bit is password protected, you must enter your user name and user pass-
word to log into a Quadstar 32-bit program:

Fig. 9-1

User name and user password must be entered only when the first Quadstar 32-bit pro-
gram is started, subsequent Quadstar 32-bit programs of the same installation recog-
nize the user automatically. After the successful login, your work environment is setup. 
If you don’t want to use the default password <ENTER> (ENTER key), you can define 
your own personal password by Change Password:

Fig. 9-2

If the password check is switched off (control field [Quadstar 32-bit Login 
enabled/Access Rights used] in ACCESSC not checked), but the Multiuser option is 
switched on (control field [Quadstar 32-bit multiuser enabled] in ACCESSC checked), 
only the user name needs to be selected from the list field.

Fig. 9-3

In this way, you can use your personal work environment without any password check.

9.1.1.1 Forgotten user password

If a user has forgotten his User password (for the Quadstar 32-bit programs) it can be 
reset in ACCESSC by [User] > [Delete Password]. See Chapter 9.2.4.2.7 Delete user 
Password, 539).
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The user can then log into a Quadstar 32-bit program with the user name and the default 
user password <ENTER> (ENTER key). He can subsequently define his personal user 
password with the Change Password command.

9.1.1.2 Logging into ACCESSC

When ACCESSC is password protected ([Protection] > [ACCESSC Login Setup] > 
[Password enabled]), the administrator password must be entered when the ACCESSC 
program is started:

Fig. 9-4

The ACCESSC password is defined under [Protection] > [ACCESSC Login Setup] .

9.1.1.3 Forgotten ACCESSC password

If the ACCESSC password is lost, the Q_ACCESS.DAT file must be copied from the 
installation diskette into the execution file path of Quadstar 32-bit. Subsequently the 
ACCESSC control program can be started without a password like after the initial soft-
ware installation. The previously defined user passwords will not be affected.

9.1.2 Safeguarding the password protection

Access privileges can be changed at any time using the ACCESSC control program, if 
it is not password protected. Therefore it is important, that ACCESSC is protected by 
another password, and the installation and backup diskettes are stored in a safe place.

If you have set up an extensive password protection (for multiusers), you should make 
backup copies of the Q_ACCESS.DAT, QUADSTAR.INI and Q_PSW.DAT files.
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9.2 Control of the access privileges

Fig. 9-5

9.2.1 Selecting the Quadstar 32-bit program

Choose the program, for which you want to determine access rights:

Fig. 9-6

9.2.2 Defining the access privileges

Fig. 9-7

For displaying the access privileges of other users, select their names from the drop-
down list boxes. The user privileges are enabled by checking the corresponding control 
boxes in the column below the user name.
534 Access Rights Control vpnb68e1 (0302), Quadstar 32-bit



9.2.3 Switch the password protection on/off

By the control fields in the lower left corner, you can switch on/off the password protec-
tion, the automatic start of sequences and the different work environments:

Fig. 9-8

Quadstar 32-bit Login enabled/Access Rights used

• Checked: Quadstar 32-bit password protection enabled.
=> When the first Quadstar 32-bit program is started, input of the user name and user 
password is requested. The granted access privileges and the specific work environ-
ment are then effective.

• Unchecked: Quadstar 32-bit password protection disabled.
=> No input of the user name or user password is requested.
=> The access privileges are not restricted, the work environment is the same for all 
users.

Run sequence by application start enabled

• Checked: A sequence can be executed automatically, when the Measure program is 
started.

Quadstar 32-bit Multiuser enabled

• Checked: If the password protection is switched off, a separate work environment for 
each user can although be supplied by using this option.

9.2.4 Main menu

Fig. 9-9

File
Display the version number, store the program settings and quit the program.

User
Modify the user password (change, delete etc.) and the user-specific work environment.

Protection
Password protection for the ACCESSC program.

Help
Displays the help contents. See Chapter 1.9 Hints concerning the work with 
Quadstar 32-bit, 56.
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9.2.4.1 File menu

Fig. 9-10

About Access Rights Control...
Display the current version number of the ACCESSC program.

Save
Save all settings.

Print...
Print access rights of one or all users.

Exit
Quit the Quadstar 32-bit ACCESSC program.

9.2.4.1.1 About Access Rights Control

Fig. 9-11

Display the version number of the Quadstar 32-bit ACCESSC program:

9.2.4.2 User menu

Fig. 9-12

Change Name...
Change an existing user name.

Insert...
Insert a new user name.
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Delete...
Delete a user name.

Copy...
Copy user privileges.

Path Setup...
Define the paths for the user’s working environment.

Set Predefined Access...
Set predefined access privileges.

Delete Password...
Delete a user password.

9.2.4.2.1 Change name

Modify an existing user name. Under Select Name choose the user name to be 
changed. Now enter under Edit Name a new name and confirm by [OK]; the old name 
is replaced, but the already defined user privileges remain unchanged.

Fig. 9-13

9.2.4.2.2 Insert

By Insert New User you can add more user names.

Fig. 9-14

NOTE:
The default password is <ENTER> (ENTER key). When a Quadstar 32-bit program 
is started, the user can define his own password by using Change Password.
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9.2.4.2.3 Delete

The user name and the corresponding access privileges are deleted from the list.

Fig. 9-15

9.2.4.2.4 Copy

The access privileges of the user selected in the Source list box are copied to the user 
selected in the Destination list box by clicking the [OK] button:

Fig. 9-16

9.2.4.2.5 Define the work environment (Path Setup)

Fig. 9-17

Execution File Path
Directory of the Quadstar 32-bit program files (.EXE).

Auxiliary File Path
Directory for auxiliary files (the information about the equipment in use is stored here, 
for example).

Parameter File Path 
Directory for the measure parameter files.

Data File Path
Directory for the measure data files.
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[Select Path]
Choose the drive and directory.

9.2.4.2.6 Set Predefined Access

Fig. 9-18

Assign predefined user privileges:
• DEFAULT - Adopt the factory settings.
• ENABLE_ALL - Enable all access privileges
• DISABLE_ALL - Disable all access privileges

NOTE:
The selection applies to all Quadstar 32-bit programs.

9.2.4.2.7 Delete user Password

Fig. 9-19

Choose Delete Password to delete a user password. This is useful e.g., if a user has 
forgotten his password.

9.2.5 Protection menu

Fig. 9-20

9.2.5.1 Administrator password (ACCESSC Login Setup...)

Password protection of the Quadstar 32-bit ACCESSC-program:
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Fig. 9-21

New Password
Enter a new ACCESSC password. The old password is deleted.

Login ACCESS
• Password disabled - Deactivate the password protection
• Password enabled - Activate the password protection.

=> The password protection is not switched on/off unless Set is activated.
540 Access Rights Control vpnb68e1 (0302), Quadstar 32-bit



10. File Handling, Data Formats, Error 
Messages, Troubleshooting

10.1 File Manager
The file manager supports the handling of all parameter and measurement data files. It 
can be used for opening files, creating new files, deleting old files, and it also provides 
an easy method for file copying. Some files relate to others in such a way that they can 
only be used together as a database (e.g. MCD-measurement: File.MCC, File.MCO and 
File.MCP belong together). Therefore, Quadstar 32-bit files should always be manipu-
lated jointly by using the Quadstar 32-bit file manager, since this way all necessary files 
will be covered.

Procedure Quadstar 32-bit calls the file manager whenever a file must be accessed that’s not set 
yet. For the following descriptions, the assumption is that the file manager dialog box is 
displayed on the screen as shown in Fig. 10-1, 542:

Loading a file

1 Use the mouse to select the desired path under «Look in:».

2 Position the cursor on the File name text box.

3 Type in the file name or select a file name in the File Name list box.

4 Press [OK].

Creating a new file

1 Use the mouse to select the desired path under «Look in:».

2 Position the cursor on the File name text box.

3 Type in the name of the file to be created.

4 Press [OK].

5 Choose Yes to answer the question: “File not existing, create ?”

Copying a file

1 Use the mouse to select the desired path under «Look in:».

2 Position the cursor on the File name text box.

3 Type in the source file name or use the mouse to select a file name in the File 
Name list box.

4 Press the Copy button.

5 In the «to» text box enter the name of the destination file.

6 Press [OK].
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7 Choose the new file in the File list box and press Open.

Deleting a file

1 Use the mouse to select the desired path under «Look in:».

2 Position the cursor on the File name text box.

3 Type in the file name or use the mouse to select a file name in the Files list box.

4 Press [Delete].

5 Confirm the Quadstar 32-bit prompt with Yes or No.

Renaming a file

1 Use the mouse to select the desired path under «Look in:».

2 Position the cursor on the File name text box.

3 Type in the source file name or use the mouse to select a file name in the Files 
list box.

4 Choose Rename.

5 Position the cursor on the «to» text box and change the name.

6 Press [OK].

Dialog box of the 
file manager

Fig. 10-1

Control elements [OPEN]
Open the selected file.

[Cancel]
Quit the file manager without activity.

[Copy]
Copy the contents of a file into an existing file or create a new file with the same con-
tents.

[Rename]
Rename a file.
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[Delete]
Delete a file.

NOTE:
Please note that a parameter set, e.g. for gas-specific calibration, can comprise 
several files. For this reason, Quadstar 32-bit files should always be manipulated 
with the Quadstar 32-bit file manager so that all related files are handled appropri-
ately.

Filename 
Enter the name of the file to be opened.

The file name can be entered directly or be chosen from a list of files. This list shows 
only files of the type that’s chosen in the field «Files of type».

NOTE:
To display a list of files with a specific extension, enter the asterisk (*), a dot and 
the three character extension.

Example: If you want to view all files of a directory that have the extension .SAC 
(containing Scan Analog Cycles), enter *.sac.

Look in
Browse the directory in which the file to be opened is located.

Files of type
In this list Quadstar 32-bit displays only the file types that are relevant to the called pro-
gram. If several file types exist, mark the type of file to be opened.

File Title of ‘...’
In this field the file title appears - if there is one - as soon as the file is selected (not 
opened yet). The file title can only be displayed here, but not edited. Enter the file title 
(within the measure data documentation) before the measurement starts. See 
Chapter 2.1.5 Documenting the measurement data (File Info), 69).
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10.2 Path and file names
Path and file names may be chosen almost freely, with the following restrictions:

• They may contain regular letters (capital or small) and figures in any order.

• They may contain the special characters ! # $ % & ( ) - \ { } ~ as well.

• They are to contain no other/special characters (such as space, Å, ö, é, ‰, @ etc.).

• A file name can consist of maximum 255 characters including three characters ex-
tension (e.g. a_long_filename.abc).

• Path and file name together can consist of maximum 255 characters.

10.3 Quadstar 32-bit files
Quadstar 32-bit uses universal data formats for storing the measurement data.

10.3.1 Overview

The Quadstar 32-bit files are allocated to the following sub directories:

• Programs and setup utilities. (EXE Group)
• Auxiliary files that are unique to the application. (AUXI Group)
• Parameter files whose names can be selected via the file manager. (PAR Group)
• Data files whose names can be selected via the file manager. (DAT Group)

The following tables contain a choice of the used files and file types:

Programs

Index Name Group Designation

n/a Accessc.exe EXE

n/a ComServ.exe EXE Communication Server for ARCNET server 
mode

n/a DispSav.exe EXE Presentation of stored data

n/a Measure.exe EXE Measurement program

n/a Parset.exe EXE Parameter setup program

n/a Service.exe EXE Service

n/a TuneUp.exe EXE Tuning

n/a Utility.exe EXE Auxiliary functions
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Additional programs

Help files

Tools

Dynamic Link Libraries (DLLs)

Quadstar 32-bit settings

Access settings

Index Name Group Designation

n/a PrtExe.exe EXE Printer executer for handling delayed line 
printing

n/a PrtServ.exe EXE Printer server for spooling line printing

Index Name Group Designation

n/a Quadstar 32-
bit.chm

EXE Quadstar 32-bit Online HTML-Help

Index Name Group Designation

n/a Exchange.exe EXE Exchange of pathnames in sequences dur-
ing installation

n/a Exchange.pif EXE Console settings for running 
EXCHANGE.EXE

Index Name Group Designation

n/a General.dll EXE General Quadstar 32-bit functions

n/a SeqEdit.dll EXE Quadstar 32-bit sequence editor

n/a Resource.dll EXE Quadstar 32-bit resources

n/a UserCtrl.dll EXE Quadstar 32-bit specific controls

n/a Ss32d25.dll EXE Tools

Index Name Group Designation

220 Q_Option.dat EXE Contains authorization information 
(encrypted)

n/a Quadstar.ini EXE Quadstar 32-bit initialization file

Index Name Group Designation

203 Q_Access.dat EXE Password for accessing ACCESSC program

200 Q_PSW.dat EXE Access rights, passwords and user names 
for ACCESSC program
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AUXI (device dependent)

AUXI (device independent)

Index Name Group Designation

131 Q_AIChar.par AUXI Analog Input characteristic curve settings

132 Q_AOChar.par AUXI Analog Output characteristic curve settings

320 Q_calfac.lib AUXI Calibration factors for MCD

101 Q_config.par AUXI QMS hardware settings

130 Q_IOID.par AUXI Digital I/O settings

120 Q_is.par AUXI Ion source parameters (QMS422/421)

123 Q_is200.par AUXI Ion source parameters (QMS200)

121 Q_ischp.par AUXI Ion source channel parameters

201 Q_MasCal.dat AUXI Adjusted mass numbers

107 Q_Setup1.par AUXI Setup parameters (multiplex)

202 Q_Zero.dat AUXI Zero gas measurement data

Index Name Group Designation

104 Q_ColTab.par AUXI Screen color settings

109 Q_CPECfg.par AUXI Channel parameter editor settings

210 Q_EH.dat AUXI Error history (generated at runtime)

211 Q_EH_AI.dat AUXI Error history - supplementary information 
(generated at runtime)

n/a Q_Fragm.wri AUXI Key fragment ions table

122 Q_leak.par AUXI Leak test parameters

n/a Q_peasrc.par AUXI Peak search parameters

105 Q_Print.par AUXI Printer settings

102 Q_QMSCom.par AUXI QMS communication settings

106 Q_SeqOpt.par AUXI Sequence editor settings

100 Q_Setup.par AUXI Setup parameters

300 Q_Spec.LIB AUXI Spectra library: data file

301 Q_Spec_h.LIB AUXI Spectra library: header file

133 Q_NodeID.PAR AUXI Node settings for ARCNET mode

108 Q_FIn.par AUXI File info settings

110 Q_pso.par AUXI Peak shape optimizer parameters
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AUXI (only PPM)

DAT (general)

DAT (grafic editor settings)

DAT (additional file information)

Index Name Group Designation

10002 P_setup.par AUXI PPM Setup parameter

10000 P_is.par AUXI PPM Ion source parameters

Index Name Group Designation

700 *.mdc DAT MID/MCD cycle data files

600 *.mdr DAT MID/MCD reference data files

710 *.sac DAT Scan Analog data files

610 *.sar DAT Scan Analog reference files

720 *.sbc DAT Scan Bargraph cycle data files

721 *.sbh DAT Scan Bargraph cycle data header files

n/a *.sbr DAT Scan Bargraph reference files

Index Name Group Designation

602 *.amr DAT MID/MCD reference files

612 *.aar DAT Scan Analog reference files

622 *.abr DAT Scan Bargraph reference files

702 *.amd DAT MID/MCD cycle data files

712 *.aad DAT Scan Analog data files

723 *.abd DAT Scan Bargraph cycle data files

Index Name Group Designation

601 *.imr DAT MID/MCD reference files

611 *.iar DAT Scan Analog reference files

621 *.ibr DAT Scan Bargraph reference files

701 *.imd DAT MID/MCD cycle data files

711 *.iad DAT Scan Analog data files

722 *.ibd DAT Scan Bargraph cycle data files
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PAR

* = any valid file name (for example AIRDEMO)

Index Name Group Designation

531 *.gcc PAR Gas specific calibration: channel parameters

530 *.gcp PAR Gas specific calibration: matrix parameters

521 *.mcc PAR MCD channel parameters

522 *.mco PAR MCD concentration parameters

520 *.mcp PAR MCD matrix parameters

500 *.mip PAR MID parameters

503 *.msp PAR Mass scale calibration parameters

501 *.sap PAR Scan Analog parameters

502 *.sbp PAR Scan Bargraph parameters

n/a *.seq PAR Sequencer text files (source code)

510 *.sqe PAR Executable sequencer files (compiled code)
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10.4 File formats
For detailed information on structure and use of Quadstar 32-bit files please contact 
your nearest service office.

10.5 Data export ASCII
In the Display Saved Values program you can convert binary data to the ASCII format. 
Choose this option if Quadstar 32-bit measurement data are to be processed in other 
programs such as Microsoft® EXCEL® etc.

Please note that the parameters:

• Column Separator (Separator for dividing columns)
• Line Separator (Separator for dividing lines)
• TimeFraction (Parameter for outputting the fraction of time)

can be chosen in the Parameter Setup program under [Setup] > [ASCII Conversion]. If 
the default values are chosen, the data will be exported in a format that can be read by 
EXCEL.

10.5.1 Scan Analog data

Scan Analog measurement data can be converted to the ASCII format in the Display 
Saved Values program under [Scan] > [Analog Data] > [File] > [Convert to ASCII]. Only 
1 cycle per ASCII file can be exported.

NOTE:
such files can become very large, since there are up to 64 measurement values 
per mass (QMS 200: 32) to be stored.
Quadstar 32-bit, vpnb68e1 (0302) File Handling, Data Formats, Error Messages, Troubleshooting 549



The following example shows the first cycle of the file airdemo.sac, in the range of 16 ... 
21 amu (here only continued until 16.5 amu):

Fig. 10-2

10.5.2 Scan Bargraph data

Scan Bargraph measurement data can be converted to the ASCII format with [Scan] > 
[Bargraph Cycles] > [File] > [Convert to ASCII].
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The following example shows peaks 18, 28 and 32 exported from 12 Scan Bargraph 
spectra.

Fig. 10-3
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10.5.3 MID/MCD Data

MID/MCD measurement data can be converted to the ASCII format with [Process] > 
[Cycles] > [File] > [Convert to ASCII].

The following example shows the intensities of the masses 14, 16, 18, 28, 32, 40, 44 
exported from the data block 0 (MID-Cycle 50 ... 72) of the airdemo.mdc file.

Fig. 10-4
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10.6 Error messages/warnings

10.6.1 General

Some of the Quadstar 32-bit messages that are displayed are based on the error mes-
sages and warnings transmitted by QMS mass spectrometer; they contain only a brief 
comment and are not explained here. For detailed information please refer to the 
QMS 422/421 or QMS 200 operating instructions:

QMS Error ‘XX’
See operating instructions of the corresponding mass spectrometer under “Trouble-
shooting”.

QMS Warning ‘XX’
See operating instructions of the corresponding mass spectrometer under “Warnings”.

10.6.2 Quadstar 32-bit Error Messages/Warnings

Error/Warning Description

0.4 <= mass deviation < 0.5 Mass scale calibration was not possible, the 
deviation exceeds the tolerance limit.

=> Selected mass number is incorrect or inac-
curate mass calibration on the RF generator.

ADC error QMS error 29 (service message).

additional data doesn’t match exist-
ing file

The additional data to be stored with the scan 
analog data doesn’t match the already stored 
data.

adjust mass too high Peak Adjust error; the selected mass is too far 
to the right of the peak.

adjust mass too low Peak Adjust error; the selected mass is too far 
to the left of the peak.

adjust range and mass too low Peak Adjust error; the electrometer Range is 
too low and the mass number too far to the left 
of the peak.

adjust range or threshold too high Peak Adjust error; the electrometer Range or 
the threshold is too high.

adjust range too low Peak Adjust error; the electrometer Range is 
too low.

adjust range too low and mass too 
high

Peak Adjust error; the electrometer Range is 
too low and the mass number too far to the 
right of the peak.

alarm at cycle: ‘Cycle’, ident: ‘Ident’, 
value: ‘Value’

Alarm (Level A , B) for cycle: ‘Cycle’, Identifi-
cation: ‘Ident’, measured value: ‘Value’.

AO-DAC error QMS error 28 (service message).
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ArcNet driver initialisation error The ArcNet driver for Windows could not be 
initialized correctly, so Quadstar 32-bit cannot 
communicate via ArcNet.

Restart Windows, update your 
Quadstar 32-bit installation or contact our ser-
vice office.

ArcNet parameters of another 
installation used

Warning: If several Quadstar 32-bit-installa-
tions use the ArcNet server, the ArcNet-proto-
col-parameters of the first installation are 
used.

ArcNet server not started or client 
not connected

Error on starting or announcing to ArcNet 
server. Check the amount of free resources or 
restart Windows®.

argument of lgn() <= 0 at sequence 
‘SeqName’ line ‘LineNbr’

The argument of the lgn() function (logarithm 
to base e) in ‘LineNbr’ of ‘SeqName’ is 0.

argument of log()<=0 at sequence 
‘SeqName’ line ‘LineNbr’

The argument of the log() function (logarithm 
to base 10) in ‘LineNbr’ of ‘SeqName’ is 0.

argument of srt() <0 at sequence 
‘SeqName’ line ‘LineNbr’

The argument of the srt() function (square root 
calculation) in ‘LineNbr’ of the ‘SeqName’ is 0.

argument out of range at sequence 
‘SeqName’ line ‘LineNbr’

The argument in ‘LineNbr’ of ‘SeqName’ is 
outside the limits.

ASCII line buffer overflow Overflow in buffer for ASCII-Lineprinting. 
Check whether your sequence prints cor-
rectly.

at least one user has to be defined 
to save data

At least one user must be defined when the 
ACCESSC program is terminated.

auto not possible Automatic operation is inhibited (filament 1+2) 
in degas mode (QMS Warning 20).

autorange algorithm couldn’t detect 
measure value

The (amplifier) measure range can not be 
determined automatically, for example 
because the measured values vary too much.

bad file handle Windows® system error, access to an opened 
file is denied.

baseline too high at mass: ‘Mass-
Nbr’, offset: ‘Offset’%, range:’1E-
XX’

Quadstar 32-bit warning.

The electrometer offset ‘Offset’ determined for 
the electrometer range ‘1E-XX’ (measured on 
Zero-Mass ‘MassNbr’) amounts to ‘Offset’%, 
i.e. it is >1.99%).

(=> The selected Zero-Mass is unfavorable or 
the hardware must be realigned)

Error/Warning Description
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baseline too low at mass: ‘Mass-
Nbr’, offset: ‘Offset’%, range:’1E-
XX’

The electrometer offset ‘Offset’ determined for 
the electrometer range ‘1E-XX’ (measured on 
Zero-Mass ‘MassNbr’) amounts to ‘Offset’%, 
i.e. it is <1.99%).

(=> The selected Zero-Mass is unfavorable or 
the hardware must be realigned)

baudrate of QMS not correct The QMS uses a bad transmission rate.

buffer not o.k. QMS warning 22.

Error in the QMS measurement data buffer 
management.

calibration factor of internal stan-
dard not defined

Calibration factor of the internal standard is 
not defined.

(=> Define the internal standard in the 
selected calibration matrix)

calibration matrix undefined Parameter setup error in the selected calibra-
tion matrix.

=> Verify that all selected mass numbers are 
assigned to a component.

CAN error QMS error message 40.

Malfunction of the ClosedAreaNetwork con-
troller.

can’t load printer install Dialog box for the printer installation cannot 
be loaded.

Can’t open communication Line for 
online printing

The defined printer port for outputting the 
sequence log cannot be used.

=> Make sure the printer port defined in 
“Sequence Printing Setup” is actually 
installed. Correct the port specification if nec-
essary.

can’t save bitmap(DIB) to .BMP file The picture to be stored can not be written to 
file, e.g. because there is not enough disk 
space.

CD error QMS error message 35.

SEM high voltage on HV 421 overloaded or 
faulty.

channel doesn’t exist in parameter 
file at sequence ‘SeqName’ line 
‘LineNbr’

The specified channel in the given parameter 
file doesn’t exist or is switched OFF. 

channel not enabled Selected QMS channel is not in the ENABLE 
state.

CLA 421 AMPE overrange Chopper Lock-In amplifier (electrometer) 
overrange.

=> Adapt the channel parameter Amp.Range.

Error/Warning Description
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CLA 421 AMP1 overrange Chopper Lock-In amplifier 1 overrange.

=> Adapt the channel parameter Amplifier 1.

CLA 421 AMP2 overrange Chopper Lock-In amplifier 2 overrange.

=> Adapt the channel parameter Amplifier 2.

CLA 421 AMP3 overrange Chopper Lock-In amplifier 3 overrange.

=> Adapt the channel parameter Amplifier 3.

client identification mismatch in Arc-
Net server

Client could not be identified by ArcNet 
server.

System error message. Restart Windows® or 
call our service office.

client not disconnected Client could not be cancelled by ArcNet 
server.

System error message. Restart Windows® or 
call our service office.

cold cathode off Sequencer test warning.

=> The cold cathode gauge should be 
switched on by SetQMS(Pen=on) before the 
first measurement is started.

communication error from QC to CS QMS error message 42.

No response from the console. 

communication error on LAN QMS error message 44.

Faulty communication via LocalAreaNetwork 
interface.

communication error on RS232C QMS error message 45.

Faulty communication via RS232C interface.

communication error QMS control 
DSP

QMS error message 43.

Faulty communication via dual port RAM.

component ‘CompName’ already 
defined

The selected component name ‘CompName’ 
is already defined in the current matrix.

concentration not defined The concentration of a component is not 
defined.

corrupted identification file 
(Q_OPTION.DAT)

The Quadstar 32-bit identification file cannot 
be read.

=> Copy the original file from the installation 
diskette.

corrupted password file 
(Q_PSW.DAT)

The Q_PSW.DAT file defines passwords and 
access rights. The file is automatically cleared 
and must subsequently be recreated by the 
ACCESSC application.

Error/Warning Description
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cross device link Input error, e.g. different disk drive or directo-
ries in rename function.

data assignment error in ArcNet 
server communication

The synchronous communication to ArcNet 
server is disturbed.

Restart Windows® or call our service office.

DDE Error at sequence ‘SeqName’ 
line ‘LineNbr’

The data exchange via DDE was not possible 
on line ‘LineNbr’ of the sequence ‘SeqName’.

degas not possible QMS warning 19. The degas function is inhib-
ited in ‘Auto’-mode (Filament 1+2).

device already open The selected interface cannot be opened 
because it claims to be open already.

device can’t print bit maps The selected printer does not support graphic 
output. 

device not open Access to the selected interface is denied 
because it has not been opened.

different number of users found in 
(Quadstar.INI) and (Q_PSW.DAT)

The two files Quadstar.INI and Q_PSW.DAT 
do not have the same number of users.

=> This error message is displayed if a differ-
ent number of users is found in these two files 
when ACCESSC is started

=> With the subsequent prompt “Load the 
default access rights for all users ?” the user 
is able to automatically adapt the 
Q_PSW.DAT file to the Quadstar.INI file. In 
this case, however, all access rights of all 
users are set to DEFAULT. If this automatic 
adaptation is not wanted, the ACCESSC pro-
gram is cancelled.

different revision number in identifi-
cation file ‘FileName’

Update Error, the Quadstar 32-bit program 
(EXE-File) does not have the same revision 
number as the identification file 
(Q_OPTION.DAT).

different software versions (ArcNet 
server and application)

Quadstar 32-bit-application and ArcNet 
server cannot work together because their 
software versions are different.

Restart Windows® or check your installa-
tion(s). Different Quadstar 32-bit-versions can 
not be run simultaneously on the same PC.

Error/Warning Description
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different usernames found in (Quad-
star.INI) and (Q_PSW.DAT)

The two files Quadstar.INI and Q_PSW.DAT 
must have the same user names.

=> If the same number of users but different 
user names are found when ACCESSC is 
started, the user names in the Q_PSW.DAT 
file are updated according to the specifica-
tions in the Quadstar.INI file. Changes are dis-
played.

=> User names can only be specified in the 
ACCESSC application.

directory ‘DirName’ not empty, not 
possible to remove

The directory ‘DirName’ is not empty so it 
can’t be removed.

division by zero at sequence 
‘SeqName’ line ‘LineNbr’

Division by zero occurred in line ‘LineNbr’ of 
the sequence ‘SeqName’.

drive change error The selected disk drive is invalid.

DSP dual port RAM defect QMS error message 25.

Access to signal processor defective.

DSP EPROM defect QMS error message 24.

The checksum of the EPROM signal proces-
sor is invalid.

emission error QMS error message 39.

The emission current does not correspond to 
the specified nominal value.

emission error on QME #’QMENbr’ The emission of the QME 125, number 
‘QMENbr’ has failed (Multiplex operation via 
the QMU 112).

emission not possible (external) The emission cannot be switched on or off by 
Quadstar 32-bit (Sequencer SetQMS()) 
because in Parameter Setup the option 
“Emission External” is selected. See 
Chapter 3.8.1 QMS Configuration, 234.

emission off The measurement cannot be started; turn on 
the emission.

empty frame received Communication error; an empty frame has 
been received from the QMS .

empty frame sent Error in ArcNet driver; the frame to be trans-
mitted is empty.

energy parameters don’t match 
existing file ‘FileName’

The scan comparison cannot be performed; 
the energy range of the reference scan does 
not match the energy range of the current 
scan (only PPM).

error in deleting printer reservation System error.

Restart Windows® or contact our service 
office.

Error/Warning Description
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error in printer reservation System error.

Restart Windows® or contact our service 
office.

error sending ASCII line to printer 
server

System error.

Restart Windows® or contact our service 
office.

external normalization factor is zero The external normalization factor is zero.

=> Perform a gas-specific calibration. Make 
sure that in the calibration matrix the determi-
nation of the external normalization factor is 
activated.

fatal communication error ‘Number’ Error message ‘Number’ of the window com-
munications driver.

filament 1 defect QMS error message 37.

Filament 1 defective.

filament 2 defect QMS error message 38.

Filament 2 defective.

file mismatch found, file(s) might be 
corrupted

Files of a compound database don’t match 
each other or are damaged. Save it all first 
and try it again.

‘FileName’ isn’t of the expected file 
extension

Due to an incorrect file name extension the 
selected ‘FileName’ is not accepted.

‘FileName’ isn’t of the expected file 
type

The type of the selected ‘FileName’ does not 
correspond to the required file type.

file ‘FileName’ exceeds maximal 
size

The file ‘FileName’ is larger than allowed.

file ‘FileName’ exceeds maximal 
size, file truncated

The file ‘FileName’ is larger than allowed and 
is therefore shortened.

file ‘FileName’ not existing at 
sequence ‘SeqName’ line ‘LineNbr’

The file ‘FileName’ on the specified line 
‘LineNbr’ of the sequence ‘SeqName’ does 
not exist.

file already existing ‘FileName’ The file ‘FileName’ cannot be created 
because it exists already.

file check impossible at ‘SeqName’ 
line ‘LineNbr’, variable file name

Warning in the test for file existence.

=> Test not possible; the file specified in line 
‘LineNbr’ of the sequence ‘SeqName’ is a file 
with a variable name.

file close error ‘FileName’ The file ‘FileName’ cannot be closed.

file manager error Error when working with the file manager.

file name too long at sequence 
‘SeqName’ line ‘LineNbr’

The file name specified in the line ‘LineNbr’ of 
the sequence ‘SeqName’ contains more than 
255 characters.
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file not existing ‘FileName’ Access to the file ‘FileName’ is denied 
because it does not exist.

file permission denied ‘FileName’ Access to the file ‘FileName’ is not allowed.

file positioning error ‘FileName’ Positioning error when writing or reading the 
file ‘FileName’.

file (Quadstar.INI/entry lastuser) not 
found

No user name can be loaded. The ‘lastuser’ 
entry in the Quadstar.INI file is missing

=> The application is cancelled.

=> To remedy the fault load the Quadstar.INI 
file from the installation diskette. All previously 
defined users and access rights will be lost.

file too small ‘FileName’ The selected file ‘FileName’ is too small for 
storing the desired number of bytes.

=> e.g. parameter file with no channel 
enabled

floating point overflow at sequence 
‘SeqName’ line ‘LineNbr’

Floating point value in the line ‘LineNbr’ of the 
sequence ‘SeqName’ is out of range.

font manager error The fonts required for the sequencer cannot 
be loaded.

=> Possible causes: - Wrong Windows® ver-
sion.

=> Incorrect Windows® installation.

=> Insufficient working storage or resources 
etc.

formula must contain at least one 
capital X

The entered formula is invalid. A correct input 
must contain a capital X as the variable.

formular dimension too small The selected size of the form to be printed is 
so small that no reasonable output is possible.

gfa[][] overflow at sequence 
‘SeqName’ line ‘LineNbr’

In line ‘LineNbr’ of the sequence ‘SeqName’ 
an array containing more than 64 elements 
was assigned to the global float field.

handshaking error (<ENQ> 
received after <ENQ>)

Contention error in the communication with 
the QMS (SECS protocol).

handshaking error (first received 
char no <ENQ>)

Protocol error when receiving a frame from 
the QMS.

handshaking error (no <EOT> 
received after <ENQ>)

Protocol error when establishing a connection 
to the QMS before transmitting a frame.

hardware COMx not available (or 
locked by another device)

The selected communication line COMx is not 
available or already occupied by another 
device.

hardware not present at sequence 
‘SeqName’ line ‘LineNbr’

The hardware option specified in line 
‘LineNbr’ of the sequence ‘SeqName’ is not 
installed.

Error/Warning Description
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illegal ‘Option’ configuration Invalid hardware configuration.

illegal file name syntax Invalid syntax in a file name.

illegal file name syntax at sequence 
‘SeqName’ line ‘LineNbr’

Invalid syntax in a file name in the line 
‘LineNbr’ of the sequence ‘SeqName’.

illegal input format The input format is invalid.

illegal Option specified Input of a configuration that is not valid in this 
place for a given option.

illegal parameter combination The chosen combination of parameters is not 
allowed.

incomplete definition Definition is incomplete (e.g. file name is 
missing etc.).

incorrect file name Entered file name is not correct.

incorrect frame length Protocol error when receiving a frame from 
the QMS

=> The specified frame length does not match 
the transmitted number of bytes.

incorrect password verfication Each password change must be confirmed 
with a password verification. The password 
verification was invalid. The old password is 
still in effect.

input incomplete, not all path names 
defined 

The data defined in the ACCESSC application 
are incomplete and cannot be stored.

=> After this error message the user is auto-
matically prompted to define the missing 
paths (working environment of a user) in the 
Set Path dialog box.

input must be between ‘Low’ and 
‘High’

The specified value is outside the ‘Low’ and 
‘High’ limits.

integrator error QMS error message 47.

Integrator value < measured background 
value.

internal standard not defined No Internal standard has been defined in the 
current calibration matrix.

invalid argument ‘FileName’ Windows® system error, e.g. invalid file posi-
tioning etc.

invalid AO identifier Entered (logical) name of the analog output is 
not defined.

invalid DI identifier Entered (logical) name of the digital input is 
not defined.

invalid DO identifier Entered (logical) name of the digital output is 
not defined.

invalid file name identifier This file type is invalid in this context.
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invalid line Type of the entered line does not exist.

invalid name Entered name does not exist.

invalid password Wrong password has been entered (User-
name was correct).

invalid QMS type for PPM A connected QMS is not suitable for Plasma 
Process Monitoring (only PPM).

invalid state Entered status does not exist (at this point).

invalid unit identifier Entered (logical) name or node number of the 
Mass Spectrometer Controller does not exist.

invalid unit identifier at sequence 
‘SeqName’ line ‘LineNbr’

The mass spectrometer called in the 
sequence ‘SeqName’ on line ‘LineNbr’ is not 
defined.

invalid username During the log-in procedure of an application 
an unknown user name has been entered.

ion source error QMS error message 36.

IS 420 voltage V1 ... V9 is outside the set point 
tolerance.

ion source set not loaded at 
sequence ‘SeqName’ line ‘LineNbr’

The access to the ion source parameters on 
the specified line ‘LineNbr’ of the sequence 
‘SeqName’ is not possible. The ion source 
parameters have to be loaded first.

less than 2 cycles stored ‘FileName’ Less than 2 cycles are stored in the selected 
file ‘FileName’, the desired display/action is 
not possible.

less than 2 masses defined Less than 2 mass numbers are defined, the 
desired display/action is not possible.

line end expected Syntax error, the selected sequencer line con-
tains invalid entries such as comments, etc. 
behind the correct line code.

line from type ‘*/’ expected Sequencer symbol ‘*/’ for end of comments 
missing.

line from type ‘End’ expected Sequencer line containing the end-of-block 
instruction (‘End’ line) missing.

line too long Entered sequencer line too long.

long string in short packet mode Error in ArcNet driver; the message to be 
transmitted is too long for the selected “Short 
Packet Mode”.

mass ‘MassNbr’ already defined Selected mass number ‘MassNbr’ is already 
defined.
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mass deviation >= 0.5 The mass deviation is greater than 0.5 amu 
and can no longer be corrected by 
Quadstar 32-bit.

=> Selected mass number incorrect or inaccu-
rate mass calibration on the RF generator

mass ‘MassNbr’ out of adjusted 
range

The ‘MassNbr’ mass number entered is out-
side the range defined in the Measure pro-
gram under [Calibration] > [Mass Scale].

matrix full The format (max. 64 mass numbers × 64 com-
ponents) of the analysis matrix is exceeded.

matrix singular The matrix is incorrectly defined, the equation 
system cannot be solved.

matrix contains undefined calibra-
tion factors

The analysis matrix makes reference to non-
existing calibration factors.

=> Set the undefined calibration factors of the 
analysis matrix to zero or calibrate them.

measured value of internal standard 
is zero, calibration impossible

The value measured on the mass number 
selected for the Internal Standard is zero; the 
calibration factors cannot be determined.

measure data dropout, measure-
ment too fast

In measure mode Dynamic Measurement, the 
QMS-internal data buffer grew completely full. 
The QMS was stopped, the buffer content 
was transferred to the PC if possible and then 
the QMS was restarted. Either the measure-
ment is too fast or the transmission to the PC 
is too slow.

measure value OVERRANGE The measured value exceeds the measure 
range.

memory allocation error System error during the temporary allocation 
of working storage by Quadstar 32-bit.

=> Possibly insufficient working storage avail-
able. Terminate all applications that are no 
longer needed.

memory allocation error in ArcNet 
server

Not enough memory for ArcNet server. Close 
all applications that are not absolutely neces-
sary.

memory re-allocation error System error during the access to temporarily 
allocated working storage by Quadstar 32-bit.

=> Possibly insufficient working storage avail-
able. Terminate all applications that are no 
longer needed.

missing scale identifier There is no ID for the scale defined.

missing text identifier There is no ID for the text window defined.

missing unit identifier There is no Mass Spectrometer defined.
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monitor-DAC error QMS error 26 (service message).

name too long The entered name contains more than 255 
characters.

name too long at sequence 
‘SeqName’ line ‘LineNbr’

The name specified in the line ‘LineNbr’ of the 
sequence ‘SeqName’ is longer than 255 char-
acters.

negative Calibration factor deter-
mined at ‘Comp’/Mass’, previous 
factor kept 

A negative calibration factor was calculated 
for the component ‘Comp’ on ‘Mass’. This fac-
tor will not be saved to the calibration factor 
library and the old calibration factor will be 
retained.

new password not stored It was not possible to store the newly entered 
user password.

no channel on state ‘ENABLED’ Parameter setup error; all measurement 
channels of the selected parameter file are in 
the OFF or SKIP state or all selected QMU 
channels in the SEM/Emission control field 
are switched OFF.

no component name defined Parameter setup error, no component name 
defined.

no data available from QMS No data available from the QMS.

no data selected Display is only possible if data (data blocks) 
have been selected.

no error history file found Printing error, the error history file to be 
printed does not exist.

no high voltage supply QMS warning 17.

Configuration error; the selected hardware 
(HV 420/421) does not exist or is not declared.

no ion source supply QMS warning 18.

Configuration error; the selected hardware (IS 
420) does not exist or is not declared.

no line from type ‘/*’ allowed Input of the sequencer symbol ‘/*’ for begin-
ning of comments is not allowed in this place.

no line from type ‘Begin’ allowed Input of a sequencer line with an instruction 
block begin (‘Begin’ line) is not allowed.

no line from type ‘Else’ allowed Input of the sequencer instruction ‘Else’ is not 
allowed.

no line from type ‘End’ allowed Input of a sequencer line with an instruction 
block end (‘End’ line) is not allowed.

no mass number defined Parameter setup error, no mass numbers 
defined.

no more channels available No additional QMS channels are available.
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no more scale entries possible at 
sequence ‘SeqName’ line ‘LineNbr’

No more entries for the scale are allowed.

no more text entries possible at 
sequence ‘SeqName’ line ‘LineNbr’

In the specified text window there is no more 
space for further entries..

no more users allowed No additional access rights for users can be 
defined because all 20 possible users have 
been defined.

no space left on Device Storing of the data has been cancelled or can-
not be started because no space is available 
on the selected disk drive.

no such file or directory ‘\Path\File-
name’

The file selected in ‘\Path\FileName’ does not 
exist or is located in a different path.

not enough memory A memory area requested by Quadstar 32-bit 
is not available.

not enough memory for measure 
display

The auxiliary window for displaying the mea-
surement data cannot be opened because 
insufficient memory is available.

not enough memory for print screen The working storage required for outputting 
the selected picture is not available on the 
system.

not enough memory, reduce rank or 
select less data

Not enough working storage available on the 
system.

Try to get more storage by closing other appli-
cations or reduce the rank of the matrix or 
select less data.

not enough resources, please close 
other applications

The computer does not have enough system 
resources to perform a function. Please close 
other applications on your computer in order 
to get more resources.

nothing selected; please check 
groups to be printed

The print job cannot be executed, because 
there is no item selected. Check the groups to 
be printed and print again.

not possible to create the file ‘File-
Name’

The desired file ‘FileName’ cannot be created.

not possible to open the file ‘File-
Name’

The selected file ‘FileName’ cannot be 
opened.

no unit enabled The communication to the Mass Spectrome-
ter cannot be opened because there is no unit 
set on state enabled.

no unit selected to get the last client 
identifier

System error.

Restart Windows® or contact our service 
office.
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no user privilege The menu option or the execution of a com-
mand is intentionally inhibited for this user.

=> The access privileges are granted or inhib-
ited with the ACCESSC program.

=> If the access privilege is denied, the corre-
sponding options/dialog boxes are automati-
cally inhibited in the program (without mes-
sage “no user privilege”).

No user privilege (Can’t identify the 
QMS xxx type, Prog-Nr check 
failed)

The type of QMS belonging to this software 
could not be determined.

Contact our service office.

No user privilege 
(QMS 200/QMS 421 instead of 
QMS 422 software installed)

Installed Quadstar 32-bit software is set up for 
use with a QMS421 or QMS200. Install a 
Quadstar 32-bit software for QMS422.

If no effect, contact our service office.

No user privilege (Software key-
number out of range)

The read software key number is bad. Restart 
Windows® or reinstall Quadstar 32-bit.

If no effect, contact our service office.

No user privilege (Unknown soft-
ware type)

The software type could not be figured out. 
Restart Windows® or reinstall 
Quadstar 32-bit.

If no effect, contact our service office.

no valid scale ID at sequence 
‘SeqName’ line ‘LineNbr’.

There is no scale with the specified identifier.

number of calibration factors > 
‘NbrOfFact’ 

No more than ‘NbrOfFact’ calibration factors 
can be stored for a component.

old version of sequence file ‘File-
Name’, please recompile

The sequence ‘FileName’ has been compiled 
with a version that is older than the current 
Quadstar 32-bit version. Please recompile 
this file in the Sequence Editor.

only one filament available Filament 2 cannot be selected, because only 
one filament is available (QMS Warning 21).

parameter ‘Group’ : ‘ParName’ 
changed from ‘OldValue’ to 
‘NewValue’ 

The ‘ParName’ parameter in the ‘Group’ 
group was changed from ‘OldValue’ to 
‘NewValue’.

parameter ‘Group’ : ‘ParName’ of 
channel ‘Qms-Chan’ changed from 
‘OldValue’ to ‘NewValue’ 

The ‘ParName’ parameter from the 
‘QmsChan’ QMS channel in the ‘Group’ group 
was changed from ‘OldValue’ to ‘NewValue’.

parameter lost QMS error message 41.

Value in the NOVRAM lost (battery is dis-
charged or EPROM has been changed).

parameter out of range The parameter is not within the valid range.
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parameter corrected to current con-
figuration

Warning, Quadstar 32-bit had to adjust the 
parameter to the changed configuration.

path ‘PathName’ not existing at 
sequence ‘SeqName’ line ‘LineNbr’

The path ‘PathName’ on the specified line 
‘LineNbr’ of the sequence ‘SeqName’ does 
not exist.

path name too long The entered path name is too long and is not 
accepted.

printer client initialization error Check whether WINDOWS has still enough 
free system resources. If no effect, call our 
service office.

printer currently not available The printer is busy at the moment. Wait until it 
gets ready or stop the other printing task and 
send your task again.

printer not installed or printer error Printer not installed or general printer error.

printer server not connected System error.

Restart Windows® or contact our service 
office.

printer server not disconnected System error.

Restart Windows® or contact our service 
office.

print screen already active Printing already in progress.

=> Close Print Screen or wait until the 
selected picture area has been transmitted to 
the print manager (or has been printed).

print screen not available The Print Screen option is blocked at the 
moment.

=> The current sequence uses the same 
printer port as the standard printer and there-
fore the printer is unavailable for Print Screen.

Process data doesn’t match existing 
file ‘FileName’ at sequence 
‘SeqName’ line ‘LineNbr’

The data created by the Process()-instruction 
at sequence ‘SeqName’ on line ‘LineNbr’ 
does not match the file ‘FileName’ (different 
number of data components).

=> Correct the data processing.

Process() table too large at 
sequence ‘SeqName’ line ‘LineNbr’

The memory required by the Process () 
instruction programmed in the line ‘LineNbr’ of 
the sequence ‘SeqName’ is not available

=> Simplify the Process() instruction.

QMS control EPROM defect QMS error message 20.

Checksum of the QMS EPROM is incorrect.

QMS control idle error QMS error message 33.

Operating system of the QMS overloaded.

Error/Warning Description
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QMS control buffer RAM defect QMS error message 23.

Working storage defective.

QMS control dual port RAM defect QMS error message 22.

Access to QMS controller defective.

QMS control NOVRAM defect QMS error message 21,

Parameter memory defective.

QMS control stack overflow QMS error message 17.

Internal instruction stack overflow.

QMS control watchdog error QMS error message 19.

Watchdog timer overflow.

QMS error bit’x’ set See QMS 422/421 or QMS 200 operating 
instructions under “Trouble shooting”.

QMS error detected, no data No measurement data because a QMS hard-
ware error has been detected.

QMS hardware not present The hardware option is not installed in the 
QMS or cannot be recognized.

QMS offline Communication with the QMS cannot be 
established, the QMS is operating in console 
mode.

QMS off, not available or wrong 
node ID configured

Communication with the QMS cannot be 
established (connection line cut off, QMS not 
switched on, wrong node ID configured on the 
QMS, ....).

QMS temperature overrange QMS error 31 (service message). Rise in tem-
perature inside of the QMS 200.

=> Cooling insufficient or temperature sensor 
inside of the QMS 200 faulty. Check if QMS is 
overheated !

QMS temperature underrange QMS error 30 (service message). Tempera-
ture sensor inside of the QMS 200 faulty or 
environment frosty.

QMS warning bit’x’ set See QMS/QMI or QMS 200 User’s guide, 
“Warnings”.

Quadstar 32-bit installation overflow 
in ArcNet server

Too many Quadstar 422-Installations. You 
may run up to eight installations of the same 
software version in eight different EXE-paths 
with ArcNet server.

Quadstar 32-bit instance overflow in 
ArcNet server

ArcNet server allows to run up to 16 
Quadstar 32-bit-applications simultaneously 
that can have communication with QMS’s.

read error ‘FileName’ Error while reading the file ‘FileName’.

Error/Warning Description
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receive checksum error Transmission error; the checksum of a 
received frame is incorrect.

reduce border size, print job aborted The page margins are too large, the page can-
not be printed. Reduce the margin size(s) and 
print again.

reference file not compatible The reference file doesn’t match the measure 
file, a comparison is not possible. Often 
caused by measuring with different settings 
for First Mass, Width, Steps, Mean Value etc.

reset error QMS error message 18.

Reset circuit defective.

residual disk space on drive ‘Drive-
Name’ is ‘Number’ MB

The available memory on the disk drive 
‘DriveName’ is only ‘Number’ MBytes.

resolution-DAC error QMS error 27 (service message).

result too large Windows® system error. Error in the specifi-
cation of a file or the path.

RF error QMS error message 46.

Error in the RF stage QMH 400/410.

RF-ID-Error QMS error message 32. RF print cannot be 
identified.

=> Missing print or bad connection.

ringbuffer overflow Memory error in the QMS data buffer.

There is not enough space in the buffer for the 
number of measured cycles requested (in Dis-
play after Measure).

=> Reduce the number of cycles.

RXD/TXD communication buffer 
flush error

Error in the Windows® communication driver 
in an attempt to clear the I/O buffers.

saved zero gas SEM voltage 
unequal to SEM voltage for 
mass(es) ‘Mass1’, ‘Mass2’,....

The actual SEM voltage does not agree with 
the SEM voltage the (stored) intensities of the 
zero gas have been measured with.

scale ID out of range at sequence 
‘SeqName’ line ‘LineNbr’

The given scale identifier is out of the allowed 
range.

SEM error QMS error message 34.

Error in the SEM high voltage.

SEM voltage off The SEM voltage is not switched on.

send/receive time out detected Timeout error during data transmission.

=> The QMS did not respond or did not trans-
mit the required number of bytes within a 
frame.

sequence editor already open The sequence editor is already open.

Error/Warning Description
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sequence file ‘FileName’ not com-
piled

The ‘FileName’ sequence file selected has not 
been compiled.

source and destination file name 
equal at sequence ‘SeqName’ line 
‘LineNbr’

Source and destination file name are equal, 
therefore the file manipulation cannot be 
done.

source and destination pathname 
equal at sequence ‘SeqName’ line 
‘LineNbr’. 

Source and destination path name are equal, 
therefore the file manipulation cannot be 
done.

source and destination pathname 
not equal at sequence ‘SeqName’ 
line ‘LineNbr’. Taking source path

Source and destination path name are not 
equal, therefore the source path is used for 
the file manipulation.

source or destination file name not 
valid at sequence ‘SeqName’ line 
‘LineNbr’

The file manipulation cannot be done, 
because one of the file names is not valid.

source path and destination path 
equal

Source and destination path are equal.

source path and destination path 
unequal

Error in the path specification.

string too long for selected packet 
mode

ArcNet driver error; the frame to be transmit-
ted is too long.

syntax error Syntax error in the entered line or word.

the selected unit is not member of 
the installation

The selected unit can’t be used by the calling 
Quadstar 32-bit-program because it is already 
occupied by another Quadstar 32-bit installa-
tion.

Make sure the defined groups of units/nodes 
of the different installations do not overlap 
each other.

too many clients announced too many Quadstar 32-bit applications run-
ning that may use the printer. A maximum of 
20 applications is allowed.

too many clocks or timers A required timer cannot be started because 
too many timers are in operation (used by 
other applications).

too many enabled channels in file 
‘FileName’, data not saved

The saving of scan measurement data is per-
mitted in single channel mode only. In the 
parameter file ‘FileName’ more than one 
channel is in state enabled.

too many entries The sequencer instruction contains more 
entries than allowed.

=> Make sure the arguments of the instruction 
are correct.

Error/Warning Description
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too many interlocked sequences at 
sequence ‘SeqName’ line ‘LineNbr’ 

Too many nested sequences in line ‘LineNbr’ 
of the sequence ‘SeqName’.

=> Reduce the number of the Sequence() 
instructions.

too many interlocks Too many nestings and loops.

=> Reduce the number of loops.

too many interlocks at sequence 
‘SeqName’ line ‘LineNbr’

Too many nested loops, etc. in the ‘LineNbr’ of 
the sequence ‘SeqName’.

=> Reduce the number of loops.

too many sequencers started Too many sequencers running, the printer is 
limited to cooperate with a maximum of 6 
sequencers.

transmission denied (receiver busy) The attempt to establish a connection with the 
QMS is being denied due to an overload con-
dition.

transmission wrong (<NAK> 
received)

A frame transmitted by Quadstar 32-bit is not 
accepted by the QMS due to transmission 
errors.

transmission to QMS failed ArcNet driver error; the QMS signals ‘not 
ready’ for a data transmission.

unbalanced number of brackets The number of opening brackets does not 
match the number of closing brackets.

undefined data type received A data frame transmitted by the QMS contains 
a measurement data identification number 
that is unknown to Quadstar 32-bit.

unexpected type The processed variable has an unexpected 
type.

unit is already used by another 
instance

The selected unit is already in use of another 
Quadstar 32-bit application.

End the other application or restart Win-
dows®.

unknown client identifier in ArcNet 
server

ArcNet server is unable to identify the calling 
Quadstar 32-bit-application.

Restart Windows® or contact our service 
office.

unknown line type The line contains an unknown sequencer 
instruction.

Error/Warning Description
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user authorization failure Attempt to use a program (or program ele-
ment) that is password protected with 
Quadstar 32-bit ACCESSC.

=> If you have forgotten the user password 
(for the applications PARSET; MEASURE, 
DISPSAV, SERVICE, TUNEUP, UTILITY), it 
can be reset with the ACCESSC program. 
You can then log in with “Username” and 
‘Enter’ and define a new user password.

=> If you have forgotten the ACCESSC Pass-
word (for the ACCESSC application), you 
must copy the Q_ACCESS.DAT file from the 
installation diskette into the EXE path of 
ACCESSC before ACCESSC is started. You 
can then start ACCESSC without a password 
and define a new ACCESSC password.

username already existing, user not 
accepted

The newly defined user exists already.

=> Define a different user name.

value out of range The entered value is not compatible with the 
format, i.e. it is outside the valid limits.

variable index out of range at 
sequence ‘SeqName’ line ‘LineNbr’

The index for an array selected in line 
‘LineNbr’ of the sequence ‘SeqName’ is larger 
than the entered limit (for this index).

window creation error The desired window can not be opened due to 
a memory problem.

windows communication driver error Receive or transmit error in the Windows® 
communications driver.

write error ‘FileName’ Error when writing to the file ‘FileName’.

wrong block ID received A frame transmitted by QMS contains an 
unknown frame identification number.

wrong communication line selected The actual sequence instruction is not allowed 
with the currently opened communication line.

wrong configuration During the test of a sequence an illegal 
access to non-existing hardware has been 
detected.

wrong data type received from QMS The data frame transmitted by QMS contains 
measurement data of a wrong type.

wrong version of identification file 
(Q_OPTION.DAT)

The Quadstar 32-bit identification file does not 
correspond to the current version.

=> Copy the original file from the installation 
diskette.

Error/Warning Description
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10.7 Troubleshooting
Problem Possible causes Solution

The measurement produces very 
small intensities, although the 
parameters are set reasonably.

• Emission and/or SEM 
switched off.

• Zero Gas Subtraction 
ON, the currently mea-
sured spectrum has 
been measured as 
Zero Gas by mistake.

• Switch Emission and/or SEM on 
(CTRL+S).

• Make a new Zero Gas Measure-
ment by using a real zero gas.

• Check in program Dispsav (Auxilia-
ry : Zero Gas), whether the Zero 
Gas values are still valid; if Not, de-
lete them and save again (File : 
Save).

• Switch the Zero Gas Subtraction off 
(Parameters : Setup).

A certain measurement produces 
various intensities, depending on 
the measure time (Speed/Dwell).

• Pause is not set cor-
rectly.

• Set the parameter Pause in Chan-
nel Parameter Editor under Amplifi-
er to a safe value (normally 1.0).

A certain measurement produces 
under various conditions always the 
same intensities.

• Simulation mode (SIM-
symbol in status bar) is 
active.

• Switch off the simulation mode un-
der Parameter Setup: Setup : Gen-
eral : Simulation Mode : OFF.

The measure curve of the 
QMS 422/200 seems to be shifted 
against the baseline.

• Offset of the measure 
amplifier not calibrated 
or calibration invalid.

• Recalibrate the measure amplifier. 
See Chapter 2.8.3 QMS Offset, 

140.

The QMS does not measure on the 
specified masses, but on slightly dif-
ferent masses.

• Mass Scale Correction 
is switched on.

• Switch off the Mass Scale Correc-
tion. See Chapter 2.8.1 Mass scale 
calibration (Mass Scale), 134 or 
Setup of the current measure mode.

Emission/SEM can’t be switched on 
in Quadstar 32-bit.

• Emission External/HV 
External option is ac-
tive.

• Protection (SEM+Fil)-
parameter is set incor-
rectly.

• Switch off Emission External/HV Ex-
ternal. See Chapter 3.8.1 QMS 
Configuration, 234.

• If you are sure, that emission and 
SEM are not controlled or protected 
externally, then switch over to IN-
TERN. See Chapter 3.8.1 QMS 
Configuration, 234; otherwise 
check the vacuum control unit.

The Analog outputs of the QMS 
(AO’s) apparently don’t work.

• AO-Characteristic-
Curve has still default 
values; it doesn’t 
match the required 
range.

• Set up the AO-Characteristic Curve 
(program Parameter Setup : Config 
: AO Characteristic Curve) in such a 
way, that the range (e.g. 0 ... 100%) 
is assigned to the AO range (e.g. -
5.12V ... +5.12V) adequately.

The printer could not print the lines 
of the sequence. Where can I find 
the ‘lost’ information?

• Paper jam, out of pa-
per, connection to the 
printer interrupted etc.

• Force the remaining lines to be out-
put by using the Print-Manager. See 
Chapter 8.4.3 Log output, 422
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If I print a screen hardcopy by 
CTRL+SHIFT+F12 while a mea-
surement is in progress, the error 
message Send/Receive Timeout 
Detected appears. How can I avoid 
that?

• The printing requires 
too much CPU time, 
the interface to the 
QMS cannot be served 
any more and there-
fore reports a timeout 
error.

• Windows® problem, unsolvable.
• Choose the print region as small as 

possible.
• Store the graphic in a file first and 

print it after the measurement is 
done.

• Try other equipment (printer, PC).

I want to print on a network printer 
from Quadstar 32-bit, but instead of 
that, the printer on LPT1 or none at 
all is printing.

• Quadstar 32-bit identi-
fies printers exclusively 
by ports (LPT1 ... 3, 
COM1 ... 4). Therefore, 
the network path can 
not be found.

• Define a virtual printer port for the 
used network path.

The printed items (parameters, 
matrix elements etc.) are not equal 
to the ones I see on the screen. 
What’s wrong?

• Some items can only 
be printed correctly by 
using files as data 
base.

• Save the corresponding files before 
printing them.

Quadstar 32-bit shows everything 
on the screen in monochrome color 
or supplies no more than two colors 
under Config : Screen Color to 
choose from, although my graphics 
system supplies much more colors. 
What’s wrong?

• In Parameter Setup 
program under Config : 
Screen Color the color 
palette Black&White is 
selected.

• Select a different color palette.

Problem Possible causes Solution
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11. Residual Gas Analysis Program 
for Prisma™

The RGA Program supplied with the mass spectrometer Prisma™ allows for quick and 
easy measurement of residual gases in vacuum chambers:

• The program leads you, step by step, to the desired results.

• For all common measuring tasks there are ready-to-use set up measurements.

• The RGA Program is easy to be used via dialog boxes and leads rapidly to the de-
sired results (overview spectra, measuring tables, gas concentrations, partial pres-
sures etc.).

• Auxiliary programs allow for fine tuning of the Prisma™ mass spectrometer.

This RGA Program was developed as a Quadstar 32-bit sequence for residual gas anal-
ysis when operating the Prisma™. It consists of a main sequence and a number of sub-
sequences. (A sequence is a program, that has been written with the sequencer, i.e. in 
the macro programming language of Quadstar 32-bit; see Chapter 8. Process Control, 

409).
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11.1 Overview of the operating modes

11.1.1 Main selection box

In the main selection box you can choose the type of measurement and start some aux-
iliary programs for fine tuning of the mass spectrometer:

Fig. 11-1

Scan
Measure a spectrum across a given mass range:

• [Analog] - Display an analog spectrum.

• [Bargraph] - Search for peaks in the spectrum and display them.

• [Stair] - Measure only on integer mass numbers.

Currents
Measure the ion currents on predefined mass numbers:

• [Table] - The intensities are displayed as a table.

• [Bargraph] - The intensities are displayed as a bar chart.

• [Vs. Time] - The intensities are displayed Versus Time.

Concentrations
Determine the concentrations of the major components of a typical residual gas (Ar, 
CO2, H2, H2O, He, CxHy, O2 and N2/CO):

• [Table] - The concentrations are displayed as a table.

• [Bargraph] - The concentrations are displayed as a bar chart.

• [Vs. Time] - The concentrations are displayed Versus Time.
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Part. Press.
Determine the partial pressures of the major components of a typical residual gas (Ar, 
CO2, H2, H2O, He, CxHy, O2 and N2/CO):

• [Table] - The partial pressures are displayed as a table.

• [Bargraph] - The partial pressures are displayed as a bar chart.

• [Vs. Time] - The partial pressures are displayed Versus Time.

Auxiliaries

Auxiliary programs for adjustment of the mass spectrometer:

• [Mass Scale] - Adjust the mass scale.

• [Backgr.] - Determine the residual gas background.

• [Leak] - Perform a helium leak test.

• [Resolution] - Change the mass resolution (smaller number = sharper discrimination 
of peaks).

• [Cal. SEM] - Optimize the SEM voltage (in such a way, that the gain is 2000).

• [Cal. Offset] - Calibrate the amplifier offset.

• [Cal. Sens] - Determine the mass spectrometer sensitivity for partial pressure mea-
surements.

11.1.1.1 Scan

Scan offers the measurement types Analog, Bargraph and Stair to choose from:

Fig. 11-2

11.1.1.2 Currents

Currents determines ion currents on predefined mass numbers. The results can be dis-
played as table, bar chart or Versus Time:

Fig. 11-3

Table Versus TimeBargraph

Analog StairBargraph
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11.1.1.3 Concentr.

Concentr. determines concentrations of gas components. The results can be displayed 
as table, bar chart or Versus Time:

Fig. 11-4

11.1.1.4 Part. Press.

Part. Press. determines partial pressures of gas components. The results can be dis-
played as table, bar chart or Versus Time:

Fig. 11-5

11.1.1.5 Auxiliaries

The auxiliary programs serve for adjusting the mass spectrometer:

Fig. 11-6

Mass Scale
Compensate mass scale deviations.

Table Versus TimeBargraph

Table Versus TimeBargraph

Mass Scale Background Leak

Resolution Cal. SEM Cal. Offset Cal. Sens.
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Backgr.
Determine residual gas background.

Leak
Perform a helium leak test.

Resolution
Change the resolution.

Cal. SEM
Optimize the SEM voltage.

Cal. Offset
Compensate the amplifier offset.

Cal. Sens.
Determine the mass spectrometer sensitivity (for partial pressure measurements).
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11.2 Working with the RGA program

11.2.1 Start of the RGA program

The RGA program is delivered in compiled form and is automatically installed during the 
installation of Quadstar 32-bit for a Prisma™:

Fig. 11-7

Double clicking on the icon RGA Program starts the program and shows the dialog box 
Introduction.

NOTE:
If Quadstar 32-bit reports an error instead, e.g. because the installation path is not 
equal to the standard path, you should start the Parset program and load a se-
quence by [Sequence] > [Editor]. Then choose [File] > [Compile All] and click on 
[Compile All], so all sequences - i.e. the RGA-program as well- are recompiled. 
Now you can start the RGA-program as described above.

If it still doesn’t work, then you should study the sections ‘Installation/Configur-
ing Quadstar 32-bit’ in Chapter 1. Introduction, 17.
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11.2.2 Introduction

First you have to state a few properties of your Prisma™:

Fig. 11-8

Mass Range
Mass range of your Prisma™ detector.

Detector Type
Type of your Prisma™ detector.

If the settings are correct, click on [Accept selection and proceed]. The program now 
performs an automatic amplifier offset correction which takes a few seconds.
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11.2.3 Switching on the emission

If the emission is switched off, you are asked to switch it on:

Fig. 11-9

Click [Yes, start]

Fig. 11-10

CAUTION
Make sure the total pressure in the vacuum chamber is low enough be-
fore activating the button [Yes] in the second dialog box. The ion source 
may be damaged if the pressure is higher than 10E-4 mbar.
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11.2.4 Display of an overview spectrum

In the following dialog box you can choose whether an overview spectrum is to be mea-
sured and displayed or not; if not, you can proceed to the main selection box directly:

Fig. 11-11

[Start Spectrum]
Choose [Start Spectrum] to display the spectrum from mass 0 ... 50.

Fig. 11-12

When the measurement is finished, a dialog box containing an [OK] button appears. If 
you want to go on to the main selection box, click on the [OK] button.

[EXIT SEQUENCE]
Exit the RGA program.

[Proceed to Selection Boxes]
Continue to the main selection box.
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11.2.5 Switching on the Channeltron

If you have chosen Channeltron-/Faraday detector in the Introduction and the SEM volt-
age has not been switched on yet, the following dialog box appears:

Fig. 11-13

If the total pressure in the vacuum chamber is below 1 × 10E-5 mbar, click on ‘Yes’. The 
SEM voltage of the channeltron is then switched on (the SEM symbol turns to yellow). 
If the total pressure is higher than 1 × 10E-5 mbar, don’t turn on the SEM voltage; click 
on ‘No’ to proceed. Your Prisma™ will work like one equipped with a Faraday detector 
in this case.

CAUTION
Switching on the SEM voltage at a total pressure >10E-5 mbar may 
cause damage to the Channeltron.
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11.2.5.1 Calibrating the Channeltron

After the SEM voltage has been switched on, Quadstar 32-bit determines the high volt-
age necessary for a gain of 2000 of the output current compared to the current mea-
sured with the Faraday cup. This calibration takes about 40 seconds. The following mes-
sage is displayed during this time:

Fig. 11-14

The determined high voltage is displayed in the status bar afterwards:

Fig. 11-15
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11.3 Main Selection Box
You have now reached the Main Selection Box. Here you can start the different types of 
measurements and auxiliary programs you have learned about previously:

Fig. 11-16

11.3.1 Terminate RGA program [EXIT SEQUENCE]

Most dialog boxes contain the [EXIT SEQUENCE] button. This allows for exiting the pro-
gram. Quadstar 32-bit asks however, whether the program is really to be terminated:

Fig. 11-17

• Choose [Yes], if you want to terminate the program. The settings you have made al-
ready (e.g. emission switched on) will remain.
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• Choose [No], if you want to continue the program; in that case, the next dialog box 
will be opened.

11.3.2 Back to previous screen

Within the RGA program you can step back to the previous screen at any time by press-
ing <SHIFT> and <F4> simultaneously or by selecting the name of the previous screen 
in the menu File.

11.3.3 Measurement programs

11.3.3.1 Scan measurements

[Analog]
Analog spectrum across the given mass range.

[Bargraph]
Peak search across the given mass range

[Stair]
The intensities on all integer masses of the given mass range are measured.

11.3.3.1.1 Enter measure and display parameters

If you click on a scan measurement (Analog, Bargraph or Stair), the following dialog box 
appears:

Fig. 11-18
Quadstar 32-bit, vpnb68e1 (0302) Residual Gas Analysis Program for Prisma™ 587



Here you can enter the most important properties of the measurement and the data dis-
play:

Measurement Speed
Speed with which the samples are taken.

First Mass 
Start mass, at which the measurement begins.

Width
Mass range from the start mass onward.

Max. Decade
Upper limit of the display.

Number of Decades
Number of decades to be displayed (when logarithmic display is chosen).

Y-Scale
Display of the Y-Scale (linear or logarithmic).

Save Data
Store the measured data on/off.

Detector
Operation mode of the detector (Faraday or Channeltron).

11.3.3.1.2 Storage of measured data

If you have chosen ON under Save Data in the dialog box above, the measured data will 
be stored.

Fig. 11-19

For that, you have to specify the name and path of the file to contain the data. You may 
enter them manually or choose them by the file manager [File Manager].
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Fig. 11-20

When you have chosen a file and clicked on the [OPEN] button, the file name and path 
will be inserted into the input field of the dialog box Data File Selection:

Fig. 11-21

11.3.3.1.3 Analog

[Analog]
The complete mass range is measured through continuously and the results are dis-
played as an analog curve.

CAUTION
If you choose an already existing file, the newly measured data must be 
compatible with the already stored ones (i.e., at least First Mass and 
Width must be equal). If this is not granted, the file may be destroyed.
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Fig. 11-22

11.3.3.1.4 Bargraph

[Bargraph]
The given mass range is searched for peaks. The maximum values of the found peaks 
are displayed over their masses.

Fig. 11-23
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11.3.3.1.5 Stair

[Stair]
On all integer masses of the specified mass range the intensities are measured and dis-
played.

Fig. 11-24

11.3.3.2 Currents

In these measurements, the ion currents are determined on all given mass numbers and 
displayed as table, bar chart or Versus Time.

[Table]
Table display.

[Bargraph]
Bar chart display.

[Vs. Time]
Display Versus Time.

When you have chosen a display mode, a dialog box appears, where you can define a 
few things like measurement parameters, display properties and data storage if neces-
sary. See Chapter 2.4 Scan menu, 76.

11.3.3.2.1 Table

[Table]
The measured intensities are displayed as a table. The entries on the left of the table 
mean:

Nbr
Number of the measured value
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Type
Type of the measured value (here: Cur., i.e. ion current)

Ident
Identification of the measured value (here: mass number)

Unit
Unit of measure (here: A, i.e. Ampere)

Fig. 11-25

On the right of the table the new measure data are displayed alternatingly.

11.3.3.2.2 Bargraph

[Bargraph]
The measured ion currents are displayed as bar chart:

Fig. 11-26
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11.3.3.2.3 Versus Time

[Vs. Time]
The measured ion currents are displayed as a curve Versus Time. On the right of the 
screen the current values are displayed numerically as well:

Fig. 11-27

11.3.3.3 Concentr.

In these measurements, the concentrations of certain gases in the vacuum chamber are 
determined and displayed as table, bar chart or Versus Time.

[Table]
Table display.

[Bargraph]
Bar chart display.

[Vs. Time]
Display Versus Time.

When you have chosen a display mode, a dialog box appears, where you can define a 
few things like measurement parameters, display properties and data storage if neces-
sary. See Chapter 2.4 Scan menu, 76.
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11.3.3.3.1 Table

[Table]
The concentrations are displayed as a table:

Fig. 11-28

11.3.3.3.2 Bargraph

[Bargraph]
The concentrations are displayed as a bar chart:

Fig. 11-29
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11.3.3.3.3 Versus Time

[Vs. Time]
The concentrations are displayed as a curve Versus Time. On the right of the screen the 
current values are displayed numerically as well:

Fig. 11-30

11.3.3.4 Part. Press. (Partial Pressures)

In these measurements, the partial pressures of certain gases in the vacuum chamber 
are determined and displayed as table, bar chart or Versus Time. To make that possible, 
the auxiliary program ‘Cal. Sens.’ must be carried out first and the current total pressure 
be given.

[Table]
Table display.

[Bargraph]
Bar chart display.

[Vs. Time]
Display Versus Time.

When you have chosen a display mode, a dialog box appears, where you can define a 
few things like measurement parameters, display properties and data storage if neces-
sary. See Chapter 2.4 Scan menu, 76.

11.3.3.4.1 Table

[Table]
The partial pressures are displayed as a table:
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Fig. 11-31

11.3.3.4.2 Bargraph

[Bargraph]
The partial pressures are displayed as a bar chart:

Fig. 11-32
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11.3.3.4.3 Versus Time

[Vs. Time]
The partial pressures are displayed as a curve Versus Time. On the right of the screen 
the current values are displayed numerically as well:

Fig. 11-33

11.3.3.5 Auxiliaries

You can choose among the following auxiliary programs:

[Mass Scale]
Calibrate the mass scale.

[Backgr.]
Determine the residual gas background.

[Leak]
Perform a helium leak test.

[Resolution]
Change the mass resolution (smaller number = sharper discrimination of peaks).

[Cal. SEM]
Calibrate the SEM voltage (in such a way, that the gain is 2000).

[Cal. Offset]
Calibrate the amplifier offset.

[Cal. Sens.]
Determine the mass spectrometer sensitivity for partial pressure measurements.
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11.3.3.5.1 Calibrate the mass scale

[Mass Scale]
For accurate measurements of ion currents, concentrations and partial pressures it is 
necessary to always measure at the peak maximum. Therefore a calibration of the mass 
scale must be done which corrects deviations up to ±0.5 amu from the nominal mass.

Fig. 11-34

11.3.3.5.2 Determine the residual gas background

[Backgr.]
In every vacuum chamber there are fairly constant gas parts, that do not come from the 
inlet gas sample; they falsify the measurement results. Those parts can be measured 
by pumping the vacuum chamber to its base pressure. In the following measurements 
those parts are subtracted in order to get correct measurement results.

You can, if desired, merely delete the values of the old background measurement. This 
may be indicated if you expect that the old values are not accurate any more (e.g. 
because you are using channeltron instead of faraday detector) but you can’t or don’t 
want to remeasure the background.
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Fig. 11-35

[Reset old background values]
Delete old, inaccurate values

[Determine actual background values]
Measure new background values

Choose the type of detector, with which the background is to be measured:

Fig. 11-36

You are then asked, whether the system is at its base pressure (the lowest possible 
pressure in the vacuum chamber):

CAUTION
If you choose a different detector later or if the SEM voltage changes, 
the previous background values will become invalid.
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Fig. 11-37

[YES]
The background is remeasured and the old values are overwritten.

Fig. 11-38

[NO]
Pump your system to its base pressure and restart the measurement afterwards:

Fig. 11-39
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11.3.3.5.3 Perform a helium leak test

[Leak]
To find leaks in the vacuum system, the intensity of helium is measured. If you applicate 
helium near the leak, Quadstar 32-bit reacts optically and acoustically to the higher 
intensity: the measurement curve shows a higher level and the signal tone rises.

Fig. 11-40

Choose the length of the time axis in such a way, that the whole search for the leak is 
recorded. After that, the leak test starts:

Fig. 11-41
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11.3.3.5.4 Change the mass resolution

[Resolution]
This auxiliary program allows for change of the peak discrimination. That may be nec-
essary, if peaks standing close to each other can not be discriminated (=> decrease res-
olution value) or if you need maximum sensitivity (=> increase resolution value).

Fig. 11-42

11.3.3.5.5 Calibrate the SEM voltage

[Cal. SEM]
To give the SEM of a Prisma™ with channeltron detector optimal working conditions, its 
voltage is set to a value which provides a gain of about 2000. The calibration process 
and the set voltage are displayed in the status bar.

Fig. 11-43

11.3.3.5.6 Calibrate the amplifier offset

[Cal. Offset]
On request, the Prisma™ determines by itself all necessary correction values to com-
pensate offsets of the measure amplifier under different conditions.
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Fig. 11-44

11.3.3.5.7 Determine the mass spectrometer sensitivity

[Cal. Sens.]
Determine the mass spectrometer sensitivity for partial pressure measurements.

In order to perform partial pressure measurements with the Prisma™, its sensitivity must 
be determined first. For that purpose, declare the current total pressure as it is measured 
by a total pressure gauge (e.g. PKR 250/251). Quadstar 32-bit calculates the sensitivity 
of the Prisma™ for the individual gases then.

Fig. 11-45

If you have entered the pressure value, press [OK]:
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Fig. 11-46

NOTE:
The RGA program was developed using the Quadstar 32-bit Process Control (Se-
quencer). The source code of this sequence(s) is supplied and can be adapted to 
new tasks. Because the source code is write-protected, a copy must be made first 
and one has to work with the copy. This way you can create new applications 
without extensive programming work.

Writing sequences is explained in detail in Chapter 8. Process Control, 409.
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12. Sputter Process Monitor Program

The routines delivered together with the SPM 200 Sputter Process Monitor allow for an 
easy measurement of process gases and residual gases in sputter process chambers.

• The parameter settings needed for solving the common problems are integrated al-
ready

• The SPM 200 Program is easily operated via dialog-fields and delivers results quickly

• Additional Auxiliary Programs enable a fine-tuning of the SPM 200

The SPM 200 Program is a Quadstar 32-bit sequence developed for the operation of the 
SPM 200. It consists out of a main sequence and several subroutines which are edited 
within the Process Control Module of Quadstar 32-bit. The different measurement 
modes are based on specific parameter files edited within the Parameter Setup program 
of Quadstar 32-bit.
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12.1 Summary of the different operation modes

12.1.1 The Measurement Selection Box

The Measurement Selection box is the main selection box within the SPM 200 program. 
From this box different measurement modes can be selected and started.

Fig. 12-1

Argon Sputter Gas
As Argon is one of the most widely used sputter gases, several routines are included to 
measure the impurities within that gas.

Measured components: Ar, CO2, H2, H2O, N2 and O2

Processes: e.g. Al, Ti, W- sputtering

For more information see Chapter 12.3 Impurity determinations, 616

• [High speed measurement]
Approx. cycle time: 2 s
For very fast determination of the trace impurities in Ar-sputter gas.

• [Medium speed measurement]
Approx. cycle time: 12 s
For medium speed determination of the trace impurities in Ar-sputter gas.

• [Low speed measurement]
Approx. cycle time: 25 s
For low speed determination of the trace impurities in Ar-sputter gas.

Others
Several routines are included for the determination of impurities in various gas mixtures 
and pure Nitrogen.
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For more information see Chapter 12.3 Impurity determinations, 616.

• [Argon and Nitrogen]
Processes: e.g. TiN
Approx. cycle time: 2 s

• [Argon, Nitrogen and Oxygen]
Approx. cycle time: 2 s

• [Nitrogen]
Approx. cycle time: 10 s

Auxiliary Routines
The routines within this field include parameter settings mostly used during trouble-
shooting at the process chamber or for defining the status of the plant.

• [Residual Gas Analysis]
Measured components: Ar, CHx (Hydrocarbons), CO2, H2, H2O, N2 and O2
Approx. cycle time: 2 s
For more information see Chapter 12.4 Residual Gas Measurements, 619.

• [Helium Leaktest]
Performs a Helium leaktest while continuously measuring and displaying the ion cur-
rent on mass 4 amu

• [Scan Analog]
A scan within the mass range 0 ... 50 amu is displayed.
Scan rate: 2 s/amu

• [Offset Determination]
The offset of the SPM 200 electrometer amplifier is determined for different ranges 
and measurement speeds. The values obtained are included in all following mea-
surements. The measurement takes about 10 s.

• [Mass Scale Adjust]
The exact peak positions of several mass numbers are defined. Peak positions of 
mass numbers not included in this measurement will be inter-/extrapolated. The 
measurement takes about 20 s.

NOTE:
The [Mass Scale Adjust] routine has to be run at or close to the base pressure of 
the process chamber. At pressures above 1×10-4 mbar the peak positions of low 
mass peaks can not be defined precisely any more. It is recommended to run this 
routine before the first measurements are performed, routinely about once a 
week.
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12.2 General functions of the SPM 200 sequence

12.2.1 Starting the SPM 200 sequence

The SPM 200 sequence is delivered in a version compiled already together with the 
Quadstar 32-bit Measure program. It will be installed automatically with a separate icon 
during the installation of Quadstar 32-bit:

Fig. 12-2

After double-clicking the SPM 200 Program icon, the SPM 200 sequence is started and 
the dialog window Introduction will be displayed.

Fig. 12-3

12.2.2 Leaving the SPM 200 sequence

Most of the windows within the SPM 200 sequence contain the button [EXIT 
SEQUENCE]. This allows for leaving the sequence in a defined way. The actuation of 
the [EXIT SEQUENCE] button has to be confirmed.
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Fig. 12-4

If the button [NO] is pressed, the sequence will continue with the next dialog window.

If the [YES] button is pressed, the sequence will be stopped and the Measure program 
will be closed. 

12.2.3 Jumping backwards within the SPM 200 sequence

Within the SPM 200 sequence it is possible always to jump backwards to a previous 
screen by simultaneously pressing the <SHIFT> and the <F4> key. Alternatively select 
<File> from the menu and select the text of the last window displayed.

12.2.4 Switching on the filament and the emission

After starting the SPM 200 sequence the emission status is checked. If the emission is 
not running already, the following windows will be displayed.
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Fig. 12-5

Fig. 12-6

CAUTION
Before switching on the Emission, check the total pressure in the pro-
cess chamber, the SPM 200 is connected to. The total pressure has to 
be below 1x10-2 mbar to start the emission without any danger for the 
filament.

If the SPM 200 is separated by an isolation valve from the process 
chamber, the SPM 200 pumping station has to be running for at least 30 
minutes before switching on the emission to allow for an evacuation of 
the volume between the ion source and the isolation valve.
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12.2.5 Switching on the Channeltron Voltage

After starting the SPM 200 sequence the Channeltron Voltage status is checked. If the 
Channeltron Voltage is not switched on already, the following window will be displayed.

Fig. 12-7

12.2.6 Calibration of the Channeltron Voltage

The Channeltron Voltage is adjusted to a value, that gives an amplification of 2.000 rel-
ative to the Faraday-data. This adjustment allows for comparable results independent 
on the aging of the Channeltron.

The amplification adjustment is performed by a comparison of the ion currents of mea-
surements in the Integral Scan mode, as long as the SPM 200 is measuring the residual 
gas composition only. If Argon is detected, the adjustment will be performed by mea-
surements on mass 36 amu. The adjustment of the Channeltron Voltage takes about 
40s. During this time the following information is displayed on the screen.

CAUTION
Before switching on the Channeltron Voltage, check the total pressure 
in the process chamber, the SPM 200 is connected to. The total pres-
sure has to be below 1×10-2 mbar to start the Channeltron Voltage with-
out any danger for the channeltron.

If the SPM 200 is separated by an isolation valve from the process 
chamber, the SPM 200 pumping station has to be running for at least 30 
minutes before switching on the Channeltron Voltage to allow for an 
evacuation of the volume between the ion source and the isolation 
valve.
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Fig. 12-8

The resulting Channeltron Voltage is displayed after completion of the adjustment rou-
tine.

Fig. 12-9

12.2.7 Display of an Overview Spectrum

An overview scan can be started immediately after the determination of the Channeltron 
High Voltage is finished.

Fig. 12-10

An analog scan will be started after pressing the Start Spectrum button.
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Fig. 12-11

12.2.8 Saving of measurement data

Measurement data of Impurity Determinations, Residual Gas Measurements and Ana-
log Scans can be saved to the hard disk or the floppy disk drive.

Fig. 12-12

12.2.8.1 Saving data from Analog Scans

The following window will be displayed only, if data from Analog Scans have to be 
stored. Storage of 1, 3, 10 or all scans is enabled. If data from more than one scan are 
stored, it will be possible to display these data in a 3-dimensional graph.

The measurement and display of Analog Scans will be repeated independently on the 
selection until the measurement is stopped manually.
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Fig. 12-13

12.2.8.2 Assigning data file names

A name has to be assigned to each data file before the storage can start. The file name 
can either be defined manually by typing it into the edit field or by selecting a file with the 
file manager.

Fig. 12-14

12.2.8.3 File Manager

The File Manager allows for the definition of the file name, the directory and the drive.
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Fig. 12-15

NOTE:
The functions of the File Manager are described more extensively in Chapter 10.1 
File Manager, 541.

The file name selected within the File Manager will be displayed in the Data File Selec-
tion window, after it has been confirmed by pressing the [Open] button.

Fig. 12-16

CAUTION
Measurement data that shall be appended to an already existing file 
have to be compatible with the data already stored. Compatibility has to 
be tested with regard to names and numbers of gas components, mass 
numbers and analog input data. Any incompatibility will destroy the data 
files!
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12.3 Impurity determinations
The impurities in sputter gases are determined in a concentration mode as %, ppm or 
ppb. The differing sensitivities for the gases Ar, CO2, N2, O2, H2O and H2 are taken 
into account.

12.3.1 Selection of different Display Modes

Data obtained during the determination of impurities in a sputter gas can be displayed 
either in Tabular form or in a Versus Time mode. The display mode can be selected from 
the following window.

Fig. 12-17

Choosing the display mode Tabular results in a multicolumn display showing the com-
ponent names, the number of measurements, the measurement parameter file name, 
the time of the measurements and the results obtained.

Display of data from Impurity Determinations in Tabular form

Fig. 12-18

Choosing the display mode Versus Time results in a display in graphical mode showing 
the measured data in a concentration/time graph. The data of the last measured cycle 
are displayed in tabular form additionally.
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The length of the time axis can be adapted to the current application.

Fig. 12-19

Display of data from Impurity Determinations in Versus Time mode.

Fig. 12-20

12.3.1.1 Adapting the concentration scale for Versus Time 
displays

The concentration scale is set from 100ppb to 100% as a standard. If a different scale 
should be selected, proceed as follows:

Procedure 1 Start the program PARSET

2 Select MEASURE

3 Select MCD

4 Select the desired file from the file manager, the analysis matrix of this routine will 
be displayed.
Quadstar 32-bit, vpnb68e1 (0302) Sputter Process Monitor Program 617



5 Select EDIT

6 Select CONCENTRATION PARAMETERS

7 Define the Disp. F.S.R.

8 Define the Disp. Decades

9 Close the windows and save the parameter changes.
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12.4 Residual Gas Measurements
Two different measurement modes are possible for the determination of the residual gas 
composition within the process chamber:

• The partial pressures of the residual gases can be determined combining the data 
from the mass spectrometer and the data from a total pressure gauge, if the analog 
output voltage of a total pressure gauge is connected to the Analog Input AI#0 of the 
SPM 200.

The analog output characteristics of the total pressure gauge has to be defined in the 
corresponding sequence RESGAS2.SEQ, line 27. If the pressure/output characteristic 
cannot be given in a mathematical formula, the characteristic has to be defined as an 
AI-Characteristic curve.

Procedure Proceed as follows:

1 Start the Parameter Setup program

2 Select Config

3 Select AI Characteristic Curve

4 Define as many as possible Basic Points for the definition of the output character-
istic

5 Check the characteristic curve using the Diagram button

6 Close the edit field by pressing the [OK]- button

7 Change line 27 in he sequence RESGAS2.SQE to a comment-line

• The partial pressures of the residual gases will be determined via the absolute sen-
sitivity of the SPM 200, as long as no signals from a total pressure gauge are avail-
able.

The following window gives the opportunity for the selection between these two modes.

Fig. 12-21

The Residual Gas composition can be determined correctly only, if the pressure in the 
process chamber is below 5×10-5 mbar. If the pressure is above this value, overflow of 
ion current measurements may occur and meaningless results would be obtained.
Quadstar 32-bit, vpnb68e1 (0302) Sputter Process Monitor Program 619



Fig. 12-22

12.4.1 Selection of different Display Modes

Data obtained from Residual Gas measurements can be displayed either in Tabular 
form or in a Versus Time mode. The display mode can be selected from the following 
window.

Fig. 12-23

Choosing the display mode Tabular results in a multicolumn display showing the com-
ponent names, the number of measurements, the measurement parameter file name, 
the time of the measurements and the results obtained. This display is similar to the win-
dow for results from impurity determinations.

Choosing the display mode Versus Time results in a display in graphical mode showing 
the measured data in a concentration/time graph. The data of the last measured cycle 
are displayed in tabular form additionally.

The length of the time axis can be adapted to the current application:
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Fig. 12-24

Display of data from Residual Gas determinations in Versus Time mode:

Fig. 12-25

12.4.1.1 Adapting the pressure scale for Residual Gas 
measurements

The pressure scale for Residual Gas measurements is set from 1×10-11 to 1×10-4 mbar 
as a standard. If a different scale should be selected, proceed as follows:

1 Start the program MEASURE

2 Select SEQUENCE

3 Select SETUP

4 Define the Maximum Display Value and the Number of Decades

5 Close the SETUP window again
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Displaying the stored measurement data
See Display Saved Values
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Ion source parameter storage function on/off in sequencer mode
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